none
Group Policy - Shorcut on users desktop

    Question

  • My shortcuts only work when a user signs into a new computer.  If I sign into my everyday laptop connected to the domain I don't get the shortcut on my machine.  However if I sign into a new machine I get the shortcut.  I know the shortcut are working just can't figure out why it's not working on machines that users are already logged into.  I have forced group policy several times.  Been reading on cached logins but don't think it's that... please help.

    Wednesday, September 11, 2013 11:00 PM

All replies

  • on which console you have configured shortcuts computer or user.  have you select 

    "apply once and do not repeat"  Please check it. also if possible please paste group polcy result here


    Akshay Pate Server Administrator

    • Proposed as answer by Akshay Pate Thursday, September 12, 2013 5:21 AM
    Thursday, September 12, 2013 5:20 AM
  • Hi Gerard,

    Before going further, I want to confirm with you how the shortcuts were deployed to the desktop. Was the policy defined under Computer Configuration or User Configuration?

    If it was under Computer Configuration, the shortcuts would be deployed to the computers in the OU to which the GPO was linked.

    If it was under User Configuration, the shortcuts would follow the users in the OU to which the GPO was linked.

    Besides, as suggested by Akshay, we need to check whether the Apply once and do not reapply option is selected, for if it is selected, the policy will apply only once.

    Regarding deploying shortcuts and common options of configuring shortcuts, the following article may be referred to for more information.

    Configure a Shortcut Item
    http://technet.microsoft.com/en-us/library/cc753580.aspx

    Configure Common Options
    http://technet.microsoft.com/en-us/library/cc772371.aspx

    If the issue persists, we may collect GPMC log to further troubleshoot.

    GPMC log
    ==================
    a.   On domain controller, click Start -> Run, type GPMC.MSC, it will load the GPMC console.
    b.   Right click on "Group Policy Result" and choose wizard to generate a report for the problematic computer and user account (please place appropriately). (Choose computer and select the proper user in the wizard)
    c.   Right click the resulting group policy result and click the "Save Report…" => save report to save the report to a HTML file.

    Once you get the report, you may upload it to the Skydirve and provide me the download link.

    Best regards,

    Frank Shen


    Tuesday, September 17, 2013 9:57 AM
    Moderator
  • Applied under Computer configuration
    Apply once and do not reapply is not checked

    https://skydrive.live.com/?cid=9069328343def419&id=9069328343DEF419%21107&Bsrc=Share&Bpub=SDX.SkyDrive&authkey=!Ag0-3yLGmNx5BYg

    Wednesday, September 18, 2013 8:47 PM
  • Akshay Pate Server Administrator

    It is - at least to my humble opinion - bad practice to vote your own post as an answer... Although it seems to be common style ;-(

    ym2c

    Edit: This opinion of mine is even more important when I review your "solution" and the real reason for this failure - see my post about it (that I did NOT mark as an answer - this task is up to Gerard...)


    Martin

    NO THEY ARE NOT EVIL, if you know what you are doing: Good or bad GPOs?
    And if IT bothers me - coke bottle design refreshment :))

    Restore the forum design - my user defined Cascading Style Sheet!


    Wednesday, September 18, 2013 10:14 PM
  • Hi Gerard,

    Sorry for the delayed response.

    In the GPMC log, I saw that the shortcut path is C:\Users\Default\Desktop\CUSI IT HELP DESK.url. Here, I want to further confirm with you how the shortcut settings was configured.

    Usually, users don’t log in with the default profiles. To fix the problem, we may try changing the shortcut path.

    Regarding configuring shortcut items, the articles provided by my post above may be referred to as reference.

    Best regards,

    Frank Shen

    Monday, September 23, 2013 8:21 AM
    Moderator