none
How to make RemoteFX support screen resolution at scale of 16:9 ?

    Question

  • When I allocate a RemoteFX virtual display adapter to virtual machine, the screen resolution that I can select is 800x600, 1024x768, 1280x1024 or 1920x1200. all these resolutions are in scale of 4:3, however, all our displayers are in scale of 16:9.

    So, the problem is, How can I make the thin clients work in full screen mode by RDP to the virtual machines? as you know, the resolution should be 1280x720,1366x768,1920×1080,etc. which is not support by RemoteFX default.

    Friday, July 12, 2013 4:36 AM

Answers

All replies

  • Hi,

    So, this is an issue that is related to your hardware display adapter.As far as i know, as long as your hardware display adapter is supported,then all the resolutions are supported.It can be supported by 1280x720,1366x768,1920×1080,etc.Pls make sure that your driver is installed correctly.

    Regards,

    Clarence

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Monday, July 15, 2013 2:36 AM
    Moderator
  • Hi, Clarence. Thanks for your reply.

    The graphics card is AMD Radeon HD6770,  and the driver is downloaded from "amd.com", so I am sure that I install the correct driver. If I don't add a RemoteFX display adapter to the VM, the displayer of the thin client can work in full screen mode by RDP to the VM, no matter 4:3 or 16:9, and no matter any resolution.

    It seems that the problem IS caused by RemoteFX. So, Clarence, do you have such a environment to confirm it? If IT IS caused by RemoteFX, how to resolve it?

    Thanks again.

    Monday, July 15, 2013 3:36 AM
  • Was this issue resolved? I have a similar issue in that when I add the remotefx adapter to a VDI guest and then connect the maximum resolution is 1440X900 irrespective of the settings I set in remotefx adapter. I need 1600X900 on my clients to get full screen.
    Tuesday, September 17, 2013 8:12 PM
  • Wanted to echo that I am seeing the same issue with 1600x900 monitors defaulting to 1440x900. Is there a workaround or is this just an unsupported scenario with RemoteFX?
    Monday, December 09, 2013 6:36 PM
  • Hi,

    Server 2012 R2 vGPU supports more resolutions, including the ones you mentioned above.  Please see this article for more information:

    RemoteFX vGPU Improvements in Windows Server 2012 R2

    http://blogs.msdn.com/b/rds/archive/2013/12/04/remotefx-vgpu-improvements-in-windows-server-2012-r2.aspx

    Thanks.

    -TP

    • Proposed as answer by TP []MVP, Moderator Monday, December 09, 2013 6:50 PM
    • Marked as answer by 林华勇 Tuesday, December 10, 2013 1:15 AM
    Monday, December 09, 2013 6:50 PM
    Moderator