none
Read privileges for Executive Group

    Question

  • I have a Project Server 2010 environment where the Executives Group - actually the entire company - should have access to view the schedule and PDPs for all projects. The do not need to edit, but do need to read. What permission can I use to enable this?
    Saturday, December 21, 2013 9:24 PM

Answers

All replies

  • If you open Executive group you will see by default My Organization category is assigned to the group which is having a lot of permission to perform actions in PWA.

    In this case either you have to create new group and category for Executives in which you will give permission as per your need. I would not suggest you to make changes in default group or in Category.  But if you want to make changes in default category then you have to make some changes in category.

     

    In My Organization category select listed permission "View Project Summary in Project Center,View Project Schedule in Project Web App " and select The Project Owner is a descendant of the User via RBS. 

    And make sure yo remove some permission the the category  Build Team On Project, Publish Project,Save Project to Project Server,Save Protected Baseline

    Please check url for better understaning

    http://technet.microsoft.com/en-us/library/cc197622(v=office.14).aspx




    kirtesh


    • Edited by Kirteshtiw Sunday, December 22, 2013 5:35 AM
    Sunday, December 22, 2013 5:32 AM
  • Thanks for the response.

    Under the Server Settings -> Manage Categories -> My Organization link, I see "Views - Add to Category" but not the permissions you listed. Can you please clarify?

    Sunday, December 22, 2013 5:55 PM
  • Please open The executive group then scroll it down then click on My organization category of the group then you will see all the permission which i have told you.

    http://technet.microsoft.com/en-us/library/cc197354(v=office.14).aspx

    download video from link which is mainly for security template and category.


    kirtesh

    Sunday, December 22, 2013 6:03 PM
  • Thanks for clarifying; however, those were already set correctly as per your instructions except for "The Project Owner is a descendant of the User via RBS", which is not there. Members the Executives group still cannot see any fields on the PDP when they click on a project and there is no link to view the schedule.

    Sunday, December 22, 2013 8:02 PM
  • By default Executive group members have permissions to view project and Project Server data. This group is intended for high-level users who need visibility into projects but are not themselves assigned project tasks. This group is associated with the My Organization category.

    In order to not to edit project you have to remove some permission. In My Organization category remove permission which are for edit project, open project or publish project.

    The Project Owner is a descendant of the User via RBS" will be available in the Server Setting -->Manage category-->click on MY organization category -->  you will find it in Project permission type "Select Include all and future project" then select The Project Owner is a descendant of the User via RBS

    Scroll it down You will see Permission then click on permission  for executive for doing this click on Executive in the box then see the setting if needed change it.

    But it will work if you are using RBS in your organization.

    In organizations admin use RBS to mention the proper visibility for project server data along with Groups. 

    I would suggest you to use RBS and groups as per the role assign group to user.


    kirtesh


    • Edited by Kirteshtiw Monday, December 23, 2013 7:53 AM
    Monday, December 23, 2013 5:10 AM
  • Thanks for the assistance.

    I found another thread about this. Looks like it's a bug-type issue where the "Open Project" permission must be checked.

    http://social.technet.microsoft.com/Forums/projectserver/en-US/81ae1ae6-d85d-4dd7-b4f1-2292fefc281f/executives-group-not-being-able-to-view-project-details-view?forum=projectserver2010general

    • Marked as answer by wsg2 Wednesday, December 25, 2013 7:59 PM
    Monday, December 23, 2013 3:51 PM
  • Yes, I just Google the open project permission issue and found one post which is describing the issue .

    You have to update the server from SP2 so as it is containing hot fix for the issue.

    http://khurramjamshed.blogspot.in/2011/01/project-server-2010-team-member-group.html

    blog is talking about team member group but you can relate it with your issue. 

    Or you create new group and category in order to achieve it.


    kirtesh


    • Edited by Kirteshtiw Tuesday, December 24, 2013 4:02 AM
    Monday, December 23, 2013 8:21 PM
  • You can use either of the below steps but I would suggest you follow the second one:

    1. Edit the existing group

    2. Create a new group and category

    1. Edit the Team Members group, add all the users that needs to have access to all the projects and then add the My Organization Category to it. Once you add the My Organization Category, edit the category permissions and set the permissions as per the Team Members Template.

    The users will be able to view all the Projects but will not be able to edit them

    2. Create a new Category as per the article http://technet.microsoft.com/en-us/library/cc197675(v=office.14).aspx. Once the category is created, create a new group and add all the users that needs to be a part of this group. Then add the new category that you have created and set permissions to the category as per the Team Members template.

    You can refer the below articles:


    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.


    Monday, December 23, 2013 9:57 PM
    Moderator