none
Cannot send mail from Exchange 2013 to Exchange 2007

    Question

  • I have an Exchange 2007server with all roles in the same server (Version: 08.03.0327.001 ) on a Windows 2008 R2 server. I have now installed two Exchange 2013 servers both with CAS and MBX roles on Windows 2012 servers (full patched). There is also a DAG between the new servers. All mail goes through a BorderWare besides the internal mail.

    I can send mail from both environments to the Internet. I can also send internal mail from Exchange 2007 to Exchange 2013.But the problem is that I am unable to send from Exchange 2013 to Exchange 2007. I've debugged, but not solved the problem and there are few articles on the Internet.

    Any suggestions?



    Friday, August 16, 2013 3:18 PM

Answers

  • create separate receive connector on exchange 2007 to receive email from exchange 2013. remove all authentications and select Anonymous users only on receive connectors. assign Exchange 2013 as accept source. if Exchange 2013 Mailbox Server has any  Other Exchange 2007 receive connectors, please remove the IP from there. keep exchange 2013 Mailbox Server IP for this receive connectors only.   create send connector from exchange 2013 and sources server as exchange 2013 mailbox Server . configure target host as Exchange 2007 Servers.

    check Ports are open from Firewall ( telnet from exchange 2013 Mailbox to Exchange 2007 HUB POrt 25 ), check whether Send connectors SMTP port is 25 (get-sendconnector -identity "Exc2013-to-exch2007" |fl

    if u can telnet and send emails from exchange 2013 to exchange 2007, it should work .

    make sure to restart Exchange transport Services on both Exchange 2007 HUB and Exchange 2013 Mailbox. might wait for 15 seconds :)



    • Edited by Indunil Tuesday, August 20, 2013 6:52 PM add
    • Marked as answer by Michael Wiskman Wednesday, August 21, 2013 4:25 PM
    Tuesday, August 20, 2013 6:49 PM
  • I faced this problem before. (my environment is ex2010 coexist with ex2013).

    and ex2013 cannot send email to ex2007.

    things you have to do is.

    1. Make sure that you don't put you "EXCHANGE IP" in any receive connector.
    make sure you have exchange IP in only default receive connector.
    just remove the Exchange's IP or even if you add IP range that including Exchange IP , you have to take it out too.

    This is so weird but it's work for me after I remove Exchange IP from other receive connector.



    Wednesday, August 21, 2013 4:28 AM
  • Finally it works. The solution is described in Indunil and Supawat Rungsarityotin reply. It's about the receive connectors on both Exchange 2007 and Exchange 2013 side.

    It does not work using the default receive connectors. You have to create new ones for coexistence of both sides. In my case, I had two Exchange 2013 servers with all roles. I had to create receive connectors on both plus of course on the Exchange 2007 server. It is important of course that the remote servers are authorized
    on each connector.

    Thanks to all who responded and I hope it makes someone else will not have to get gray hair.


    Michael Wiskman

    Wednesday, August 21, 2013 4:02 PM

All replies

  • These two sentences are in conflict : "I can also send internal mail from Exchange 2007 to Exchange 2013. But the problem is that I am unable to send from Exchange 2007 to Exchange 2013. " Can you describe what is your real problem? Flow from E2007->E2013? Or vice versa?

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question. That will encourage me - and others - to take time out to help you. Thank you! Damir

    Sunday, August 18, 2013 9:03 PM
  • Hello,

    Do you mean you can't send message from exchange 2013 send message to exchange 2007? If so, I recommend you check if you have enable "anonymous users" on exchange 2007 receive connector.

    Besides, I recommend you message tracking to trace these messages.


    Cara Chen
    TechNet Community Support

    Monday, August 19, 2013 6:29 AM
    Moderator
  • Cara thank you for your replay. I cannot send internal mail between Exchange 2013 to Exchange 2007.

    My settings on the receive connector Exchange 2007:

    Network

    All IPv6 addresses port 25

    All IPv4 addresses port 587

    Permissions Groups

    Anonymous users

    Exchange users

    Exchange servers

    Legacy Exchange servers

    Authentication

    TLS

    Basic Authentication (offer basic only after starting TLS)

    Exchange Server Authentication

    Monday, August 19, 2013 7:16 AM
  • Diagnostic information for administrators:

    Generating server: EXCHANGE-1.admin.xxxxxx.org

    Receiving server: TC31.admin.xxxxxxx.org (xxx.xxx.xxx.xxx)

    2013-08-18 14:27:16 - Remote Server at TC31.admin.xxxxx.org (xxx.xxx.xxx.xxx) returned '550 4.4.7 QUEUE.Expired; message expired'

    2013-08-18 14:17:10 - Remote Server at TC31.admin.xxxxxx.org (xxx.xxx.xxx.xxx)) returned '451 4.4.0 Primary target IP address responded with: "451 5.7.3 Cannot achieve Exchange Server authentication." Attempted failover to alternate host, but that did not succeed. Either there are no alternate hosts, or delivery failed to all alternate hosts. The last endpoint attempted was xxx.xxx.xxx.xxx):25'


    Monday, August 19, 2013 9:18 AM
  • Hi

    >> I have a Exchange 2007 server with all roles on the same server (Rollup 11 not installed)

    Does this server have SP3 RU10 installed?  If not you will need to do this for coexistence to work.

    Steve

    Monday, August 19, 2013 9:28 AM
  • Version: 08.03.0327.001

    Before the weekend I had RU 10 on the Exchange 2007 server.

    I'm sorry Steve I did not control better when I wrote my question. I am aware of the need to install RU 10 for coexistence. So my previous question remains.


    Monday, August 19, 2013 9:55 AM
  • OK, do you have any firewalls between these servers or firewall software running on the Exchange 2007 server - including anti-virus that monitors/blocks SMTP traffic?

    Monday, August 19, 2013 10:43 AM
  • There are no firewalls internally but Windows firewalls on the servers is activated. The Exchange 2013 and 2007 is on the same vlan. F-secure is installed on the Exchange 2007 but no antivirus on Exchange 2013 yet.
    Monday, August 19, 2013 11:15 AM
  • No luck with kb979175
    Monday, August 19, 2013 7:18 PM
  • Michael,

    So you know you are not alone - I had this same issue occur to me right after updating to CU2 about 2 weeks ago.

    The Exchange 2013 server stopped sending to the Exchange 2007 server. The Exchange 2007 could send to Exchange 2013. Re-setting up send/receive connectors didn't help. Restarting services didn't help. We ended up just switching the mail routing and moving all the mailboxes in one night, rather than the staged migration. Never did find a solution.

    • Edited by ABCFED Monday, August 19, 2013 11:53 PM dsfg
    Monday, August 19, 2013 11:52 PM
  • For a while I thought that it's probably just me who has this problem. It helps a bit that there are more people in the same boat. Since we must live in both environments for a while, I have to find a solution. Anyone?

    Tuesday, August 20, 2013 9:50 AM
  • 1) Make Sure you have sufficient disk space

    2) restart Exchange services for both Exchange version.

    3) you can try Custom DNS setting also. follow below steps

    Go to Servers-->Select Edit--> DNS lookup--- Internal ---Select Custom --type internal DNS IP address


    • Edited by chotu24 Tuesday, August 20, 2013 11:48 AM
    Tuesday, August 20, 2013 11:47 AM
  • 1) Exchange 2007 c:\ 5,4 Gb
       Exchange 2013 c:\ 204 Gb
       Exchange 2013 c:\ 210 Gb

    2) Done serveral times including reboot.

    3) Have tried it now without success.

    Tuesday, August 20, 2013 2:22 PM
  • create separate receive connector on exchange 2007 to receive email from exchange 2013. remove all authentications and select Anonymous users only on receive connectors. assign Exchange 2013 as accept source. if Exchange 2013 Mailbox Server has any  Other Exchange 2007 receive connectors, please remove the IP from there. keep exchange 2013 Mailbox Server IP for this receive connectors only.   create send connector from exchange 2013 and sources server as exchange 2013 mailbox Server . configure target host as Exchange 2007 Servers.

    check Ports are open from Firewall ( telnet from exchange 2013 Mailbox to Exchange 2007 HUB POrt 25 ), check whether Send connectors SMTP port is 25 (get-sendconnector -identity "Exc2013-to-exch2007" |fl

    if u can telnet and send emails from exchange 2013 to exchange 2007, it should work .

    make sure to restart Exchange transport Services on both Exchange 2007 HUB and Exchange 2013 Mailbox. might wait for 15 seconds :)



    • Edited by Indunil Tuesday, August 20, 2013 6:52 PM add
    • Marked as answer by Michael Wiskman Wednesday, August 21, 2013 4:25 PM
    Tuesday, August 20, 2013 6:49 PM
  • I faced this problem before. (my environment is ex2010 coexist with ex2013).

    and ex2013 cannot send email to ex2007.

    things you have to do is.

    1. Make sure that you don't put you "EXCHANGE IP" in any receive connector.
    make sure you have exchange IP in only default receive connector.
    just remove the Exchange's IP or even if you add IP range that including Exchange IP , you have to take it out too.

    This is so weird but it's work for me after I remove Exchange IP from other receive connector.



    Wednesday, August 21, 2013 4:28 AM
  • Finally it works. The solution is described in Indunil and Supawat Rungsarityotin reply. It's about the receive connectors on both Exchange 2007 and Exchange 2013 side.

    It does not work using the default receive connectors. You have to create new ones for coexistence of both sides. In my case, I had two Exchange 2013 servers with all roles. I had to create receive connectors on both plus of course on the Exchange 2007 server. It is important of course that the remote servers are authorized
    on each connector.

    Thanks to all who responded and I hope it makes someone else will not have to get gray hair.


    Michael Wiskman

    Wednesday, August 21, 2013 4:02 PM
  • Dear Michael. Could you please explain how exactly you did this in a tutorial format. I'm facing a similar issue and I don't want to end up breaking the current Ex2007 environment.

    So what do I do on the Ex2007 server and on the Ex2013 server?

    Thanks in advance.

    Sunday, September 29, 2013 3:25 PM
  • create separate receive connector on exchange 2007 to receive email from exchange 2013. remove all authentications and select Anonymous users only on receive connectors. assign Exchange 2013 as accept source. if Exchange 2013 Mailbox Server has any  Other Exchange 2007 receive connectors, please remove the IP from there. keep exchange 2013 Mailbox Server IP for this receive connectors only.   create send connector from exchange 2013 and sources server as exchange 2013 mailbox Server . configure target host as Exchange 2007 Servers.

    check Ports are open from Firewall ( telnet from exchange 2013 Mailbox to Exchange 2007 HUB POrt 25 ), check whether Send connectors SMTP port is 25 (get-sendconnector -identity "Exc2013-to-exch2007" |fl

    if u can telnet and send emails from exchange 2013 to exchange 2007, it should work .

    make sure to restart Exchange transport Services on both Exchange 2007 HUB and Exchange 2013 Mailbox. might wait for 15 seconds :)



    Could somebody please explain how I can do this. Basically I need a tutorial-level explanation of what I should be doing on each server. I have tried creating these connectors but I'm missing some finer details and I might end up breaking the existing Ex2007 environment.

    So if you could explain in almost point form in a manner like this:

    On Ex2007| Server Configuration| Hub Transport| send Connectors, create Coexistence send connector (then go through its settings)

    And on Ex2013| EAC| Mail flow| Send Connectors, create ....

    That would be much appreciated. My migration has been stalled for over two weeks because of this issue. And I'm planning on doing a few more at other sites.

    Friday, October 04, 2013 6:16 AM
  • Xisingwana,

    I'm glad to help as well, but the information provided should be adequate information for a properly trained Exchange admin to set everything up correctly.

    1. Set up the 2007 receive connector. Set the details as stated above.

    2. Set up the 2013 send connector. Set the details as stated above.

    3. Check the firewall settings

    4. Attempt a telnet session on port 25.

    That's it.

    If you want a step-by-step guide on how to do all of that with screenshots and such, there are many books and tutorials on the web. Youtube, train-signal, and others have how-to videos on how to set up connectors within Exchange. Here is an example...

    http://exchangeserverpro.com/configuring-the-exchange-server-2007-hub-transport-server/

    Friday, October 04, 2013 2:46 PM
  • The solution that worked in my scenario:

    1. On Ex2007 created a receive connector called "receive ex2013 mail". Cleared all security and authentication. Under authentication, selected "Exchange Server Authentication". Under Permissions group, selected "anonymous users." Under Scoping I added the Ex2013 server's IP address.

    2. Created a send connector on the Ex2013 server called "Ex2013 Send Connector". Under delivery, Route mail through this smart host, added Ex2007 IP address only. Create the rest as I would any internet-facing send connector.

    Mail flow is now sorted between the two servers and for external access.

    This is more or less what I was requesting from the forum but no one was really forthcoming with such a solution. So I used suggestions from this question and coupled them with this solution to come up with the correct approach: http://support.microsoft.com/kb/979175

    Monday, October 21, 2013 1:42 PM