locked
Outlook 2003 nem tud az Exchange 2003 szerverhez csatlakozni a belső hálón

    Question

  •  

    Sziaszok!

     

    Egy nagyon érdekes problémám állt elő:

    Adott: egy win 2k3 sp2, rajta az Exchange 2003 és rajta egy ISA 2006 sp1.

    Megvan az a szabály az Isa-n amikor a "Mail Server Publishing Rule"-ban hozzáférés tipusa kliens-hozzáférés, majd "Outlook RPC standard ports", protokoll: "Exchange RPC Server", iránya: "Internal" to "Local Host".

     

    Előzmények:  Az ISA 2004-et 1 hónapja uninstall-oztam, majd Isa 2006 sp1 feltelepitettem és mostanáig rendesen ment a belső hálóról az Outlook levelezés a fenti "Mail Server Publishing Rule"-lal.

     

    Jelenleg ha elinditom az Outlook-ot a munkaállomásokról, azt van hogy nem tud kapcsolódni az Exchange szerverhez!

    Az OWA-n pedig tökéletesen mennek ki-be a levelek.

     

    Lehet, hogy valami RPC-s gond van az Exchange szerveremen?

     

    NAGYON FONTOS LENNE MEGOLDANOM A PROBLÉMÁT, MERT CSAK AZ OWA-t TUDJÁK HASZNÁLNI!

    KÉREM SEGÍTSETEK! NAGYON FONTOS!

    KÖSZI!

     

    Sunday, December 07, 2008 6:20 PM

All replies

  • Szokásos kérdés. Tűzfal logjában mit látni?

     

    Sunday, December 07, 2008 6:27 PM
    Owner
  • A tűzfal log-ban ez van amikor a kliensen Küldés/Fogadást nyomok:

     

    MEDI01 2008-12-07 19:26:26 TCP 10.1.1.152:1239 10.1.1.1:135 10.1.1.152 Internal Local Host Terminate 0x80074e20 OUTLOOK LAN Exchange RPC Server Exchange RPC Server 516 516 420 420 79938 79938 - - 3 2726


     

    MEDI01 2008-12-07 19:26:27 TCP 10.1.1.152:1245 10.1.1.1:135 10.1.1.152 Internal Local Host Establish 0x0 OUTLOOK LAN Exchange RPC Server Exchange RPC Server 0 0 0 0 - - - - 3 2726

     

    Sunday, December 07, 2008 7:28 PM
  • Ebben az esetben én az exchange szerveren vizsgálódnék. Eseménynaplóban például, esetleg nyitott portokat nézni rajta, satöbbi.

     

    Sunday, December 07, 2008 9:55 PM
    Owner
  • Bármit nézek az Exchange Server-en semmi okosat nem látok.

    Az Isa 2006 logban bejön az RPC kérés a 135-ös porton az Outlooktól, kifele meg valami dinamikus portokon (1024-től felfele) menne, de nem megy.

     

    Maga az Exchange Server 2003 meg megy, sőt OWA-n simán be tudok lépni, és ott küldeni-fogadni.

    Egyedül csak a benti hálóról inditott Outlook nem megy, az RPC miatt.

     

    Van valakinek konkrét ötlete mit, hol és hogyan ellenőrizzek le?

    Nagyok kéne a segítség mert nem tudunk levelezni bentről az Outlookkal. Nem lehet bentről az Outlook-ot rábirni a kommunikációra RPC kihagyásával?

    Köszi!

    Tuesday, December 09, 2008 12:40 PM
  • Már azon is gondolkodtam, hoggy egy másik uj szerverre felhuzok egy Exchange 2007-et és átmozgatom rá a mélboxokat, és ahhoz konnektálom a belső Outlook klienseket. De lehet hogy ez is RPC-s és nem is menne a dolog?

     

     

    Tuesday, December 09, 2008 12:43 PM
  • A parancssori "outlook /Rpcdiag" -ra milyen választ kapsz?

     

    Lásd: (http://www.petri.co.il/testing_rpc_over_http_connection.htm)

    Tuesday, December 09, 2008 12:49 PM
  • Elindul a diag és kiirja a szerver nevét, próbál csatlakozni, majd aszongya nincs kapcsolat.

    Aztán ismételgeti ugyanezt. Ha a kliensről pingelem a szerverip-t vagy nevét rendesen megy, azaz a DNS feloldás is ok.

    Még a file share is megy a kliensről a szerverre, egyedül csak az Outlook ne tud az Exchange servehez kapcsolodni. Sad

     

    Más ötlet?

     

    Tuesday, December 09, 2008 1:15 PM
  • Vszínű, hogy van RPC over HTTP/S konfigurálva. Ha igen, olvasd el a hivatkozott cikket!
    Tuesday, December 09, 2008 1:19 PM
  •  

    Nincs RPC over HTTP/S definiálva! Nem használok olyat.

    Webről az OWA HTTPS-en megy, bentről pedig az Outlook meg RPC-ről.

    1. isa szabály van ehhez beállitva: Exchange RPC-LAN : internal to localhost, port 135 inbound.

    2. isa szabály: Localhost to internal, all outbound protokoll.

     

    Tuesday, December 09, 2008 1:31 PM
  • Az Exch. RPC-LAN szabályon jobb-klikk: a "configure Rpc protokoll"-nál be van pipálva az "Enforce strict RPC compliance" checkbox. Ugyanez van a "system firewall policy-n" is.

     

    Tuesday, December 09, 2008 1:34 PM
  • IMAP4-hez hogy kell bekonfigolni a klienst?

    Mert az exchange-n látok ilyet a protokolloknál.

     

    Tuesday, December 09, 2008 1:38 PM
  •  

    Bár az Imap4 elég eccerű, régi cucc, felejtős.
    Tuesday, December 09, 2008 1:44 PM
  • Nem lehet, hogy az exchange van valahogy behalva az rpc-jénél?

    Hogy tudnám ezt megnézni?

     

    Tuesday, December 09, 2008 2:36 PM
  • Az alábbi exchange services-ek futnak:

     

    Microsoft Exchange IMAP4,

    Microsoft Exchange Event,

    Microsoft Exchange Information Store,

    Microsoft Exchange Management,

    Microsoft Exchange MTA Stacks,

    Microsoft Exchange System Attendant,

    Microsoft Exchange Routing Engine.

     

     

    Tuesday, December 09, 2008 2:40 PM
  •  

    És ha feltolok egy uj szerverre egy másik Exchange 2003-at, és átmozgatom a postafiókokat, a régit meg likvidálom?

    Win2k8 x64-re felmegy egyébként az Exc2k3?

     

    Wednesday, December 10, 2008 9:19 AM
  • Nem megy fel.

     

    Wednesday, December 10, 2008 10:01 AM
    Owner
  •  

    Akkor mi lenne a legjobb és leggyorsabb megoldás, hogy ujra menjen a belső hálón az outlook?

     

    Wednesday, December 10, 2008 10:57 AM
  • Megpróbálhatnád kideríteni mi a hiba. Smile

     

    http://support.microsoft.com/default.aspx/kb/300479

     

    Aztán exchange server és kliens eseménynaplójában biztosan van valami.

     

    Wednesday, December 10, 2008 11:14 AM
    Owner
  •  

    Az oulook-os gép hibanaplója: Event id: 19

    Nem sikerült végrehajtani a távoli eljáráshívást (EcDoConnectEx) a kiszolgálóra (medi01.haz.hu). A hiba kódja: 6d9. A program 41938 ezredmásodpercet várt; eeInfo: Block (0), Error = 6d9, Version = 1, GeneratingComponent = 2, DetectionLocation = 1f4, Flags = 0, Params = 4, [Param (0) Type = eeptUnicodeString, Value = ncacn_ip_tcp], [Param (1) Type = eeptUnicodeString, Value = medi01.haz.medi.hu], [Param (2) Type = eeptLongVal, Value = a4f1db00], [Param (3) Type = eeptLongVal, Value = 10001], Block (1), Error = 6ba, Version = 1, GeneratingComponent = 2, DetectionLocation = 2f9, Flags = 0, Params = 1, [Param (0) Type = eeptUnicodeString, Value = 2182], Block (2), Error = 6ba, Version = 1, GeneratingComponent = 8, DetectionLocation = 143, Flags = 0, Params = 0, Block (3), Error = 4d5, Version = 1, GeneratingComponent = 8, DetectionLocation = 139, Flags = 0, Params = 0, Block (4), Error = 274c, Version = 1, GeneratingComponent = 8, DetectionLocation = 137, Flags = 0, Params = 3, [Param (0) Type = eeptLongVal, Value = 886], [Param (1) Type = eeptPointerVal], [Param (2) Type = eeptPointerVal], Block (5), Error = 274c, Version = 1, GeneratingComponent = 8, DetectionLocation = 13e, Flags = 0, Params = 0.

    További tájékoztatást a súgóban talál a következő helyen: http://go.microsoft.com/fwlink/events.asp.

     

    Exchange Szerveren lévő eseménynaplóban semmi.

     

    A szerveren lefuttattam:

     

    rpingc.exe:

     

    IP: 10.1.1.1 ALL PROTOKOLL eredménye:

    "RPC Binding returned (0x6be). Network address: 10.1.1.1.  Endpoint: 251  UUID:     "

    "Failed to Bind on ALL protokolls."

     

    IP: 10.1.1.1 TCP/IP PROTOKOLL eredménye:

    "RPC Binding returned (0x6ba). Network address: 10.1.1.1.  Endpoint: 2256  UUID:     "

    "Protokoll sequence:  ncacn_ip_tcp" 

    "The server is unavailable" Ping#1 failed.

     

    Akkor ezt az RPC Binding hibát hogy lehetne elháritani?

     

    Wednesday, December 10, 2008 1:46 PM
  •  

    Felhúztam egy Outlook-ot az Exchange serverre, és tökéletesen megy.

    Akkor csakis az ISA 2006 lehet a hunyó, szakaggyon meg.

    Aszem Isa 2006 reinstall lesz.

     

    Friday, December 12, 2008 7:53 AM
  • Hali,

     

    Na az Outlookot az Exchange szerverről azonnal szedd le, ha jót akarsz magadnak.

    http://support.microsoft.com/kb/266418

     

    Ez ugyan csak irgum burgum, de rengeteg gondot okozott már.

     

    üdv,

    Zoli

     

    Tuesday, January 27, 2009 9:26 AM
  • Zoli!

     

    Csak teszt céljából ment fel az Exc2k3-ra az Outlook 2k3 és semmi gondja se volt.

    Már átálltam Ex2k7SP1-re és oda azé nem teszek fel outlook-otSmile

    Épp az utolsó exchange 2k3 sp2-öt fogom most kitakaritani a domain-ből.

    Van valami buktatója a dolognak?

    Tuesday, January 27, 2009 11:45 AM
  • Hali,

     

    Nincs. Ami van azzal már találkoztál itt:

    http://forums.microsoft.com/TechNet-HU/ShowPost.aspx?PostID=4313752&SiteID=52

     

    üdv,

    Zoli

     

    Tuesday, January 27, 2009 12:35 PM