none
Error de Aplicacion en el servidor

    Question

  • Buenas tardes mi nombre es Jose Garcia, les comento lo que me pasa con el servidro haber si alguien puede ayudarme:

    Bueno tengo un servidor con S.O. Windows Server 2008 R2 Fundation y tengo instalada una aplicacion web desarrollada en visual estudio 2008, lo que pasa es que cuando instalo la aplicacion, lo hace todo correctamente, me deja instalar, y ejecutar la aplicacion despues de unos dias me marca el siguiente error:

    Error de Servidor en la aplicacion web, Error de Tiempo de Ejecucion

    Descripción: Error de aplicación en el servidor. La configuración actual de errores personalizados de esta aplicación evita que se muestren los detalles del error de la aplicación de manera remota (por razones de seguridad). Sin embargo, se pueden ver los detalles en los exploradores que se ejecuten localmente en el servidor

    Esta es la segunda vez que me pasa pense que era porque el servidor se habia actualizado y eso podia causarme conflictos con los permisos de la aplicacion pero esta vez formatee el servidor le volvi a instalar el mismo S.O y ahora lo puse para que no se actalizara per el mismo error me salio nuevamente, no se que pueda causar ese erro, alguien tiene alguna idea?????

    Monday, March 14, 2011 9:32 PM

Answers

  • ¿No tienes acceso a las paginas .asp?

    Olvida lo de depurar que creí que eran aspx y podrias depurarlo en VS, para poder solucionar el problema es necesario que tengas acceso al código de la página y comprobar las consultas que se ejecutan en esta, ya que parece que el problema viene ocasionado por un error en la sintaxis de un comando sql.

    Un saludo.


    http://www.lopezatienza.es
    Wednesday, March 23, 2011 10:26 PM

All replies

  • Todo da para pensar que el problema está en la aplicación

    ¿Has ejecutado el explorador localmente como sugiere el mensaje para poder ver el error?

     


    Guillermo Delprato - Buenos Aires, Argentina
    Visite Notas Windows Server
    MVP-MCT-MCSE-MCSA MCITP: Enterprise/Server Administrator MCTS: Active Directory/Network/Applications Configuration
    Este mensaje se proporciona "como está" sin garantías de ninguna clase. Usted asume todos los riesgos.
    Tuesday, March 15, 2011 8:06 PM
  • Se rompio el hdd del server 2003 y no tenian copia de seguridad, no sabian como se llamaba el server ni configuracion que llevaba.

    Es una aplicacion que corre a traves de un server 2003 que esta hecha en .asp los clientes acceden a traves de una direccion ip server/configuracion.asp ya configurado por fin el iis nos conectaba a la pagina pero en el momento el logueo nos salia el siguiente error.

    Tras solucionar el error siguiente:

    No existe el servidor SQL Server o se ha denegado el acceso al mismo. (problema del nombre del servidor)

    Me aparece el siguiente error cuando en dicha web meto el usuario y contraseña para acceder a la base de datos.

    Driver={SQL Server};Server=SERVIDOR;uid=peluquero;pwd=peluquero;Database=TLRT_PadreColoma
    Microsoft OLE DB Provider for ODBC Drivers error '80040e4d'

    [Microsoft][ODBC SQL Server Driver][SQL Server]Error de inicio de sesión del usuario 'peluquero'.

    /TLRT_PadreColoma/conexion.asp, línea 63

    Alguien sabe de que puede ser ?

     

    un saludo

    Tuesday, March 15, 2011 8:16 PM
  • Como comenta Guillermo, si accedes a la aplicación web desde el propio servidor, te mostrará el error en todo su esplendor.

    El problema puede venir ocasionado por muchas razones, el Servicio de SQL Server, Mysql.. no está inciado porque no esté configurado el Inicio de sesión, alguna dll no está registrada, el típico fallo de que no tenga permisos el usuario ASPNET, o simplemente algún fallo de programación..

    Ejecuta la aplicación directamente en el servidor y seguramente verás la luz.

    Tuesday, March 15, 2011 11:23 PM
  • buenas lopeztienza. el fallo de que el usuario no tenga permisos aspnet me pasa a mi pero no se como resolverlo es el error que me da. haber si me puedes ayudar.

     

    un saludo

    Tuesday, March 15, 2011 11:50 PM
  • Hola mexposito.

    Si no te importa pégame aquí el error que te da para poder asesorarte con más exactitud.

    Es posible que sea un fallo en el mismo Web.config

    ¿Que tipo de autenticación tienes configurado en el Sitio Web del IIS?

    Un saludo!


    http://www.lopezatienza.es
    Wednesday, March 16, 2011 7:38 AM
  • Hola mexposito.

    Si no te importa pégame aquí el error que te da para poder asesorarte con más exactitud.

    Es posible que sea un fallo en el mismo Web.config

    ¿Que tipo de autenticación tienes configurado en el Sitio Web del IIS?

    Un saludo!


    http://www.lopezatienza.es

    Me aparece el siguiente error cuando en dicha web meto el usuario y contraseña para acceder a la base de datos.

    Driver={SQL Server};Server=SERVIDOR;uid=peluquero;pwd=peluquero;Database=TLRT_PadreColoma
    Microsoft OLE DB Provider for ODBC Drivers error '80040e4d'

    [Microsoft][ODBC SQL Server Driver][SQL Server]Error de inicio de sesión del usuario 'peluquero'.

    /TLRT_PadreColoma/conexion.asp, línea 63.

    esta como mixta

    Wednesday, March 16, 2011 8:51 AM
  • ¿Has añadido el inicio de sesión del usuario "peluquero" en la base de datos "TLRT_PadreColoma"?

    ¿Que versión tiene la instancia de SQL Server?

    Después de habilitar el inicio de sesión deberás darle permisos de lectura al usuario en las tablas a las que necesites obtener datos.

    Comentame.


    http://www.lopezatienza.es
    Wednesday, March 16, 2011 9:49 AM
  • ¿Has añadido el inicio de sesión del usuario "peluquero" en la base de datos "TLRT_PadreColoma"?

    ¿Que versión tiene la instancia de SQL Server?

    Es posible que tengas que darle permisos de lectura al usuario en las tablas a las que tengas acceso.

    Comentame.


    http://www.lopezatienza.es


    Esque de sql mas bien poco entiendo.

    yo me meto en dicha tabla y voi a usuarios y me aparecen 3 usuarios y uno de ellos es peluquero pero ellos entran con torta1 no se porque aparece lo de peluquero como usuario

    Wednesday, March 16, 2011 9:54 AM
  • esta instalado sql2000
    Wednesday, March 16, 2011 9:58 AM
  • Que instancia tienes de SQL Server para guiarte en cómo habilitar el inicio de sesión al usuario "peluquero".

    Un saludo.

     


    http://www.lopezatienza.es
    Wednesday, March 16, 2011 10:02 AM
  • Que instancia tienes de SQL Server para guiarte en cómo habilitar el inicio de sesión al usuario "peluquero".

    Un saludo.

     


    http://www.lopezatienza.es
    como se mira la instancia?
    Wednesday, March 16, 2011 10:15 AM
  • Buenas mexposito.

    Con saber si es SQL Server 2000, 2005, 2008 es suficiente, principalmente para saber el SQL Server Management Studio que tienes instalado para orientarte.

    Un saludo.


    http://www.lopezatienza.es
    Wednesday, March 16, 2011 10:47 AM
  • sql server 2000.

     

    Wednesday, March 16, 2011 11:20 AM
  • Dentro de SQL Server Enterprise Manager, sigue los siguientes pasos:

    - Inicia sesión en la instancia desea con el usuario sa o algun usuario que tenga permisos.

    - Expande las opciones y busca una opcion que se llama Seguridad, y dentro de esta Inicios de sesión, pulsa botón derecho encima y selecciona Nuevo inicio de sesión...

    - Introduce el nombre del usuario en cuestión y marca Autenticación de SQL Server y ponle la contraseña.

    - Selecciona la base de datos Predeterminada.

    - Acepta para finalizar.

    - Me parece que debe aparecerte ahora otra ventana con las Propiedades de inicio de sesión, asegúrate que tienes permisos de lectura en las tablas que necesites.

    Sigue las indicaciones y coméntame.

    Un saludo.

     


    http://www.lopezatienza.es
    Wednesday, March 16, 2011 12:03 PM
  • Dentro de SQL Server Enterprise Manager, sigue los siguientes pasos:

    - Inicia sesión en la instancia desea con el usuario sa o algun usuario que tenga permisos.

    - Expande las opciones y busca una opcion que se llama Seguridad, y dentro de esta Inicios de sesión, pulsa botón derecho encima y selecciona Nuevo inicio de sesión...

    - Introduce el nombre del usuario en cuestión y marca Autenticación de SQL Server y ponle la contraseña.

    - Selecciona la base de datos Predeterminada.

    - Acepta para finalizar.

    - Me parece que debe aparecerte ahora otra ventana con las Propiedades de inicio de sesión, asegúrate que tienes permisos de lectura en las tablas que necesites.

    Sigue las indicaciones y coméntame.

    Un saludo.

     


    http://www.lopezatienza.es


    Haber desinstale el SQL y lo e vuelto a instalar.

    - Abro el administrador corportivo

    - añado de nuevo la base de datos

    -llego hasta la pestaña de seguridad inicios de sesion y creo un inicio de sesion nuevo, seleccion el usuario local que habia creado que se llama torta1 con permisos de usuario y administrador.

    -marco la autentificacion y pongo una contraseña

    - selecciono la base de datos que quiero

    - ACepto y finalizo

    Entro desde el server para probar a la direccionhttp:\\ipservidor\nombre de la carpeta\conexion.asp y me logueo pero me da el mismo error del usuario peluquero yyo entro con torta1 que es como me han dicho que han entrado siempre.

    Wednesday, March 16, 2011 12:40 PM
  • Ten en cuenta que en el ConnectionString que utilizar, usas el nombre de usuario "uid:peluquero" contraseña "pwd=peluquero"

    Driver={SQL Server};Server=SERVIDOR;uid=peluquero;pwd=peluquero;Database=TLRT_PadreColoma
    Microsoft OLE DB Provider for ODBC Drivers error '80040e4d'

    Debes cambiar el nombre de usuario y la contraseña por la que acabas de crear para poder iniciar sesión.

    Para asegurarte que el ConnectionString que utilizas es correcto, crealo de la siguiente forma:

    http://www.lopezatienza.es/sin-categoria/bases-de-datos-creacion-de-connectionstring-rapida/

    Es una forma muy sencilla y rápida.

    Si tienes dudas de crear el ConnectionString coméntame.

    Un saludo.


    http://www.lopezatienza.es
    Wednesday, March 16, 2011 12:49 PM
  • buenas.

    hize el connectonstring, me da conexion satsifactoria.

    cuando voy a crear el inicio de sesion con peluquero me dice que usuario ya existe, me voy a usuarios de la base de datosy esta alli, segun he leido por ai hay que eliminarlo con un script pero no lo encuentro.

    saludos

     

    Thursday, March 17, 2011 9:02 AM
  • te voy a copiar el fichero al cual los clientes hacen la llamada.

    http:\\ipserver\nombrebasedatos\conexion.asp.

    te copio el contenido del .asp para que veas y si ai algo mal.

    d<html>
        <head>
            <title>Pantalla de Empresa </title>
            <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
            <LINK href="css/tablas.css" type="text/css" rel="stylesheet">
                <script language="JavaScript" src="js/ir.js"></script>
                <%
        dim login
    %>
            <!--body BACKGROUND="imagenes/FONDOCONFERENCIA3.jpg" class="BODY"--></head>
        <body class="BODY" bgColor="red" background="imagenes/BroadnetLogo2.jpg">
            <%

    setlocale("en-us")

            'Session.abandon
            login=request.form("login")
            password=request.form("password")
           
            'ip=Request.ServerVariables("REMOTE_ADDR")
           
            ip="192.168.0.255"
           
           
            'response.Write(ip)


            'response.write("login="&login&"<br>")
            'response.write("Password="&password&"<br>")
            'response.write("Acceso="&acceso&"<br>")
            'response.write("Primera="&primera&"<br>")
                   
            if login<>"" and password<>"" then
                   
                'modo = "rdifusion"
                modo = "contabilidad"
               
                session("servidor") = "SERVIDOR"
                NombreBBDD = "TLRT_PadreColoma"
                NombreBBDDContab = "TLRT_PadreColoma_Contab"
               
                if modo = "rdifusion" then

                    conexion_peluquero =  "Driver={SQL Server};Server=" & session("servidor") & ";uid=peluquero;pwd=peluquero;Database=" & NombreBBDD
                    conexion_contabilidad =  "Driver={SQL Server};Server=" & session("servidor") & ";uid=peluquero;pwd=peluquero;Database=" & NombreBBDDContab
               
                end if

                if modo = "contabilidad" then

                    'conexion_peluquero =  "Driver={SQL Server};Server=" & session("servidor") & ";uid=peluquero;pwd=peluquero;Database=" & NombreBBDDContab
                    conexion_peluquero =  "Driver={SQL Server};Server=" & session("servidor") & ";uid=peluquero;pwd=peluquero;Database=" & NombreBBDD
                    conexion_contabilidad =  "Driver={SQL Server};Server=" & session("servidor") & ";uid=peluquero;pwd=peluquero;Database=" & NombreBBDD
               
                end if

                ' ABRIMOS BASE DE DATOS
                Server.ScriptTimeout=1800
                Session.Timeout=240
               
                Set ConnSQL_bdgis = Server.CreateObject("ADODB.Connection")
                response.Write(conexion_peluquero)
                ConnSQL_bdgis.Open conexion_peluquero
       
                set Rs = server.CreateObject("ADODB.Recordset")
                rs.CursorLocation = 3    ' Tipo Cliente
                rs.CursorType = 1        '
                rs.LockType = 3            ' Optimista
                rs.Open "SELECT * FROM vista_usuarios WHERE cenborrado=0 AND login='"& login & "' AND borrado=0",ConnSQL_bdgis

                ' ESTO ES PARA QUE NO CASQUE LA PRIMERA VEZ O CUANDO
                ' NO ENCUENTRE UN USUARIO
                if rs.EOF or rs.BOF then
                    ACCESO=false
                    'Response.Write "USUARIO NO EXISTE"
                    rs.close
                    ConnSQL_bdgis.close   
                else
                    if rs.Fields("password")=password then
                        ACCESO=true
                        session("acceso")=true
                 
                        MES = Month(Date)
                        if MES < 10 then MES="0"&MES end if
                        DIA = Day(Date)
                        if DIA < 10 then DIA="0"&DIA end if
                        fecha=Year(Date)&"/"& MES &"/"& DIA

                        hora=FormatDateTime(Time(),4)
                            
        
                         '### Establecer hora teorica
                         if hora < "06:00" then
                            anio2 = year(DateAdd("d",-1,fecha))
                           
                            mes2 = month(DateAdd("d",-1,fecha))
                            if mes2 < 10 then mes2="0"&mes2 end if
                           
                            dia2 = day(DateAdd("d",-1,fecha))
                            if dia2 < 10 then dia2="0"&dia2 end if
                           
                            fecha_teorica =  anio2 &"/" &mes2 & "/" & dia2
                           
                        else
                            fecha_teorica = fecha
                        end if
                            
                             Session("fechateorica") = fecha_teorica
                            
                             response.write fecha_teorica
                            
                            
                            
                        entradas=rs.Fields("entradas")
                        entradas = entradas+1
                 
                        idusuario = rs.Fields("idusuario")

                        Session("login") = login
                        Session("password") = password
                       
                        Session("maquina") = Request.ServerVariables("REMOTE_HOST")
                       
                        If session("maquina") = "" then
                            session("maquina") = Request.ServerVariables ("REMOTE_ADDR")
                        end if

                        session("maquina") = "255.255.255.255"

                       
                        Session("idusuario") = rs.Fields("idusuario")
                        session("idinstitucion") = rs.Fields("idinstitucion")
                        session("institucion") = rs.Fields("nombreinstitucion")
                        session("idtipoiva") = rs.Fields("idtipoiva")
                        session("idgruposervicio") = rs.Fields("idgruposervicio")
                       
                        session("administracion") = 1
                        session("recepcion") = 1
                        session("clientes") = 1
                        session("almacen") = 1
                        session("informes") = 1
                        session("contabilidad") = 1
                        session("pedidos") = 1
                        session("procesos") = 1
                        session("marketing") = 1
                        session("catalogo") = 1
                        session("numcentro") = rs.fields("numcentro")
                        session("ano") = rs.Fields("ano")
                       

                       
                       
                        ' Variables de conexión a DATABASES de SQL SERVER             
                        Session("conexion_peluquero") = conexion_peluquero
                        Session("conexion_contabilidad") = conexion_contabilidad
                 
                        ' ESTABLECEMOS EL TIPO DE nivel QUE TENEMOS
                        if (Rs.Fields("nivel"))<>"" then
                            Session("nivel")= cstr(rs.Fields("nivel"))
                   
                        else
                            Session("nivel")= "7"    ' RESTRINGIDO
                        end if
                       
                        rs.close   
                       
                        sql = "UPDATE usuarios SET entradas='" & entradas & "', fecha_entrada='" & fecha & "', hora_entrada='" & hora & "' WHERE idusuario='" & idusuario & "';"
                        'response.Write(sql)
                        rs.Open sql, connsql_bdgis

                        'rs.Fields("fecha_entrada")=fecha
                        'rs.Fields("hora_entrada")=hora
                        'rs.Fields("entradas") = entradas
                        'rs.Update


                        sql = "INSERT INTO entradas_usuarios (fecha, hora, idusuario, ip) VALUES ('" & fecha & "','" & hora & "','" & session("idusuario") & "','" & ip & "');"
                        'response.Write(sql)
                        rs.Open sql, connsql_bdgis
                       
                        ConnSQL_bdgis.close

                        'Response.Write "ACCESO PERMITIDO"
                        Session("acceso")=true
                        'Response.redirect "viewer.asp"
                       
                        if session("nivel")<1000 then %>
            <script>
                //parent.location="jframeset.asp"
                var now = new Date();
                screenW = screen.width;
                screenH = screen.height-20;     
                mainW = window.open ("jframeset.asp","empresa"+now.getSeconds() ,"height="+screenH+",width="+screenW+",top=0,left=0,status=yes,fullscreen=no");
                 window.opener = top;
                window.close();      
            </script>
            <%

                        else %>
            <script> //parent.location="distribuidor.asp"
            </script>
            <%

                        end if
                    else
                        ACCESO=false
                        ' NO PONGO NINGUNA VARIABLE DE SESSION PORQUE SINO
                        ' ME DA COMO EJECUTADO EL SESSION_ON START
                        ' Y NO NOS INTERESA ESO!!!
                        rs.close
                        ConnSQL_bdgis.close   
                    end if
                end if
           


                ' Si no podemos acceder que pregunte de nuevo usuario y password
                if not ACCESO Then
                    %>
            <script> parent.location="conexion.asp" </script>
            <%
                End if
           
            end if
        %>
            <form name="conexion" action="conexion.asp" method="post" target="_top">
                <input type="hidden" name="ip">
                <div id="tablamarco" style="Z-INDEX: 2; LEFT: 260px; WIDTH: 435px; POSITION: relative; TOP: 190px; HEIGHT: 100px">
                    <table class="texto  pes" height="20%" cellSpacing="0" cellPadding="0" width="100%" align="center"
                        border="0">
                        <!--CABECERA DEL PRICIPAL FRAME-->
                        <tr>
                            <td>
                                <TABLE cellSpacing="0" cellPadding="0" bgColor="#ffffff" border="0">
                                    <TR class="textopes" bgColor="red">
                                        <td align="left" width="18" background="imagenes/roundleft.gif">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
                                        </td>
                                        <td align="center" width="200" bgColor="#ffffff"><font color="red"><b>Pantalla de Inicio</b></font></B>
                                        </td>
                                        <td width="18" background="imagenes/roundright.gif">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
                                        </td>
                                        <td></td>
                                        <td width="18"></td>
                                    </TR>
                                </TABLE>
                            </td>
                        </tr>
                        <tr vAlign="top" height="100%">
                            <td class="TABLAMEDIO">
                                <table height="30%" width="100%" align="center" bgColor="#ffffff" border="0">
                                    <tr>
                                        <td vAlign="middle" align="center" bgColor="red"><IMG id="IMG1" src="images/logo_telericatorta.jpg">
                                        </td>
                                    </tr>
                                    <tr>
                                        <td vAlign="middle" align="center" bgColor="#ffa19b">
                                            <table class="TABLADATOS" height="100%" cellSpacing="3" cellPadding="0" width="100%" border="0">
                                                <tr>
                                                    <td width="40%" colSpan="1" height="18" rowSpan="1">
                                                        <div align="right">Nombre de Usuario</div>
                                                    </td>
                                                    <td width="60%" height="18"><input class="CAJAS" type="text" name="login">
                                                    </td>
                                                </tr>
                                                <tr>
                                                    <td width="40%">
                                                        <div align="right">Contraseña</div>
                                                    </td>
                                                    <td width="60%"><input class="CAJAS" type="password" name="password">
                                                    </td>
                                                </tr>
                                                <tr>
                                                    <td width="60%" colSpan="2"><div align="right"><input class="CONECTAR" type="submit" value="Buscar" name="busqueda">
                                                        </div>
                                                    </td>
                                                </tr>
                                            </table>
                                        </td>
                                    </tr>
                                </table>
                            </td>
                        </tr>
                        <tr>
                            <td>
                                <TABLE cellSpacing="0" cellPadding="0">
                                    <TR class="TABLAPRINCIPAL" height="15">
                                        <td align="left" width="18" background="imagenes/roundleftdown.gif" bgColor="red">&nbsp;&nbsp;&nbsp;
                                        </td>
                                        <td align="right" width="100%"><b><font Color="red">Telericatorta - Alborgis</font></b>&nbsp;
                                        </td>
                                        <td width="18" background="imagenes/roundrightdown.gif" bgColor="red">&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;
                                        </td>
                                    </TR>
                                </TABLE>
                            </td>
                        </tr>
                    </table>
                </div>
            </form>
            <script>
    //alert("<% =Request.ServerVariables("REMOTE_ADDR") %>");

    document.conexion.login.focus();
                                       
                                
                                       
    function avanza(){
        //window.location="jframeset.html";
    }
            </script>
        </body>
    </html>

    Thursday, March 17, 2011 11:10 AM
  • Buenas mexposito.

    No estoy seguro si te estoy entendiendo mal, explicame una cosa.

    El usuario "peluquero" al que haces referencia es un Inicio de sesión en la base de datos o un registro de la vista "vista_usuarios" de la base de datos.

    Tienes que diferenciar entre el Usuario que inicia sesión en la base de datos, necesario para el ConnectionString (que te hice una guia un poco más arriba de cómo hacerlo, que veo que lo conseguiste), y aparte el Usuario que inicia sesión en el Sitio Web, que me figuro que cuando inicias sesión se hace una comprobación en una base de datos.

    Debes usar el usuario y la contraseña de Inicio de sesión únicamente en el ConnectionString para conseguir conectar y luego en la página asp, utilizar un usuario que esté registrado en la base de datos.

    No estoy seguro si es lo que te pasa.

    Comentame.


    http://www.lopezatienza.es
    Thursday, March 17, 2011 11:31 AM
  • Buenas mexposito.

    No estoy seguro si te estoy entendiendo mal, explicame una cosa.

    El usuario "peluquero" al que haces referencia es un Inicio de sesión en la base de datos o un registro de la vista "vista_usuarios" de la base de datos.

    Tienes que diferenciar entre el Usuario que inicia sesión en la base de datos, necesario para el ConnectionString (que te hice una guia un poco más arriba de cómo hacerlo, que veo que lo conseguiste), y aparte el Usuario que inicia sesión en el Sitio Web, que me figuro que cuando inicias sesión se hace una comprobación en una base de datos.

    Debes usar el usuario y la contraseña de Inicio de sesión únicamente en el ConnectionString para conseguir conectar y luego en la página asp, utilizar un usuario que esté registrado en la base de datos.

    No estoy seguro si es lo que te pasa.

    Comentame.


    http://www.lopezatienza.es


    el usuario peluquero esta creado en usuarios de la base de datos junto a dbo.

    ellos para entrar en la sesion entran con torta1 que es el que use para el connectionstring que es el que esta creado en la tabla dentro de usuarios

    Thursday, March 17, 2011 11:35 AM
  • Aver, en el formulario de inicio de sesión, debe iniciar sesión:

    Usuario: UsuarioX

    Contraseña: ContraseñaX

    Estos datos deben estar en la tabla "Usuarios", o no se como se llamará, como un registro como..

    TEMPLEADOS

    LOGIN       NOMBRE     APELLIDOS      DNI               CONTRASEÑA

    UsuarioX    Pepito        Lopez              23423487S     ContraseñaX

    UsuarioY    Manolito      Perez              23344334A    ContraseñaY

    Luego en los ConnectionStrings tienes q poner el usuario "peluquero" con la contraseña que le establecieras.

    Tienes que diferenciar entre Inicio de sesión en la Aplicación Web y Inicio de sesión en la Base de Datos .

    Un saludo.

     


    http://www.lopezatienza.es
    • Proposed as answer by mexposito Thursday, March 17, 2011 4:03 PM
    Thursday, March 17, 2011 12:56 PM
  • La creacion de usuario no tiene que ser a nivel windows no?

    bueno creo el usuario peluquero dentro del administrador de sql entrerprise managament dentro de la base de datos-usuarios y ai esta peluquero.

    En el connection setting lo habia exo con sa y salia perfecto.

    Cuando lo hago con peluquero voy a desplegar el nombre de la bbdd me dice:

    error inciio sesion usuario peluquero.

    que toy haciendo mal? como creo un usuario nuevo de 0? elimino este de peluquero y que pasos debo de seguir para que los usuarios entren en la aplicacion no lo entiendo de sql no conozco nada.

    un saludo

    Thursday, March 17, 2011 3:36 PM
  • ahora ya me funciona peluquero con el connectionstring
    Thursday, March 17, 2011 3:53 PM
  • lopezatienza ya esta solucionado el problema estaba en que el usuario de alli habia metido la mano en el conexion.asp y hbaia puesto user dbo e modificado el fichero por peluquero y todo ha tirado.

    muchas gracias por tu atencion y tu paciencia.

    un saludo

    Thursday, March 17, 2011 4:03 PM
  • parecia que estaba todo solucionado pero cuando voi a meter un pedido me da este error ya consegui que entrase en la base de datos y me la mostrase y navegar por ella pero ahora me da este error

    Microsoft OLE DB Provider for ODBC Drivers error '80040e14'

    [Microsoft][ODBC SQL Server Driver][SQL Server]Línea 1: sintaxis incorrecta cerca de '85'.

    /TLRT_PadreColoma/jpedido.asp, línea 628

    Thursday, March 17, 2011 11:26 PM
  • Hola Mexposito

    Lo que suena es un problema de string para conexión con banco de datos.

    Lo mejor es cambiar para el foro de SQL o de ASP.Net

    Como sigue el tema?

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    Monday, March 21, 2011 6:25 PM
  • sigue igual el problema ismael

    saludos

    Tuesday, March 22, 2011 11:40 AM
  • Hola mexposito

    Entonces mejor plantear una nueva pregunta en el foro de ASP.Net

    http://social.msdn.microsoft.com/Forums/es-es/netfxwebes/threads

    Saludos


    Ismael Borche - LATAM Forum Support Engineer
    Microsoft Corporation
    Tuesday, March 22, 2011 5:11 PM
  • Buenas mexposito.

    He estado de viaje y no he podido acceder en estos dias.

    Me alegro que solucionaras el tema de la autenticación.

    Tiene pinta de que alguna consulta sql de la página "jpedido.asp" esté mal montada.

    Prueba a depurar la página y comprueba las variables donde almacenas las consultas; en tiempo de ejecución, copia el contenido de estas variables y trata de ejecutarlas desde el SGBD.

    Un saludo.


    http://www.lopezatienza.es
    Wednesday, March 23, 2011 11:05 AM
  • Buenas mexposito.

    He estado de viaje y no he podido acceder en estos dias.

    Me alegro que solucionaras el tema de la autenticación.

    Tiene pinta de que alguna consulta sql de la página "jpedido.asp" esté mal montada.

    Prueba a depurar la página y comprueba las variables donde almacenas las consultas; en tiempo de ejecución, copia el contenido de estas variables y trata de ejecutarlas desde el SGBD.

    Un saludo.


    http://www.lopezatienza.es

    buenas lopezatienza.

    no te preocupes no pasa nada.

    el tema supongo que esta en el jpedido.asp, pero lo que me comentas no se como verificarlo que sql y de como esta generado el fichero .asp y no se como verficarlo.

    muchas gracias y un saludo

    Wednesday, March 23, 2011 5:53 PM
  • ¿No tienes acceso a las paginas .asp?

    Olvida lo de depurar que creí que eran aspx y podrias depurarlo en VS, para poder solucionar el problema es necesario que tengas acceso al código de la página y comprobar las consultas que se ejecutan en esta, ya que parece que el problema viene ocasionado por un error en la sintaxis de un comando sql.

    Un saludo.


    http://www.lopezatienza.es
    Wednesday, March 23, 2011 10:26 PM