none
msisadrv.sys file missing or corrupt

    Question

  • Hello,

    I have a customised XP wim which i'm trying to deploy & then capture with the new sata drivers. But i keep getting the error in blank screen saying "windows could not start because the following file is missing or corrupt: system32\DRIVERS\msisadrv.sys". I have selected the standard client task sequence. Please suggest!!

    Friday, August 12, 2011 12:32 AM

Answers

  • Do you have a customised XP in wim format that was captured using MDT? What did you do for your sysprep? The sysprep need the sata drivers prepared.

    You can do this with MDT. Before captureing XP create a seletion profile with your sata drivers selected. Then use the name of that profile in the variable torageDriverSysPrepGroup001. Finaly capture your image.

    customsettings.ini example would be if your selection profile is named MSISata

    [Settings]
    Priority=Default
    [Default]
    StorageDriverSysPrepGroup001=MSISata
    OSInstall=YES
    JOINWorkGroup=Workgroup
    UserDataLocation=NONE

     

    • Marked as answer by TMishra Monday, March 05, 2012 7:24 PM
    Friday, August 12, 2011 8:40 AM

All replies

  • Do you have a customised XP in wim format that was captured using MDT? What did you do for your sysprep? The sysprep need the sata drivers prepared.

    You can do this with MDT. Before captureing XP create a seletion profile with your sata drivers selected. Then use the name of that profile in the variable torageDriverSysPrepGroup001. Finaly capture your image.

    customsettings.ini example would be if your selection profile is named MSISata

    [Settings]
    Priority=Default
    [Default]
    StorageDriverSysPrepGroup001=MSISata
    OSInstall=YES
    JOINWorkGroup=Workgroup
    UserDataLocation=NONE

     

    • Marked as answer by TMishra Monday, March 05, 2012 7:24 PM
    Friday, August 12, 2011 8:40 AM
  • Thanks Michael....i'll surely try that out.

    But i figured out that the wim file i was using was corrupt so was getting the msisadrv.sys file missing or corrupt error.

    Friday, August 12, 2011 10:58 PM