none
Copy/Paste stops working on certain RDP Sessions

    Question

  • I have done a bunch of searching on this and havn't found an answer to my exact problem.

    Running Windows 7 Professional, Copy and Paste works fine, until I open a remote desktop to one certain VM (lets call it VM1), all other RDP sessions work fine.

    If I close the remote desktop to VM1, my copy and paste starts working on my desktop.  If I open an RDP to another VM (lets call it VM2) my copy and paste works fine.

    I have run sfc /scannow on my desktop but nothing has shown up.

    I am confused as to why this one RDP causes my copy and paste to stop working.


    • Edited by SheacS Friday, September 27, 2013 2:46 PM
    Friday, September 27, 2013 2:42 PM

All replies

  • Hi,

    Whether or not you are using shortcuts instead of manually input the taget computer when trying to do a remote?

    If so, please help check the settings of RDC which connect to VM1:

    1. Open MSTSC in Start - Run (Remote Desktop Connection)

    2. Go to Local Resources tab, check Apply Windows key combinations is selected as Only when using the full screen or On the remote computer.

    3. Check if Clipboard under Local devices and resources is also selected. 


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Monday, September 30, 2013 11:46 AM
    Moderator
  • I have tried setting Only when using the full screen and On the remote computer both are not working.

    I have also tried this with a windowed RDP session (assuming the only when using the full screen actually means that) and no go.

    Chris.

    Monday, September 30, 2013 6:14 PM
  • Hi Chris,

    when using full screen means click on the Maximums button to make it full screen.

    If all settings are correct, please test:

    1. If copy/paste will work in a Notepad.

    2.  Go to Task Manager, end the process rdpclip.exe, changing focus from task manager to another program and back to task manager, choose file>new task (Run) and then typing in rdpclip.exe and hit enter.  This will restart clipboard. See if issue still exists. 


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Wednesday, October 02, 2013 9:20 AM
    Moderator
  • I have tried the rdpclip.exe kill and restart (found that before posting this question).  Like I said it is with only one RDP session, all other RDP sessions work fine.
    Wednesday, October 02, 2013 1:16 PM