none
Windows 8 + UEFI BIOS, “UEFI Firmware Settings” Missing

    Question

  • Originally installed Windows 8 (non-UEFI install) with a GA-Z68MA-D2H-B3 motherboard. 

    After upgrading the BIOS to a UEFI version and enabling some fast-boot settings and Windows 8 integration, the system boots to the OS extremely fast. However, I found that the "UEFI Firmware Settings" option is missing from the Windows advanced startup options. Also note, boot loader path is \Windows\system32\winload.exe. 

    Is there a method that allows for changing/enabling the UEFI Firmware Settings menu entry?

    I'm even willing to reinstall the OS, though I also can't seem to boot from CD/DVD at this point.
    Friday, March 29, 2013 7:16 PM

Answers

  • I also posted this question on superuser.com and actually got a good answer/solution.

    Original Question Post + Answer: http://superuser.com/questions/575063/windows-8-uefi-bios-uefi-firmware-settings-missing

    Link with Solution: https://gitorious.org/tianocore_uefi_duet_builds/pages/Windows_x64_BIOS_to_UEFI

    In the end, I actually resorted to removing my CMOS battery for a while to restore the BIOS settings to optimized defaults... this allowed getting things out of "Ultra Fast Boot" mode for the time being. After that, because I've got a good backup solution in place, I decided to just reinstall the OS entirely and restore my data. After all was said and done, the Ultra Fast Boot setting was actually significantly more delayed with a proper UEFI install than it was previously... still a relatively fast boot time though.

    • Marked as answer by jimmy_nimmo Tuesday, April 02, 2013 3:35 PM
    Monday, April 01, 2013 3:36 AM

All replies

  • I also posted this question on superuser.com and actually got a good answer/solution.

    Original Question Post + Answer: http://superuser.com/questions/575063/windows-8-uefi-bios-uefi-firmware-settings-missing

    Link with Solution: https://gitorious.org/tianocore_uefi_duet_builds/pages/Windows_x64_BIOS_to_UEFI

    In the end, I actually resorted to removing my CMOS battery for a while to restore the BIOS settings to optimized defaults... this allowed getting things out of "Ultra Fast Boot" mode for the time being. After that, because I've got a good backup solution in place, I decided to just reinstall the OS entirely and restore my data. After all was said and done, the Ultra Fast Boot setting was actually significantly more delayed with a proper UEFI install than it was previously... still a relatively fast boot time though.

    • Marked as answer by jimmy_nimmo Tuesday, April 02, 2013 3:35 PM
    Monday, April 01, 2013 3:36 AM
  • Hi,

    If the boot loader points to Windows\system32\winload.exe, this means you are using a legacy bios rather than UEFI.


    Juke Chou
    TechNet Community Support

    Tuesday, April 02, 2013 9:16 AM
    Moderator
  • Yes, I'm already pretty clear on that fact. That's why I included that detail. I was asking how to change that though (but already found a solution)
    Tuesday, April 02, 2013 3:35 PM
  • What was the solution? I have the identical situation and can't figure out what to do...?

    Thanx in advance... :D

    Friday, April 26, 2013 2:25 AM
  • Work-around was shutting down, draining flea power, and removing the CMOS battery long enough to reset settings. You could also try cutting power a second or two into boot-up a few times to try to force default settings. Solution that I actually implemented was a reinstall to get a proper UEFI install in place. Check the post I mentioned above on superuser.com too, someone shared an article with a potentially useful solution that wouldn't require a reinstall.
    Friday, April 26, 2013 2:39 AM
  • I did a clean install of 8.0, do still have the Legacy , anyone know exactly how to get the UEFI? I'd appreciate any feedback. thx , And I was remiss I have reinstalled it once to see if I missed something.

    "Opportunity Never Knocks"



    • Edited by KCAPPMAN Thursday, November 14, 2013 6:59 AM
    Thursday, November 14, 2013 6:50 AM
  • A reinstall of what mr. jimm ?

    "Opportunity Never Knocks"

    Thursday, November 14, 2013 6:52 AM
  • A reinstall of the operating system. You'll need to ensure your BIOS actually supports UEFI, then boot from installation media in UEFI mode (my system presented UEFI and non-UEFI versions of each option in the boot menu).
    Saturday, November 16, 2013 4:25 PM