locked
No connection could be made because the target machine actively refused it

    Question

  • the client side error states this when i try to refresh the publishing server


    Application Virtualization Error

    The Application Virtualization Client could not update publishing information from the server vappserv.

     No connection could be made because the target machine actively refused it.

    Error code:450519-190D062A-0000274D




    i am using

    SQL 2005
    Microsoft Application Virtualization RC

    MSAppVirt_management_server_setup_4.5.0.1305
    Name: vappserv
    os: windows server enterprise 2003x86
    IIS 6
    SQL 2005




    I tried everything, windows firewall is off on all the servers and i tried re-installing the virtual application client and the server side multiple times and tried re-installing the application server side and SQL a few times. and i still get the same error. i also uninstall symantec because i thought it might have been blocking the connection.
    Thursday, July 24, 2008 6:48 PM

Answers

  • "Actively refused" means that you got at least as far as a tcp connect packet arriving to the named server.

     

    The first question to ask is what the setting for the publishing server is.  Ultimately, I expect you are using rtsp on port 554 to server vappserv.  Check the publishing server settings to be sure.

     

    Next, run this test from that client to see if the publishing server and service is running.  From a command prompt, issue the following command

    telnet vappserv 554

    Hit the "Enter" key a couple of times.  You get one of two things:

    1. "Could not open connection to ....." message.  This means you either could not reach the server or the MAV service is not running or listening to port 554.
    2. If you get a response with something like "RTSP/1.0 400 Bad Request", that means that the service is running just fine (it simply didn't understand the empty rtsp command you gave it).

     

    You can try this test from different machines when you are concerned about firewall and other blocking issues, including load balancing.

     

    -----------------------------

    PS: You can try this test with rtsps as well.  Just remember the correct port number (322 for version 4.5 and above, 332 for older releases)  You don't get the "RTSP/1.0" response to the Enters, but a lack of "could not open connection" means that you made it.  I have found that a bunch of spaces in a row breaks the connection.

     

     

     

    Friday, July 25, 2008 11:48 AM
    Moderator

All replies

  • "Actively refused" means that you got at least as far as a tcp connect packet arriving to the named server.

     

    The first question to ask is what the setting for the publishing server is.  Ultimately, I expect you are using rtsp on port 554 to server vappserv.  Check the publishing server settings to be sure.

     

    Next, run this test from that client to see if the publishing server and service is running.  From a command prompt, issue the following command

    telnet vappserv 554

    Hit the "Enter" key a couple of times.  You get one of two things:

    1. "Could not open connection to ....." message.  This means you either could not reach the server or the MAV service is not running or listening to port 554.
    2. If you get a response with something like "RTSP/1.0 400 Bad Request", that means that the service is running just fine (it simply didn't understand the empty rtsp command you gave it).

     

    You can try this test from different machines when you are concerned about firewall and other blocking issues, including load balancing.

     

    -----------------------------

    PS: You can try this test with rtsps as well.  Just remember the correct port number (322 for version 4.5 and above, 332 for older releases)  You don't get the "RTSP/1.0" response to the Enters, but a lack of "could not open connection" means that you made it.  I have found that a bunch of spaces in a row breaks the connection.

     

     

     

    Friday, July 25, 2008 11:48 AM
    Moderator
  • alright i got the server to connect using telnet and the desktop icons now appear  when i refresh the publishing server from the client. but when i go to launch the appplication i get the following error

    The Application Virtualization Server has returned an Internal System error

    Error code : 450519-1690630A-20001F4




    other people have stated this error too so i think i should be good if i just read some more threads


    Monday, July 28, 2008 7:29 PM
  • Hi

    I have the same error,

    what i noticed is that even though the server is configured as RTSP, the default package as a URL with RTSPS

    Since the client tries to connect on port 322 the error appears.

    Will check if i find a workaround

    brgds

     

    Wednesday, July 30, 2008 9:09 AM
  •  

    The first place I look when seeing this is the AppVirt Management service. It seems to stop every now and then, especially after each reboot. Just a thought..
    Wednesday, July 30, 2008 6:32 PM
  •  ixtc4233 wrote:

    The first place I look when seeing this is the AppVirt Management service. It seems to stop every now and then, especially after each reboot. Just a thought..

     

    That just should not happen - except in test environments.  2 causes.  1 = can't talk to database because it is not up yet (handle via service dependencies).  2 = running on VMs and cores take too long to start up (handle by not starting multiple VMs at once on underperforming hardware).

    Wednesday, July 30, 2008 10:28 PM
    Moderator
  •  

    Hi

    My problem ended up the client was misconfigured. At install, secure server was choosen and it defaulted to wrong port for all comms.

    hope it helps

    Thursday, July 31, 2008 7:58 AM
  • Thanks Tim, it was number 1 you mentioned. I always seem to forget to setup the service dependancy.

     

     

     

    Friday, August 01, 2008 2:40 PM
  • is there a pdf deployment guide for the 4.5rc because it is very different then soft grid 4.5. does anyone know the system requirements of rc1? and i am running VM in hyper V could this be the cause of everthing connecting correctly and the desktop icons appearing correctly and telnet on the RSTP giving me the error showing the service is running?
    Monday, August 18, 2008 6:35 PM
  • Presumably release quality documentatin will happen with the release, with side pieces that have been promised (such as an updated sizing guide) possibly later.  There is a chm help file in the RC for the client and management console, but you may not find it to be much help.

     

    I can tell you that the training guides that we write for GridMasterTraining have more than doubled in size with the 4.5 release because of all the differences.

    Tuesday, August 19, 2008 1:38 AM
    Moderator
  • alright sweet thanks for the update
    Tuesday, August 19, 2008 4:09 PM
  • Greetings...

     

    I am new to this Virtual app game and I have the same problem as noted in the initial post of this thread.

    The client attempts to load the app and sits at 0% for a period of time then bombs with the error

    message as noted (0000274D).

    I have followed the suggested tests i.e. telnetting etc and all check out successfully.

    However I am unable to proceed past this point.

     

    For reference the test systems are :- 1 physical dual quad core server running Server 2K8 Enterprise x64

    with guest OS of 2K8 x86 and SQL Express 2K5 and the 4.5 App-V server. The clients are a guest

    Vista x86 on the same physical hardware as the server and a separate physical XP 32 bit system.

     

    Any help, information or light that can be shed on this issue would be gratefully accepted.....

     

    Friday, August 22, 2008 11:11 AM
  • Check the log files for more information on this kind of problem.

     

    The Client log is located in the All Users\AppData\SoftGrid Client folder (you may need to enable viewing of hidden system folders in the windows explorer to find it) and should be checked first.  You will find your error at the end of the file.  Also look at the message or two above it for possible hints on the problem.  In particular, the message will specify the protocol (RTSP or RTSPS),  server name, port, and path to the sft file.  Look carefully at each of these for a hint to your problem.

     

    • The sequencer now defaults to RTSPS and port 322.  Did you set up enhanced security or should this be RTSP on port 554?
    • Is the server name what you expect?  The sequencer defaults to use a variable %SFT_SOFTGRIDSERVER% which needs to be changed or added as an environment variable on your systems (can be done via Group Policy Preference).  If a server name is in place was it fully qualified (foo.domain.xxx)?  Whatever is showing here must be pingable as shown (in most environments it doesn't need to be fully qualified, but I have seen some multi-domain environments where that is necessary.
    • Is the path and filename to the sft correct?  The path needs to be relative to the content share.  If the client is talking to the correct server via the correct port, look to that server's log file (under Management Server\Logs) for more detail.  The sft files should be stored in a file share somewhere.  This file share must be readable by the account that the Management Server service runs under.  One possibly newby issue is that the content share should have been defined using the server's management console.  On the left side of the console, right click on the top level item on the left side of that console, select properties.  Specify the path to the content share, as in \\servername\content.  After setting this, you need to restart the service.

     

    If the problem is the first two, you can fix either at the clinet (setting the variable or using an ASR override), or you might need to go back to the server to fix the setting at the source.  This involves using the server management console to modify the application parameters, or editing the OSD, removing and re-importing the package.  I know this paragraph gives a lot of choices without detail or reasons to choose, but "IT DEPENDS".  If this post doesn't help, post the relivant client and server log messages.

     

    Tim Mangan

    TMurgent Technologies - Offering GridMasterTraining for App-V

    Friday, August 22, 2008 1:18 PM
    Moderator
  • Hello again, I'm back...

    I read and digested ( I hope) what you wrote Tim.
    However between then and now I decided to simplify things.
    I built a 2K3 server and deployed the software (as demonstrated on your video part 7) with no problems at all.
    I installed App-V using the latest versions from the Connect site (again).

    I came to the XP client and modified the server and the deleted the app then got the same error as before
    when I ran the Default App. The shortcuts appear in the Start Menu and on the desktop. Connecting to the
    server seems to be fine. So I dug around a bit more and it appears that although I am using RTSP and port 554
    the default app is set to RTSPS and 322.

    From the sftlog.txt file :-

    [08/25/2008 22:23:28:426 AMGR WRN] {tid=A60}
    Attempting Transport Connection
    URL: RTSPS://HYPA32BITTEST:322/DefaultApp.sft

    From the Application Virtualization (need to change that "z" to an "s") Client I see

    URL = rtsp://HypA32BitTest:554

    Does this indicate an issue within the default app or am I off on the wrong track altogether?


    Monday, August 25, 2008 9:51 PM
  • the machine returning the error, No connection could be made because the target machine actively refused it is mostly the server application service not turning on for  some reason so restarting it fixes that issue. other issues i had i over came them. i just got soft grid working 100% streaming and everything. i found out that the package location must be right on the root of  the share and not in any sub folders or it will not load it will just give you some kind of error. i also think alot of people are having problems giving the correct path to each file with the relative path being quit ocward. i think many people havent changed the default app to RSTP instead of it defaulting to RSTPS alos but the main thing i found out is THE CONTANT MUST BE PLACED ON THE ROOT OF THE SHARE WITH correct permissions. has anyone else discovered this bug? because changing the relative path doesnt help this for example..

    works

    share folder:
    \\vappserv\content\
    full path for package file:
    \\vappserv\content\DefaultApp.sft
    relative path: DefaultApp.sft


    i can place the package on the root and it will work fine if i save it somewhere else or move it it wont work for example i place it in a sub folder called test


    dont work

    share folder: \\vappserv\content\
    sub folder: test
    full path for package file:
    \\vappserv\content\test\DefaultApp.sft
    relative path: test\DefaultApp.sft


    and the package will never load client side, is this a bug or a user error?
    Tuesday, August 26, 2008 1:48 AM
  • BrainDeid

     

    Microsoft seemed to make the defaults be to use RTSPS in the release candidate.  In my oppinion this was no more than a misguided application of the "secure by design" principle.  After all, https is not the default for the web browser, is it?

     

    Any way, if you did not install a certificate you have the server using RTSP, so OSDs need to match (or apply an Application Source Root override at each client).

     

    Glad to see you got things moving!

     

    Tuesday, August 26, 2008 2:45 AM
    Moderator
  • B14CKH4WK,

     

    They do not need to be at the root of the content folder.

     

    They path must match that in the CODEBASE line of the OSD file being used.  In your example, for DefaultApp.sft to be in the test folder of the content share, the codebase line of the OSD would be

      RTSP://vappserv:554/test/DefaultApp.sft

    or

     RTSPS://vappserv:322/test/DefaultApp.sft

     

     

    Tuesday, August 26, 2008 2:50 AM
    Moderator
  • I have my default app in it's own folder instead of the root content directory. I usually delete the original Default app in console after installation, create a new folder in content called DefaultApp and moved the four files into it instead of the root. I re-import by OSD, verifiy my paths included the foldername ..defaultapp/defaultapp.osd/ico/sft. This streams fine to my clients.

     

    As far as getting the correct paths right everytime, 2 things need to happen.

    1.  You must have your default content path setup exactly like you want it. Under system options in the console, I use https://Softgrid.company.com/content ..this way, anything I import tacts this to the beginning(HTTP or UNC paths are fine too)

    2. During sequencing, before you save, copy the name of your app to clipboard, go to the next tab and paste the name into the path field. Then when i save it, I create a new folder on the desktop and paste. Under the filename, paste. This way the paths are always consistant. I never have a need to edit my paths ever.

     

    General rule to watch for after importing your apps, if you don't see the icons to the app you imported in the console, might want to check it out. If the path is wrong, you'll see the default orange square icon. (may also just need to refresh the console sometimes)

     

    Next if you swear the path looks right, copy the ico path into the address bar of IE. It should resolve and show the icon in the page. If page not found, better check again. (It can be tricky to visually review the path sometimes with some having long version number, %20 instead of spaces, ect.)

     

    Hope this helps!

     

     

    Tuesday, August 26, 2008 2:54 AM
  • Looks like I spoke too soon.
    When I refresh the Publishing server I also get the dreaded blah blah 0000274D error.

    Tuesday, August 26, 2008 2:01 PM
  • Looks like I am living up to my screen-name.
    Ignore the last post I made. I have the Default App working after modifying the ASR in the registry. The last "error"
    was due to the App Virt. service not having started.

    I'll probably be back with more posts later but in the meantime thanks guys!
    Tuesday, August 26, 2008 11:36 PM
  • Same with me, Insead of configuring the port 554 I had configured it to 544 in the .osd file.

    Thanks alot.
    Sandeep
    Monday, May 11, 2009 10:48 AM
  • We can check whether SQL express is installed on a machine or not and then can install it along with our application.Following is the code sample in VB.NET to implement the same.
    [VB.NET CODE STARTS HERE]
     
    ' Need to add System.Management reference
    Imports System.Management
     
     '   Check if SQL express is already installed in the destination machine
     
        Public Shared Function isExpressInstalled() As Boolean
            Const edition As String = "Express Edition"
            Const instance As String = "MSSQL$SQLEXPRESS"
            Const spLevel As Integer = 1
            Dim fCheckEdition As Boolean = False
            Dim fCheckSpLevel As Boolean = False
            Try
                Dim getSqlExpress As ManagementObjectSearcher = New ManagementObjectSearcher("root\Microsoft\SqlServer\ComputerManagement", "select * from    SqlServiceAdvancedProperty where SQLServiceType = 1 and ServiceName = '" + instance + "' and (PropertyName = 'SKUNAME' or PropertyName = 'SPLEVEL')")
                If getSqlExpress.Get.Count = 0 Then
                    Return False
                End If
                For Each sqlEngine As ManagementObject In getSqlExpress.Get
                    If sqlEngi



    Cheers, Eliza
    Tuesday, March 09, 2010 1:16 PM
  • Try this solution, http://support.microsoft.com/kb/2417815

     

     

    Wednesday, March 30, 2011 8:47 PM