none
Customsettings.ini default values not applied in task sequences

    Question

  • My Customsettings.ini default values are not applied after choosing a task sequence. It looks like it's parsed, but not applied.

    I'm using MDT 2012. I tried to set the  Gather local only attribute in the task sequence to Gather local data and process rules (customsettings.ini) and the default value. I have rebuilt the boot images and my boot media.

    It won't work in all task sequences. Before selecting a TS, it looks like the skip wizard screens are indeed working. After the selection of a TS, I think the values are overwritten, so the wizard pages are added to the left of the wizard. I've made a picture of it (added the files to a dropbox folder below).

    The customsettings.ini file:

    [Settings]
    Priority=Default
    Properties=MyCustomProperty
    
    [Default]
    OSInstall=Y
    _SMSTSOrgName=MyTest USB
    SkipCapture=YES
    
    SkipAdminPassword=YES
    AdminPassword=password
    
    SkipProductKey=NO
    SkipComputerBackup=YES
    SkipBitLocker=YES
    
    SkipDomainMembership=YES
    SkipFinalSummary=NO
    SkipRoles=YES
    SkipTaskSequence=NO
    SkipUserData=YES
    
    ApplyGPOPack=NO
    
    SkipTimeZone=YES
    SkipLocaleSelection=YES
    TimeZoneName=W. Europe Standard Time
    TimeZone=110
    AreaCode=0413
    UserLocale=nl-NL
    InputLocale=nl-US
    KeyboardLocale=0413:00000409 
    
    SkipComputerName=YES
    SkipDomainMembership=YES
    OSDComputerName=WindowsPC
    JoinWorkgroup=WORKGROUP
    

    I've added all relevant log files (and debug of ZTIGather) in my Dropbox folder. If anything else is needed, I can provide this ofcourse.

    https://www.dropbox.com/sh/wy7ojq05p0tonlr/ffHfBkwmwc

    Why is the customsettings.ini not applied? Is it possible to fix this?

    Thanks in advance,

    Bart


    • Edited by BartSG Saturday, August 24, 2013 10:52 PM
    Saturday, August 24, 2013 10:50 PM

Answers

  • Well, for that purpose your .ini-file looks correct, and the wizard should not display the language selection pane.

    From the logs it looks like you are deploying from a media, and a media has it's own CustomSettings.ini file that is different from the one in your deployment share\control folder.

    Did you modify the correct CustomSettings.ini file? The one in your media item?

    Did you update the media afterwards?

    / Johan

    Regards / Johan Arwidmark Twitter: @jarwidmark Blog: http://www.deploymentresearch.com FB: www.facebook.com/deploymentresearch

    • Marked as answer by BartSG Sunday, August 25, 2013 6:08 PM
    Sunday, August 25, 2013 4:22 PM
    Moderator
  • Update 2:

    I  managed to get it working!

    I edited the cs.ini inside the deployement share, however, I had to edit the rules for my media share! I didn't know it had an alternative customsettings.ini.

    Just right click on the media > properties > rules tab.

    Still thanks for your help!

    Bart

    • Marked as answer by BartSG Sunday, August 25, 2013 4:27 PM
    Sunday, August 25, 2013 4:27 PM

All replies

  • The wizard will change panes depending on what you select in the wizard, but wizard settings in the cs.ini file are not re-evaluated after you select a task sequence.

    In addition, most values in the cs.ini file are first writer wins.

    / Johan


    Regards / Johan Arwidmark Twitter: @jarwidmark Blog: http://www.deploymentresearch.com FB: www.facebook.com/deploymentresearch

    Sunday, August 25, 2013 2:01 AM
    Moderator
  • Thanks for your reply.

    Any clue where it could be rewritten? Is it possible to force the cs.ini values?

    Sunday, August 25, 2013 6:06 AM
  • You can customize the wizard, but it's quite painful.

    What is it that you are trying to do? There might be other options available to you.,,

    / Johan


    Regards / Johan Arwidmark Twitter: @jarwidmark Blog: http://www.deploymentresearch.com FB: www.facebook.com/deploymentresearch

    Sunday, August 25, 2013 8:58 AM
    Moderator
  • Exactly that values no apply?

    Region and languages or Hostname or JoinWorkgroud

    / Andrés

    Sunday, August 25, 2013 9:02 AM
  • I don't really need to edit the wizard pages. I just want to skip some of the wizard pages with pre defined values defined in the cs.ini file. For example: I want skip the timezone/language /keyboard layout page. I defined the default values in cs.ini file and the skiptimezone, locale selection etc. The cs.ini file just won't apply to the TS wizard. The timezone and keyboard layout are different values compared to the stated values.

    The pages are not skipped during the wizard.

    Sunday, August 25, 2013 9:38 AM
  • Update:

    I slightly changed the customsettings.ini localeselection settings:

    SkipLocaleSelection=YES
    SkipTimeZone=YES
    TimeZoneName=W. Europe Standard Time
    TimeZone=110
    AreaCode=045
    Language=00000413
    SystemLocale=00000413
    UserLocale=nl-NL
    UILanguage=nl-NL
    InputLocale=nl-US
    KeyboardLocale=nl-US

    It still won't work. I made a new screenshot:

    https://www.dropbox.com/s/zq971ykalxqwi08/Locale%20and%20Time%20page.PNG

    As stated in the cs.ini I would like:

    - to skip the Computer Details page, Move data and settings page, user data (restore) page, Locale and Time page, Administrator Password page. I want to define the needed values in cs.ini.

    - As for the locale and time page, I want to set the timezone to (UTC+1:00) Amsterdam, Berlin, Bern, Rome, Stockholm, Vienna. I would like the keyboard layout US International (nl-US). The language and locale values are already correct.

    Did I miss something important?

    Sunday, August 25, 2013 3:55 PM
  • Well, for that purpose your .ini-file looks correct, and the wizard should not display the language selection pane.

    From the logs it looks like you are deploying from a media, and a media has it's own CustomSettings.ini file that is different from the one in your deployment share\control folder.

    Did you modify the correct CustomSettings.ini file? The one in your media item?

    Did you update the media afterwards?

    / Johan

    Regards / Johan Arwidmark Twitter: @jarwidmark Blog: http://www.deploymentresearch.com FB: www.facebook.com/deploymentresearch

    • Marked as answer by BartSG Sunday, August 25, 2013 6:08 PM
    Sunday, August 25, 2013 4:22 PM
    Moderator
  • Update 2:

    I  managed to get it working!

    I edited the cs.ini inside the deployement share, however, I had to edit the rules for my media share! I didn't know it had an alternative customsettings.ini.

    Just right click on the media > properties > rules tab.

    Still thanks for your help!

    Bart

    • Marked as answer by BartSG Sunday, August 25, 2013 4:27 PM
    Sunday, August 25, 2013 4:27 PM
  • I just saw your comment. You were completely right!

    Thanks!

    Bart

    Sunday, August 25, 2013 6:09 PM