none
Problem with custom Image on MDT2012

    Question

  • Hi,

    I have created a custom Windows 7 x64 Image.

    Image has been updated with apps and WSUS updates, syspreped in audit mode (generalise and OOBE)

    Added custom Wim to MDT, created a catalogue file & unnattended.XML with WSIM.

    Image deploys, runs through installing devices etc and just as you would expect it to finish I get the following error ...

    "Windows could not parse or process unattended answer file [C:\windows\Panther\unattended.xml] for pass [specialize]. A component or setting specified in the answer file does not exist."

    The system ends up in constant reboot cycle when I press ok.

    Where am I going wrong?

    This is the first time I have created a custom W7 image never mind added to MDT :)

    Any help would be appreciated.

    Many thanks,

    Tuesday, May 14, 2013 6:51 PM

Answers

  • Is Internet Explorer 10 in your image by any chance?  IE 10 seems to have issues with IEWelcomeMsg value existing.  You can delete it by:

    • Modifying the Unattend.xml in \Control\<TS ID>\ directly and remove that line.
    • Modify it in WSIM, find the value for it, right click, disable "write image value".


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    • Marked as answer by St4vr0s Wednesday, May 15, 2013 2:36 PM
    Wednesday, May 15, 2013 1:49 PM
    Answerer

All replies

  • When you say "created ... unattended.xml with WSIM", where did you put this Unattend file?  When you create a Task Sequence, MDT will generate an Unattend.xml for you based on a template (which has some required bootstrapping in it).  If you want to edit it with WSIM, you should open the Task Sequence properties, OS Info Tab, and click on 'Edit Unattend.xml'.  This should open it in WSIM.  In WSIM, make sure you use Tools --> Validate Answer File to make sure everything is valid (doesn't assure it will work, just that it's valid).

    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, May 14, 2013 7:03 PM
    Answerer
  • Thanks David,

    I added the custom WIM to my operating systems. I then created a new Standard Task Sequence and pointed to this WIM. When I opened the Task Sequence to edit the unattended XML it generates a catalogue file to use in WISM. The only thing I added was my OEM details.

    I will validate the answer file tomorrow when I'm in the office to check.

    Out of curiosity when I sysprep my "Custom W7 Image" do I have to use an unattended.xml file in the sysprep?

    Ideally when I delete the temporary user profile in Audit mode I would like the sysprepped image when booted to a new PC to include the desktop background, user account picture, custom power profile and any shortcuts I create to the desktop in audit mode.

    What is the best way to achieve this?

    Thanks

    Tuesday, May 14, 2013 10:30 PM
  • No, the unattend.xml is used as a parameter only during unattended installation.

    Are you building your image by hand and then manually capturing it or are you automating the build and capture via a MDT Task Sequence?

    And don't miss this fantastic post about these types of settings and automating them: http://blogs.technet.com/b/deploymentguys/archive/2009/10/29/configuring-default-user-settings-full-update-for-windows-7-and-windows-server-2008-r2.aspx



    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    Tuesday, May 14, 2013 11:07 PM
    Answerer
  • I have validated the answer file and the only errors I have are the following:-

    • Setting IEWelcomeMsg is depreciated in the Windows image.
    • Setting SkipUserOOBE is depreciated in the Windows image.

    The install goes through Installing devices but as soon as it gets to "system is applying settings I get the error.

    Wednesday, May 15, 2013 1:36 PM
  • Is Internet Explorer 10 in your image by any chance?  IE 10 seems to have issues with IEWelcomeMsg value existing.  You can delete it by:

    • Modifying the Unattend.xml in \Control\<TS ID>\ directly and remove that line.
    • Modify it in WSIM, find the value for it, right click, disable "write image value".


    David Coulter | http://DCtheGeek.blogspot.com | @DCtheGeek

    • Marked as answer by St4vr0s Wednesday, May 15, 2013 2:36 PM
    Wednesday, May 15, 2013 1:49 PM
    Answerer
  • That worked a treat!

    I changed the value "write image value". in WSIM and redeployed and it worked as expected.

    Thanks David

    Wednesday, May 15, 2013 2:37 PM