none
Table Tools Analyze tab not appearing - despite the presence of DM Add-in showing up

    Question

  • I have the following installed:

    - SQL Server 2008 DM Add-ins

    - SQL Server 2008 Developer Edition

    - Microsoft Excel 2010

    While the data mining tools show up and work just fine, the table analysis tools do not, even when I select a cell in a properly designated table.

    Please see the images below:

    [Here is the sample data file for the DM and Table Tools Add-ins, showing the presence of DM Tools, but the absence of the Analyze tab under Table Tools]

    What is going wrong, and how do I fix it?

     

    Saturday, September 24, 2011 6:40 PM

Answers

  • Hi Beau,

    Thanks for sharing me with your screen snapshots. They are helpful.

    It looks that your SQLServer.DMXAddIn was listed under the Inactive Application add-ins list which means that it is existed on your computer but not loaded into Excel. By default if everything is going smoothly during the installation process, after the installation, you should see the two COM add-ins in the active add-in list:

    If you click the Go... button, you will find the full qualified name of the loaded add-ins are as follows:

    I recommend that:

    1. Try loading this DLL manually. Still in the Add-in's panel, select "COM add-in" under the Manage list, and click Go. Then check the "SQLServer.DMXLAddIn" and click OK. After these steps, check if the Analyze tab appears when you click a cell of your table.

    2. If this issue persists, please go to the Trust center from the Options panel, and check if you set any restriction for the Add-ins. If there is, please first uncheck them. More information, please see, http://office.microsoft.com/en-us/help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx#BM5

    3. If 1 and 2 do not work, try uninstalling and reinstalling the add-in again. Uninstall the Data Mining Add-in from the Control Panel->Programs->Uninstall a program. After that, try downloading the add-in here, http://office.microsoft.com/en-us/excel-help/sql-server-data-mining-add-ins-HA010342915.aspx. During the installation process, please make sure you enable "Data Mining Client for Excel".


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Friday, September 30, 2011 8:06 AM

All replies

  • 1. It looks that your Excel file is in Read-Only mode. What is the result if you enable editing?

    2. Go to Excel File Options, switch to the Add-Ins and make sure that the two Microsoft SQL Server datamining add-ins are loaded:
        Microsoft.SqlServer.DataMining.Office.Excel.ClientConnect
        Microsoft.SqlServer.DataMining.Office.Excel.Connect

    If everything seems fine, I recommend that you try uninstalling and re-installing the Add-Ins to see if it helps.

    http://office.microsoft.com/en-us/excel-help/sql-server-data-mining-add-ins-HA010342915.aspx

     


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Tuesday, September 27, 2011 10:00 AM
  • Hi Charles,

    Thanks for your response. The same problem occurs regardless of the file.

    On the addins, I have two add-ins for SQL Server, but they have somewhat of a different name:

    1) SQLServer.DMClientXLAddIn

    2) SQLServer.DMXLAddIn

    Any advice on how to get the other two addins installed. I've tried installing and unstalling several times, with no effect.

    I've included screenshot below:

     

    Thanks,

    Beau

     

     

    Thursday, September 29, 2011 1:18 AM
  • Hi Beau,

    Thanks for sharing me with your screen snapshots. They are helpful.

    It looks that your SQLServer.DMXAddIn was listed under the Inactive Application add-ins list which means that it is existed on your computer but not loaded into Excel. By default if everything is going smoothly during the installation process, after the installation, you should see the two COM add-ins in the active add-in list:

    If you click the Go... button, you will find the full qualified name of the loaded add-ins are as follows:

    I recommend that:

    1. Try loading this DLL manually. Still in the Add-in's panel, select "COM add-in" under the Manage list, and click Go. Then check the "SQLServer.DMXLAddIn" and click OK. After these steps, check if the Analyze tab appears when you click a cell of your table.

    2. If this issue persists, please go to the Trust center from the Options panel, and check if you set any restriction for the Add-ins. If there is, please first uncheck them. More information, please see, http://office.microsoft.com/en-us/help/enable-or-disable-add-ins-in-office-programs-HA010034127.aspx#BM5

    3. If 1 and 2 do not work, try uninstalling and reinstalling the add-in again. Uninstall the Data Mining Add-in from the Control Panel->Programs->Uninstall a program. After that, try downloading the add-in here, http://office.microsoft.com/en-us/excel-help/sql-server-data-mining-add-ins-HA010342915.aspx. During the installation process, please make sure you enable "Data Mining Client for Excel".


    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Friday, September 30, 2011 8:06 AM
  • Hi, Charles,

    I am trying to make Table Analysis function to work on my Excel 2010, but tried all three of your methods, and spent days, still couldn't get it right. Please help. Let me explain my status: I downloaded SQL2012 data mining add ins for Excel 2010 from Microsoft website, and it's 64 bits. and installed it. The data Mining tab showed up, and even I tried to click on table content, the table analyze tab wont' show. I checked the File-Options-Add ins, it was exactly as your first screenshot in your reply.

    And I tried to checked all the boxes in COM Add-ins, and Excel Add-ins, checked trust center settings, and install, uninstalled. Nothing worked.

    It seems to me the problem is the client connect and Connect are in the Inactive Application Add-ins category, and I can't get them activated.

    Please advise. Thanks so much.                                                  Sincerely, GraceL

    Thursday, July 25, 2013 9:27 PM
  • I have the exact same problem.  I have followed all the instructions on this page, but still no good.

    Any other steps I could try?

    Monday, November 25, 2013 3:41 AM