none
Solaris 11 Shown as Unknown

    Question

  • Hi all,

    I successfully installed the Solaris agent on Solaris 11 machines, it is shown as healthy; however SCOM is showing it under Platform: Unknown and Version: Unknown.

    Running the scxadmin -status command, output the below:

    scxcimserver: is running
    scxcimprovagt: is stopped

    Running /opt/microsoft/scx/bin/tools/scxcimcli -n root/scx ei SCX_OperatingSystem to extract basic OS info fails with the below error:

    ld.so.1: scxcimcli: fatal: libpegclient.so: open failed: No such file or directory

    Enabling the verbose logs did not help or point to the exact error.

    Any suggestions?


    • Edited by aealhamad Wednesday, December 25, 2013 7:49 AM
    Wednesday, December 25, 2013 7:47 AM

Answers

  • Hi Steve,

    The issue is now sorted, I actually missed adding the Solaris account to SCOM Unix/Linux profiles.

    The agent is now monitoring the machines.

    • Marked as answer by aealhamad Thursday, January 02, 2014 2:46 PM
    Thursday, January 02, 2014 2:45 PM

All replies

  • For the scxcimcli tool you need to source the /opt/microsoft/scx/bin/tools/setup.sh file first.

    Run '.  /opt/microsoft/scx/bin/tools/setup.sh' then try the scxcimcli tool again.

    For the Platform/Version issue it can take SCOM sometime to update this. Are you still seeing the issue since it's been a week since this post?

    Regards,

    -Steve


    Thursday, January 02, 2014 2:21 PM
  • Hi Steve,

    The issue is now sorted, I actually missed adding the Solaris account to SCOM Unix/Linux profiles.

    The agent is now monitoring the machines.

    • Marked as answer by aealhamad Thursday, January 02, 2014 2:46 PM
    Thursday, January 02, 2014 2:45 PM