none
UEFI task sequence fails to apply operating system image.

    Question

  • Hello,

    I’m having trouble with SCCM 2012’s UEFI support. I’m working with a ‘Deploy Win7’ task sequence I created to run on both a VMWare VM and a Dell OptiPlex 990 – both set to EFI mode. I already upgraded WinPE to version 3.1.

    Here’s what I tried first:

    • Followed the SCCM task sequence creation wizard, and changed the ‘Partition Disk’ step to GPT. In this case, the TS fails at the step ‘Apply Operating System’.  The error I get is "Marking partitions as active is only supported by MBR disks" and "Unable to activate partition (0x80004001)". I initiated the TS through PXE.
    • Disabled the default “Partition Disk” step and added a “Run Command Line” action to run a script similar to the one found here: http://social.technet.microsoft.com/Forums/en-US/mdt/thread/a6679550-a343-463c-9301-1bf9706ad9af. This attempt was also initiated by PXE. In this case, the machine showed an error of “Unable to find a partition on the system disk that can be set as active” within the prestaging environment.  This happened in the TSPxe component.  It also showed “Failed to stage WinPE” with an error code 0x80070490

    These errors indicated to me that the system was not PXE booting in UEFI mode. I was reading that UEFI PXE booting was not supported by WDS by default, so I created “Standalone” task sequence media from the above TS.  The .ISO that the GUI process created was not recognized as being bootable by the UEFI boot menu. I looked at the files in the ISO and I can see "bootmgr.efi", but when I try to boot to the CD even though the EFI prompt it fails to boot.

    I then decided to try out MDT 2012 and see if it supports UEFI. The task sequence I made with MDT initiated through MDT boot media worked _perfectly_.  It created litetouch.iso, from which I was able to boot to and install windows 7 on a UEFI based machine with no problems.  So MDT is working great, I just need to translate this work to SCCM.

    I then thought that the problem might be with the GUI-based SCCM boot media ISO, so I tried to create my own bootable ISO from the SCCM task sequence’s boot media WIM via the guide here: http://technet.microsoft.com/en-us/library/dd744537(v=ws.10).aspx.

    I was able to boot from this .iso in UEFI mode, but no task sequences showed up.  It started up, and shut down immediately.  I checked the smsts.log files and noticed the error "Failed to open PXE registry key. Not a PXE boot." 

    It seems my new WinPE UEFI ISO is booting properly, but once it loads the environment it expects a PXE boot and shuts down.

    Has anyone actually had success with SCCM Deploy Windows 7 to a system in UEFI mode? 

    Thanks in advance,

    Josh


    Thursday, October 04, 2012 3:36 PM

All replies

  • SCCM 2012 does not support UEFI. The task sequence engine does not have the ability to correctly stage boot images or OS images in UEFI mode.
    Tuesday, October 09, 2012 1:19 AM
  • How can this answer be correct?

    The MDT integrated Task Sequence has UEFI mode built into it for partitioning/formatting the target machine.


    Mike Brown

    Friday, January 04, 2013 5:27 PM
  • What the OP was saying is that his MDT TS works correctly with UEFI. He wanted to do the same with just SCCM, and it would not work.

    The reason for that is SCCM (without MDT) does not have the ability to correctly state images in UEFI mode.

    Monday, January 07, 2013 9:46 PM
  • CM 2012 definetly has the ability to image in UEFI in Windows 8, I have done it successfully with ease. With Windows 7 I am having a bit more trouble. You have to partition correctly AND have the BIOS configured to UEFI not "compatability", or "legacy bios" or it won't work correctly.
    Monday, February 03, 2014 9:42 PM
  • Yep,it seems you have got the right point.The disk partition must be set to UEFI mode(GPT) and I have a bit trouble about this, could help to provide more details about this partion?
    Saturday, May 24, 2014 9:53 AM
  • CM 2012 definetly has the ability to image in UEFI in Windows 8
    True, but have a look when the question was posted originally. That's been two years ago. UEFI was not supported back then.

    Torsten Meringer | http://www.mssccmfaq.de

    Saturday, May 24, 2014 11:22 AM
  • The point being made is that ConfigMgr doesn't stage WinPE correctly if you're in UEFI (non-CSM) mode.

    Running in CSM is the same as running via Legacy BIOS mode using MBR partitions - ConfigMgr works great in BIOS/MBR scenarios.

    But in UEFI/GPT scenarios, your *boot image*, via bootable media or PXE, *MUST* match the boot image associated with the task sequence or the task sequence will fail if ConfigMgr determines that it must stage WinPE on the hard drive.

    I hope the issue is addressed in CM12 R2 CU2.


    V/R, Darrick West - Senior Systems Engineer, ConfigMgr: OSD

    Thursday, July 17, 2014 2:34 PM