none
Windows Server 2008 R2 DataCenter - No longer allows Local Resources to map

    Question

  • Typically mapping local resources works correctly when connecting to the server via RDP. In the Local Resources section, select the drives you would like to map, connect to the server and they show up. Well this has recently stopped working (for no apparent reason) and acts rather intermittent. It will map correctly for a few weeks and then just stop allowing you to map ANY drives through the RDP session. IF you restart the server, everything works correctly again. There are no errors in the Event Viewer for not being able to map the local resources and clearly there is no GPO that is affecting the mapping as well as anything local to any machine RDPing to the server since it works most of the time. As a note this issue happens on several different servers running Windows Server 2008 R2 (with all of the most recent Windows updates) and to ALL users attempting to map local resources after the "problem" occurs.

    Any suggestions or ideas as to what might be happening would be GREATLY appreciated.

    Thanks,
    - Robert

    Tuesday, September 24, 2013 5:46 PM

All replies

  • Hi,

    Make sure the Network Providers entry has at least the default entries:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider\Order

    In the right pane, item ProviderOrder with default data value: RDPNP,LanmanWorkstation,webclient


    Niki Han
    TechNet Community Support

    Wednesday, September 25, 2013 2:35 PM
  • This did not seem to resolve the issue. Any other suggestions or ideas?
    Monday, September 30, 2013 4:10 PM