none
write-caching policy not restored after reboot.

    Question

  • The problem I've been experiencing is very similar to this old one from server 2000:

    http://support.microsoft.com/kb/290757

    After a system restart, the write-caching policy is not being saved on the server and the settings are not persistent.

    The system hardware is an Intel RST express chipset, and the Intel Raid 5 Volume (Microsoft version) driver is 6.2.9200.16384 (win3_rtm.120725-1247)

    are there any hotfixes available for this driver to correct the problem on server 2012?

    Thursday, August 15, 2013 8:58 PM

Answers

  • I have finally found an answer.

    Since my server has AD, caching is automatically disabled and must be re-enabled after every restart.

    This seems over the top.  Anyone running any server should know better and have backup PSU in place.  I can understand the condition, but forcing the settings even after I have over-ridden should not happen in my mind.

    regardless, I could either script the caching and force it back myself... or just not use the system for AD.  I'll choose the later.

    I am curious to know if AD LDS suffers from this forced non-caching policy.

    • Marked as answer by tsw Friday, August 22, 2014 4:40 AM
    Friday, August 22, 2014 4:40 AM
  • ya, I can give that a try.. why not.

    Do you have any hints on the registry paths for those values, or is there a quick cmdlet for the cache policy?

    Of course you can. See:

    Enable or Disable Disk Cache

    http://blogs.msdn.com/b/winsdk/archive/2009/10/09/enable-or-disable-enable-write-caching-on-disk-behavior-on-disk.aspx

    You can write a tiny app in C or C# enabling / disabling disk cache settings and use PowerShell to spawn it, handle scripting and scheduling.


    StarWind VSAN [Virtual SAN] clusters Hyper-V without SAS, Fibre Channel, SMB 3.0 or iSCSI, uses Ethernet to mirror internally mounted SATA disks between hosts.

    • Marked as answer by tsw Friday, August 22, 2014 11:31 PM
    Friday, August 22, 2014 3:18 PM

All replies

  • The problem I've been experiencing is very similar to this old one from server 2000:

    http://support.microsoft.com/kb/290757

    After a system restart, the write-caching policy is not being saved on the server and the settings are not persistent.

    The system hardware is an Intel RST express chipset, and the Intel Raid 5 Volume (Microsoft version) driver is 6.2.9200.16384 (win3_rtm.120725-1247)

    are there any hotfixes available for this driver to correct the problem on server 2012?

    Have a benchmark tool to compare write performance for the block device with cache set ON and OFF. For virtual LUN as RAID5 is I guess this setting does not have sense and is simply ignored (and not stored anywhere).

    StarWind iSCSI SAN & NAS

    Thursday, August 15, 2013 10:14 PM
  • Please let us know if there is any progress in comparing write performance as mentioend by VR38DETT.

    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Saturday, August 17, 2013 3:58 PM
    Moderator
  • there is a significant different in performance:

    with write cache enabled:

    write cache disabled:

    Saturday, August 17, 2013 6:49 PM
  • and to just clarify when I state "disabled", it is to turn off Windows write-cache buffer flushing.  the entire policy settings are not persistent.

    Saturday, August 17, 2013 6:59 PM
  • Hi,

    I searched in registry key and this value could help disable write-cache:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\IDE\DiskVirtual_HD______________________________1.1.0___\5&2807dd3&0&0.1.0\Device Parameters\Disk

    "CacheIsPowerProtected"=dword:00000001

    Thus please check if the value will be changed to 0 or removed after a reboot.


    TechNet Subscriber Support in forum |If you have any feedback on our support, please contact tnmff@microsoft.com.

    Thursday, August 22, 2013 2:56 AM
    Moderator
  • in my case that key does not exist, but rather...

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\IDE\DiskVolume01.0.00__\4&1ec96dd5&0&0.0.0\Device Parameters\Disk]
    "UserWriteCacheSetting"=dword:00000000

    the value does not change after reboot; however, the policy properties are reset to default. (both write cache polices are not checked as shown in screen image previously).

    Thursday, August 22, 2013 5:25 AM
  • any updates related to this issue?
    Wednesday, September 11, 2013 9:42 PM
  • ... removed comment ...

    appears this is not fixed.

    • Edited by tsw Monday, October 28, 2013 12:51 PM
    Sunday, October 13, 2013 3:11 AM
  • I have the very same issue on my Windows Server 2012 Essentials.

    I did "check for updates" but Windows didn't find any :/

    The last updates (quite alote) were installed on 18-10-2013.

    I have already rebooted since.. So they are all applied. But sill, the problem persist. And the performance are catastrophic :(

    I read somewhere that this is possibly because the server is not battery backuped ?!



    Valéry Letroye



    Sunday, October 27, 2013 5:20 PM
  • I double checked after a restart today, and it does not in fact seem to be fixed.

    this system is on a backup power system, so that is not the solution.

    Monday, October 28, 2013 12:51 PM
  • I have finally found an answer.

    Since my server has AD, caching is automatically disabled and must be re-enabled after every restart.

    This seems over the top.  Anyone running any server should know better and have backup PSU in place.  I can understand the condition, but forcing the settings even after I have over-ridden should not happen in my mind.

    regardless, I could either script the caching and force it back myself... or just not use the system for AD.  I'll choose the later.

    I am curious to know if AD LDS suffers from this forced non-caching policy.

    • Marked as answer by tsw Friday, August 22, 2014 4:40 AM
    Friday, August 22, 2014 4:40 AM
  • I have finally found an answer.

    Since my server has AD, caching is automatically disabled and must be re-enabled after every restart.

    This seems over the top.  Anyone running any server should know better and have backup PSU in place.  I can understand the condition, but forcing the settings even after I have over-ridden should not happen in my mind.

    regardless, I could either script the caching and force it back myself... or just not use the system for AD.  I'll choose the later.

    I am curious to know if AD LDS suffers from this forced non-caching policy.

    Write a PowerShell script turning cache ON and put it into Scheduler :)

    StarWind VSAN [Virtual SAN] clusters Hyper-V without SAS, Fibre Channel, SMB 3.0 or iSCSI, uses Ethernet to mirror internally mounted SATA disks between hosts.

    Friday, August 22, 2014 6:51 AM
  • ya, I can give that a try.. why not.

    Do you have any hints on the registry paths for those values, or is there a quick cmdlet for the cache policy?

    Friday, August 22, 2014 2:30 PM
  • ya, I can give that a try.. why not.

    Do you have any hints on the registry paths for those values, or is there a quick cmdlet for the cache policy?

    Of course you can. See:

    Enable or Disable Disk Cache

    http://blogs.msdn.com/b/winsdk/archive/2009/10/09/enable-or-disable-enable-write-caching-on-disk-behavior-on-disk.aspx

    You can write a tiny app in C or C# enabling / disabling disk cache settings and use PowerShell to spawn it, handle scripting and scheduling.


    StarWind VSAN [Virtual SAN] clusters Hyper-V without SAS, Fibre Channel, SMB 3.0 or iSCSI, uses Ethernet to mirror internally mounted SATA disks between hosts.

    • Marked as answer by tsw Friday, August 22, 2014 11:31 PM
    Friday, August 22, 2014 3:18 PM
  • ah ha! some meat to chew on.. very nice.

    Thank you sir!   I was considering re-writing my LCD powershell script in C#, so this could certainly be an added feature.

    http://blugged.wordpress.com/

    I bumped yours as the answer... thanks again!

    Friday, August 22, 2014 11:34 PM
  • ah ha! some meat to chew on.. very nice.

    Thank you sir!   I was considering re-writing my LCD powershell script in C#, so this could certainly be an added feature.

    http://blugged.wordpress.com/

    I bumped yours as the answer... thanks again!

    Looks good! Please connect me over LinkedIn (account is in my profile) and I think we have a topic about C# to take off-the-thread :) Good luck!!!

    StarWind VSAN [Virtual SAN] clusters Hyper-V without SAS, Fibre Channel, SMB 3.0 or iSCSI, uses Ethernet to mirror internally mounted SATA disks between hosts.

    Sunday, August 24, 2014 2:41 PM