none
Не отображаются вложения в Outlook, хотя в самом письме они есть

    General discussion

  • Собственно ситуация такая.

    Есть некоторое количество клиентов, которые подключены по POP/SMTP, основная масса по Exchange. К серверу Exchange 2010.
    Проблема возникает, если клиент (POP/SMTP) делает Forward письма с вложением, не важно каким.
    Те, кто получил этот forward В ОСНОВНОМ (те есть те, у которых такой эффект не наблюдается) видят тело письма, но не видят вложение!

    НО! если они сделают forward этого письма на любую другую почтовую сиcтему (gmail, yahoo и тп) то вложение чудесным образом появляется!
    Да! и оно видно если это письмо посмотреть через OWA!!!!

    Если первоначально пользователь делал не forward, а новое письмо, то вложение видно без проблем!

    От версии Outlook, похоже,  не зависит... что 2003, что 2010... С клиентами по Exchange похоже, тоже такой проблемы нет.

    подобное нашел тут:
    http://social.technet.microsoft.com/Forums/ru-RU/msoclientru/thread/360262ac-9e40-4706-9e08-0a9f30288489

    Сам думал что антивирус, но ни каких антивирусов на почту не стоит, на данных машинах!
    Могу приложить собственно пример msg файла. Если его открыть аутлуком, вложения нет, а если поместить на сервер то через OWA вложение доступно.

    Куда смотреть не понятно! Заранее благодарю за советы!

     

    • Changed type Vinokurov YuriyModerator Monday, January 31, 2011 12:06 PM давность и отсутствие активности в теме
    Thursday, January 13, 2011 12:39 PM

All replies

  • А зачем вы подключатесь к Exchange по Pop3? Что до вашего случая, то описан он, как я понимаю, вот здесь http://support.microsoft.com/default.aspx?scid=kb;en-us;961940, то есть MIME-содержимое вашего письма повреждается. Помимо прочего проверьте, будут ли отображаться вложения, если настроить чтение входящих сообщений в текстовом формате: http://support.microsoft.com/kb/831607

    Да, и вот еще что. Скажите, исчезают только вложения с кириллическими именами? Или любые, не зависимо от того, какой алфавит использован в имени вложения?


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Tuesday, January 18, 2011 8:06 AM
    Moderator
  • Значится так. Клиент, КОТОРЫЙ делает FORWARD, те пораждает ТАКИЕ письма, подключается по POP/SMTP к Exchange серверу.

    Тот, кто получает эти письма может быть подключен, как угодно. Абсолютно без разницы, даже письмо из Send Items (того кто сделала forward) если сохранить в MSG формат и перенести на флешке на другой комп, то аутлуком оно откроется без вложений.

    Алфавит, и содержание вложения значения не имеют! Если при форварде, перекодировать письмо в palin text то все становиться хорошо.

    Читать уже принятое такое письмо можно в любом формате, вложений не будет. Если это письмо сохранить в msg формат и открыть сторонним приложением (НЕ аутлуком), то вложения видны!

    Могу прислать сам msg файл, просто не понимаю, как его прикрепить в форуме. Либо на Email если скажите.
    Своему account-менеджеру (в microsoft) я уже отправил этот файл. Подозреваю, что проблема эта происходит из-за какого-то обновления, причем не аутлука.
    Не исключено, что XML-parser или что-то подобное. Проблема в том, что возможности эксперементировать с этими клиентами у меня мало.
    Их всего несколько и это достаочно занятые люди, просто так окупировать их машину достаточно сложно. Но мы пытаемся ;-)

     

     

     

    Tuesday, January 18, 2011 8:41 AM
  • Моя почта указана в профиле - пришлите на нее.  И все-таки, причина скорее всего в проблемах с MIME, как описано в статье, на которую я сослался самой первой.
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Tuesday, January 18, 2011 10:20 AM
    Moderator
  • Отключите на проблемных клиентах Word 2003 как редактор сообщений электронной почты, либо обновите его по максимуму.


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Tuesday, January 18, 2011 11:31 AM
    Moderator
  • Не помогает!
    Tuesday, January 18, 2011 2:00 PM
  • В каком формате по умолчанию создается/отправляется сообщение? И повторюсь - в чем причина использования POP в организации Exchange? Outlook Anywhere существенно удобнее и не имеет таких проблем. меняется ли ситуация, если пользователя переместить в другое хранилище на сервере Exchange?


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Wednesday, January 19, 2011 9:32 AM
    Moderator
  • поумолчанию письмо создается в формате HTML. Но если при форварде поставить plain text, все будет хорошо!

    Outlook Anywhere не используется по двум причинам:

    1) Тормоза протокола Exchange, а в случае использования кеширования еще и глюки кеша. Все это дополнительная головная боль для админов хелпдеска.
    Тормоза особенно сильно выявляются в регионах где нет возможности арендовать хороший канал связи. Даже не по причине дороговизны, просто нет такой технической возможности. Возмем в пример Туркменистан - там канал НА ВСЮ СТРАНУ 300Мб/с!!!! Какой там Outlook Anywhere, о чем вы!  Там 2 мбита для конечного пользователя стоят примерно, как Рено Логан в месяц! И наши регионы примерно в таком же состоянии, чуть полегче, но...

    2) необходимость использования в качестве шлюза MS ISA или сейчас это Forefront. У нас корпоративная структура не нуждается в таком шлюзе и нам не хочется держать доменный хост в DMZ, посему простейший transparent-proxy продукт типа nginx  нас полностью устраивает.Использовать ISA только, как прокси на мой взгляд это как использовать какой-нибудь сетевой анализатор для забивания гвоздей. Это не лучшим образом организованая, но малая часть возможностей ISA. Остальные возможности нам не требуются, посокльку структура сети организована иным образом и ISA в нее не вписывается ни по архитектуре, ни по производительности.

    Nginx прекрасно справляется с проксированием и защитой POP/IMAP/SMTP и очень прост в клонировании и настройке. Так же не требователен к ресурсам прекрасно живет на виртуальной машине. Но, к сожалению он не умеет транслировать RPC over HTTP пакеты.

    От хранилища это, не зависит, зависит это ТОЛЬКО от клиентской машины и только от нее, к сожалению. Если аккаунт пользователя с проблемами поднять на другой машине, тоже по POP/SMTP, все будет хорошо работать. Проблемы это исключительно локального софта!

    Wednesday, January 19, 2011 9:53 AM
  • А вот это важный момент, он многое меняет. Вопрос - если на проблемной машине пересоздать профиль пользователя, проблема остается? И какая версия Office 2003 установлена на машине?

    Кстати, ISA для Outlook Anywhere не особенно обязательна, насколько я знаю.


    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Wednesday, January 19, 2011 10:25 AM
    Moderator
  • Профиль пересоздавать не пробовали. Профиль Outlook точно не влияет. С профилем пользователем попробуем...

    Такая ерунда не только в Office 2003, но и 2010! Мы используем профессиональный выпуск или проф.плюс.

    Для Outlook Anywhere действительно ISA не обязательна, но тогда эту машину надо выставить, пардон, голым задом в инет, либо ее 443 порт.
    Этого бы не хотелось делать. Мы н езря используем transparent-proxy, эта машина находить в DMZ которая отделена от инета и локальной сети фаирволами
    в этой сети нет машин имеющих информацию о внутренней инфраструктуре сети, на фаирволах открыты только нужные порты и доступы к серверам.

    В нашем случае захват злоумышленником прокси сервера не обеспечит доступа к сети и данным пользователей, и взлом может быть легко ликвидирован  востановлением "чистого" снапшота виртуальной машины. Мы этого не делаем, но чисто теоретически эту операцию можно делать периодически, например раз в сутки... Открывать, вот так запросто порт IIS... я к этому не готов ;-) Хотя сейчас у нас стоит Cisco ASA как шлюз в локалку, наверное можно настроить безопаный проброс порта. Посмотрим, подумаем. Но мне всеравно это не нравиться ;-)

    Wednesday, January 19, 2011 10:37 AM
  • С пользовательским профилем что-нибудь получилось?
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Tuesday, January 25, 2011 10:20 AM
    Moderator
  • Добрый день!

    Мы  столкнулись точно с такой же проблемой.

    Что есть:

    Есть Свежый домен, свежий MS Exchange 2010.

    Клиенты так же не видят вложения в сообщениях присланных из вне, либо при форвардинге (но по объему сообщения видно, что там должно быть вложение), хотя в OWA вложения видно.

    Что делали:

    Тему гуглили много, но так панацеи и не нашли....

    Еще хуже стало когда решили обновиться обновлением для MS Exchange 2010 (думали все будет чудно), но почтарь вообще повис на обновлении номер 5 из 10 и почта перестала работать во всей конторе , пришлось откатится снэпшотом..

    Вопрос:

    Может кто-то как то разрешил текущий трабл, а то наше руководство уже в бешенстве..:-))


    Век живи, век учись!

    • Edited by rеstless Friday, November 11, 2011 2:43 PM
    Friday, November 11, 2011 2:40 PM
  • В общем продукт есть, а вот пролемы остались и пока их не решить, как же так может быть , такой продукт как MS Exchange 2010, а уже начинает разочаровывать!:-(

     


    Век живи, век учись!
    • Edited by rеstless Thursday, November 17, 2011 7:53 AM
    Thursday, November 17, 2011 7:52 AM
  • Если по проблеме, то ее так и не решили. Мы решили уводить клиентов с POP/SMTP на RPC over HTTP, благо все-равно с внедрением Lync пришлось от Nginx отказаться и настроить TMG. Микрософт в новых продукатах предлогает странный метод авторизации по HTTP, такой, что
    ни Nginx, ни Apache не умеют его транслировать! 

    По поводу Exchange 2010 я понял, что все калькуляторы и прочая теория на тему его развертывания, долстаочно далеки от практики.
    По опыту могу сказать, что НОРМАЛЬНО без "лагов"  роль хранилища почтовых ящиков на 2010, для 2000 юзеров и около 1Tb общий размер
    хранилищ. При таком раскладе мы добились хороших показателей на сервере HP DL380 c 144Gb RAM два проца x5690 в качестве хранилища
    используется HP EVA P6000 по оптике 8 gb/s. При таких условиях у нас есть даже приличный запас в производительности. 

    Более скромные машики или виртуалки... для таких объемов уже не подходят, к сожалению! 2010 очень чуствителен к размеру хранилища, надо стремиться, чтобы максимальное число активных ящиков пользователей было кешировано в памяти иначе тормоза, особенно при большом объеме.

    Thursday, November 17, 2011 12:36 PM
  • Добрый день!

    Мы  столкнулись точно с такой же проблемой.

    Что есть:

    Есть Свежый домен, свежий MS Exchange 2010.

    .....

    Вопрос:

    Может кто-то как то разрешил текущий трабл, а то наше руководство уже в бешенстве..:-))


    Век живи, век учись!

    +1  

    Добрый день.

    Мое начальство пока не бешенстве, но уже смотрит косо.

    Точно такая же проблема. Приходит письмо с пдф, вложение в аутлуке не видно, но через owa доступно.

    Friday, February 21, 2014 9:49 AM
  • Подниму тему.

    Вчера столкнулся с такой же проблемой. 

    Outlook 2010 + Exchange 2010. Пришло письмо с вложением (pdf), вложения в outlook не видно, в owa все видно. Пересылка письма на outlook 2013 не помогла отобразить вложения.

    Outlook 2010 подключен к Exchange 2010 по OutlookAnywere.

    ПС: письмо прошло с вложением нормально после 5-6 попыток.

      Может кто-нибудь решил данную проблему?

    Tuesday, February 25, 2014 1:38 PM
  • Сделал так:

    On the HUB servers browse to the your Exchange installation location e.g. C:\Program Files\Microsoft\Exchange Server\V14\Bin

    Edit file EdgeTransport.exe.config using notepad

    At the end of the 'add key' list add:     <add key="TreatInlineDispositionAsAttachment" value="true" />

    Save the file

    Restart the 'Microsoft Exchange Transport' service

    Repeat the above steps for all HUB servers in your environment

    Issue resolved.

    отсюда: http://social.technet.microsoft.com/Forums/exchange/en-US/478c326b-486b-461c-9141-dd544b245c75/outlook-20032007-cannot-see-attachments-but-owa-can?forum=exchangesvrclientslegacy

    Пока жалоб не было, но суть проблемы как раз в том, что "невидимые вложения" были не так часто. Поэтому сто процентов гарантии, что помогло, дать не могу.

    Wednesday, March 12, 2014 1:56 PM