none
Sending Email Error:Recipient address rejected: Access denied.

    Question

  • Hi all ,
    I got this error in TraCE LOG...


    Cannot send email to xxx@sss.net for the reason: Transaction failed. The server response was: <xxx@sss.net>: Recipient address rejected: Access denied.

    How to resolve this error..

    Below i given details :::how i configured Mail system

    --------------------------------------------------------


    I did follwoing things:

    1.) enabled notifications in the workflow that the assignment came from.
    2)  user who the assignment is assigned to has a valid email address that the mail server will allow you to send to.
    3)  there are no authentication errors in the mail server
    <!--[if !supportLineBreakNewLine]-->
    <!--[endif]-->

    In Webservice Computer URL : Servername:46787

        Send Email Address : abc@mail.com

      SMTP server : mail.sss.net

    I run the PPSprotocolhandler.exe in Cmd Prompt


    I did following things :
     
    1.) To install the feature per user, type PPSProtocolHandler.exe –REGISTER:U, and then press Enter.

    output:

    Registering Monicker ... done


    2.)To install the feature per computer, type PPSPointProtocolHandler.exe –REGISTER:M, and then press Enter.

    output:

    Registering Monicker ... done


    -------------------------------------------------------------------------------------------------------------------------------



    Thanks in Advance


    Abdul



     


    Wednesday, February 06, 2008 5:19 PM

Answers

  • (Hi, I merged your new thread back to this one since there is no solution yet)

    I don't think this is a PPS problem because you are able to connect to the SMTP server and it is providing the access denied message. Certainly if you have an available local SMTP server to debug with you can use it.

    When you send mail as your id do you need to login? Since there is no place in the administration console to enter password to send email I think you should be using the user account that the planning process service runs under. Also note when you look at help it says the SMTP server must be in the same domain as the computer running the Planning Web Service or it must be a trusted domain.
    Thursday, February 07, 2008 6:32 PM
    Moderator

All replies

  • first a quick note: The protocol handler only needs to be registered on client machines. (And you should pick either U or M for user or machine respectively)

    In any event the error you are getting refers to sending mail: you need to confirm that the xxx@sss.net address is valid. Either step 2 or 3 is failing from the error messag you gave: the server is saying the the address is either invalid or the account that the message is trying to send from is not allowed to send mail to it.

    Please check that the account you have PPS running under is allowed to send mail on your mail server as abc@mail.com.


    Wednesday, February 06, 2008 6:12 PM
    Moderator
  • Hi peter,


    I am using that Mail ID in Outlook Express to Send mail.(My machine)
    In server i just gave my mail id.
    Still i am not getting

    Expecting Reply

    Abdul

    Thursday, February 07, 2008 7:54 AM
  • Hi all ,

    I got an error.Can anybody resolve this.For long time i am having this.


    Cannot send email to xxx@sss.net for the reason: Transaction failed. The server response was: <xxx@sss.net>: Recipient address rejected: Access denied.

    How to resolve this error..

    I given my mail Id in Sender address and also I assigned the Assigments Task to myself.
    Still i am Getting This Error..

    Can i Check using local installed SMTP server to check whether it is Problem in PPS

    Thanks You

    Abdul @PTPL

    Thursday, February 07, 2008 5:03 PM
  • (Hi, I merged your new thread back to this one since there is no solution yet)

    I don't think this is a PPS problem because you are able to connect to the SMTP server and it is providing the access denied message. Certainly if you have an available local SMTP server to debug with you can use it.

    When you send mail as your id do you need to login? Since there is no place in the administration console to enter password to send email I think you should be using the user account that the planning process service runs under. Also note when you look at help it says the SMTP server must be in the same domain as the computer running the Planning Web Service or it must be a trusted domain.
    Thursday, February 07, 2008 6:32 PM
    Moderator


  • Hi ,


    Thanks  to all and to you who has given this nice reply ..I got that point. I am not using the SMTP Server in the same domain. So time being I am trying this with local SMTP Server for sending email.



    Bye
    Abdul@PTPL


    Friday, February 08, 2008 12:52 PM