none
Restaurar Active Desktop

    Question

  • Amigos,

     

    To com um problema pra restaurar o active desktop em algumas máquinas. As máquinas possuem uma política pra não alterar papel de parede, aparece uma mensagem assim:

     

    Recuperação do Active Desktop
      Erro inesperado no Microsoft Windows. Como precaução, o Active Desktop foi desativado. Para restaurá-lo, siga estas dicas de solução de problemas:
    O navegador parou de funcionar ou você reiniciou o computador sem o desligar primeiro? Neste caso, clique em:
     
    Você trocou o plano de fundo por uma página da Web? Neste caso:
      1. Clique com o botão direito do mouse na área de trabalho e selecione Propriedades.
    2. Na guia Área de trabalho, em Plano de fundo, clique no plano de fundo desejado.
    Você adicionou recentemente um novo item ao Active Desktop? Neste caso:
      1. Clique com o botão direito do mouse na área de trabalho e selecione Propriedades.
    2. Na guia Área de trabalho, clique em Personalizar área de trabalho.
    3. Na guia Web, em Páginas da Web, desmarque a caixa de seleção do último item adicionado.
    Deseja desativar o Active Desktop? Neste caso:
      1. Clique com o botão direito do mouse na área de trabalho e selecione Propriedades.
    2. Na guia Área de trabalho, clique em Personalizar área de trabalho.
    3. Na guia Web, em Páginas da Web, desmarque todas as caixas de seleção.

     

    Se eu clicar em "restaurar active desktop" aparece uma mensagem de erro dizendo que a página exibida não permite execução de scripts. Eu fui nas políticas locais e forcei a habilitação do active desktop mas não deu certo, a mensagem persiste. Alguém sabe alguma coisa sobre isso? Alguma chave de registro que eu forço a exibição do papel de parede?

     

    Este problema eu consigo sanar se eu excluir a pasta do usuário do c:\documents and settings, o problema é que todas as vezes que faço isso preciso reconfigurar todo o usuário (outlook, desktop, preferencias de ie e etc...).

     

    Grato desde já

    Friday, July 27, 2007 1:29 PM

Answers

  •  

    Bom.. consegui resolver o problema da seguinte maneira:

     

    Tenho uma GPO que aplica um papel de parede padrão pra empresa e bloqueia alteração de papel de parede. Se eu desativasse esta GPO desativaria para o dominio inteiro, então criei uma OU no AD. No Group Policy Management eu dei um Block Inheritance para ele não herdar as políticas do domínio e crieu uma GPO que permitia a alteração de papel de parede.

    Como o problema era no usuário, eu movi os usuários que estavam com este problema, pedi que dessem um logoff e um logon e solicitei que mudassem o papel de parede para um qualquer. A tela de restauração do active desktop sumiu. Coloquei então todos os usuários nas suas OUs de origem e pedi que dessem mais um logoff e um logon. O papel de parede padrão da GPO foi aplicado e não apareceu mais a tela de recuperação.

     

    Foi uma trabalheira danada, mas que no final resolveu o problema. Obrigado a todos pela atenção.

    Monday, July 30, 2007 8:25 PM

All replies

  •  

    Olá Gabriel tudo bem?

     

    Nessa Política, qual a permissão da Pasta compartilhada que existe o papel de parede?

    Fico no Aguardo

    Abraço

    Friday, July 27, 2007 1:55 PM
  • Fabio, obrigado pela atenção!

     

    O papel de parede é no micro, está na pasta C:\TEMP, a permissão nesta pasta é total, temos um bat que roda no servidor e copia o papel de parede em bmp sempre pra esta pasta. O problema é que quando o micro trava e vc precisa reiniciar no botão direto ele dá erro no desktop... tenho três máquinas, e uma delas é a minha inclusive.

     

    Friday, July 27, 2007 2:11 PM
  • Da uma olhada nas propriedades do papel de parede, especificamente na aba 'Web', testa desabilitar a opção 'tornar está página disponível off-line', claro, se estiver marcada!

    Friday, July 27, 2007 7:35 PM
  • Eu tentei de tudo já...rs inclusive colocar a página disponível off, incluir em sites confiáveis, ativar e desativar o active directory. Creio q seja alguma configuração em registro q eu posso fazer. Obrigado pela força... mas tentei já e não consegui

    Monday, July 30, 2007 12:43 PM
  •  

    Bom.. consegui resolver o problema da seguinte maneira:

     

    Tenho uma GPO que aplica um papel de parede padrão pra empresa e bloqueia alteração de papel de parede. Se eu desativasse esta GPO desativaria para o dominio inteiro, então criei uma OU no AD. No Group Policy Management eu dei um Block Inheritance para ele não herdar as políticas do domínio e crieu uma GPO que permitia a alteração de papel de parede.

    Como o problema era no usuário, eu movi os usuários que estavam com este problema, pedi que dessem um logoff e um logon e solicitei que mudassem o papel de parede para um qualquer. A tela de restauração do active desktop sumiu. Coloquei então todos os usuários nas suas OUs de origem e pedi que dessem mais um logoff e um logon. O papel de parede padrão da GPO foi aplicado e não apareceu mais a tela de recuperação.

     

    Foi uma trabalheira danada, mas que no final resolveu o problema. Obrigado a todos pela atenção.

    Monday, July 30, 2007 8:25 PM
  • Obrigado pela dica Gabriel, eu sempre tive o mesmo problema e tinha que reconfigurar o perfil do usuário, mas o bom mesmo seria alguém nos explicar porque isto acontece né? rsss

     

    Abço!

     

    Thursday, June 19, 2008 6:46 PM
  • É bom quando encontramos usuários que compartilham suas soluções com os demais....
    Eu estou com o mesmo problema.

    Farei o teste.

    Valeu
    Thursday, June 26, 2008 7:18 PM
  •  

    Fala Daniel!

     

    Cara, com esta solução eu consegui resolver para todos os casos, tenta aí, se não conseguir avisa!

     

    Abraço

    Thursday, June 26, 2008 7:57 PM
  •  

    Alguém já conseguiu descobrir porque isso acontece?, tem alguma forma de impedir que volte a ocorrer?

     

    Abraços,

    Friday, August 08, 2008 12:08 PM
  • Boa Noite,

     

    Bem gente isto acontece porque quando compartilhamos uma pasta, automaticamente o cahe do compartilhamento é habilitado (padrão do windows para arquivos off line) sendo assim, como vários usuários acessam simultaneamente a mesma pasta aonde se encontra o papel de parede, ela é corrompida, então é necessária a exclusão do perfil local e o movel se houver para resolver o problema. Para evitá-lo, basta apenas desativar o cache do compartilhamento que este problema não ocorre. Obrigado a todos e espero ter esclarecido.

     

    Tuesday, August 12, 2008 11:04 PM
  • Pessoal,

     

       Vamos ver se vocês podem me ajudar, ativamos aqui na empresa o recurso de active desktop no AD. Todas as maquinas estão sendo atualizadas, porem a imagem que colocamos esta no formato jpg e tem cerca de 170Kb, e quando a 'policy' é aplicada o arquivo é transferido para a estação no 'HomePath' do usuario no diretorio 'Configurações locais\Dados de aplicativos\Microsoft'. porem ela esta sendo convertida em BMP e ficando com 2,3Mb... Meu AD esta no Windows 2000. A opção Active Desktop esta configurado conforme abaixo:

    - Enable Active Desktop - Enable

    - Active Desktop Wallpaper - Enable, Wallpaper Name -> %logonserver%\netlogon\wallpaper.jpg, Wallpaper Style -> Stretch

    - Allow only bitmapped wallpaper - Disable. - Esta opção já esteve como 'Not Configured' e o problema era o mesmo...

     

    Alguem tem alguma dica do porque ele converte o arquivo para BMP...

     

    Muito Obrigado desde já.

     

    Sidnei Freire

     

    Thursday, August 14, 2008 4:56 PM
  •  

    Olá Sidnei!

     

    Tenta seguir o tutorial do Miguel, neste link:

     

    http://forums.microsoft.com/Technet-BR/ShowPost.aspx?PostID=3620533&SiteID=29

     

    Desta forma vc vai restringir que o papel de parede seja JPG. Deixa esta regra do bitmapped wallpaper em not configured.

    Thursday, August 14, 2008 5:50 PM
  • Gabriel,

     

    Obrigado pela dica do roteio, só tem uma coisa... por algum motivo na minha GPO do Desktop não tenho a opção Allow HTML e JPEG Wallpaper (Permitir Papel de Parede HTML e JPEG).... Tem algum truque para incluir esta opção no template (.adm) desta GPO.

     

    Obrigadão..

     

    Sidnei

    Thursday, August 14, 2008 7:07 PM
  •  MarFaL wrote:

    Obrigado pela dica Gabriel, eu sempre tive o mesmo problema e tinha que reconfigurar o perfil do usuário, mas o bom mesmo seria alguém nos explicar porque isto acontece né? rsss

     

    Abço!

     

     

    o que acontece é o seguinte herança de diretiva,a default domain police tem precedência sobre qualquer outra,por isso que o nosso amigo conseguiu resolver criando uma UO separado e bloqueando a herança.... 

    Friday, August 15, 2008 5:45 PM
  • Sei q já faz algum tempo desta postagem... mas eu tive o mesmo problema aqui na minha empresa e, depois de semanas quebrando a cabeça, mesmo com todas as soluções propostas, consegui arranjar um método alternativo para resolver este problema...

    Apenas mudar um valor de uma chave no registro do Windows....

    Comigo aqui funcionou..

    segue o link onde eu adquiri a informação: http://support.microsoft.com/kb/929200/pt-br

    Não sei se já criaram alguma solução nova... apenas tô postando pq acho q pode ajudar alguém no futuro...

    Abraço!
    Tuesday, September 23, 2008 7:07 PM
  • Olá amigo,

     

    Fico muito agradecido pelo seu "feedback", pois isso pode ser muito útil futuramente.

     

    Abraços

    Tuesday, September 23, 2008 7:54 PM
  • Olá,

    entendi como resolver o problema... pois isto esta acontecendo comigo...

    Mais para evitar nosso amigo citou em desativar o cache do compartilhamento..

    ai eu pergunto.... (rsrsrs)

    Como desativar o cache do compartilhamento?

     

    Valeu... fico no aguardo!

    Thursday, November 20, 2008 5:39 PM
  • Gabriel

    Tive esse problema aqui na minha rede também. Utilizei o gpupdate /force e não obtive exito.
    Acabei por fazer algo que sempre acaba resolvendo problemas referntes a Aplicação de GPO sem sucesso.

    Na maioria das vezes, as politicas pegam com um usuário, e com outros não, e quando isso ocorre, eu deleto a pasta
    C:\Documents and Settings\usuário onde usuário é a pasta vamos dizer, problemática, claro fazendo o backup de Meus Documentos e peço para o Usuário que estava com problemas, efetuar novamente o login.

    Isso faz com que as GPO's sejam todas baixadas novamente.

    Espero que isso ajude. Aqui comigo funcionou.

    Abraços
    Monday, December 01, 2008 7:32 PM
  • Boa tarde!

     

    tive o mesmo problema e depois de muitas tentativas e pesquisas, consegui solucionar!

     

    Logado com o perfil com problema, acesse o regedit e vá até a seguinte chave:

     

    HKEY_USERS/S-1-5-21-199545654-1198993787-798298422-1612/Software/Microsoft/Internet Explorer/Desktop/Scheme/Display

     

    Na chave Display terá um valor Safemode, apague esse valor e reinicie a máquina.

     

    PS1: A chave S-1-5-21-199545654-1198993787-798298422-1612 varia de máquina para máquina;

    PS2: Edite o registro com a GPO aplicada.

     

    Espero ter ajudado.

    Wednesday, January 21, 2009 6:14 PM
  •  

    Boa Noite Srs

     

    Consegui resolver isso aqui na empresa para máquinas adicionando estes valores

     

    REGEDIT4
    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components]
    "DeskHtmlVersion"=dword:00000000
    "DeskHtmlMinorVersion"=dword:00000005
    "Settings"=dword:00000001
    "GeneralFlags"=dword:00000000

     

    fazendo isso, basta um F5 que fica tudo OK

     

    porem.. ai vem a pergunta...

     

    para windows server 2003, usando WTS, e tendo GPO de papel de parede, como resolveria??? (a GPO de papel de parede funciona tanto para os WTS como para máquinas XP)

     

    excluindo dentro de documents and settings o perfil do usuário, resolve em partes... gostaria de uma solução definitiva..

     

    alguém???

     

    obrigado

     

    Diego

    Wednesday, January 28, 2009 8:25 PM
  • Galera depois de sofrer muito aqui na minha rede onde o papel de parede é aplicado via GPO e o arquivo esta em uma pasta compartilhada; toda vez que tinhamos falta de energia ou a estação era desligada fora do "metodo normal" acontecia esse erro; tentei todas as dicas encontradas a única que funcionava era a de deletar o perfil e criar um novo; porém era trabalhosa e demorada; nisso pesquisando mais; descobri um jeito pelo registro que é "rapido e indolor";

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components\DeskHtmlVersion mude o valor da chave para decimal e troque de 272 para 0; feche o registro e vá ate o desktop clique com o direito e mande atualizar (ou reinicie a maquina se preferir);

    Consegui essa solução depois de pesquisar muito por ae; mas perdi o link para fazer referencia; :D
    • Proposed as answer by Ricardo Araujo Thursday, March 12, 2009 6:55 PM
    Thursday, February 19, 2009 5:40 PM
  • Obrigado,

    esse foi de muita ajuda.

    Resolveu meu problema eu tinha uma estação apresentando o erro.

    Alterei a Key dei atualizar no Desktop e pronto.

    Muito Obrigado.

    Abs.
    Wednesday, June 24, 2009 1:16 PM
  • Galera depois de sofrer muito aqui na minha rede onde o papel de parede é aplicado via GPO e o arquivo esta em uma pasta compartilhada; toda vez que tinhamos falta de energia ou a estação era desligada fora do "metodo normal" acontecia esse erro; tentei todas as dicas encontradas a única que funcionava era a de deletar o perfil e criar um novo; porém era trabalhosa e demorada; nisso pesquisando mais; descobri um jeito pelo registro que é "rapido e indolor";

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components\DeskHtmlVersion mude o valor da chave para decimal e troque de 272 para 0; feche o registro e vá ate o desktop clique com o direito e mande atualizar (ou reinicie a maquina se preferir);

    Consegui essa solução depois de pesquisar muito por ae; mas perdi o link para fazer referencia; :D

    Ok, no meu caso só resolveu desta forma.

    Obrigado.
    Thursday, August 06, 2009 2:28 PM
  • Vinícius,
    Muito boa dica,
    Foi a única solução para o meu problema.

    Precisamos de gente assim.
    marcado como útil.
    Tuesday, October 13, 2009 11:02 PM

  • Muito Obrigado,

    Resolveu meu problema.
    Friday, October 16, 2009 7:35 PM
  • Olá quase "xará"!!!!
    Estou com esse mesmo problema e resolvo sempre apagando o usuário....
    Vi sua dica e a dúvida é: altera o registro no servidor ou na estação que está com o problema???
    Aguardo!!!

    Odemar Gilson Santana Júnior
    Friday, November 20, 2009 1:45 PM

  • Altere a chave no micro e logado com o usuário que está com o problema, quando vc da um perfil novo para o usuário essa chave não está com esse problema por isso também funciona, mas sempre fiz o procedimento abaixo e funcionou.
    Monday, November 23, 2009 12:05 PM
  • Galera depois de sofrer muito aqui na minha rede onde o papel de parede é aplicado via GPO e o arquivo esta em uma pasta compartilhada; toda vez que tinhamos falta de energia ou a estação era desligada fora do "metodo normal" acontecia esse erro; tentei todas as dicas encontradas a única que funcionava era a de deletar o perfil e criar um novo; porém era trabalhosa e demorada; nisso pesquisando mais; descobri um jeito pelo registro que é "rapido e indolor";

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components\DeskHtmlVersion mude o valor da chave para decimal e troque de 272 para 0; feche o registro e vá ate o desktop clique com o direito e mande atualizar (ou reinicie a maquina se preferir);

    Consegui essa solução depois de pesquisar muito por ae; mas perdi o link para fazer referencia; :D

    Olá amigo, so uma pergunta, eu fiz assim como falou, mais nao deu certo, será porque to usando o service pack 3 do winxp ?

    Desde já agradeço
    Friday, March 05, 2010 10:21 PM
  • Pessoal to na mesma situação, fiz as duas opcoes, criando uma OU e separada e movi o usuario em questao, blza o papel nao sobe, o usuário consegue altera-lo, porem quando volto o usuario para a OU a qual ele pertence, o continua o erro do desktop.


    alterei a chave no registro, e tambem nao foi, será, que tem haver eu esta usando o service pack 3 do windows XP no cliente.



    desculpa ai a bobeira, mais se alguem puder me ajudar eu agradeço.


    Michel Teixeira
    Friday, March 05, 2010 10:25 PM
  • Ademar Junior,

    Bom Dia!

    Valeu pela força!

    Aqui na minha rede funciona com o mesmo esquema que a sua referente ao papel de parede, também tentei todas as dicas e a unica que funcionava era criando um novo perfil para o usuário onde o processo era demorado e não agil.

    Já com a sua dica tem uma certa agilidade, só que na minha rede tem um pequeno detalhe devido a restrições serem radicais então eu tenho que mover o usuario para uma OU que não tenha restrições para executar o processo e depois voltar para sua OU de origem com suas devidas restrições.

    Grato.

    Carlos Alziro Moreira Lima

     

    Thursday, April 08, 2010 1:03 PM
  • Bom... tenho esse problema as vezes... e sempre que tive, solucionei de uma forma meio boba até... mas que funcionou até agora.

    Basta clicar c/ o botão direito no Desktop e em seguida Propriedades. Na janela Propriedades de Vídeo, clique na segunda aba (Área de Trabalho) e em seguida, no botão Personalizar Área de Trabalho. Na janela que se abrir, desmarque um dos ícones da área de trabalho e de OK. Feito isso clique em aplicar e.... voila... problema solucionado.

    Depois disso vocês podem voltar em personalização e incluir novamente esse ícone.

    ... comigo funciona..

    Abç.

    Carlos Eduardo

    Tuesday, April 13, 2010 11:17 AM
  • Segui as instruções e resolvi o problema na hora. ... obrigado .
    Monday, May 10, 2010 2:07 PM
  • Aí vai mais uma dica...

    Abra o bloco de notas copie e cole o código abaixo:

     

    Windows Registry Editor Version 5.00

    [HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components]
    "DeskHtmlVersion"=dword:00000000
    "DeskHtmlMinorVersion"=dword:00000005
    "Settings"=dword:00000001
    "GeneralFlags"=dword:00000000

     

    Salve com a extensão .reg  e execute.

     

    Pronto...

    Thursday, May 20, 2010 7:59 PM
  • Vinicios.Oliveira

    Apos sua dica também conseguir resolver o problema aqui na empresa. Muito boa por sinal.

    "Galera depois de sofrer muito aqui na minha rede onde o papel de parede é aplicado via GPO e o arquivo esta em uma pasta compartilhada; toda vez que tinhamos falta de energia ou a estação era desligada fora do "metodo normal" acontecia esse erro; tentei todas as dicas encontradas a única que funcionava era a de deletar o perfil e criar um novo; porém era trabalhosa e demorada; nisso pesquisando mais; descobri um jeito pelo registro que é "rapido e indolor";

    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components\DeskHtmlVersion mude o valor da chave para decimal e troque de 272 para 0; feche o registro e vá ate o desktop clique com o direito e mande atualizar (ou reinicie a maquina se preferir);

    Consegui essa solução depois de pesquisar muito por ae; mas perdi o link para fazer referencia"

     

    crédito: Vinicios.Oliveira

    Tuesday, June 01, 2010 12:32 PM
  • Michel, parabens, eu estava com este problema na maquina do meu diretor e criar novamente o perfil não seria a melhor pratica pra mim, o seu metodo foi o melhor para resolver o problema. Muito obrigado

     

    Wednesday, July 14, 2010 11:47 AM
  • É muito simples resolver esse problema, mesmo para quem se loga em um domínio e pega alguma GPO que porventura altera a proteção de tela, siga o procedimento abaixo:

    1- Em executar acesse o regedit.

    2 - Acesse o caminho: HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\SafeMode\Components

    3 - Edite o valor de DeskHtmlVersion.

    - Apague o conteúdo e coloque o valor 0 no lugar. Clique em OK


    Edite o valor de GeneralFlags.

    - Apague o conteúdo e coloque o valor 0 no lugar. Clique em OK.

    4 - Feche o regedit e clique no botão “Restaurar o Active desktop”. Aparecendo o “Erro no Script desta página” clique em “Sim”, em seguida clique em atualizar.

    Pronto, espero que isso ajude.

    Thursday, August 05, 2010 1:47 PM
  • estava com o mesmo problema aki.

    Esta dica trouxe a solução..

     

    Valeu

     

    Jean

    Friday, June 17, 2011 1:28 PM
  • Se o micro estiver no Domínio e a GPO estiver bloqueando é só mudar a resolução da tela (800x600 por exemplo) e depois voltar para a anterior ;)

     

    assim o problema é resolvido facilmente e rapidamente!

     

     

     

    Valeu!!

    Wednesday, September 21, 2011 12:46 PM
  • Nossa foi muito valida sua explicação já faz muito tempo que queria tirar uma imagem e não conseguia de jeito nenhum,só foi seguir os passos,que consegui.Muito obrigada.

    Tatyana Santorio.

    Tuesday, January 17, 2012 12:03 AM