none
BUG? Mac RDP Client won't forward Mac Keyboard layout (@ symbol for instance)

    Question

  • Hi

    This is something that works fine on the old MS Mac RDC client but not the new one.

    The Mac keyboard layout does not seem to be brought forward to the server 2012 session and it uses the Windows keyboard layout (note that this is not a language settings issue).

    For instance, the @ and ' symbols are in opposite places on the Mac keyboard, so currently all of my Mac users are pressing @ and getting '.

    I've tested the language settings, read the FAQ multiple times, tested both RDP clients on both 2008 R2 and 2012 with the same group policy settings and I'm convinced there is nothing on my side.

    Does anyone know of a workaround? Such as forcing users to use a custom keyboard layout via group policy until this missing feature is replaced?

    Kind Regards

    Ryan

    Thursday, November 14, 2013 10:12 AM

All replies

  • Can you try a machine with no group policies applied?

    Kind regards, Kev

    Thursday, November 14, 2013 10:16 AM
  • Hi Kev

    I've tested our Windows 2008 system which works with the old RDP as it doesn't have a seperate gateway server.

    So using the same login (fresh each time) on the same server, the old client works but the new one doesn't.

    I must also point out though that when it comes to keyboard and language settings, we don't touch this on any server with group policy.

    Cheers

    Thursday, November 14, 2013 10:28 AM
  • I'm currently attempting a workaround whereby I use group policy to alter the keyboard layout to English - American so that the " and @ symbols are changed around via registry changes, but wondered if anyone else had a similar issue?
    Tuesday, November 19, 2013 10:18 AM
  • Hi Ryan

    this is from the FAQ Site of Remote Desktop Client on Mac. you can find it here:http://technet.microsoft.com/en-us/library/dn473006.aspx

    How do I type various symbols on a Mac keyboard?

    The location of many symbols on your keyboard depends on the used keyboard layout and language setting.

    also

    Why are the characters mixed up in the session?

    This issue can occur if the keyboard language has been switched on the remote PC while running a remote desktop session. In the case you would like to switch to a different keyboard language follow these instructions.

    ImportantImportant
    The remote PC selects the system language of the device running the remote desktop client and not the keyboard language. When switching the keyboard language on your device, you need to manually switch the keyboard language on the remote PC.

    1. Open settings on your device.
    2. Tap General and then tap International.
    3. Tap Language and select the language running on the remote PC.
    4. Open the RD Client and connect to the remote PC and check if the Windows keyboard language matches the language that you selected.

    cheers Stephan

    Tuesday, November 19, 2013 2:46 PM
  • Hi Stephen

    I suspect they made an error in the guide as on a Mac you can't go to "General" and then "International". Not on Mountain Lion or Mavericks anyway.

    Like I say, I've read this guide thoroughly but there is no help for this issue yet the old RDC connection program works perfectly.

    Cheers

    Wednesday, November 20, 2013 11:04 AM