none
Remote Desktop - IDLE Timeout Disconnect - CHANGE LENGTH OF IDLE TIME

    Question

  • When I connect to a server running Windows Server 2003 via RDP, the connection is disconnected after 15 minutes of idle timeout.

    I want to lengthen the amount of idle time before a RDP session is disconnected.

    Where can I change that value?

    I have seen references to running gpedit.msc, and then "In Computer Configuration, Administrative Templates, Windows Components, Terminal Services, Sessions, enable the settings you want to configure."

    Sounds nice, in theory, except that I HAVE NO "Terminal Services" line item in this location. Under Windows Components, I have "Event Forwarding, Windows Remote Management, Windows Remote Shell, Windows Media Player, Windows Update".

    I would appreciate commentary from someone who understands the question I am asking. If you don't understand my question, then please don't respond with more questions.

    Thursday, July 11, 2013 9:18 PM

Answers

  • Hi,

    There is a policy called "set time limit for active but idle rds session "which is under Computer Configuration-Administrative Templates-Windows Components-Remote desktop Services-remote desktop Session host-session time limit.

    Pls check whether you have enabled this setting.

    Also,running the RSOP or the gpresult on the server 2003 to see what GP has been applied on this server to narrow down the issue.

    Regards,

    Clarence

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, July 12, 2013 8:39 AM
    Moderator
  • Hi,

    It appears that you do not have all of the default templates loaded into GPO Editor for some reason.  Open gpedit.msc, in the left pane right-click on Administrative Templates and choose Add/Remove Template.  Enter system.adm and click Open.  After you do this you should see Terminal Services under Windows Components like you would expect.

    The session timeouts may also be set in Terminal Services Configuration (tscc.msc), Properties of RDP-Tcp, Sessions tab, Properties of the User object (Sessions tab), and via group policy computer or user configuration.

    -TP

    Thursday, July 18, 2013 6:43 PM
    Moderator

All replies

  • Hi,

    There is a policy called "set time limit for active but idle rds session "which is under Computer Configuration-Administrative Templates-Windows Components-Remote desktop Services-remote desktop Session host-session time limit.

    Pls check whether you have enabled this setting.

    Also,running the RSOP or the gpresult on the server 2003 to see what GP has been applied on this server to narrow down the issue.

    Regards,

    Clarence

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedbackhere.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Friday, July 12, 2013 8:39 AM
    Moderator
  • No, as I said, under Computer Configuration - Administrative Templates - Windows Components, all that I have listed is: Event Forwarding, Windows Remote Management (WinRM), Windows Remote Shell, Windows Media Player and Windows Update.

    I do not have "Remote Desktop Services".

    If I look under Windows Remote Shell, I do have an item labeled "Specify idle Timeout", which I have ENABLED.

    Under Terminal Services Configuration - Connections - RDP-Tcp - Sessions the Idle session limit is still greyed-out.

    Thursday, July 18, 2013 6:10 PM
  • I ran gpresult, but Group Policy was applied from: is N/A.

    This is a standalone server. I am the administrator, yet I am unable to configure the )_#$(#&$*#$&&*($&() RDP idle timeout. Extremely frustrating and quite inexplicable.

    Thursday, July 18, 2013 6:12 PM
  • Hi,

    It appears that you do not have all of the default templates loaded into GPO Editor for some reason.  Open gpedit.msc, in the left pane right-click on Administrative Templates and choose Add/Remove Template.  Enter system.adm and click Open.  After you do this you should see Terminal Services under Windows Components like you would expect.

    The session timeouts may also be set in Terminal Services Configuration (tscc.msc), Properties of RDP-Tcp, Sessions tab, Properties of the User object (Sessions tab), and via group policy computer or user configuration.

    -TP

    Thursday, July 18, 2013 6:43 PM
    Moderator