locked
Issue: Big inch display and lack of DPI-scaling for text in Start Screen (and/or Metro UI)

    Question

  • Just tried out Windows 8 on a 52" Sony Display.

    Got them default 5 rows of tiles on the 1920x1080 HD display.

    However, the text was very hard to read. Normally you use DPI-scaling to fix that. I.e. in Windows Desktop in Windows 7 you can do that by adjusting DPI to like 125%.

    Only - in Windows 8 that only works for the desktop. Not the Start Screen (or Metro UI??)

    Then you can go to the 2nd personalization option for the Metro stuff (??) like Start Screen: PC Settings: Ease Of Access Center and hit make EVERYTHING BIGGER.

    Then EVERYTHING GETS BIGGER - but that does not solve the problem of not having DPI-scaling.

    It just means the tiles gets completely oversize and also stuff in the Metro UI.

    To repeat the problem: Run Win8 on a 50 to 60 inch screen in 1920x1080 native resolution.

    Boot into the Start Screen and try reading it from 1.5 to 3 meters.

    Now - your only option (not having DPI-scaling for just the text in Metro UI) is to go an MAKE EVERYTHING BIGGER.

    Do that.

    Then open i.e. the Wheather app on that 50 - 60 inch display. I.e. now you can only see a fraction of the content.

    MAKE EVERYTHING BIGGER IS FOR BLIND PEOPLE. NOT FOR RESETING DPI-SCALING FOR BIG SCREENS.

    Please fix.


    Sunday, June 10, 2012 10:34 PM

Answers

All replies

  • Could you post back some screenshots of your issue.
    Tuesday, June 12, 2012 12:39 PM
  • Hi,

    Thanks for your feedback. It seems DPI-scaling setting does not work in Metro style app. I will record this.


    Juke Chou

    TechNet Community Support

    Wednesday, June 13, 2012 2:43 PM
    Moderator
  • Wait, I thought improved scaling was definitely in on the Metro side but remained a mystery on the Desktop side.

    http://blogs.msdn.com/b/b8/archive/2012/03/21/scaling-to-different-screens.aspx

    Wednesday, June 13, 2012 9:46 PM
  • The desktop DPI setting is used in the desktop alone.

    Windows 8 Metro UI uses the primary display's EDID information (screen size and DPI) to scale object sizes so that it is readable and touchable.

    But when using an external screen (in your case, a TV) which provides no EDID information (much like the MacBook Pro's retina display issue), Windows 8 Metro UI uses the default DPI of 96.

    MacBook Pro's problem was addressed with driver updates from nVidia and Apple. The retina display now reports correct EDID to Windows 8 and it is all good!

    But since TVs and projectors will never report correct EDID to Windows 8, Windows 8 needs a more easily user configurable (now it is only automatic) setting for custom DPI.

    I know my answer is not helpful until Micorsoft makes it work. So never mind ;)

    .....................................................

    UPDATE:

    I have come up with a manual workaround:
    Rebuild the EDID registry to wipe out all but the current monitor's EDID info by deleting all but the 'default monitor' subtree in the HKLM\System\CurrentControlSet\Enum­ \DISPLAY registry, after first changing the permissions on each branch. Then refresh the Device Manager to rebuild the data.

    Then use ViewSonic EDID Editor 3.1.5 or Phoenix EDID Designer 1.3 to edit your display's EDID information and decrease* your vertical and horizontal screen size proportionally (in 'mm').

    Related Helpful Source: http://blog.komeil.com/2008/06/fixing-edid-dvi-monitors-no-signal.html

    *(Yes screen size decrease == increase in DPI; so that Windows 8 Metro UI will use more pixels to draw an object thus making it appear bizzer on the TV)

    • Proposed as answer by AnindyaMaiti Thursday, October 04, 2012 12:37 PM
    • Unproposed as answer by AnindyaMaiti Thursday, October 04, 2012 12:37 PM
    • Edited by AnindyaMaiti Thursday, October 04, 2012 1:01 PM
    • Proposed as answer by AnindyaMaiti Thursday, October 04, 2012 1:01 PM
    Wednesday, October 03, 2012 7:49 AM
  • Is there a simple solution to this? I have Windows 8 on my HTPC, but Metro ui is far too small and scale very poorly ... it's impossible to read text or navigate some apps on a 50inch television.
    Thursday, November 29, 2012 9:13 AM
  • An easier way than AnindyaMaiti's method to override the screen size can be found at: http://support.microsoft.com/kb/2737167


    • Edited by xgg Saturday, December 08, 2012 7:49 PM
    Saturday, December 08, 2012 7:49 PM
  • An easier way than AnindyaMaiti's method to override the screen size can be found at: http://support.microsoft.com/kb/2737167


    That solution worked for Release Preview and does not work on final RTM version of Windows 8. nVidia released an updated driver with EDID support for MacBook Pro to solve the problem with Windows 8 RTM.
    Thursday, January 10, 2013 9:15 AM