none
Remote Web Workplace display resolution (SBS 2008)

    General discussion

  • I am using RWW to connect remotely to a host PC inside an SBS 2008 domain.  My local PC is running Win7.  The host PC is running Win XP (SP3).

    The problem is with screen resolution.  Normally, the host PC has a screen resolution of 1280 x 1024 pixels and colour quality set to "highest (32 bit)".  But when I connect through RWW (in full screen), I'm not seeing the complete desktop of the host PC.  The reason is that the RWW session has changed the screen resolution on this host PC to 1600 x 900 pixels with colour quality only medium (16 bit).

    Unlike RDP, I can't find an end-user setting to override this.  I have also looked in the most obvious place on the server (i.e. Start / Administrative Tools / Terminal Services / Terminal Services Configuration).  Under the Client Settings tab, the "colour depth" is in fact set to "32 bits per pixel".

    Anyone know how to resolve this?





    Friday, June 21, 2013 4:02 PM

All replies

  • Hi,

    1. On your XP SP3 PC, please set the maximum color depth to 24 bit (max for RDP 5.2).  You may set this via group policy or via the registry.  Below is the registry setting:

    HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    ColorDepth     REG_DWORD     0x00000004

    Please note that at certain resolutions it will automatically drop the color depth.  For example, I believe above 1600 x 1200 it will drop to 16 bit, and at a certain higher point it will drop to 8 bit.

    2. Your local Win7 PC is most likely at 1600 x 900 resolution, correct?  It is making a full screen connection which means the session resolution will match your local resolution (if possible).  I do not have a SBS 2008 in front of me at the moment and I do not remember if RWW gives you the option to set a different resolution.

    If possible, you could set your local resolution to 1280 x 1024 before making the connection, that way you will get the session resolution you would like.

    Thanks.

    -TP

    Saturday, June 22, 2013 4:06 AM
  • Thanks for the suggestions - but no progress I'm afraid.  I made the registry change on the host XP SP3 PC but it had no effect (even after a reboot).

    Yes, my Win7 PC is at 1600 x 900.  I tried changing this to 1280 x 720 but that made no difference either.  I couldn't try your suggested 1280 x 1024 as that wasn't an available setting on my Win7 PC (i.e. under Start / Control Panel / Display / Adjust resolution).

    Saturday, June 22, 2013 9:19 AM
  • An update:

    Two Win7 PCs in another office are reporting that the resolution is fine.  So it looks like TP's suggestion is good.  Next time I'm in that office, I'll take my Win7 laptop along to compare settings (i.e. the resolution on mine still isn't right).

    Tuesday, June 25, 2013 2:50 PM