none
Autenticação.

    Pregunta

  • Bom dia!

    Tenho o seguinte ambiente.

    Utilizo um windows server 2008 r2 com SQL SERVER 2008 R2 e SSRS 2008 R2 para publicar meus relatórios, unicamente para isso.

    Meu ambiente de criação é um windows 7 Ultimate com SQL SERVER 2008, SSRS 2008.

    Utilizando o windows 7, abro o navegador e tento entrar no meu servidor de relatório: http://windowsserver2008r2/Reports

    Ele pede a janela de senha, se eu digitar qualquer usuário e senha do meu domínio, funciona.

    Porém eu gostaria que NÃO fosse solicitado usuário e senha, passasse direto para os relatórios.

    No meu ambiente windows 7 que utilizo como teste, se eu digitar no navegador hhtp://localhost/Reports ele vai abrir a página de relatórios, MESMO que seja um usuário novo no computador, ele abrirá, e só terá permissões nos RELATÓRIOS se eu configurar no gerenciador de relatórios.

    Então eu gostaria que acontecesse isso também no meu ambiente windows2008r2.

    Já comparei as configurações de um e outro, estão quase identicos, com uma única diferença. IIS.

    Eu já li de que não há necessidade do IIS, mas nem para autenticação?

    Espero que possam me ajudar.


    Rodrigo Ataíde.
    jueves, 01 de diciembre de 2011 14:28

Todas las respuestas

  • Rodrigo,

     

    Estou apenas com Win Server 2003 aqui para testar, porem, creio que é quase a mesma coisa, simplismente alterando aonde fica uma opção ou entra, enfim, segue um steo by step do windows server 2003:

    -> Iniciar -> IIS Manager -> Ache o website do Reporting Service -> Botão direito propriedades -> Directory Security -> Edit no Container Authentication and Access Control -> Cheque a opção Enable Anonymous Access -> Coloque um usuario valido de dominio.

     

    Dessa maneira, voce esta dizendo que não ira pedir senha ao logar, pois a permissao de acesso ao site do IIS sera feita por esse usuario que voce especificou, porem, quando cair no report, ele sim fara o filtro de visualisação dos relatorios.


    Fabrizzio A. Caputo
    MCT
    Certificações:
    Oracle OCA 11g
    MCITP SQL Server 2008 Implementation and Maintenance
    MCITP SQL Server 2008 Developer
    Blog Pessoal: www.fabrizziocaputo.wordpress.com
    Blog Empresa: www.tripletech.com.br/blog
    Twitter: @FabrizzioCaputo
    Email: fabrizzio.antoniaci@gmail.com
    martes, 06 de diciembre de 2011 12:17
  • Acho que no meu caso é um pouco diferente. Porque eu não quero que peça usuário nem senha, mas eu quero que considere a autenticação do windows. O máximo que eu consegui fazer foi: o usuário digita http://meuserver/reports em qualquer navegador, ai abre um pop up de usuário e senha, MESMO que o usuário de domínio logado no computador esteja com autorização no reports, e se ele repetir seu usuário e senha de domínio no pop up a conexão passa.
    Rodrigo Ataíde.
    martes, 06 de diciembre de 2011 13:22
  • Rodrigo,

    Se o seu ambiente de produção é 2008 r2, voce deveria considerar ter no seu ambiente de desenvolvimento 2008 r2 tambem, pois senão voce nao pode usar as features do 2008 r2 (elas nao aparecem na sua ferramenta de desenvolvimento).

     

    Com relacao as permissoes, no seu servidor abra o reportmanager como administrador, em site settings/permissions adicione os usuarios/groups que voce quer que tenham acesso. Depois em Folder settings, de permissao ao folder para que o usuario/grupo possa ver os relatorios.

     

    Outra coisa é que o browser tem que estar configurado para usar a autenticacao do windows automaticamente, isso vai acontecer se o site do seu SSRS estiver na lista de trusted sites, ou se voce configurar enviar autenticacao por padrao para zona de intranet. Tambem vai mudar de browser para browser. No IE 9 voce pode mudar isso em tools/internet options/security/custom level e la embaixo na lista tem user authentication/logon.

     

    Att

    Boreki


    Boreki[MSFT] - SQL Server Reporting Services
    jueves, 08 de diciembre de 2011 0:24
  • Bom dia Boreki [MSFT],

    Infelizmente estes procedimentos não deram certo.

    Se você tiver mais alguma outra idéia, fico no aguardo.


    Rodrigo Ataíde.
    jueves, 08 de diciembre de 2011 11:04
  • Boa tarde,

    Eu também estou com o mesmo problema.

    miércoles, 09 de mayo de 2012 20:04