none
A Web Exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown

    Pregunta

  • Legacy Exchange Info
    Exchange 2003 SP2 single server with second Exchange-oma folder for activesync -- All works fine
    New 3rd party "legacy.domain.name" SSL installed.
    I have reset the virtual directories -- http://support.microsoft.com/default.aspx?kbid=883380
    I have followed single server setup -- http://support.microsoft.com/kb/817379

    Exchange 2010 info
    Exchane 2010 MBX server & 2010 CAS/Hub server on two separte servers.

    We use webmail.domain.name for external access for Activesyhnc, OWA & RPC. As per specified configuration I have the 2003 activesync Virtual directory set to basic and integrated. OWA & RPC/Outlook anywhere works just fine when pointing to webmail.domain.name.
    Activesync only works by pointing to legacy.domain.name, when I try to use the 2010 CAS to connect to activesync I get promted for password constantly or when testing with activesync test site I get "A Web Exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown"

    Migrated a couple mailboxes to 2010 and everything works fine (OWA, RPC & activesync)

    Any suggestions on how to get the 2003 mailboxes to use activesync or what I am doing wrong would be greatly appreciated...

    Thanks Steve

    miércoles, 16 de diciembre de 2009 17:37

Respuestas

  • Ok, I have figured out the issue for my setup.  Hopefully, it will help others.  If you're getting the 503 error stated above, it could be because you've enabled HTTP redirect to HTTPS for your Exchange virtual directories.  When I did this years ago, I used the following article - http://support.microsoft.com/kb/839357.

    The 2010 server doesn't like the 300~ redirect code that the 2003 server is sending back which causes it to send the 503 back in response.  To fix this issue, I had to disable the HTTP redirect.  If you used the KB article above, you would just go to the \exchange virtual directory, click on the "Custom Errors" tab and set the 403.4 error back to default. 

    When I did this, I started getting another error while testing with testexchangeconnectivity.com.  This error was "An HTTP 403 forbidden response was received. The response appears to have come from IIS7."  This error was due to the option "Require secure channel (SSL)" on the Directory Security tab of the Microsoft-ServerActiveSync virtual directory. 

    Unfortunately, this setup is not ideal as I don't want users to be able to connect with ActiveSync without using SSL.  So, that's my next thing to figure out.

    viernes, 27 de agosto de 2010 20:09

Todas las respuestas

  • Take a look at this doc - http://technet.microsoft.com/en-us/library/ee332348.aspx. Make sure you've got the 2003 EAS vDir set for Integrated Windows auth.
    Active Directory, 4th Edition - www.briandesmond.com/ad4/
    miércoles, 16 de diciembre de 2009 22:43
  • Thanks for the suggestion...

    Yes, this has been done. I forgot to list this document.

    Also the OS for Exch03 is server 2003 with latest service pack and updates.
    Os for Exch2010 is server 2008 R2

    jueves, 17 de diciembre de 2009 1:36
  • I am in the same situation as TaceySM.  Users on the 2003 server can access their mailbox via ActiveSync ONLY if they point their devices to legacy.company.com.  The proxying from the 2010 CAS server doesn't work.  When testing with the test site I get "A Web Exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown".  Mailboxes that are moved to 2010 work fine, but of course that means the users need to reconfigure their devices at exactly the point when their mailbox is migrated -- not a good solution and definitely not working as advertised by Microsoft.  I opened a support case with Microsoft and after 3 hours they declared everything configured correctly but they still couldn't figure out the solution.  They noticed that the Exchange 2003 server was running on VMware, so they used that as an excuse to give up and close the ticket.  Obviously VMware is not the problem here.  I'd be curious to hear if anyone else has run into this problem and found a workable solution.

    sábado, 19 de junio de 2010 0:19
  • It exists some devices out there that dont understand/follow the redirect sent from Exchange 2010 when mailbox is located on the old Exchange 2003/2007 server.

    I have found iPhone and Androids be such devices.

    What you can do if you have an ISA/TMG in front of Exchange IIS is to force authentication on it and then send the next connection to either Excange 2010 or the old system depending on group membership.
    Benefit is that ISA/TMG know who the user is and can send the internal request to the correct IIS without users/devices noticing. Backside is that you have to manage group membership while migrating.

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    lunes, 21 de junio de 2010 20:27
  • Lasse,

    Besides our iPhones and Android phones not redirecting, our Palm Pre phones are also not redirecting.  Also, the "testexchangeconnectivity.com" Web site  returns the error "A Web Exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown" for all users still on the 2003 server.  I am surprised that the "testexchangeconnectivity.com" would report a problem -- shouldn't that Web site understand redirection?  I don't have any Windows Mobile devices to test because everyone in the company has either an iPhone, Android phone, or Palm Pre, but I'm starting to think the problem isn't necessarily with the mobile devices, but more likely an Exchange 2003 configuration issue.  We also get this error in the Event Log on the Exchange 2010 server for every users who exists on the 2003 server:

     

    Exchange ActiveSync has been disabled for the user XXXX\XXXX. It's possible the user's mailbox is in the process of being moved. Please either complete the move or have the user remove the partnership from the device using Outlook Web App.

     

    Despite this error, ActiveSync is in fact enabled for the user, and I also verified the inherited permissions are enabled for the user in ADUC.

     

    Anyone have any other ideas?  Standing up an ISA server is not an option.

     

    Thanks,

    Bill

    miércoles, 23 de junio de 2010 11:09
  • testexchangeconnectivity understand redirection etc.

    Is there anything in the Exchange 2003 IIS logfiles?

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    jueves, 24 de junio de 2010 6:45
  • Bill,

     

    Funny thing, we had a power outage for the building we are in last night. I just brought all the systems up and everything is running except for Exchange active sync. Active sync tester had the following error.

     

    An ActiveSync session is being attempted with the server.

     

    Errors were encountered while testing the ActiveSync session

     

    Test Steps

     

    ExRCA is attempting to send the OPTIONS command to the server.

     

    Testing of the OPTIONS command failed. For more information, see Additional Details.

     

    Additional Details

     

    A Web Exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown

    No mobile device is working but this has to be a network or exchange issue. I have no choice but to fix it before 7am, so I will post my findings when I’m done.

    jueves, 24 de junio de 2010 10:02
  • Running into the exact same issues.
    viernes, 25 de junio de 2010 22:37
  • Try this http://support.microsoft.com/kb/823159

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    sábado, 26 de junio de 2010 8:31
  • Hi Mark-

    Did you find the issue or are you still having the problem?

    Kary

    jueves, 15 de julio de 2010 3:15
  • Any updates?  We're having the same problem.

    miércoles, 18 de agosto de 2010 15:26
  • Hey all... was having the same problems that everyone on the site seemed to be having. I know it's kind of minor to check, but make sure in the Application Pools the MSExchangeSyncAppPool is started. For whatever reason on my Exchange 2010 box it decided it didn't want to start. After i manually started it up... active sync works perfectly and i was able to pass all the tests ActiveSync part on https://www.testexchangeconnectivity.com . Now it's just a matter of making sure i do the security propagation trick in the AD for some accounts. 

     

    lunes, 23 de agosto de 2010 21:35
  • We're having the same issues.  The MSExchagneSyncAppPool is started on the 2010 server, so that doesn't seem to be the issue for us.  Curious if anyone has found a solution yet.
    viernes, 27 de agosto de 2010 18:49
  • Ok, I have figured out the issue for my setup.  Hopefully, it will help others.  If you're getting the 503 error stated above, it could be because you've enabled HTTP redirect to HTTPS for your Exchange virtual directories.  When I did this years ago, I used the following article - http://support.microsoft.com/kb/839357.

    The 2010 server doesn't like the 300~ redirect code that the 2003 server is sending back which causes it to send the 503 back in response.  To fix this issue, I had to disable the HTTP redirect.  If you used the KB article above, you would just go to the \exchange virtual directory, click on the "Custom Errors" tab and set the 403.4 error back to default. 

    When I did this, I started getting another error while testing with testexchangeconnectivity.com.  This error was "An HTTP 403 forbidden response was received. The response appears to have come from IIS7."  This error was due to the option "Require secure channel (SSL)" on the Directory Security tab of the Microsoft-ServerActiveSync virtual directory. 

    Unfortunately, this setup is not ideal as I don't want users to be able to connect with ActiveSync without using SSL.  So, that's my next thing to figure out.

    viernes, 27 de agosto de 2010 20:09
  • The redirect methid described in http://support.microsoft.com/kb/839357 does not work for Exchange 2007/2010. There exists other methods how to make the redirect work correct.

    Here is a good example http://www.ucblogs.net/blogs/exchange/archive/2010/04/28/Redirecting-the-root-web-site-to-_2F00_owa-and-forcing-SSL-in-Exchange-2010.aspx

    Personally I try not to change any IIS settings since it wil bite you a year later when you try to apply a patch  or similar.
    Better to have users learn the correct URL or have them click on a link that points them to correct URL.

     

     


    lasse at humandata dot se, http://anewmessagehasarrived.blogspot.com
    domingo, 29 de agosto de 2010 8:35
  • Anyone find an answer to the issue?

    Exchange ActiveSync has been disabled for the user XXXX\XXXX. It's possible the user's mailbox is in the process of being moved. Please either complete the move or have the user remove the partnership from the device using Outlook Web App.

    I have the exact same error.  If I point the iphone to the legacy URL for a 2003 user it works fine if I point it to a user on 2010 with main url it works fine.  Only using the main url proxying back to the 2003 server fails and it displays the above error each time I try to sync.  I installed the hotfix and enabled integrated authentication per MS during deployment.

    sábado, 25 de septiembre de 2010 20:36
  • First off thanks lampoit & Lasse for your posts.  It solved the problem for me.

    I have a little bit of insite for you.  It appears that in this scenario (Exchange 2003/2010 coexistence) that using activesync is not a redirect but a proxy.  The proxy does/will not use port 443 it uses port 80.  So when you have SSL required on the Microsoft-Server-Activesync directory on exchange 2003 it will break the proxy from the 2010 server.

    This isn't a big deal because it is a proxy (ie client --(SSL)--> Exch 2010 --(http)--> Exch 2003).

    I discovered this while troubleshooting with MS support.

    So the proper way to have this setup:

    1. Make sure you do not have any site redirection on 2003 websites in IIS.   If you do change it back to default.  (we had it on the default website as well as the activesync virtual directory).
    2. Disable SSL on 2003 ActiveSync virtual directory.
    3. Follow all the other normal steps in this scenario (install hotfix, etc...).  Follow the deployment assistant or see this article http://msexchangeteam.com/archive/2009/12/08/453472.aspx

    Hope this can help others.  I have spent easy 20+ hours on this issue. :-)

    • Propuesto como respuesta Andrew R. Cook martes, 11 de septiembre de 2012 22:41
    jueves, 28 de octubre de 2010 19:54
  • James

    Thank you! You saved me so many hours of headaches. In order to setup an Exchange 2010/2003 coexistence scenario, I followed the Microsoft tech doc (listed above) as well as other instructions on how to do it. I configured everything perfectly paying attention to every little detail. For users whose mailboxes were still on the EX2003, I was having the ActiveSync problems others were having above. After readin your post I noticed that the thing that was causing it not to work was SSL was required on the Exchange virtual directory on the Exchange 2003 server. There is no mention of this in any of the Microsoft or other literature on coexistence scenarios yet this is a very common configuration (to have SSL required on the Exchange virtual directory).

    Thank you for pointing it out! After I unchecked it, iPhones and Droids started synching using the same URL they did before.

     

     

    miércoles, 12 de enero de 2011 0:32
  • Your welcome, After rereading my post, I would like to make one clarification for others as well. In step one I mention website redirection, this would include the widely used method of redirecting users from HTTP(80) to HTTPS(443) using one of the http error codes. Thanks.
    jueves, 13 de enero de 2011 13:29
  • hi jgolden,

     

    i am unable to delete&move mails in exch 2010 owa (2007 to 2010 migration in process)..

    we moved some exch 2007 user mailbox to 2010 server and checked.

    we can able to access owa but some time unable to delete and move mails to other folder also free busy is not working

     

    I am getting this below event IDs.

    Log Name:      Application
    Source:        MSExchange OWA
    Date:          28-11-2011 12:25:26
    Event ID:      108
    Task Category: Configuration
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      INMAA3BMS0036.ifmr.co.in
    Description:
    Outlook Web App couldn't connect Exchange Web Services due to a configuration error. Response code = "503".
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange OWA" />
        <EventID Qualifiers="49152">108</EventID>
        <Level>2</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-11-28T06:55:26.000000000Z" />
        <EventRecordID>22009</EventRecordID>
        <Channel>Application</Channel>
        <Computer>INMAA3BMS0036.ifmr.co.in</Computer>
        <Security />
      </System>
      <EventData>
        <Data>503</Data>
      </EventData>
    </Event>

     

    Log Name:      Application
    Source:        MSExchange Availability
    Date:          28-11-2011 10:25:05
    Event ID:      4002
    Task Category: Availability Service
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      INMAA3BMS0036.ifmr.co.in
    Description:
    Process 10216: ProxyWebRequest IntraSite from S-1-5-21-3939489263-3197679683-2137223578-1869 to https://webmail.ifmr.co.in/ews/exchange.asmx failed. Caller SIDs: NetworkCredentials. The exception returned is Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException: System.Net.WebException: The request was aborted: The request was canceled.
       at System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()
       at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult, Object& internalAsyncState, Stream& responseStream)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling():<No response>. The request information is ProxyWebRequest type = IntraSite, url = https://webmail.ifmr.co.in/ews/exchange.asmx
    Mailbox list = <Satya Srinivasan | IFMR Trust | Marketing & Branding>SMTP:Satya.Srinivasan@ifmr.co.in, Parameters: windowStart = 27-11-2011 00:00:00, windowEnd = 01-12-2011 00:00:00, MergedFBInterval = 30, RequestedView = Detailed
    . ---> System.Net.WebException: The request was aborted: The request was canceled.
       at System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()
       at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult, Object& internalAsyncState, Stream& responseStream)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling()
       --- End of inner exception stack trace ---
    . Name of the server where exception originated: INMAA3BMS0036. Make sure that the Active Directory site/forest that contain the user's mailbox has at least one local Exchange 2010 server running the Availability service. Turn up logging for the Availability service and test basic network connectivity.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="MSExchange Availability" />
        <EventID Qualifiers="49156">4002</EventID>
        <Level>2</Level>
        <Task>4</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-11-28T04:55:05.000000000Z" />
        <EventRecordID>21934</EventRecordID>
        <Channel>Application</Channel>
        <Computer>INMAA3BMS0036.ifmr.co.in</Computer>
        <Security />
      </System>
      <EventData>
        <Data>10216</Data>
        <Data>ProxyWebRequest IntraSite from S-1-5-21-3939489263-3197679683-2137223578-1869 to https://webmail.ifmr.co.in/ews/exchange.asmx</Data>
        <Data>NetworkCredentials</Data>
        <Data>Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequestProcessingException: System.Net.WebException: The request was aborted: The request was canceled.
       at System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()
       at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult, Object&amp; internalAsyncState, Stream&amp; responseStream)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling():&lt;No response&gt;. The request information is ProxyWebRequest type = IntraSite, url = https://webmail.ifmr.co.in/ews/exchange.asmx
    Mailbox list = &lt;Satya Srinivasan | IFMR Trust | Marketing &amp; Branding&gt;SMTP:Satya.Srinivasan@ifmr.co.in, Parameters: windowStart = 27-11-2011 00:00:00, windowEnd = 01-12-2011 00:00:00, MergedFBInterval = 30, RequestedView = Detailed
    . ---&gt; System.Net.WebException: The request was aborted: The request was canceled.
       at System.Web.Services.Protocols.WebClientAsyncResult.WaitForResponse()
       at System.Web.Services.Protocols.WebClientProtocol.EndSend(IAsyncResult asyncResult, Object&amp; internalAsyncState, Stream&amp; responseStream)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.Proxy.Service.EndGetUserAvailability(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.FreeBusyApplication.EndProxyWebRequest(ProxyWebRequest proxyWebRequest, QueryList queryList, Service service, IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.ProxyWebRequest.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Exchange.InfoWorker.Common.Availability.AsyncWebRequest.EndInvokeWithErrorHandling()
       --- End of inner exception stack trace ---
    . Name of the server where exception originated: INMAA3BMS0036</Data>
      </EventData>
    </Event>

    lunes, 28 de noviembre de 2011 7:40
  • I can not tell you how happy I am to find this fix.  I've spent 3-4 days trying to figure this issue out and even sprung for the $260 call to Microsoft who were going to have me replace the store.exe file, etc.....Made me very nervous that they couldn't figure out the problem.  After simply removing the SSL requirement and setting the Custom Error 403;4 back to default, all 2003 and 2010 Exchange users can access ActiveSync using the Exchange Remote Connectivity Analyzer tool.  Thank you, Thank you, Thank you.
    jueves, 05 de enero de 2012 16:29
  • Thank you very very much for this answer. Most solutions out there talk about kerberos, remove passcode on phones and resetting passwords, but this was so ingeniously simple. Great!
    lunes, 23 de abril de 2012 21:55
  • Thank you so much for this.. been stuck a few hours and found this.
    martes, 11 de septiembre de 2012 22:41