none
Promedio en excel

    Pregunta

  • Hola spero puedan ayudarme     A  (CELDA)  
                                  
                

    4

    4
    5
    2
    5
    4
    4
    5

                      --------------

    =PROMEDIOA(A1:A9)=>>>EL RESULTADO ES  4.13, PERO SI LOS DATOS OSN INGRESADOS EN ESA HOJA,PERO SI YO JALO LOS VALORES DE UNA HOJA ANTERIOR,CUANDO KIERO APLICAR ESTA FUNCION TOMA LAS CELDAS VACIA Y EL PROMEDIO CAMBIA EJ, RESUL ES 3.3 ,COMO PUEDO ARREGLAR ESTE ERROR

     

    sábado, 28 de julio de 2007 5:27

Respuestas

  •  

    La funcion PROMEDIO no toma en cuenta las celdas vacias bajo ningun concepto. Creo que se te han quedado en el tintero algunos detalles.

     

    Supongo que se trata de que trasladas los valores de una hoja a otra mediante una simple formula del tipo

     

    =A1

    =A2

    =A3

    etc.

     

    En este caso si la celda de origen estaba vacia, la formula devolveria cero (0) lo cual ya no se puede considerar como valor de celda vacia.

     

    La celda tiene el valor VACIO solamente si esta realmente vacia y no hay forma de reproducirlo sino vaciando la celda de todo su contenido.

     

    Eso si, en algunos casos se puede emular el vacio usando formulas que devuelven la cadena te texto de longitud cero (""), p.ej.:

     

    =SI(A1<>"";A1;"")

    =SI(A2<>"";A2;"")

    =SI(A3<>"";A3;"")

    etc.

     

    Tambien podrias considerar la opcion de sacar el promedio directamente de los datos de la hoja original, p.ej.:

     

    =PROMEDIO(Hoja1!A1:A10)

     

    Finalmente, está la opcion de descartar las celdas que no interesan dentro de la formula, siempre y cuando el valor cero (0) no debiera formar parte del promedio en ningun caso, p.ej.:

     

    =SUMAR.SI(A1:A10;"<>0")/CONTAR.SI(A1:A10;"<>0")

     

    o una formula matricial (se introduce mediante las teclas Ctrl+Shift+Enter y no un simple Enter)

     

    =PROMEDIO(SI(A1:A10<>0;A1:A10))

     

    sábado, 28 de julio de 2007 10:17