none
Partición oculta de arranque

    Pregunta

  • Hola.

    Al revés que a mucha gente, a mi me gusta que el W7 cree una partición para el arranque y la recuperación oculta. El caso es que instalando un Seven en un SSD, se me quedaba colgada la partición del disco durante el formato, supongo que debido a que no funcionaba correctamente al ser un Netbook con controladora IDE y conversor a SATA. Formateé la partición desde otro W7 e instalé sin problemas y todo funciona a la perfección ......... pero unos días después me he dado cuanta que se quedaron los 100 megas sin usar al principio del disco. He formateado esa partición y ahora está vacía. Lo que me gustaría hacer es poner ahí el arranque y la recuperación, tal y como hace Seven por defecto, sin necesidad de reinstalarlo, que me da pereza, llevo varios días configurando todo a mi gusto. Y lamentablemente, por la red solo encuentro información de como eliminar esa partición, no de como crearla.

    Gracias por anticipado
    viernes, 06 de noviembre de 2009 20:18

Respuestas

  • Hola.

    Al revés que a mucha gente, a mi me gusta que el W7 cree una partición para el arranque y la recuperación oculta. El caso es que instalando un Seven en un SSD, se me quedaba colgada la partición del disco durante el formato, supongo que debido a que no funcionaba correctamente al ser un Netbook con controladora IDE y conversor a SATA. Formateé la partición desde otro W7 e instalé sin problemas y todo funciona a la perfección ......... pero unos días después me he dado cuanta que se quedaron los 100 megas sin usar al principio del disco. He formateado esa partición y ahora está vacía. Lo que me gustaría hacer es poner ahí el arranque y la recuperación, tal y como hace Seven por defecto, sin necesidad de reinstalarlo, que me da pereza, llevo varios días configurando todo a mi gusto. Y lamentablemente, por la red solo encuentro información de como eliminar esa partición, no de como crearla.

    Gracias por anticipado
    Copiate en esa particion el bootmgr de otra instalacion (esta oculto). Luego arrancas con el DVD de isntalacion y nada mas seleccionar el idioma en la paginasiguiente en la parte inferior izquierda hay un enlace de "recuperacion". Entra y haz que te recupere el boot...


    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 06 de noviembre de 2009 20:26

Todas las respuestas

  • Hola.

    Al revés que a mucha gente, a mi me gusta que el W7 cree una partición para el arranque y la recuperación oculta. El caso es que instalando un Seven en un SSD, se me quedaba colgada la partición del disco durante el formato, supongo que debido a que no funcionaba correctamente al ser un Netbook con controladora IDE y conversor a SATA. Formateé la partición desde otro W7 e instalé sin problemas y todo funciona a la perfección ......... pero unos días después me he dado cuanta que se quedaron los 100 megas sin usar al principio del disco. He formateado esa partición y ahora está vacía. Lo que me gustaría hacer es poner ahí el arranque y la recuperación, tal y como hace Seven por defecto, sin necesidad de reinstalarlo, que me da pereza, llevo varios días configurando todo a mi gusto. Y lamentablemente, por la red solo encuentro información de como eliminar esa partición, no de como crearla.

    Gracias por anticipado
    Copiate en esa particion el bootmgr de otra instalacion (esta oculto). Luego arrancas con el DVD de isntalacion y nada mas seleccionar el idioma en la paginasiguiente en la parte inferior izquierda hay un enlace de "recuperacion". Entra y haz que te recupere el boot...


    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 06 de noviembre de 2009 20:26
  • ¿Porqué ha de ser el bootmrg de otra instalación?
    Solo tengo a mano un instalación de W7 X64 en otro ordenador, y el que quiero recuperar es un X32 ..........

    Gracias
    viernes, 06 de noviembre de 2009 20:45
  • ¿Porqué ha de ser el bootmrg de otra instalación?
    Solo tengo a mano un instalación de W7 X64 en otro ordenador, y el que quiero recuperar es un X32 ..........

    Gracis
    Da igual.. colocale el bootmgr. (no hay de 32 o de 64, ese archivo que inicia el boot es seimpre de 32 y unico)

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 06 de noviembre de 2009 20:49
  • Ok. Voy ha hacer una copia de seguridad con el Acronis primero, y luego pruebo. Ye te contaré ........
    viernes, 06 de noviembre de 2009 20:50
  • Ok. Voy ha hacer una copia de seguridad con el Acronis primero, y luego pruebo. Ye te contaré ........
    ok.

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 06 de noviembre de 2009 21:08
  • Perfecto, gracias. Se te olvidó un detalle, quizás porque lo consideraste obvio, y es que hay que marcar como activa esa partición, si no el disco de W7 no detecta ningún error y no hace nada. Luego, si quieres, le quitas la letra y ocultas la partición, le pones como nombre lo de "Reservado para el sistema", y ya está como el original.
    Un placer volver a "verte" José Manuel. Te perdí la pista cuando cerraste tus News, donde participaba. No se si recordarás, hice unas FAQ sobre Vista que se publicaron en ellas en PDF. Lo dicho, un abrazo, y gracias otra vez.
    viernes, 06 de noviembre de 2009 22:20
  • Perfecto, gracias. Se te olvidó un detalle, quizás porque lo consideraste obvio, y es que hay que marcar como activa esa partición, si no el disco de W7 no detecta ningún error y no hace nada. Luego, si quieres, le quitas la letra y ocultas la partición, le pones como nombre lo de "Reservado para el sistema", y ya está como el original.
    Un placer volver a "verte" José Manuel. Te perdí la pista cuando cerraste tus News, donde participaba. No se si recordarás, hice unas FAQ sobre Vista que se publicaron en ellas en PDF. Lo dicho, un abrazo, y gracias otra vez.
    ;-)

    Las news estan abiertas.. mirate en el gruspo de avisos.y.funcinamiento y te da las claves al resto de grupos.

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 07 de noviembre de 2009 8:19
  • Una cosa, para "rizar el rizo". Desde que he hecho esto, ahora al pulsar f8 las opciones salen en inglés en vez de en castellano. ¿Se puede cambiar de manera fácil?
    Saludos
    sábado, 07 de noviembre de 2009 21:13
  • Una cosa, para "rizar el rizo". Desde que he hecho esto, ahora al pulsar f8 las opciones salen en inglés en vez de en castellano. ¿Se puede cambiar de manera fácil?
    Saludos
    ha sido el disco de instalacion al recuperar el que te lo ha creado así... pero da igual ¿no?... cuando instales otro win 7 te macahará otra vez con el idioma que en él hayas seleccionado...

    Recuerda que todo windows 7 es en ingles y que cuando instalas uno en castellano sigue siendo la base el de inglés y le cambian 4 enlaces a las carpetas que siguen relamente en ingles...

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 07 de noviembre de 2009 21:31
  • Realmente no es ninguna molestia que esté en Inglés. De hecho, si arranco un Ubuntu NBR que tengo en tarjeta SD, su GRUB de arranque me ha leído dos instalaciones diferentes de Seven, y una enlaza a la partición oculta, y en ese caso si está en Inglés, y el otro enlaza con la partición original, donde si sale en Español al pulsar f8, aunque ambos, lógicamente, arrancan el mismo Windows. Pensé que igual simplemente sobrescribiendo algún archivo de la partición oculta con el de la original, volvería a salir en Español.

    Saludos

    sábado, 07 de noviembre de 2009 22:08
  • Realmente no es ninguna molestia que esté en Inglés. De hecho, si arranco un Ubuntu NBR que tengo en tarjeta SD, su GRUB de arranque me ha leído dos instalaciones diferentes de Seven, y una enlaza a la partición oculta, y en ese caso si está en Inglés, y el otro enlaza con la partición original, donde si sale en Español al pulsar f8, aunque ambos, lógicamente, arrancan el mismo Windows. Pensé que igual simplemente sobrescribiendo algún archivo de la partición oculta con el de la original, volvería a salir en Español.

    Saludos

    Mejor no manipular... los ficheros de la carpeta oculta boot estan pilados siempre por el sistema... y son delicados...

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 07 de noviembre de 2009 22:31
  • No se di debería de ir aquí, pero el tema esta relacionado:

    Despues de instalar Windows 7, una instalación limpia, borre el contenido de la partición recovery que venia con mi dell, 10gb, ahi pegue una copia de botmgr y de momento la unidad esta oculta, ahora viene la duda:

    Instale el ubuntu en otra particiones, después de toquetear grub tengo arranque dual, el día que quiera eliminar el ubuntu, si se da el caso... solo tendría que marcar esa partición donde tengo la copia del bootmgr como activa y reparar con el disco de windows 7 ? es correcto?   luego desde administrador de discos seria facil formatear las particiones donde esta el ubuntu.

    Gracias
    miércoles, 11 de noviembre de 2009 12:08
  • No se di debería de ir aquí, pero el tema esta relacionado:

    Despues de instalar Windows 7, una instalación limpia, borre el contenido de la partición recovery que venia con mi dell, 10gb, ahi pegue una copia de botmgr y de momento la unidad esta oculta, ahora viene la duda:

    Instale el ubuntu en otra particiones, después de toquetear grub tengo arranque dual, el día que quiera eliminar el ubuntu, si se da el caso... solo tendría que marcar esa partición donde tengo la copia del bootmgr como activa y reparar con el disco de windows 7 ? es correcto?   luego desde administrador de discos seria facil formatear las particiones donde esta el ubuntu.

    Gracias
    Eso te funcionaria sin problemas. Pero por si acaso, incluso ahora si quieres, metes del DVD de windows, vas a la carpeta boot desde una consola (cmd.exe) arrancada como administrdor y desde ella:

    bootsect /nt60  X:  /force

    siendo X: la letra asignada a esa unidad. Esto crea el registro de "boot" el cual es el que invoca al bootmgr. Es decir si el registro no tienen el codigo para arrancar bootmgr, tampoco sería arrancable aunque esté como activa.

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    miércoles, 11 de noviembre de 2009 13:26
  • Bueno, aprovechando que me quede sin ubuntu XD esto del bootsect, aquí el resultado:

    -----------------------------------------------------------------------------------
    F:\boot>bootsect /nt60 E: /force
    Target volumes will be updated with BOOTMGR compatible bootcode.

    E: (\\?\Volume{5a2b4422-cede-11de-a7f8-806e6f6e6963})

        Forced dismount complete, open handles to this volume are now invalid.

        Successfully updated NTFS filesystem bootcode.

    Bootcode was successfully updated on all targeted volumes.
    ----------------------------------------------------------------------------------

    Supongo que todo correcto :) ahora me quedaría, hacer que esta particion sea la de arranque, y ya seria rizar el rizo  meter el grub del ubuntu ahi tambien. XD

    Gracias otra vez Jose Manuel :)

    miércoles, 11 de noviembre de 2009 17:00
  • Bueno, aprovechando que me quede sin ubuntu XD esto del bootsect, aquí el resultado:

    -----------------------------------------------------------------------------------
    F:\boot>bootsect /nt60 E: /force
    Target volumes will be updated with BOOTMGR compatible bootcode.

    E: (\\?\Volume{5a2b4422-cede-11de-a7f8-806e6f6e6963})

        Forced dismount complete, open handles to this volume are now invalid.

        Successfully updated NTFS filesystem bootcode.

    Bootcode was successfully updated on all targeted volumes.
    ----------------------------------------------------------------------------------

    Supongo que todo correcto :) ahora me quedaría, hacer que esta particion sea la de arranque, y ya seria rizar el rizo  meter el grub del ubuntu ahi tambien. XD

    Gracias otra vez Jose Manuel :)

    No me gusta el grub... nada... 

    ¿por que no te planteas el instalarlo como entrada dentro del menu de windows, es decir NO meterlo en el MBR. Tengo un ejemplo para antiguos windows en el documento mio de "Instalacion de un sistema operativo.doc" que está publicado en http://www.multingles.net/jmt.htm en su apendice. Este articulo se refiere a los viejos sistemas operativos como XP y anteriores pero se puede hacer algo similar en sistema como Vista y superiores. Echalo una miradita...

    Es decir en vez que te salga primero el grub y te permita seleccionar windows, que salga el de windows y te permita seleccionar el arranque de Linux...

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    miércoles, 11 de noviembre de 2009 17:56
  • Lo acabo de leer, suena bien, habrá que investigar esto :)

    Ya te contare

    Gracias
    miércoles, 11 de noviembre de 2009 18:16
  • Lo acabo de leer, suena bien, habrá que investigar esto :)

    Ya te contare

    Gracias
    Es facil... piensalo... y antes de hacer me nada... me comentas. Veras que con 4 lineas en el cmd.exe se puede hacer en el menu de arranque de windows 7...  :-)

    Mirate la secuencia de arrnauqe de un Vista o sueperior en este ariculo mio, para irte orientando tambien un poco:

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    miércoles, 11 de noviembre de 2009 18:24
  • Yo lo que hago es decirle a GRUB que se instale en un medio extraible (tarjeta SD o Pendrive) y así, además de no tocar nada del Windows, puedo arrancar en caso de necesidad tanto este como Linux desde ese dispositivo. Me parece lo más limpio.

    Saludos
    miércoles, 11 de noviembre de 2009 18:26
  • Yo lo que hago es decirle a GRUB que se instale en un medio extraible (tarjeta SD o Pendrive) y así, además de no tocar nada del Windows, puedo arrancar en caso de necesidad tanto este como Linux desde ese dispositivo. Me parece lo más limpio.

    Saludos
    Si efectivmanete, es lo mas limpio... :-)

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    miércoles, 11 de noviembre de 2009 18:33
  • Pues tampoco esta mal, hacerlo así, desde un usb, ya vere que hago, mejor mañana por la mañana que ahora ando espeso:)

    Gracias a los dos

    Voy a relajarme con unas partiditas de ajedrez:)
    miércoles, 11 de noviembre de 2009 18:42
  • Bueno, pasito a pasito:)
    Ya tengo esa vieja particion del recovery como Sistema, Activo, partición primaria. dentro ya esta la carpeta boot con BCD así que imagino que es correcto y ahí es donde arranca Win7, aunque c: aparece como arranque? y ya no aparece como activo.

    Ahora solo me queda ocultar esa partición y hacer una copia con el acronis :) (otra vez, bendito acronis XD)

    Ahora me queda instalar el dichoso grub en un usb, llevo 2 horas con ello y no hay manera XD, luego miramos la manera de hacer que arranque linux desde Windows:)

    Gracias
    jueves, 12 de noviembre de 2009 9:47

  • Ahora me queda instalar el dichoso grub en un usb, llevo 2 horas con ello y no hay manera XD, luego miramos la manera de hacer que arranque linux desde Windows:)

    Gracias

    ok.

    Un saludo,
    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 12 de noviembre de 2009 11:58
  • Hola Jose Manuel, me lei tu articulo, estaría muy bien eso, el problema es que no tengo manera de arrancar linux para ejecutar nada parecido a dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1, me estoy peleando con el usb, a ver si lo consigo, pero no hay manera, debo de ser un poco torpe, con el linux este, que ganas de complicarme la vida XD
    Almenos estoy contento que conseguí meter el arranque de windows en la partición oculta:)

    Ya veré que hago.

    Muchas gracias por todo crack

     


    jueves, 12 de noviembre de 2009 17:34
  • Hola Jose Manuel, me lei tu articulo, estaría muy bien eso, el problema es que no tengo manera de arrancar linux para ejecutar nada parecido a dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1, me estoy peleando con el usb, a ver si lo consigo, pero no hay manera, debo de ser un poco torpe, con el linux este, que ganas de complicarme la vida XD
    Almenos estoy contento que conseguí meter el arranque de windows en la partición oculta:)

    Ya veré que hago.

    Muchas gracias por todo crack

     


    Es decit tienes ese sector de 512 con el nombre que sea en la particion oculta ¿no? Llevalo a tu unidad C: de WIndows 7.... asumo que se llama linux.dat (lo voy a referencia así, cambialo donde proceda mas abajo).

    Si es así, consiguete un NTLDR y un NTDETECT.COM de XP o W2003 o W2000... y los dejas en C:. Te creas tambien un boot.ini en esa particion que diga:

    [boot loader]
    timeout=0
    default=c:\LINUX.DAT
    [operating systems]
    c:\LINUX.DAT="Linux"

    Si ya tuvieses arranque dual con XP, ya tendrias lo anterior y solo seria añadir la ultima linea de lo anterior al boot.ini.

    Ademas, en caso de no tener el arranque dual con XP o anteriores, deberas ejecutar en una consola en modo elevado (Ejecutar como Administrador)


    bcdedit -create {ntldr} -d "Linux"
    bcdedit -set {ntldr} device partition=C:
    bcdedit -set {ntldr} path \ntldr
    bcdedit -displayorder {ntldr} -addlast


    Y a correr....

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 12 de noviembre de 2009 17:54
  • Esto -> dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1 lo copie de tu doc, ni idea si es eso o parecido lo que tendría que poner. En la particion oculta solo esta bootmgr y  la carpeta boot con el famoso BCD y bcd.log ademas de  $recicle.bin y la carpeta System Volume information.
    El arranque dual me lo cargue ayer al machacar el MBR cuando todavía estaba en C:, la unica manera que encontre de recuperar el error de BOOT/BCD :)

    Por cierto, que tal la herramienta EasyBCD de http://neosmart.net/dl.php?id=1, la conoces?

    Saludos
    jueves, 12 de noviembre de 2009 18:14
  • Esto -> dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1 lo copie de tu doc, ni idea si es eso o parecido lo que tendría que poner. En la particion oculta solo esta bootmgr y  la carpeta boot con el famoso BCD y bcd.log ademas de  $recicle.bin y la carpeta System Volume information.
    El arranque dual me lo cargue ayer al machacar el MBR cuando todavía estaba en C:, la unica manera que encontre de recuperar el error de BOOT/BCD :)

    Por cierto, que tal la herramienta EasyBCD de http://neosmart.net/dl.php?id=1, la conoces?

    Saludos
    El EasyBCD es sacrilegio !!!!   :-P

    Coloca el bootsect.lnx en C:\ y los archvos que te he dicho tambien... (en tu WIndows 7, no en la oculta). Y luego ejecutas las instrucciones del bcdedit...  que esto funciona !!!!.  (cambia en el boot.ini el linux.dat por ese bootsect.lnx

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 12 de noviembre de 2009 18:35
  • Ok, lo intento, pero si me peta todo y luego te miro con mala cara no te quejes eh XD

    Toco madera, bueno mejor el cd de arranque del acronis XD

    Ya te cuento, a ver si puedo hacerlo hoy
    jueves, 12 de noviembre de 2009 18:44
  • Ok, lo intento, pero si me peta todo y luego te miro con mala cara no te quejes eh XD

    Toco madera, bueno mejor el cd de arranque del acronis XD

    Ya te cuento, a ver si puedo hacerlo hoy
    desde luego... en el peor de los casos... si eres un poco zarpas... :-P ... lo peor que puede pasar es que linux no te arranque: pero windows 7 seguro que si.   ;-)

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 12 de noviembre de 2009 18:48
  • Jojojo, empezamos mal, este bootsect.lnx no existe , en mi instalación de linux XD me he tenido que meter con el cd de ubuntu XD para buscarlo, esto -> dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1  lo copie de tu documento sobre instalación de sistemas operativos, solo lo pegue como ejemplo de algo que no podía hacer por no puedo arrancar ese ubuntu instalado XD

    Saludos :)


    jueves, 12 de noviembre de 2009 19:06
  • Lo que dije de poner el GRUB en un medio extraible, lo puedes hacer de manera fácil cuando instalas Ubuntu, marcando avanzadas, te da la opción de donde quieres ponerlo. Si es con el sistema instalado, ya no se muy bien, no lo he hecho nunca, pero creo recordar que lleva una herramienta para crear un disco de rescate ......

    Saludos
    jueves, 12 de noviembre de 2009 20:06
  • Jojojo, empezamos mal, este bootsect.lnx no existe , en mi instalación de linux XD me he tenido que meter con el cd de ubuntu XD para buscarlo, esto -> dd if=/dev/hda2 of=/bootsect.lnx bs=512 count=1  lo copie de tu documento sobre instalación de sistemas operativos, solo lo pegue como ejemplo de algo que no podía hacer por no puedo arrancar ese ubuntu instalado XD

    Saludos :)


    Es que mi ejemplo es para el device hda2.  Esto hay que cambiarlo en funcion del dispositivo en donde lo hayas instalado y eso te lo genera en donde estés en ese momento en la consola. Lo copias luego a la particion de windows y a correr...

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    jueves, 12 de noviembre de 2009 21:02
  • No hay manera , de momento:)
    Instale el XP en una maquina virtual para conseguir NTLDR y NTDETECT.COM, he repasado varias veces el tema, el boot.ini esta correcto lo del ntldr lo hice bien, arranca windows y me da opcion de arrancar windows o linux, cuando le doy a windows ningún problema, pero si le doy a linux se reinicia sin ningún mensaje de error... lo he probado con todos los discos duros que me aparecen en linux, para asegurarme, el resultado es el mismo, seguiré investigando, ahora ya me he puesto tozudo XD

    Gracias
    viernes, 13 de noviembre de 2009 18:43
  • No hay manera , de momento:)
    Instale el XP en una maquina virtual para conseguir NTLDR y NTDETECT.COM, he repasado varias veces el tema, el boot.ini esta correcto lo del ntldr lo hice bien, arranca windows y me da opcion de arrancar windows o linux, cuando le doy a windows ningún problema, pero si le doy a linux se reinicia sin ningún mensaje de error... lo he probado con todos los discos duros que me aparecen en linux, para asegurarme, el resultado es el mismo, seguiré investigando, ahora ya me he puesto tozudo XD

    Gracias
    dejame aquí el contenido del boot.ini que has creado...


    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 13 de noviembre de 2009 18:49
  • Puse lo mismo que me dijiste mas arriba:

    [boot loader]
    timeout=0
    default=c:\LINUX.DAT
    [operating systems]
    c:\LINUX.DAT="Linux"

    Claro, en linux grabe el LINUX.DAT y lo copie a c:\

    Esto es el bcdedit:

    Administrador de arranque de Windows
    ----------------------------------
    Identificador           {bootmgr}
    device                  partition=\Device\HarddiskVolume2
    path                    \bootmgr
    description             Windows Boot Manager
    locale                  es-ES
    default                 {current}
    displayorder            {current}
                            {ntldr}
    timeout                 30

    Cargador de arranque de Windows
    -----------------------------
    Identificador           {current}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Windows 7 Home Premium (recuperado)
    locale                  es-ES
    recoverysequence        {c11d82dd-cf65-11de-9686-b916090c7441}
    recoveryenabled         Yes
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {ce5cfaa8-cf65-11de-9d5c-806e6f6e6963}

    Cargador del SO Windows heredado
    --------------------------------------------------
    Identificador           {ntldr}
    device                  partition=C:
    path                    \ntldr
    description             linux

    Una duda com ->  bcdedit / delete {ntldr} / cleanup  eliminaria este arranque dual?

    Saludos:)
    viernes, 13 de noviembre de 2009 18:53
  • Puse lo mismo que me dijiste mas arriba:

    [boot loader]
    timeout=0
    default=c:\LINUX.DAT
    [operating systems]
    c:\LINUX.DAT="Linux"

    Claro, en linux grabe el LINUX.DAT y lo copie a c:\

    Esto es el bcdedit:

    Administrador de arranque de Windows
    ----------------------------------
    Identificador           {bootmgr}
    device                  partition=\Device\HarddiskVolume2
    path                    \bootmgr
    description             Windows Boot Manager
    locale                  es-ES
    default                 {current}
    displayorder            {current}
                            {ntldr}
    timeout                 30

    Cargador de arranque de Windows
    -----------------------------
    Identificador           {current}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Windows 7 Home Premium (recuperado)
    locale                  es-ES
    recoverysequence        {c11d82dd-cf65-11de-9686-b916090c7441}
    recoveryenabled         Yes
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {ce5cfaa8-cf65-11de-9d5c-806e6f6e6963}

    Cargador del SO Windows heredado
    --------------------------------------------------
    Identificador           {ntldr}
    device                  partition=C:
    path                    \ntldr
    description             linux

    Una duda com ->  bcdedit / delete {ntldr} / cleanup  eliminaria este arranque dual?

    Saludos:)
    Cambialo por esto:

    [boot loader]
    timeout=30
    default=c:\LINUX.DAT
    [operating systems]
    c:\KK.DAT="Falso...."
    c:\LINUX.DAT="Linux"


    ¿llegas a ver un segundo menu despues de seleccionar linux?...

    Y por cierto... tambien te dije que habioa que cambiar LINUX.DAT por el nombre de lo que hubiese generado el fichero en linux al salvar el registro de boot... el que debes copiar a C:\   ¿está copiado? ¿con que nombre?... cambiale el nombre en el boot.ini de LINUX.DAT al tuyo...


    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 13 de noviembre de 2009 19:19
  • Cambie el boot.ini y el resultado es el mismo, le doy y reinicia, sin ningún menú.
    Si esta copiado bien, y en boot ini esta con su nombre, lo he probado generandolo en linux con los nombres de linux.dat y bootsect.lnx , cambiando cada vez el boot.ini, y reiniciando un montón de veces:) suerte que el 7 arranca rapidísimo :)

    Con ->  bcdedit / delete {ntldr} / cleanup  eliminaria este arranque dual?


    viernes, 13 de noviembre de 2009 20:17
  • Cambie el boot.ini y el resultado es el mismo, le doy y reinicia, sin ningún menú.
    Si esta copiado bien, y en boot ini esta con su nombre, lo he probado generandolo en linux con los nombres de linux.dat y bootsect.lnx , cambiando cada vez el boot.ini, y reiniciando un montón de veces:) suerte que el 7 arranca rapidísimo :)

    Con ->  bcdedit / delete {ntldr} / cleanup  eliminaria este arranque dual?


    Si lo eliminaria... pero no lo hagas todavía.

    A ver,,, copialos a la particion oculta (el ntldr, boot.ini...etc)

    Y ahora haz:

    bcdedit /set {ntldr} device=\Device\HarddiskVolume2

    y dime que pasa...


    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    viernes, 13 de noviembre de 2009 20:47
  • Hice esto: bcdedit /set {ntldr} device partition=\Device\HarddiskVolume2 , con el comando que me pusiste tu daba error
    También cambie las referencias en boot.ini, para que apuntaran a la partición de arranque.

    Ahora sale el menú, cuando le doy a linux, me devuelve el mensaje Falso...   y aparece linux otra vez, le doy y me dice que falta el archivo system32\hal.dll

    Nada que no hay manera :)

    Ejecute ->  bcdedit /delete {ntldr} /f , y  con el acronis recupere un mbr con GRUB  en esa partición oculta, si si, me rendi XD


    Gracias
    sábado, 14 de noviembre de 2009 7:25


  • Ejecute ->  bcdedit /delete {ntldr} /f , y  con el acronis recupere un mbr con GRUB  en esa partición oculta, si si, me rendi XD

    ..que verguenza... :-PPP

    Esto hay que intentarlo de nuevo... porqure funcionar.. funciona.  :-)


    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 14 de noviembre de 2009 9:10
  • Seguro que funciona, y seria mas elegante que el grub, pero no hallamos la manera, imagino que la culpa es del sector de arranque del linux, no lo pasamos bien a windows.
    Ahora me he asegurado, tengo copiados el MBR con y sin GRUB, ademas de toda la partición oculta y el disco con windows 7 acronis power!!! XD

    Saludos y gracias crack:)
    sábado, 14 de noviembre de 2009 15:19
  • Seguro que funciona, y seria mas elegante que el grub, pero no hallamos la manera, imagino que la culpa es del sector de arranque del linux, no lo pasamos bien a windows.
    Ahora me he asegurado, tengo copiados el MBR con y sin GRUB, ademas de toda la partición oculta y el disco con windows 7 acronis power!!! XD

    Saludos y gracias crack:)
    No. Si hiciste la prueba de modificar y dejar este boot.ini

    [boot loader]
    timeout=30
    default=c:\LINUX.DAT
    [operating systems]
    c:\KK.DAT="Falso...."
    c:\LINUX.DAT="Linux"

    despues de seleccionar Linux en el menu inicia de arranque de windows 7, deberia haberte salido otro menu estilo antiguo que te diese la opcion de "Falso" o "linuX" (por eso te lo modifqué. Si no te salió indica que el ntldr no estaba bien... que hay error en su carga...

    Un saludo,



    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 14 de noviembre de 2009 16:25
  • Si ti, como dije mas arriba si sale ese menú:

    -Ahora sale el menú, cuando le doy a linux, me devuelve el mensaje Falso...   y aparece linux otra vez, le doy y me dice que falta el archivo system32\hal.dll -

    Saludos
    sábado, 14 de noviembre de 2009 16:45
  • Si pusiste IDENTICO ese boot.ini  ¿dejaste el archivo del arranque de linux con ese nombre de LINUX.DAT?...
    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 14 de noviembre de 2009 16:54
  • No, claro que no, puse el nombre del archivo que saque del ubuntu, bootsect.lnx, de hecho probe con los 3 discos que aparecen en el ubuntu, cargando cada vez un bootsect.lnx distinto para asegurarme, y nada, lo único que se me ocurre es que ese bootsect.lnx no esta bien.

    Saludos
    sábado, 14 de noviembre de 2009 20:46
  • No, claro que no, puse el nombre del archivo que saque del ubuntu, bootsect.lnx, de hecho probe con los 3 discos que aparecen en el ubuntu, cargando cada vez un bootsect.lnx distinto para asegurarme, y nada, lo único que se me ocurre es que ese bootsect.lnx no esta bien.

    Saludos
    Por si acaso, ¿por que no puebas cambiando las referencia de C:\ por D:\  (es mas que posible que el NTLDR se esté liando... y al final me vas a liar a mi y lo voy a tener que probar... :-P)

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    sábado, 14 de noviembre de 2009 21:46
  • De acuerdo, mañana por la mañana lo pruebo, a ver, pero sigo pensando que es el bootsect.lnx que lo pillamos mal. Mira que me das trabajo eh XD

    No estaría de mas que lo probaras eh :P  pero acuérdate de hacer una copia del MBR , y luego me cuentas ;)

    Saludos
    domingo, 15 de noviembre de 2009 20:04


  • No estaría de mas que lo probaras eh :P  pero acuérdate de hacer una copia del MBR , y luego me cuentas ;)

    Saludos
    je!... pero no te iba a servir... depende de cada particion (y sería casualidad que coincidiesemos... :-P)

    Un slaudo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    domingo, 15 de noviembre de 2009 20:14
  • Hombre si el fallo esta donde yo creo claro que me  servira:)

    Creo que todo el proceso esta bien, lo que falla es el sector de arranque del linux.

    Bueno, mañana te cuento que tal me fue.

    Saludos
    domingo, 15 de noviembre de 2009 20:36
  • Hombre si el fallo esta donde yo creo claro que me  servira:)

    Creo que todo el proceso esta bien, lo que falla es el sector de arranque del linux.

    Bueno, mañana te cuento que tal me fue.

    Saludos
    supongo que al aplicar mi articulo, en vez de hda2, pones lo que corresponde a tu instalacion... ¿no?...

    Un saludo,

    Untitled 1

    Jose Manuel Tella Llop news://jmtella.com

    domingo, 15 de noviembre de 2009 20:44
  • Hombre, pues claro, por quien me tomas eh XD que manejo ordenadores desde antes del MS-DOS, el CP/M,en aquellas maquinas con bus S100, ha llovido un poco desde entonces XD

    lunes, 16 de noviembre de 2009 10:58
  • Hombre, pues claro, por quien me tomas eh XD que manejo ordenadores desde antes del MS-DOS, el CP/M,en aquellas maquinas con bus S100, ha llovido un poco desde entonces XD

    Debemos ser de la misma quinta... :-P

    je... y por cierto...hay que preguntar de todo por si acaso... ¿te sabes eso?.. de aquel que llama al centro de soporte y dice; "no se me instala el sistema operativo". Pregunta: ¿ha metido los tres disquetes?. Respuesta: pues si, el primero sin problemas, el segundo he tenido que apretar un poco y lo que pasa es que el tercero ya no me entra por mucha fuerza que haga... :-P
     

    Un saludo,

    Jose Manuel Tella Llop news://jmtella.com

    lunes, 16 de noviembre de 2009 11:45