none
windows no tiene suficiente informacion para verificar este certificado

    Pregunta

  • Hola,

    a raiz de un problema con Office (no se que paso con esa maquina pero tenia el 2007 y un dia aparecio tambien el 2003 menos el outlook y me empezo a pedir archivos .msp) el caso que ya solucione este tema y ahora solo tengo el office 2007, pues a raiz de esto, me da un error con el certificado que tengo para la cuenta exchange
    Cuando abro outlook 2007 me sale un recuadro de seguridad siempre....os pongo el link porque desconozco si se puede subir fotos...

    http://img35.imageshack.us/i/alerta1.jpg/

    Si voy a mirar la informacion mas detallada me sale el mensaje que aparece en esta web
    http://www.entrust.net/knowledge-base/technote.cfm?tn=7972

    El certificado lo tengo empresas de confianza. Lo he quitado, puesto, no esta caducado. He reinstalado y reparado el office. He limpiado resgistro de posibles entradas del Office 2003, tanto a mano como con ccleaner.
    El iexplorer es la 8, y tambien desintale y volvi a instalar por si el problema viene por iexplorer

    El outlook luego funciona bien, tras darle a SI en la primera ventana, pero no me fio un pelo y me gustaria saber donde esta el error

    Muchas gracias
    miércoles, 12 de enero de 2011 15:15

Respuestas

  • Hola, Quique:

    El problema que planteas se refiere al certificado de seguridad que tienes implementado en tu servidor MSExchange, cuyo proceso de asignación ha cambiado radicalmente y ahora hace falta hacer uso del PowerShell (o Exchange Managemente Shell) para gestionarlos sin que te salga éste molesto mensaje, a pesar de tener el certificado correctamente implementado entre las entidoras de confianza.

    Te recomiendo accedas a la consola PowerShell y desde la misma identifica los certificados implementados para tus servicios asociados a MSExchannge haciendo uso del comando 'Get-ExchangeCertificate' (sin comillas) y, una vez identificado tu certificado correcto (que será mucho más sencillo si previamente desde la consola MMC-Certificates - Computer - eliminas los 'sobrantes') asegúrate de conocer el thumbprint asociado al mismo (copiándolo al bloc de notas, por ejemplo) e indícalo posteriormente haciendo uso del comando 'Enable-ExchangeCertificate [código thumbprint] -Services:"IIS".

    Más información:
    · Uso correcto del comando 'Enable-ExchangeCertificate':
    http://technet.microsoft.com/en-us/library/aa997231(EXCHG.80).aspx

    · Uso de certificados en MSExchange 2k7:
    http://technet.microsoft.com/en-us/library/bb851505(EXCHG.80).aspx

    Espero haberte servido de ayuda
    Un saludo

    viernes, 21 de enero de 2011 10:36

Todas las respuestas

  • Hola Quique,

    Ustedes administran su servidor exchange ?

    el certificado que utilizas por que entidad certificadora fue expedido, fue por Entrust como aparece en la imagen ?

    revisa los equipos que actualmente no presentan este problema que certificados tienen instalados, de que entidad y en que contenedores, para ver si existe alguan diferencia entre los certificados, esto lo puedes revisar como indica la pagina

    1 - Start > Run; type MMC and press Enter.
    2 - Click FileAdd/Remove Snap-in.
    3 - Click Add.
    4 - Select Certificates and click Add.
    5 - A wizard will open. Select Computer account and click Next.
    6 - Select Local Computer and click finish
    7 - Click Close.
    8 - Click Okay.
    9 - Expand Certificates on the left hand side of the console window.

    esperamos tus comentarios

    Saludos


    Ruben Rosales Matamoros MCSE + M / MCTS
    miércoles, 12 de enero de 2011 16:57
  • Hola,

    no, no administro el exchange, pero no es problema del exchange porque tengo mas equipos de la misma forma y con el mismo certificado y no les aparece esa primera ventana

    Y no, el certificado no es de Entrust, solo era por poner la foto

    Ademas, el certificado administra cuenta de usuario no cuenta de equipo

    Les cuento mas datos porque no se por donde cogerlo....

    A modo de ejemplo, el certificado a instalar para los buzones exchange le vamos a llamar CERT-A y pongamos que esta emitido por la empresa EMPR-A y enviado a EMPR-A

    Pues bien, cuando sale esa primera ventana que puse en imagesshack, el certificado que aparece es otro, llamemosle CERT-B, con otras fechas de emision y caducidad y pone emitido por EMPR-B y enviado a "nombre de dominio de correo" osea, xxxxx.es. Vamos que no se porque me esta apareciendo ese segundo certificado ni que pinta en todo esto

    Desde la mmc quite ese certificado de todos los sitios que aparecia pero aun me sigue apareciendo el mensaje. Tambien busque en el registro pero no aparecio nada

    Tambien probe a configurar un perfil nuevo en el XP y configurar desde el principio, el problema no desaparece

    Y aqui ya viene el poltergeist, instale el certificado bueno y configure la cuenta exchange en otro equipo y pasa lo mismo. Pero problema del certificado no tiene que ser porque esta funcionando en otros equipo desde hace meses y ese primer mensaje no aparece

    Puede ser que esos equipos tengan algo en comun y por eso les pasa a los dos? si es asi no caigo en que.... Puede ser que se haya hecho algun cambio en la CA o en exchange y a partir de ahora cuando se configura todo aparezca ese mensaje?

    El caso que el outlook funciona correctamente, entiendo que porque el certificado bueno esta instalado, pero no se porque me sigue apareciendo esa ventana datos de ese certificado

    Sigo dandole vueltas, si a alguien se le ocurre algo.....

     

    Gracias

    jueves, 13 de enero de 2011 12:37
  • Hola Quique,

    Podemos hacer la siguiente prueba asi como tu nos comentas:

    que instalaste el certificado bueno y configuraste la cuenta exchange en otro equipo y pasa lo mismo. Pero problema del certificado no tiene que ser porque esta funcionando en otros equipo.

    ya probaste en configurarla en un equipo que no presenta ningun problema con el certificado que actualmente este funcionando con cualquier otra cuenta, configura la cuenta en un equipo funcionando para ver como se comporta y vicebersa configura una cuenta que actualmente este funcionando en el equipo nuevo donde instalaste el certificado bueno y en el equipo donde presentas el problema para ver tambien como se comporta con esta cuenta.

    Lo del exchange te lo preguntaba por si es necesario revisar ciertos paramentros, lo de los certificados solo confirma que esten instalados los mismos certificados y en los mismos contenedores.

    puede ser algun detalle con el user y la CA pueden validar esto tambien

    Saludos


    Ruben Rosales Matamoros MCSE + M / MCTS
    jueves, 13 de enero de 2011 16:49
  • Gracias de nuevo, seguire haciendo revisandolo
    viernes, 14 de enero de 2011 7:56
  • Hola, Quique:

    El problema que planteas se refiere al certificado de seguridad que tienes implementado en tu servidor MSExchange, cuyo proceso de asignación ha cambiado radicalmente y ahora hace falta hacer uso del PowerShell (o Exchange Managemente Shell) para gestionarlos sin que te salga éste molesto mensaje, a pesar de tener el certificado correctamente implementado entre las entidoras de confianza.

    Te recomiendo accedas a la consola PowerShell y desde la misma identifica los certificados implementados para tus servicios asociados a MSExchannge haciendo uso del comando 'Get-ExchangeCertificate' (sin comillas) y, una vez identificado tu certificado correcto (que será mucho más sencillo si previamente desde la consola MMC-Certificates - Computer - eliminas los 'sobrantes') asegúrate de conocer el thumbprint asociado al mismo (copiándolo al bloc de notas, por ejemplo) e indícalo posteriormente haciendo uso del comando 'Enable-ExchangeCertificate [código thumbprint] -Services:"IIS".

    Más información:
    · Uso correcto del comando 'Enable-ExchangeCertificate':
    http://technet.microsoft.com/en-us/library/aa997231(EXCHG.80).aspx

    · Uso de certificados en MSExchange 2k7:
    http://technet.microsoft.com/en-us/library/bb851505(EXCHG.80).aspx

    Espero haberte servido de ayuda
    Un saludo

    viernes, 21 de enero de 2011 10:36