none
¿Tiene Windows capado el puerto 25 para ciertas aplicaciones?

    Pregunta

  • Hola a todos.

    Extraña pregunta la del titulo del hilo, pero os explico que me pasa. Ya se que este foro es para productos Microsoft Windows, pero debo mencionar otro sistema operativo para explicar el problema.

    Hemos montado un servidor de correo con Linux (en realidad es una maquina virtual que corre sobre un Windows XP x64), para dar servicio de correo internamente en nuestra LAN, no sale a Internet para nada. Los motivos no tiene importancia comentarlos.

    El caso es que una vez montado el servidor de correo, para comprobar que funcionaba, he configurado una cuenta de correo, y me funciona el recibir, pero no puedo enviar (no es del todo cierto como luego explico). Para comprobar si el puerto 25 esta abierto, he hecho un netstat en el Linux, y pone que si esta escuchando. Telnet desde el propio Linux virtual a localhost en el puerto 25 funciona, pero desde mi maquina (Windows 7 con telnet instalado) no funciona telnet al puerto 25. La maquina la veo, porque hago ping a su IP, e incluso telnet al puerto 110, pero el 25 no me funciona. Desde el propio XP que corre la maquina virtual, tampoco hace telnet al puerto 25, pero sin embargo, desde un Linux externo (maquina física separada), si funciona el telenet al puerto 25.

    Antes he mencionado que no podía enviar correo, pero que era una verdad a medias, y es por lo siguiente. No puedo enviar correo si configuro la cuenta de correo en Windows Live Mail (lo uso como sustituto del Outlook Express en Windows 7), pero sin embrago, me funciona sin problemas si configuro la cuenta de correo el Microsoft Outlook 2010, con los mismo datos que use en el Live Mail.

    Debido a todas estas cosas, deduzco que el puerto 25 si esta escuchando, ya que desde un Linux hago telnet, y desde Microsoft Outlook envía correo, pero no se porque no me funciona hacer telnet desde el Windows 7, o incluso desde el propio Windows XP donde esta corriendo la maquina virtual. Incluso he detenido el firewall del Windows XP donde corre la maquina virtual para comprobar si ese era el problema.

    ¿Acaso Windows corta el puerto 25 a algunas aplicaciones, como el Live Mail, o el telenet, pero no al Outlook?

    No se, ya se que esto es muy extraño, pero por mas pruebas que hago, no le encuentro la solución ni la lógica.

    Gracias de antemano.

    lunes, 17 de junio de 2013 11:19