none
Server Error in '/' Application. for non admin users

    Pregunta

  • HI All,

    I have recently installed FIM 2010 which i am trying to set up for Self Service Password Portal. I have FIM synchronising users from an OU in my domain which seems fine so far. I can log in to the /IdentityManagement page on the server (or any server for that matter) using the domain admin account (which is not synced to FIM....) but if i use any other users (who are synced) i get the error page:

    Server Error in '/' Application.

    The endpoint could not dispatch the request.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Microsoft.ResourceManagement.WebServices.Faults.ServiceFaultException: The endpoint could not dispatch the request.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ServiceFaultException: The endpoint could not dispatch the request.]
       Microsoft.ResourceManagement.WebServices.Client.ResourceTemplate.EnumerateResources(SearchParameters parameters) +1457
       Microsoft.IdentityManagement.WebUI.Controls.ConfigurationModelBase.RetrieveResources(String type, String filter, List`1 attributes) +499
    
    [ServerDownException: Error connecting to server]
       Microsoft.IdentityManagement.WebUI.Controls.ConfigurationModelBase.RetrieveResources(String type, String filter, List`1 attributes) +1171
       Microsoft.IdentityManagement.WebUI.Controls.UserConfigurationModel.RetrieveUserConfiguration() +536
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarConfigurationModel.get_NavigationBars() +148
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarProvider.BuildSiteMap() +242
       Microsoft.IdentityManagement.WebUI.Controls.NavigationBarProvider.get_RootNode() +13
       System.Web.UI.WebControls.SiteMapDataSource.GetNodes() +231
       System.Web.UI.WebControls.SiteMapDataSource.GetTreeView(String viewPath) +35
       System.Web.UI.WebControls.HierarchicalDataBoundControl.GetData(String viewPath) +43
       System.Web.UI.WebControls.Menu.DataBindItem(MenuItem item) +53
       System.Web.UI.WebControls.Menu.PerformDataBinding() +49
       System.Web.UI.WebControls.HierarchicalDataBoundControl.PerformSelect() +114
       System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +82
       System.Web.UI.WebControls.Menu.EnsureDataBound() +38
       System.Web.UI.WebControls.Menu.OnPreRender(EventArgs e, Boolean registerScript) +64
       Microsoft.SharePoint.WebControls.AspMenu.OnPreRender(EventArgs e) +166
       System.Web.UI.Control.PreRenderRecursiveInternal() +108
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Control.PreRenderRecursiveInternal() +224
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3394
    


    Version Information: Microsoft .NET Framework Version:2.0.50727.4963; ASP.NET Version:2.0.50727.4971

    Now if i log on to this same PC (Windows 7 with IE 8) it works ok for that user.

    I can browse the default SharePoint page using this user as i have anonymous browsing set up on the base and on the IdentityManagement pages

    I have also checked:

    1. Attrib values for user: 

    AccountName : mgibney
    DisplayName : Martin Gibney
    Domain      : TEC
    ObjectSID   : AQUAAAAAAAUVAAAAwLjIx+qbqvgxreposQQAAA==
    StringSID   : S-1-5-21-3351820480-4171930602-1760210225-1201
    using the script : http://social.technet.microsoft.com/wiki/contents/articles/2100.how-to-use-powershell-to-display-a-users-attribute-values-for-fim-portal-access-en-us.aspx

    2. Checked the MPR using the script and i get the following :

    FIM MPR Configuration For Synchronization Check
    ===============================================


    Missing attributes of Synchronization: Synchronization account controls users it synchronizes:
     -MVObjectID
     -DisplayName
     -Domain
     -FirstName
     -LastName
     -ObjectSID
     -AccountName
     -SIDHistory

    Caution: Your current MPR configuration requires your attention!

    So maybe the above? However, all these attributes are synced for the users (im not syncing the FIM service accounts... or should i?)

    any help much appreciated.

    Martin


    Martin

    jueves, 01 de marzo de 2012 16:56

Todas las respuestas