none
SBS 2008 reinstall Sharepoint or fix?

    Pregunta

  • Hi Guys,

    We have a SBS 2008 install. We cannot access Sharepoint. Going to sharepoint or the admin console gives a 404 error. I've checked the bindings and it all seems fine. We don't really want to reinstall as we've read about horror stories of doing this.

    The services are all running, could anyone make a suggestion on troubleshooting this?

    Thanks

    miércoles, 13 de junio de 2012 4:43

Respuestas

Todas las respuestas

  • Hello,

    Do you have any data stored within Sharepoint or any Customisations ?

    I have actually found that with an unconfigured broken Sharepoint, it is easier to fully remove it and reinstall it.

    With regards to your issue, are there any errors in the eventlog?, any services that are not started?, Is the IIS default Web started? Can you open the Sharepoint Central administration from the Administrators tools on the start menu ?

    Thanks


    Michael Jenkin (Mickyj) www.mickyj.com (Community website) - SBS MVP (2004 - 2008) *5 times Microsoft MVP award winner *Previously MacWorld Australia contributer *Previously APAC Vice Chairman Culminis (Pro IT User group support system)* APAC chairman GITCA *Director Business Technology Partners, Microsoft Small Business Specialist, SMB150 2012 Member

    miércoles, 13 de junio de 2012 9:39
  • Hey Michael, got a link for that full remove/re-install of SharePoint on SBS08? Last time I looked at the MS instructions, well, they left a bit to be desired.
    miércoles, 13 de junio de 2012 10:24
  • Hi Michael,

    The SharePoint admin console returns a 404 error as well. There is no SharePoint data or customisation  on the server. 

    event logs 

    Log Name:      Application
    Source:        Windows SharePoint Services 3 Search
    Date:          14/06/2012 10:11:16 a.m.
    Event ID:      2424
    Task Category: Gatherer
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      TJGSERVER.tjg.local
    Description:
    The update cannot be started because the content sources cannot be accessed. Fix the errors and try the update again.

    Context: Application 'Search', Catalog 'index file on the search server Search'
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows SharePoint Services 3 Search" />
        <EventID Qualifiers="32768">2424</EventID>
        <Level>2</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-13T22:11:16.000Z" />
        <EventRecordID>2023366</EventRecordID>
        <Channel>Application</Channel>
        <Computer>TJGSERVER.tjg.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>

    Context: Application 'Search', Catalog 'index file on the search server Search'</Data>
      </EventData>
    </Event>


    Log Name:      Application
    Source:        Windows SharePoint Services 3 Search
    Date:          14/06/2012 10:11:16 a.m.
    Event ID:      2436
    Task Category: Gatherer
    Level:         Warning
    Keywords:      Classic
    User:          N/A
    Computer:      TJGSERVER.tjg.local
    Description:
    The start address <sts3://tjgserver:4721/contentdbid={5b40a634-7376-4cbb-adc4-89e6b0d8a5b4}> cannot be crawled.

    Context: Application 'Search index file on the search server', Catalog 'Search'

    Details:
    Error in the Site Data Web Service.   (0x80042616)
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows SharePoint Services 3 Search" />
        <EventID Qualifiers="32768">2436</EventID>
        <Level>3</Level>
        <Task>3</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-13T22:11:16.000Z" />
        <EventRecordID>2023365</EventRecordID>
        <Channel>Application</Channel>
        <Computer>TJGSERVER.tjg.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>

    Context: Application 'Search index file on the search server', Catalog 'Search'

    Details:
    Error in the Site Data Web Service.   (0x80042616)</Data>
        <Data>sts3://tjgserver:4721/contentdbid={5b40a634-7376-4cbb-adc4-89e6b0d8a5b4}</Data>
      </EventData>
    </Event>


    Log Name:      Application
    Source:        Windows SharePoint Services 3
    Date:          14/06/2012 10:11:15 a.m.
    Event ID:      6800
    Task Category: Topology
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      TJGSERVER.tjg.local
    Description:
    The database ShareWebDb on TJGSERVER\Microsoft##SSEE is not accessible to missing Windows Internal Database signatures.
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows SharePoint Services 3" />
        <EventID Qualifiers="0">6800</EventID>
        <Level>2</Level>
        <Task>807</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2012-06-13T22:11:15.000Z" />
        <EventRecordID>2023361</EventRecordID>
        <Channel>Application</Channel>
        <Computer>TJGSERVER.tjg.local</Computer>
        <Security />
      </System>
      <EventData>
        <Data>The database ShareWebDb on TJGSERVER\Microsoft##SSEE is not accessible to missing Windows Internal Database signatures.</Data>
      </EventData>
    </Event>

    any ideas?

    Thanks


    • Editado Neal03 miércoles, 13 de junio de 2012 22:14
    miércoles, 13 de junio de 2012 20:20
  • Hello SuperGumby,

    Great to hear from you. I have to say, with the Microsoft documentation, I have to agree. I still in some cases have found this difficult process easier than trying to repair a broken Companyweb. Depends on what broke.

    With this case, we need more information before we go for a full reinstall.

    To answer SuperGumby's question (and not necessarily the answer for Neil03)

    .. Unfortunately I have lots of different resources to fix Companyweb, as many of the fixes work in a particular situation.

    If they have removed the Microsoft Windows SharePoint Services 3.0 from control panel, I have used this to get them back up http://technet.microsoft.com/en-us/library/dd548327(v=ws.10).aspx

    I have also used the restore features of Symantec System Recovery to bring back an earlier version of the website.

    I have used SBS 2008 disk 2 - WSS setup (Windows SharePoint Services 3.0), run the exe file, click the repair option. You also need to run "SharePoint Products and Technologies Configuration Wizard"  (Start > Administration Tools)

    there is also a run through here http://www.thehelpdesk.co.nz/2011/03/reinstallrepair-sbs-2008-companyweb.html

    Michael Jenkin (Mickyj) www.mickyj.com (Community website) - SBS MVP (2004 - 2008) *5 times Microsoft MVP award winner *Previously MacWorld Australia contributer *Previously APAC Vice Chairman Culminis (Pro IT User group support system)* APAC chairman GITCA *Director Business Technology Partners, Microsoft Small Business Specialist, SMB150 2012 Member

    jueves, 14 de junio de 2012 7:58
  • Looking around at other peoples solution to similar issues, it looks like the sharepoint wizard did not complete completely.

    There are some ideas that I think are worth following in these two links.

    http://www.itsolutionskb.com/2009/05/the-database-wss_content-on-computernamemicrosoftssee-is-not-accessible-to-missing-windows-internal-database-signatures/

    http://support.microsoft.com/?id=941678


    Michael Jenkin (Mickyj) www.mickyj.com (Community website) - SBS MVP (2004 - 2008) *5 times Microsoft MVP award winner *Previously MacWorld Australia contributer *Previously APAC Vice Chairman Culminis (Pro IT User group support system)* APAC chairman GITCA *Director Business Technology Partners, Microsoft Small Business Specialist, SMB150 2012 Member

    jueves, 14 de junio de 2012 8:03
  • Try these links:

    Repair user access to the internal Web site - http://technet.microsoft.com/en-us/library/dd548330%28WS.10%29.aspx

     

    Reinstall Windows SharePoint Services - http://technet.microsoft.com/en-us/library/dd548327(WS.10).aspx

     

    Repair other issues with Windows SharePoint Services - http://technet.microsoft.com/en-us/library/dd560621(WS.10).aspx

     

    Blank page or 401.1 Unauthorized accessing Companyweb from SBS Server - http://support.microsoft.com/kb/971272


    Thanks Robert Crane [MVP-Office365] www.ciaops.com

    viernes, 15 de junio de 2012 2:51
    • Marcado como respuesta infused domingo, 17 de junio de 2012 23:03
    domingo, 17 de junio de 2012 23:03
  • Thanks infused!

    This fixed my problem more thatn one times.  I consult with many clients and I have had three servers where the companyweb has been broken.  This fixed all three locations.  Yahoo!!!!

    http://blogs.technet.com/b/sbs/archive/2009/05/06/companyweb-inaccessible-after-sharepoint-3-0-service-pack-2.aspx


    miércoles, 09 de julio de 2014 3:00