none
RPC_S_SERVER_UNAVAILABLE error (0x6ba)

    Pregunta

  • Hello,

     

    We have Windows Server 2008 STD SP2 x64 DC running all roles of Exchange 2010 STD. OWA is working fine but I had problems configuring Outlook 2007 with it so I used remote connectivity analyzer and encountered this error:

     

      Attempting to ping RPC Endpoint 6001 (Exchange Information Store) on server xxx
      Failed to ping Endpoint
       <label for="testSelectWizard_ctl12_ctl06_ctl08_tmmArrow">Tell me more about this issue and how to resolve it </label>
     
    Additional Details
     

    RPC_S_SERVER_UNAVAILABLE error (0x6ba) was thrown by the RPC Runtime

    Also I have tried to start Microsoft Exchange RPC client access service (MSExchangeRPC) since it was stopped, but it failed with this error:

    Failed to register service principal name ExchangeMDB. Failed with error code The specified account does not exist (1317)

     

    Running test-outlookwebservices completes successfully from the exchange server and I can telnet to 6002 and 6004 but not 6001.

     

    Any ideas?

    miércoles, 28 de abril de 2010 17:17

Todas las respuestas

  • It sounds like the CAS server isn't able to find its' machine account in AD to register those SPNs. Can you verify the account exists and the ACLs on it haven't been modified?
    Active Directory, 4th Edition - www.briandesmond.com/ad4/
    sábado, 01 de mayo de 2010 0:11
  • Hello Brian,

     

    The machine accounts exists under Domain controllers OU since Exchange runs on the same server as the DC.

    How can I verify correct ACLs? I did not touch them but just in case...

     

    Also when I run setspn -L SERVNAME I get:

     exchangeMDB/SERVNAME
     exchangeMDB/SERVNAME.contoso.com

     

    So they are already registered.

    • Editado icest0rm_ sábado, 01 de mayo de 2010 9:55 Added setspn output
    sábado, 01 de mayo de 2010 9:51
  • Sounds like your trying to test for Outlook Anywhere (RPC/HTTPS).  Make sure that you've installed the RPC/HTTPS feature and that you've enabled Outlook Anywhere in the EMC, as well as a valid self-signed or third-party SSL certificate.
    martes, 11 de mayo de 2010 15:30
  • RPC over HTTPS feature installed, Outlook Anywhere installed and 3rd party SSL is installed and working fine.
    martes, 11 de mayo de 2010 16:03
  • Sounds like your trying to test for Outlook Anywhere (RPC/HTTPS).  Make sure that you've installed the RPC/HTTPS feature and that you've enabled Outlook Anywhere in the EMC, as well as a valid self-signed or third-party SSL certificate.

    The ExRCA tool will fail with a self signed cert.
    Active Directory, 4th Edition - www.briandesmond.com/ad4/
    martes, 11 de mayo de 2010 16:49
  • Hey mate, I found disabling IPv6 can resolve this problem. Please read:

    http://clintboessen.blogspot.com/2010/07/error-occurred-while-testing-nspi-rpc.html

    If you still experiance problems please see:

    http://messagexchange.blogspot.com/2008/12/outlook-anywhere-failing-rpc-end-points.html

    Kind Regards,


    Clint Boessen MVP - Exchange Server, MCSE, MCITPx4, Dip Network Engineering
    Perth, Western Australia

    Blog: http://clintboessen.blogspot.com/

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    • Propuesto como respuesta Clint BoessenMVP miércoles, 09 de febrero de 2011 7:17
    miércoles, 09 de febrero de 2011 7:16
  • We encounter the same problem after  Exchange 2007 SP3 update, we were able to resolve the problem by adding IP address and DNS record of our exchange server in the HOST file..  please   bewlow.

     http://blogs.technet.com/b/exchange/archive/2008/06/20/3405633.aspx

    If you're in a single-server scenario where the RPCProxy and Mailbox are on the same machine, then the above does not work since the loopback interface still uses IPv6. In this case, you need to make the following changes in the system32\drivers\etc\hosts file:

    Comment out the line ":::1    localhost"

    Add the following two lines:

       <IPv4 address>    <hostname of the computer>

       <IPv4 address>    <FQDN of the computer>

    Thanks to Kevin Reeuwijk and others for finding and reporting the issue and solution. A fix (make DSProxy listen on the IPv6 stack) is on the way and is expected to be available in Exchange 2007 SP1 RU4 in Q3 2008.

    martes, 08 de mayo de 2012 15:58