none
Faulting module path: C:\Windows\SysWOW64\ntdll.dll

    Pregunta

  • Hi all,

    A client of mine is asking me to help with the following problem:
    When trying to invoke a BAPI Class the BTS stops and gives this error:
    Faulting application name: BTSNTSvc.exe, version: 3.9.469.0, time stamp: 0x4c547e09
    Faulting module name: ntdll.dll, version: 6.1.7600.16695, time stamp: 0x4cc7ab86
    Exception code: 0xc0000374
    Fault offset: 0x000cea27
    Faulting process id: 0x1080
    Faulting application start time: 0x01cbde68386b2b59
    Faulting application path: C:\Program Files (x86)\Microsoft BizTalk Server 2010\BTSNTSvc.exe
    Faulting module path: C:\Windows\SysWOW64\ntdll.dll
    Report Id: 77b16dd1-4a5b-11e0-8106-005056936523

    More details:

    Log Name:      Application
    Source:        Windows Error Reporting
    Date:          09-03-2011 15:35:15
    Event ID:      1001
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      sv004051.grohe.pt
    Description:
    Fault bucket , type 0
    Event Name: APPCRASH
    Response: Not available
    Cab Id: 0

    Problem signature:
    P1: BTSNTSvc.exe
    P2: 3.9.469.0
    P3: 4c547e09
    P4: StackHash_3cd5
    P5: 6.1.7600.16695
    P6: 4cc7ab86
    P7: c0000374
    P8: 000cea27
    P9:
    P10:

    Attached files:

    These files may be available here:
    C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_BTSNTSvc.exe_8a913a115294419865d338c793e84e544be76df_15505efe

    Analysis symbol:
    Rechecking for solution: 0
    Report Id: d3c7e465-4a62-11e0-9b72-005056936523
    Report Status: 4
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Windows Error Reporting" />
        <EventID Qualifiers="0">1001</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-03-09T15:35:15.000000000Z" />
        <EventRecordID>30284</EventRecordID>
        <Channel>Application</Channel>
        <Computer>sv004051.grohe.pt</Computer>
        <Security />
      </System>
      <EventData>
        <Data>
        </Data>
        <Data>0</Data>
        <Data>APPCRASH</Data>
        <Data>Not available</Data>
        <Data>0</Data>
        <Data>BTSNTSvc.exe</Data>
        <Data>3.9.469.0</Data>
        <Data>4c547e09</Data>
        <Data>StackHash_3cd5</Data>
        <Data>6.1.7600.16695</Data>
        <Data>4cc7ab86</Data>
        <Data>c0000374</Data>
        <Data>000cea27</Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>
        </Data>
        <Data>C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_BTSNTSvc.exe_8a913a115294419865d338c793e84e544be76df_15505efe</Data>
        <Data>
        </Data>
        <Data>0</Data>
        <Data>d3c7e465-4a62-11e0-9b72-005056936523</Data>
        <Data>4</Data>
      </EventData>
    </Event>

    Anyone have any idea what this is?

    He is using: SO Windows server 2008 r2 Standard and BizTalk 2010 Standard


    Sandro Pereira Blog: http://sandroaspbiztalkblog.wordpress.com/ Please mark as answered if this answers your question.
    miércoles, 09 de marzo de 2011 16:32

Respuestas

Todas las respuestas

  • Hi,

    I read on a thread in other forum the following:

    "As the error message indicated that the “ntdll.dll” is faulting module, please run the command SFC to check if there is a corruption: Type the following command to an elevated command prompt, and then press ENTER:

    sfc /scannow

    The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions. Then, please run DXDIAG and see if it works."

    I recall in other situation I used these commands (sfc and dxdiag) and it helped.

    HTH

    Regards,

    Steef-Jan Wiggers
    MCTS & MVP BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    BizTalk
    miércoles, 09 de marzo de 2011 19:30
  • Hi Steef,

    Unfortunately it doesn’t solve the problem.
    sfc /scannow
    Beginning system scan.  This process will take some time.
    Beginning verification phase of system scan.
    Verification 100% complete.
    Windows Resource Protection did not find any integrity violations.

    problem remains...

    The only thing that BAPI Class makes is communicating with a Web Service but for some reason it fails (crash!). Not glad to have failed, the problem is more critical because it stops the BizTalk services .

    Nevertheless we managed to find a workaround ... we stop using the BAPI and start to make the communication with the Web service through BizTalk adapters.

    But we have yet to find the problem, but now with more calm :):)


    Sandro Pereira Blog: http://sandroaspbiztalkblog.wordpress.com/ Please mark as answered if this answers your question.
    • Propuesto como respuesta Byzza miércoles, 28 de septiembre de 2011 5:17
    • Votado como útil Byzza miércoles, 28 de septiembre de 2011 5:17
    viernes, 11 de marzo de 2011 10:03
  • Hi,
    By setting up Symbol Server for diagnostics, my client was able to find the problem in theirs BAPI Class.


    Sandro Pereira Blog: http://sandroaspbiztalkblog.wordpress.com/ Please mark as answered if this answers your question.
    viernes, 27 de mayo de 2011 9:24
  • Hi

    i have solve it in the same manner ... but why?

    Thanks in advance


    EZ BizTalk Specialist
    jueves, 14 de julio de 2011 12:33
  • Hi,
    By setting up Symbol Server for diagnostics, my client was able to find the problem in theirs BAPI Class.


    Sandro Pereira Blog: http://sandroaspbiztalkblog.wordpress.com/ Please mark as answered if this answers your question.

    very good
    EZ BizTalk Specialist
    jueves, 14 de julio de 2011 12:37
  • Hi twhensley,

    Unfortunately I don’t remember what exactly was the problem.

    In this process the client asked me to help detecting the problem, and with this strategy we were able to see what was happen.

    After that they changed the project to fix the problem, but I do not remember what exactly.


    Sandro Pereira
    DevScope | MVP & MCTS BizTalk Server 2010
    http://sandroaspbiztalkblog.wordpress.com/ | @sandro_asp
    Please mark as answered if this answers your question.

    lunes, 30 de julio de 2012 15:59