none
can't update global address list exchange 2010 sp1

    السؤال

  • I recently migrated from a SBS 2003 Exchange environment to a full 2010 Exchange environment.  The Legacy server has been retired/uninstalled 

     

    I didn't realize that my global address list wasn't updating when I retired the server and now I can't get it to update.  When I run the update command from the command line I get the following errors:

    ----------------------------------------------------------------------------------------------------

    [PS] C:\Windows\system32>Update-GlobalAddressList -Identity "Default Global Address List"

    Creating a new session for implicit remoting of "Update-GlobalAddressList" command...

    WARNING: The recipient "stc.local/Microsoft Exchange System Objects/OAB Version 3a" is invalid and couldn't be updated.

    WARNING: The recipient "stc.local/Microsoft Exchange System Objects/Offline Address Book -\/o=STC\/cn=addrlists\/cn=oabs\/cn=Default Of" is invalid and couldn't be updated.

    WARNING: The recipient "stc.local/Microsoft Exchange System Objects/Offline Address Book - first administrative group" is invalid and couldn't be updated.

    WARNING: The recipient "stc.local/Microsoft Exchange System Objects/Schedule+ Free Busy Information - first administrative group" is invalid and couldn't be updated.

    -------------------------------------------------------------------------------------------------------------

     

    I read a few articles that talked about spaces in public folders names causing problems like this.  The solution was to disable "mail enabled folders" and then re-enable it.  After disabling it, I am now unable to re-enable it.  I get the following error:

    ------------------------------------------

    Mail enabling a public folder as a subtree root or under NON_IPM_SUBTREE isn't allowed. Path: \NON_IPM_SUBTREE\OFFLINE ADDRESS BOOK.

    ------------------------------------------

     

    Any ideas or help would be greatly appreciated!

    Thanks

    19/جمادى الأولى/1432 04:16 ص

الإجابات

جميع الردود

  • The folders that you have posted are designed to have spaces in them, because they are system folders.
    Did you replicate the system folders to the server? Have you checked the public folder store is correct on the properties of the mailbox database?

    I would suggest that you run the best practises analyser from the toolbox, ensure that it doesn't flag anything.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    19/جمادى الأولى/1432 04:19 م
  • Hi, we have also migrated our exchange from 2003 to 2010 recently after migration we have having almost the same issue, our Global Address list is not showing up the updated address list. but when we are selecting All Users from the address tab we are able to see the user,

     

    Is there any command to refresh or update our GAL,

     

    Thanks..

     

     

    20/جمادى الأولى/1432 09:41 ص
  • Be sure your 2010 server is included in the PF replication from the 2003.

     

    20/جمادى الأولى/1432 09:58 ص
  • Its already migrated successfully 2 months back, but we have come to know that few users is not shwoing up in GAL, so we just need to update it ...
    20/جمادى الأولى/1432 10:06 ص
  • Hi,

    Be sure if your GAL in OWA is updating? If the Address List is correct, the problem should be on your OAB side. Otherwise, your GAL should be corruped.

    After you migrate the mailbox from 2003 to 2010, you also need replicate all the public folder to 2010 and you have to do it manully.

    http://www.simple-talk.com/sysadmin/exchange/upgrade-exchange-2003-to-exchange-2010/

    If you haven't done the above step, you can create a new GAL and set it as default.

    http://technet.microsoft.com/en-us/library/bb232063(EXCHG.80).aspx

    http://technet.microsoft.com/en-us/library/dd535387(EXCHG.80).aspx


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • تم وضع علامة كإجابة بواسطة Novak Wu 25/جمادى الأولى/1432 01:22 ص
    21/جمادى الأولى/1432 08:06 ص
    المشرف
  • Hi,

    During the co-existence, you should have enabled Active Directory virtual list view (VLV). Exchange 2010 now creates system address lists in a new container. Recipients created or modified using Exchange 2003 or Exchange 2007 management tools won’t be stamped with these system address lists. As a result, they won’t be seen by the Exchange 2010 Get-Recipient cmdlet.

    To fix this issue, you must enable Active Directory virtual list view (VLV). After you have completed the upgrade of an existing Exchange 2003 organization to Exchange 2010 and have decommissioned your Exchange 2003 servers.

    To enable VLV for Exchange 2010, run the "Enable-AddressListPaging" cmdlet.


    Irfan Ali. Snr. Infrastructure Consultant
    29/جمادى الأولى/1432 04:15 م
  • Hi All:

    Seems like every upgrade project I do I have had the same issue since Exchange 2007. 

    For those of you interested:The way I always resolve this specific situation is Mail Disabling the offending Public folder. As far as I can tell, the replication continues to work just fine between the new and legacy servers. I'm not certain why OAB public folders were mail-enabled in Exchange 2003 but for certain, they are not created mail-enabled by when you create a secondary OAB and publish it via PF in Exchange 2007/2010 so, it must not needed it to be.

    So far I've done over 20 migrations of different types from Exchange 2003 to 2007/2010 and this has always been an issue. 

    Another issue I always encounter when migrating Public Folders is invalid Exchange Aliases (special chars or whitespaces). I remove whitespaces and invalid characters from the Exchange Alias before adding any Exchange 2007/2010 as replica.

    HTH

    Alfredo Larracuente, Stronghold System Solutions Corp. Guaynabo, Puerto Rico

     

    • تم الاقتراح كإجابة بواسطة Fred_Larracuente 29/محرم/1433 06:20 م
    13/جمادى الثانية/1432 04:05 م
  • +1 on Public Folder migration headaches.  It is obvious that Microsoft does not want to support Public Folders anymore so they are not putting any effort into fixing the replication process.  Case in point, Exchange 2007 doesn't even have a PF database by default.  I once spent 3 days with MS Exchange support trying to iron out PF replication/permission problems.  The end result, backup to PST, delete all PFs, recreate all PFs and restore PSTs.  What a waste of time!

    13/ذو القعدة/1434 04:12 م