none
OOF not working with Exchange 2007

    Frage

  • Hi,

    Have had an issue with configuring OOF to work when using Exchange 2007 & Outlook 2007 onwards. We have the correct certificates installed with regards to SAN names and i believe that i've set the correct host records in DNS. Autodiscover appears to be working, atleast when using Outlook's "Test Email AutoConfiguration" tool and i believe that i've set the addresses for the services below in line with my organisation's naming scheme

    • Offline Address Book (OAB)
    • Unified Messaging
    • Out of Office (OOF)
    • Availability Services

    But OOF will still report that the server is unavailable when i try to set it?

    Any ideas?

    Thanks


    Ashley

     

    Montag, 11. Juni 2012 12:42

Antworten

Alle Antworten

  • When you run:

    Get-WebServicesVirtualDirectory | FL Server,InternalUrl,ExternalUrl

    do the results look right?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Montag, 11. Juni 2012 18:23
  • Hi,

    Have had an issue with configuring OOF to work when using Exchange 2007 & Outlook 2007 onwards. We have the correct certificates installed with regards to SAN names and i believe that i've set the correct host records in DNS. Autodiscover appears to be working, atleast when using Outlook's "Test Email AutoConfiguration" tool and i believe that i've set the addresses for the services below in line with my organisation's naming scheme

    • Offline Address Book (OAB)
    • Unified Messaging
    • Out of Office (OOF)
    • Availability Services

    But OOF will still report that the server is unavailable when i try to set it?

    Any ideas?

    Thanks


    Ashley

    Hi Ashley,

    Please follow the steps below to troubleshoot this issue:

    1. Can OOF work in OWA with the affected user account?

    2. Can you open OOF url (Returned by "Test Email AutoConfiguration" ) in the affected client computer in IE?

    3. Can you open EWS url in CAS server concel (https://localhost/EWS/Exchange.asmx) ?

    4. How many users are not able to use OOF?


    Fiona Liao

    TechNet Community Support

    Dienstag, 12. Juni 2012 03:32
    Moderator
  • Hi Ed,

    Yes the results look fine and as expected....

    Server = The NETBIOS name of my Exchange Server

    InternalURL = https://"Exchange Server FQDN"/EWS/Exchange.asmx

    ExternalURL = https://"External Domain Name of Exchange Server"/EWS/Exchange.asmx

    Thanks

    Ashley

    Dienstag, 12. Juni 2012 07:37
  • Hi Fiona,

    Answers as requested.....

    1. Can OOF work in OWA with the affected user account? Yes, OOF works when set through OWA

    2. Can you open OOF url (Returned by "Test Email AutoConfiguration" ) in the affected client computer in IE? Yes, I can access the xml page

    3. Can you open EWS url in CAS server concel (https://localhost/EWS/Exchange.asmx) ? Yes, but I get a security certifcate error when using "localhost". If I try to access the same page with "ExchangeFQDN" then I can access it fine

    4. How many users are not able to use OOF? Everyone who use's Outlook 2007 & 2010 are affected

    Thanks

    Ashley



    • Bearbeitet xxAsHxx Mittwoch, 13. Juni 2012 08:53
    Dienstag, 12. Juni 2012 08:02
  • Is both "Exchange Server FQDN" and "External Domain Name of Exchange Server" in the certificate?

    Is there any reason you can't use the external name internally?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Dienstag, 12. Juni 2012 20:18
  • Hi Ed,

    Yes, both names are on the certificate.

    I can navigate to the external address internally via IE.... However, when I run Test-OutlookWebServices I get a 1013 & 1016 error regarding the external OOF url

    Thanks

    Ashley



    • Bearbeitet xxAsHxx Dienstag, 12. Juni 2012 20:57
    Dienstag, 12. Juni 2012 20:46
  • Always post the complete results.  Few of us memorize the error codes.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Dienstag, 12. Juni 2012 21:55
  • Hi Ed,

    Full results of Test-OutlookWebServices | fl

    Id      : 1003
    Type    : Information
    Message : About to test AutoDiscover with the e-mail address xxxxxxxxxxxxx@guests.co.uk.

    Id      : 1007
    Type    : Information
    Message : Testing server mailbox.guest.motors with the published name https://"ExchangeFQDN"/ews/exchange.asmx & https://"ExternalExchangeDomainName"/ews/exchange.asmx.

    Id      : 1019
    Type    : Information
    Message : Found a valid AutoDiscover service connection point. The AutoDiscover URL on this object is https://"ExchangeFQDN"/AutoDiscover/AutoDiscover.xml.

    Id      : 1006
    Type    : Information
    Message : The Autodiscover service was contacted at https://"ExchangeFQDN"/AutoDiscover/AutoDiscover.xml.

    Id      : 1016
    Type    : Success
    Message : [EXCH]-Successfully contacted the AS service at https://"ExchangeFQDN"/ews/exchange.asmx. The elapsed time was 46 milliseconds.

    Id      : 1015
    Type    : Success
    Message : [EXCH]-Successfully contacted the OAB service at https://"ExchangeFQDN"/ews/exchange.asmx. The elapsed time was 0 milliseconds.

    Id      : 1014
    Type    : Success
    Message : [EXCH]-Successfully contacted the UM service at https://"ExchangeFQDN"/unifiedmessaging/service.asmx. The elapsed time was 0 milliseconds.

    Id      : 1013
    Type    : Error
    Message : When contacting https://"ExchangeExternalDomainName"/ews/exchange.asmx received the error The request failed with HTTP status 401: Unauthorized.

    Id      : 1016
    Type    : Error
    Message : [EXPR]-Error when contacting the AS service at https://"ExchangeExternalDomainName"/ews/exchange.asmx. The elapsed time was 31 milliseconds.

    Id      : 1015
    Type    : Information
    Message : [EXPR]-The OAB is not configured for this user.

    Id      : 1014
    Type    : Success
    Message : [EXPR]-Successfully contacted the UM service at https://"ExchangeExternalDomainName"/unifiedmessaging/service.asmx. The elapsed time was 31 milliseconds.

    Id      : 1017
    Type    : Success
    Message : [EXPR]-Successfully contacted the RPC/HTTP service at https://"ExchangeNetBios"/Rpc. The elapsed time was 15 milliseconds.

    Id      : 1006
    Type    : Success
    Message : The Autodiscover service was tested successfully.

    Id      : 1021
    Type    : Information
    Message : The following web services generated errors.
                  As in EXPR
              Please use the prior output to diagnose and correct the errors.

    Thanks

    Ashley


    • Bearbeitet xxAsHxx Mittwoch, 13. Juni 2012 11:39
    Dienstag, 12. Juni 2012 22:09
  • Does the external host name go to the right place?  Does it hairpin out of your network and back in?  If so, does it go through some kind of web publishing device?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Mittwoch, 13. Juni 2012 15:32
  • Hi Ed,

    Yes, as we've created a primary zone on our Primary DNS server which relates to our external host namespace. We've created an 'A' record in that name space for our "ExchangeServer".externaldomainname.com and also autodiscover.externaldomainname.com which points to our Exchange server's private IP address...

    Therefore my understanding would be that it I doesn' t hairpin out and then back into our network.

    Mittwoch, 13. Juni 2012 16:37
  • You'll want to verify that, and you'll want to be sure that the URL works internally for the external name, because that's what is apparently failing.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Mittwoch, 13. Juni 2012 17:09
  • Hi,

    If I navigate to the external url internally I arrive at the xml page with no problem at all....

    Out of interest should the Availability Service share the same url as the OOF url?

    Mittwoch, 13. Juni 2012 17:26
  • Out of Office and Availability are both parts of Web Services, so both use the URL specified in Set-WebServicesVirtualDirectory cmdlet.

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Mittwoch, 13. Juni 2012 18:15
  • Thanks.....

    However I can navigate to the external url internally with no problem at all.....

    Mittwoch, 13. Juni 2012 18:16
  • Did you create the CAS probing account using the ...\Scripts\new-TestCasConnectivityUser.ps1 script?

    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Mittwoch, 13. Juni 2012 20:30
  • Hi,

    Forgive me but i'm not really sure what you mean?

    I'm working on an Exchange server that someone else set up a while ago and who no longer works for us 

    I've tested "Test-OutlookWebServices -digestauthentication $true" with Windows & Basic authentication set to $false and then re-tried Test-OutlookWebServices |fl again; I get no errors...... Yet OOF still doesnt work !!


    • Bearbeitet xxAsHxx Mittwoch, 13. Juni 2012 21:44
    Mittwoch, 13. Juni 2012 21:01
  • Some of the Test- cmdlets require the user account created by the script I mentioned.  I'm not sure if that has anything to do with your failure.  But that doesn't sound like it's your problem now.

    Why do you have Windows and Basic authentication set to $False?


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Donnerstag, 14. Juni 2012 02:25
  • Setting them to $false is just something that I was playing around with. With them both set to $true I get the http errors mentioned above when running Test-OutlookWebServices. When they are set to $false and Digest Authentication is set to $true, the errors go away when using the cmdlet Test-OutlookWebServices

    The following sentence reflects how our Exchange server is currently configured - if I leave the EWS virtual directory at its default authenitcation level (Windows & Basic $true) and amend the registry in the manor described in Method 2 of this link http://support.microsoft.com/?id=896861 then Test-OutlookWebServices passes with flying colours

    • Bearbeitet xxAsHxx Donnerstag, 14. Juni 2012 07:45
    Donnerstag, 14. Juni 2012 07:22
  • We also have the exact same problem at a customer site. <o:p></o:p>

    There is also a DNS zone with the external domain name "mobile.customerdomainname.nl" that is pointing to the private IP in the internal network. All links are working fine (internal and external).<o:p></o:p>

     

    It doesn’t matter what we do, the OOF is still not working. so I’m interested what other options there are to set and test.<o:p></o:p>

    Dienstag, 19. Juni 2012 11:49
  • Take a look at this, I had the same issue and fixed it with a few permission changes. Let me know if it works.

    http://forums.msexchange.org/Out_of_Office_Assistant_not_working/m_1800561781/tm.htm

    • Als Antwort markiert Gavin-Zhang Montag, 9. Juli 2012 10:45
    Dienstag, 19. Juni 2012 15:02
  • Hi,

    So, finally sorted out our multidomain certificate (Lets call that Certificate 1) but my colleague registered the wrong Autodiscover SAN name for our mail server. Apart from that mistake, the certificate is functioning fine.

    Aside from adding the correct SAN's to the certificate, my colleague was advised to purchase a separate certificate with correct Autodiscover name and to run both certificates concurrently (Lets call this one Certificate 2).

    However, the Autodiscover website (created in IIS) that gets created by Exchange can only use one certificate at a time. Therefore I created a separate website for autodiscover and have assigned Certificate 2 to that website. However, Outlook is still referencing Certificate 1 for Autodiscover even though the only Autodiscover webpage that exists on our mail server should be using Certificate 2.

    The Autodiscover virtual directory is configured correctly and is pointing to the second webpage that I created.

    Is it possible for Autodiscover to work correctly in this configuration?

    Montag, 17. September 2012 12:20
  • No, it cannot.  Create a new certificate signing request with the correct names and have your colleague get the certifiate reissued.  Your provider will probably do that at no cost.


    Ed Crowley MVP "There are seldom good technological solutions to behavioral problems."

    Montag, 17. September 2012 15:58