none
Outlook Anywhere Auto Discover Failing - Autodiscover settings weren't obtained when the Autodiscover POST request was sent.

    Question

  • I am trying to get autodiscover to work on a Server2008R2/Exchange 2010 config but it fails fairly late on with an XML type error as shown below. Does anyone know what might be wrong?

    Thanks,

     

    Rob

     

    ExRCA is attempting to send an Autodiscover POST request to potential Autodiscover URLs.
      Autodiscover settings weren't obtained when the Autodiscover POST request was sent.
       Test Steps
       Attempting to Retrieve XML AutoDiscover Response from url https://hostedexchsvr1.domain.co.uk/Autodiscover/Autodiscover.xml for user User@adomain.com
      Failed to obtain AutoDiscover XML response.
       Additional Details
      The Autodiscover XML response received by ExRCA was invalid. Exception: Exception details:
    Message: There is an error in XML document (1, 2).
    Type: System.InvalidOperationException
    Stack trace:
    at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
    at System.Xml.Serialization.XmlSerializer.Deserialize(Stream stream)
    at Microsoft.Exchange.Tools.ExRca.Tests.AutoDiscover.AutoDiscoverGetXMLBase`2.Discover()
    Exception details:
    Message: There is an error in XML document (1, 2).
    Type: System.InvalidOperationException
    Stack trace:
    at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
    at System.Xml.Serialization.XmlSerializer.Deserialize(Stream stream)
    at Microsoft.Exchange.Tools.ExRca.Tests.AutoDiscover.AutoDiscoverGetXMLBase`2.Discover()

    Thursday, September 16, 2010 11:44 AM

Answers

  • Please check the authentication settings on the /AutoDiscover virtual directory as below, incorrect settings will cause the symptom:

    ·         Anonymous Authentication: Enable

    ·         ASP .NET Impersonation: Disabled

    ·         Basic Authentication: Enabled

    ·         Digest Authentication: Disabled

    ·         Forms Authentication: Disabled

    ·         Windows Authentication: Enabled


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    • Marked as answer by Krobar Tuesday, September 28, 2010 2:39 PM
    Tuesday, September 21, 2010 8:05 AM
    Moderator
  • How's the issue currently?
    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    • Marked as answer by Krobar Tuesday, September 28, 2010 2:39 PM
    Thursday, September 23, 2010 5:51 AM
    Moderator

All replies

  • Do you have the autodiscover record registered on the Exchange DNS?

    Outlook AnyWhere will ALWAYS use AUTODISCOVER.domain.co.uk to connect and you mentioned it is HOSTEDEXCHSVR1. Make sure you have created your DNS host record for the name AUTODISCOVER and have pointed it to your CAS server.

    Are you able to use a browser to connect to the URL from an external source?


    Thank you, Ibrahim Benna MCSA+Messaging, MCSE+Messaging, MCT, MVP "Did you backup your Information Store Today?!"
    Thursday, September 16, 2010 7:37 PM
  • Please check the authentication settings on the /AutoDiscover virtual directory as below, incorrect settings will cause the symptom:

    ·         Anonymous Authentication: Enable

    ·         ASP .NET Impersonation: Disabled

    ·         Basic Authentication: Enabled

    ·         Digest Authentication: Disabled

    ·         Forms Authentication: Disabled

    ·         Windows Authentication: Enabled


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    • Marked as answer by Krobar Tuesday, September 28, 2010 2:39 PM
    Tuesday, September 21, 2010 8:05 AM
    Moderator
  • How's the issue currently?
    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com
    • Marked as answer by Krobar Tuesday, September 28, 2010 2:39 PM
    Thursday, September 23, 2010 5:51 AM
    Moderator
  • Thank you James :)

    Basuc Auth was disabled and Forms Auth was enabled. I have changed the permissions to as above and it now works perfectly.

     

    Thanks again,

    Rob 

    Tuesday, September 28, 2010 2:38 PM
  • Please check the authentication settings on the /AutoDiscover virtual directory as below, incorrect settings will cause the symptom:

    ·         Anonymous Authentication: Enable

    ·         ASP .NET Impersonation: Disabled

    ·         Basic Authentication: Enabled

    ·         Digest Authentication: Disabled

    ·         Forms Authentication: Disabled

    ·         Windows Authentication: Enabled


    James Luo
    TechNet Subscriber Support (http://technet.microsoft.com/en-us/subscriptions/ms788697.aspx)
    If you have any feedback on our support, please contact tngfb@microsoft.com

    Hello James,

    I have very similar problem and symptoms with autodiscovery, would like to try your solution, but can't find where to modify virtual directory settings - do you mind providing a bit more info?

    thanks in advance

    Tomasz

    Monday, September 10, 2012 3:41 PM
  • ok, ignore my question - figured it out and your fix did worked! thanks

    (IIS Admin/Sites/Def Web Site/Autodiscovery/ then under IIS: Authentication)

    Monday, September 10, 2012 6:08 PM