none
Room booking issues with Outlook 2010 on Exchange 2010-no "room" is already booked for specified time pop-up

    Question

  • When we were using Exchange 2007, a user who attempted to double book a room was greeted with a pop-up stating "'RoomX' is already booked for the specified time. You must use another time or find another resource."

    We are now using Exchange 2010 SP2 Rollup5 and no longer receive this pop-up. We now receive an email rejection from the Room saying that the meeting was declined. However, invitees still receive the invites.

    We would like to re-enable to pop-up behavior. Is this an Outlook setting or an Exchange Setting. I have tried several fixes:

    1. Add Registry entry for EnableDirectBooking for Outlook 2010 as referenced here - http://support.microsoft.com/kb/982774

    2. Attempt Direct Booking as referenced here - http://support.microsoft.com/kb/291616

    3. Tried both AutoAccept and AutoUpdate for AutomatedProcessing parameter on Exchange 2010.

    Is there an actual fix for this?

    Tuesday, February 05, 2013 11:31 PM

Answers

  • Hello,

    I suggest you follow these steps to have a try:

    The CalnedarProcessing set to AutoAccept on the room mailbox and then use blow steps to enable the popup message on senders Outlook.

    1) Enable the room mailbox account from AD users & computers console.

     2) Login to Outlook using this account.

     3) Open Outlook and click Options from Tools menu, and click “Calendar options” button from preferences tab

     4) Click “Resource scheduling” button and enable automatically accept and decline option. Check the first two options-

      a. Automatically accept meeting requests and process cancellations.

      b. Automatically decline conflicting meeting requests.

    5) When you click on OK, you will get a popup warning message that “You must give users permission to view and edit this calendar”, you need to select the check box and click on OK here. If you don’t give permission, the popup feature wouldn’t work so since you need to grant permission for all users and this will allow all users to open the resource’s calendar.

    6) Disable the resource account again.

    Thanks,

    Evan Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com


    Evan Liu
    TechNet Community Support

    Wednesday, February 06, 2013 3:00 AM
    Moderator

All replies

  • Hello,

    I suggest you follow these steps to have a try:

    The CalnedarProcessing set to AutoAccept on the room mailbox and then use blow steps to enable the popup message on senders Outlook.

    1) Enable the room mailbox account from AD users & computers console.

     2) Login to Outlook using this account.

     3) Open Outlook and click Options from Tools menu, and click “Calendar options” button from preferences tab

     4) Click “Resource scheduling” button and enable automatically accept and decline option. Check the first two options-

      a. Automatically accept meeting requests and process cancellations.

      b. Automatically decline conflicting meeting requests.

    5) When you click on OK, you will get a popup warning message that “You must give users permission to view and edit this calendar”, you need to select the check box and click on OK here. If you don’t give permission, the popup feature wouldn’t work so since you need to grant permission for all users and this will allow all users to open the resource’s calendar.

    6) Disable the resource account again.

    Thanks,

    Evan Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com


    Evan Liu
    TechNet Community Support

    Wednesday, February 06, 2013 3:00 AM
    Moderator
  • Hi Evan,

    I have confirmed that AutomateProcessing is set to AutoAccept.

    I am using Outlook 2010 so there is no Tools menu so I've gone to File>Options>Calendar>Resource Scheduling and clicked on the Resource Scheduling button.

    This bring up a window with slightly different option, but I have checked the following"

    Automatically accept meeting requests and remove canceled meetings

    Automatically decline meeting requests that conflict with an existing appointment or meeting.

    However, when I click OK, I am not prompted about permissions. There is a button at the bottom of the window labeled "Set Permissions". Once I am in there, the default permissions are:

    Default-Free/Busy time

    Anonymous-None

    What level of permission should default be set to or should I add "Everyone" and assigned a specific permission to that?

    Thanks,

    Chris
    Wednesday, February 06, 2013 5:43 PM
  • Hi chris,

    Just I posted before, you only need give users permission who should to edit on the resource mailbox calendar.

    Thanks,

    Evan Liu

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tnmff@microsoft.com


    Evan Liu
    TechNet Community Support

    Monday, February 11, 2013 1:38 AM
    Moderator
  • Team,

    I was having the same issue. I'm not getting the pop-ups, but one user is getting the pop-ups. User who is getting the pop-ups having the Full access control on the resource mailbox and user is the manager of that resource mailbox.

    I've allowed only some users to book the room. If they try to book meeting in a busy slot (already booked by someone ) they are not warned (pop up is not displayed) , meeting request is going to all the recipients and after some time the resource room is declining the meeting with no message details like slot is busy or something. (simply declined email to the organizer)

    My outlook version - 14.0.4760.1000  (2010)

    Exchange Version - 2010 SP2 RU4

    I've asked the outlook version and service pack levels of users outlook for whom it is working. I'll post that information tomorrow.

    Once I got the information I'll let you know mean while please let me know if you have any solution and if you want the calendar parameter values I can post.


    Thanks ..Kishore Bitra


    • Edited by Kittu Bitra Wednesday, February 20, 2013 7:02 AM Added information
    Wednesday, February 20, 2013 6:46 AM