none
How to force the Outlook rule to be server-side?

    Question

  • Using Outlook 2010 with a corporate Exchange Server.

    The rule I want to create is this:

    After email arrives from MachineMonkey and with Passed in the subject, Move it to the SuccessBuilds folder and mark it Read.

    When I did that, the Outlook marked the rule as Client-Side. So I removed the part about marking it Read and it became a server side rule.

    So I thought, ok, maybe marking an email as read is a client-side only activity. So I sent myself an email, closed Outlook, opened the email on my iPhone (thus marking it read). Then I opened the Outlook again and the email was already marked read. So clearly marking emails read can be a server-side activity.

    So why is my rule being shoved client-side?

    Monday, April 25, 2011 6:09 PM

Answers

  •  

    Using Outlook 2010 with a corporate Exchange Server.

    The rule I want to create is this:

    After email arrives from MachineMonkey and with Passed in the subject, Move it to the SuccessBuilds folder and mark it Read.

     

    When I did that, the Outlook marked the rule as Client-Side. So I removed the part about marking it Read and it became a server side rule.

    So I thought, ok, maybe marking an email as read is a client-side only activity. So I sent myself an email, closed Outlook, opened the email on my iPhone (thus marking it read). Then I opened the Outlook again and the email was already marked read. So clearly marking emails read can be a server-side activity.

    So why is my rule being shoved client-side?


    Create the rule in OWA instead ( With the more options choice). ( I assume you are using Exchange 2010). You can create a server-side rule to make it read there.

     

    • Marked as answer by Frank.Wang Tuesday, May 03, 2011 1:35 AM
    Monday, April 25, 2011 7:04 PM
  • A rule will always be server-side unless the Exchange server simply cannot do what the rule asks of it. It’s not a matter of forcing it. Your test was flawed because you read the email on a client, in this case the iPhone. The iPhone told the server it was read so the server marked it accordingly. The server didn’t magically mark it read, it had to be told by a client.
     
     
     
    "frizzo2154" wrote in message news:0c291a0f-047d-4a5c-bbed-328935940b86...

    Using Outlook 2010 with a corporate Exchange Server.

    The rule I want to create is this:

    After email arrives from MachineMonkey and with Passed in the subject, Move it to the SuccessBuilds folder and mark it Read.

    When I did that, the Outlook marked the rule as Client-Side. So I removed the part about marking it Read and it became a server side rule.

    So I thought, ok, maybe marking an email as read is a client-side only activity. So I sent myself an email, closed Outlook, opened the email on my iPhone (thus marking it read). Then I opened the Outlook again and the email was already marked read. So clearly marking emails read can be a server-side activity.

    So why is my rule being shoved client-side?


    Mark Arnold, Exchange MVP.
    • Marked as answer by Frank.Wang Tuesday, May 03, 2011 1:35 AM
    Monday, April 25, 2011 6:20 PM
  • You can't force it. Outlook is viewing that rule from an Outlook perspective and doesn't consider any other clients such as iphone.
    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Frank.Wang Tuesday, May 03, 2011 1:35 AM
    Monday, April 25, 2011 6:53 PM

All replies

  • A rule will always be server-side unless the Exchange server simply cannot do what the rule asks of it. It’s not a matter of forcing it. Your test was flawed because you read the email on a client, in this case the iPhone. The iPhone told the server it was read so the server marked it accordingly. The server didn’t magically mark it read, it had to be told by a client.
     
     
     
    "frizzo2154" wrote in message news:0c291a0f-047d-4a5c-bbed-328935940b86...

    Using Outlook 2010 with a corporate Exchange Server.

    The rule I want to create is this:

    After email arrives from MachineMonkey and with Passed in the subject, Move it to the SuccessBuilds folder and mark it Read.

    When I did that, the Outlook marked the rule as Client-Side. So I removed the part about marking it Read and it became a server side rule.

    So I thought, ok, maybe marking an email as read is a client-side only activity. So I sent myself an email, closed Outlook, opened the email on my iPhone (thus marking it read). Then I opened the Outlook again and the email was already marked read. So clearly marking emails read can be a server-side activity.

    So why is my rule being shoved client-side?


    Mark Arnold, Exchange MVP.
    • Marked as answer by Frank.Wang Tuesday, May 03, 2011 1:35 AM
    Monday, April 25, 2011 6:20 PM
  • You can't force it. Outlook is viewing that rule from an Outlook perspective and doesn't consider any other clients such as iphone.
    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by Frank.Wang Tuesday, May 03, 2011 1:35 AM
    Monday, April 25, 2011 6:53 PM
  •  

    Using Outlook 2010 with a corporate Exchange Server.

    The rule I want to create is this:

    After email arrives from MachineMonkey and with Passed in the subject, Move it to the SuccessBuilds folder and mark it Read.

     

    When I did that, the Outlook marked the rule as Client-Side. So I removed the part about marking it Read and it became a server side rule.

    So I thought, ok, maybe marking an email as read is a client-side only activity. So I sent myself an email, closed Outlook, opened the email on my iPhone (thus marking it read). Then I opened the Outlook again and the email was already marked read. So clearly marking emails read can be a server-side activity.

    So why is my rule being shoved client-side?


    Create the rule in OWA instead ( With the more options choice). ( I assume you are using Exchange 2010). You can create a server-side rule to make it read there.

     

    • Marked as answer by Frank.Wang Tuesday, May 03, 2011 1:35 AM
    Monday, April 25, 2011 7:04 PM