none
Message being rejected due to size limit - how do I increase maximum size?

    Question

  • I have my ISP email forwarded to a Gmail account and then forwarded to my Exchange account.  I have an email sitting in the Gmail account that has 4 attachments, totalling 21095KB.    I can't for the life of me get it to transfer to my Exchange server.  I keep making changes to Exchange and then re-forwarding the message, but every time I get the following message:

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the recipient domain. We recommend contacting the other email provider for further information about the cause of this error. The error that the other server returned was: 552 552 5.3.4 Message size exceeds fixed maximum message size (state 18).

    I have searched and searched for the answer to this issue.  I modified the max message size send and receive connectors on my Exchange server and set it to 25600KB (25MB).  I also modified the global settings to that same capacity.  Here is the readout of Get-ReceiveConnector:

    Identity                                MaxHeaderSize                           MaxMessageSize
    --------                                -------------                           --------------
    DGX\Default DGX                         128 KB (131,072 bytes)                  25 MB (26,214,400 bytes)
    DGX\Client DGX                          128 KB (131,072 bytes)                  25 MB (26,214,400 bytes)

    Here is the readout of Get-TransportConfig:

    MaxReceiveSize : 25 MB (26,214,400 bytes)
    MaxSendSize    : 25 MB (26,214,400 bytes)

    I've also verified that my user account does not have a specific message size limit imposed on it.

    I have tried restarting the Transport service in addition to restarting the whole server multiple times after adjusting various values.  What must I do to allow up to 25MB of attachments?


    Drew Green MCSA, CCENT, Security+, Network+, A+
    Monday, June 14, 2010 7:57 PM

Answers

  • Sorry I cant help BUT.. I will mention something I tell our users.

    Email attachments expand by 33%. So if in windows it looks like a 15mb attachment your mail server will see it as 20mb.

    Would that be the problem? If you try a 16mb attachment does it go through. A 17mb doesnt? If that is the case.. then there is your issue.

    Monday, June 14, 2010 8:53 PM

All replies

  • Sorry I cant help BUT.. I will mention something I tell our users.

    Email attachments expand by 33%. So if in windows it looks like a 15mb attachment your mail server will see it as 20mb.

    Would that be the problem? If you try a 16mb attachment does it go through. A 17mb doesnt? If that is the case.. then there is your issue.

    Monday, June 14, 2010 8:53 PM
  • Yes, try increasing limit to 30MB and verify...

    Amit Tank
    MVP: Exchange Server | MCTS: Microsoft Exchange Server 2010, Configuration | MCITP: EMA | MCSA: M
    Blog: http://ExchangeShare.WordPress.com | User Group: http://MUC-UG.org.in


    Monday, June 14, 2010 11:01 PM
  • Hi,

     

    Please check the size of below configurations:

     

    1.Organizaion Configuration

    Organization Configuration | Hub Transport | Global Settings tab | Transport Settings |

     

    2.Server Configuration

    Server Configuration | Hub Transport | select a HT server | Receive Connectors -> select a connector | Properties |

     

    3.Send Connector Configuration

    Organization Configuration | Hub Transport | Send Connectors -> select connector | Properties |

     

    4.Recipients Configuration

    Recipients Configuration | Mailbox | select mailbox | properties | Mail Flow Settings | Message Size Restrictions|

     

    5.Recipients Group Configuration

    Recipients Configuration |Distribution Group | select Group | properties | Mail Flow Settings | Message Size Restrictions

     

    6.Global Setting

    Please use adsiedit to connect Configuration container :

    Configuration container | Services | Microsoft Exchange |YourOrgName| Global Settings | Message Delivery | Propertiescheck the below values

    a. delivContentLength

    b. SubmissionContentLength

    c. msExchRecipLimit

     

    7.Transport Rules

    Organization Configuration | Hub Transport | Transport Rules

     

    Mailbox Size Limits Are Not Enforced in a Reasonable Period of Time

    http://technet.microsoft.com/en-us/library/bb684892(EXCHG.80).aspx

     

    Thanks

     

    Richard

     


    Your expertise never fails to impress!
    Tuesday, June 15, 2010 7:29 AM
  • Please go through the following link

    http://technet.microsoft.com/en-us/library/bb124708.aspx

    Hope this will help out.


    MCT,MCSE,MCSA,MCTS, Server Administrator
    Tuesday, June 15, 2010 11:36 AM
  • I set the limits to 1.3 times the size that I wanted to allow (thought you had said 30%, not 33%, but I'll go back in and adjust that).  Message came through.  That's very wierd, but I've found articles referencing Exchange 2000 that talk about that issue as well, so I guess it's been around for ever and not going anywhere.
    Drew Green MCSA, CCENT, Security+, Network+, A+
    Tuesday, June 15, 2010 1:26 PM
  • Hello BHM

    I have the same problem, Do you found any solution?

    Regards.

    Wednesday, December 21, 2011 5:54 PM
  • Pay attention to Receive Coonectors. If you have more than one, only the smallest value is used . So , if you have Default Receive Conector at 30M ant Test Connector ( even disabled!) set at 10M, will result a limit of 10M in receive attach mail size.

    This was my case, and i was stuck quite some time with this problem.

    Thursday, October 25, 2012 2:02 PM
  • We have reproduced some of the information we have found around the Internet on Message size limits in the various versions of Exchange here on our blog to ensure it is preserved for future use:

    http://exchangeantispam.wordpress.com/

    Wednesday, July 24, 2013 8:33 AM
  • You need to increase the MaxMessageSize to allow for MIME increases. I would suggest 50MB if you have the storage. (Get-ReceiveConnector)

    You also need to increase the MaxReceiveSize, MaxSendSize, ExternalDSNMaxMessageAttachmentSize, InternalDSNMaxMessageAttachmentSize. (Get-TransportConfig)

    This should increase your receive connector settings and your organizational settings. Transport rules to allow greater size attachments works well, but will only apply to authenticated users.

    Hope this helps.

    Thursday, August 15, 2013 2:34 PM