none
Outlook 2010 With exchange 2010 "Cannot open your default e-mail folders.

    Question

  • Hi,

    i have installed exchange 2010 and all seems to be working fine on the exchange machine.

    My outlook clients can't connect i am getting the following massage " Cannot open your default e-mail folders.  You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost)."

     

    any idea ?

     

     

    Thursday, March 03, 2011 6:16 PM

All replies

  • check this link out I think it will help you

    http://support.microsoft.com/kb/2006508

     


    MCP, MCSE 2000 , MCSA 2000 ,MCSA 2003 , MCITP , MCTS , MCT
    Thursday, March 03, 2011 6:24 PM
  • Non of the methods described in that article works for me

     

    Thursday, March 03, 2011 6:39 PM
  • would you please describe how you configure your Outlook and which version in use
    MCP, MCSE 2000 , MCSA 2000 ,MCSA 2003 , MCITP , MCTS , MCT
    Thursday, March 03, 2011 6:46 PM
  • Hello EladRez,

     

    Does this issue occur on one user or several users?

     

    How about other user who is using Outlook 2007 or Outlook 2003?

     

    If this issue occur on one user, I suggest you follow these steps to have a try:

     

    1.       Go to this path c:\users\%username%\appdata\local\Microsoft\Outlook.

    2.       Now look for any .ost files and delete them. ( Please backup the .ost file before you delete them or rename the .ost file. Eg; change to .ost.old)

    3.       After you deleted the .ost file, restart the Outlook.

     

    Thanks,

     

    Evan

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 07, 2011 7:48 AM
  • Hello EladRez,

    I got the same issue. I built a test domain with Hyper-V.

    I installed two DCs. I installed then  Exchange 2010 on a DC. It seemed OK.

    Then I installed two virtuals PC with Windows 7 and I installed Office 2010

     above.

     

    When  I run Outlook 2010, the profile is set, but I cannot use it. It is like the .ost file was unreachable, I have no more idea for the moment...

     

    Hope it is running fine for you!

     

    denis

    Friday, March 11, 2011 1:52 PM
  • Hi EladRez,

     

    I am having the same issue - did you ever get to the bottom of it?

     

    Russell

    Tuesday, June 14, 2011 7:17 PM
  • I have solved my problem - the Microsoft Exchange RPC Client Access service was not starting with the server booting up, after starting this service outlook opened on my clients.
    • Proposed as answer by JWMKitsap Wednesday, August 17, 2011 6:59 PM
    Wednesday, June 15, 2011 3:06 PM
  • Go to Control Panel > Mail > Email Account > Click Change > Insert your correct User ID and Password > Check box Save Password > Click OK.

    Now start Outlook.


    Naushad Khan - System Administrator - MCITP
    Monday, June 20, 2011 7:27 PM
  • I have had to solve this problem everytime I deploy a new laptop that use RPC over HTTPS. It seems that every time I have to rediscover what I did.  Here is what has worked for me.

     

    If you think that everything is configured correctly you can test with https://www.testexchangeconnectivity.com

    Add the following Registery entry

    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Outlook

    Add Key Value "RPC" then DWord DefConnectOpts Set value to 0

    You may see \14.0\Outlook if it is outlook 2010.

     

    This has worked everytime for me.

     

    John

     

    • Proposed as answer by John Winner Thursday, June 30, 2011 11:06 PM
    Thursday, June 30, 2011 11:02 PM
  • This was my problem in deploying a test SBS2011.  Why would the RPC client not start, anyone?  I have set it for a delayed start, hopefully that will solve it.
    David N. Peterson
    Sunday, July 10, 2011 5:38 PM
  • moved all the files out of the default directory.  Started exchange and it created a new ost and synched with exchange.

    Friday, September 02, 2011 1:49 PM
  • None of them worked for me. Exchange server was on the network but lost Internet connection for 2 days while the ISP resolved a $2 connector error. Clients running Outlook 2010 took this to apparently mean there would never be a connction again as they would only show as not connected when connectivity was restored. Deleted profiles to recreate the connection and received this error. after deleting every .ost and every .pst, After unistalling Office 2010, what worked perfectly was Format C: and a reinstall of the o/s and the resultant 2 days of patches. Wish one of the pimply geeks at Micosoft would figure how to stream them into 1 patch like everyone else on the Internet has.

    Thankfully this was only email and really not a necessary app

    Saturday, September 03, 2011 5:54 AM
  • Russell,

    Many thanks for posting your solution, I had exactly this problem and wasted several hours before I found your post.  Not sure I would have tracked down the problem without this post!

    I don't suppose you (or anyone else reading) know's why the service fails to start?  On my system it's certainly configured to start automatically, but (to test) even on rebooting several times, it didn't start once.


    [EDIT: incorrectly proposed my post as answer, meant to propose Russell's post as answer]
    • Proposed as answer by Taligort Saturday, October 08, 2011 2:27 PM
    • Unproposed as answer by Taligort Saturday, October 08, 2011 2:27 PM
    • Edited by Taligort Saturday, October 08, 2011 2:31 PM
    Saturday, October 08, 2011 2:27 PM
  • hi

    after deleting a ost file problem did not resoved.

    this is not correct answer.

    what we found Microsoft Exchange client Access service was stopped.

    starting this service outlook will be back online.

    Answer by Russell Walker is correct answer.

     

    Regards


    Naeem Bhatti MCITP EA, MCITP, MCTS Exchange 2007 MCSE security,MCSE AD, MCSE in Messaging, MCDST SBS2003 and SBS2008 Specialist
    Saturday, October 22, 2011 8:37 AM
  • hi

    after deleting a ost file problem did not resoved.

    this is not correct answer.

    what we found Microsoft Exchange client Access service was stopped.

    starting this service outlook will be back online.

    Answer by Russell Walker is correct answer.

     

    Regards


    Naeem Bhatti MCITP EA, MCITP, MCTS Exchange 2007 MCSE security,MCSE AD, MCSE in Messaging, MCDST SBS2003 and SBS2008 Specialist


    Naeem Bhatti MCITP EA, MCITP, MCTS Exchange 2007 MCSE security,MCSE AD, MCSE in Messaging, MCDST SBS2003 and SBS2008 Specialist
    Saturday, October 22, 2011 11:42 AM
  • I met the same error message, tried to deleted the ost files, but doesn't help. Thanks to Russell's post, we checked the service and resolve the issue. A little difference, the Microsoft Exchange RPC Client Access service was running, but after restart that service, all clients (both Outlook 2007 and 2010) works well.
    Tuesday, October 25, 2011 1:24 AM
  • We've experienced this same issue with Outlook 2003, Outlook 2007, and Outlook 2010. Not once has it ever been a server issue as we use an outsourced/hosted Exchange solution and we have no access to the Exchange server.

    Most of the time, deleting the mail profile, deleting the empty .ost file associated with the profile, and recreating the profile from scratch will solve the problem. This does not always solve the problem. This is especially baffling when multiple profiles on the same machine with the same exact settings results in several profiles working just fine and one profile not working (giving the error message above). For example, on the same laptop, Profile A works, Profile B works, Profile C works, Profile D gives the error indicated in the original poster's message. The settings for all 4 profiles are identical. The only difference is the account username, password, email address. This also rules out a "service not running on the Exchange server" possibility for us because we can switch back and forth between a profile that works and one that doesn't in a matter of a minute. Also, using the same "broken" profile settings, user name, password, email on a different laptop will work despite the same laptop make/model, OS, patch level, and version of Outlook.

    This is not being caused by a corrupt .ost file as the error occurs the first time the profile is used after the profile is created. It is not a credentials issue. The same username and password work correctly through OWA. Thus, it is also not a matter of the Exchange server not being able to find the mailbox on the server.

    If you're running Outlook 2007 and you've patched it to Office SP2 before creating the first profile, you can often resolve this issue by removing the profile, removing Office SP2, and recreating the profile. This has proven to be the case for us several times. Once a profile is created and working, Office SP2 can be applied again and everything works. Additionally, new profiles created after Office SP2 is applied will work.

    My opinion is that the error message itself is bogus in that the same error message is being used for multiple errors/causes. That's why there are so many different potential "fixes", depending on the situation.

    At this point in time, we're revisiting this issue because we're experiencing it on Outlook2010 and none of the usual fixes work. None of the suggested fixes here has worked.
    • Edited by UnMonkey Friday, November 18, 2011 10:39 PM
    Friday, November 18, 2011 10:36 PM
  • Hi All,

    I am  using Exchange 2010 and faced similar problem. Its solved after starting the Microsoft Exchange RPC Client Access service.

    Thursday, December 08, 2011 11:51 AM
  • Same issue here.  Outlook 2010 SP1 on Vista attempting to connect to VereCloud's hosted Exchange service.  All other users working just fine.  Just one use having an issue.  Looks like maybe 2010 is having different issues with the same error message as older releases.
    Sys Admin
    Friday, December 09, 2011 4:35 AM
  • That one looks similar but this error message does not appear in it.
    Sys Admin
    Friday, December 09, 2011 4:35 AM
  • I restarted the service "Microsoft Exchange Client RPC Access" and the issue was resolved. Is this a bug?

    My patch level of Exchange 2010 is SP1 update 6.


    • Edited by Maverick Pu Tuesday, December 20, 2011 4:06 PM
    • Proposed as answer by pcap_001 Thursday, April 18, 2013 8:02 PM
    Tuesday, December 20, 2011 4:05 PM
  • i have same problem after upgraded to SP1 update 6
    Monday, January 09, 2012 7:54 AM
  • HI,

    My self is vinesh Rathi

    I installed exchange server 2010 SP2 in virtual evironment, its a fresh installation. I am facing the same issue with outlook, outlook configured successfully but not able to create ost file.Error is maintioned bellow:

    My outlook clients can't connect i am getting the following massage " Cannot open your default e-mail folders.  You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your Outlook data file (.ost)."

    please help me if anyone have the solution for the same.

    vinesh rathi

    Thursday, January 26, 2012 5:21 PM
  • I have the same enviroment as Vinesh Rathi.

    I had the same problem. Restarting the the service "Microsoft Exchange Client RPC Access" on the server, i manage to solve the problem temporary. The profile was created and i could download the emails.

    The next day, the outlook 2010 client was showing as disconected. Again Restarting the service the client was connected successfuly.

    The next day the same issue. On the server the service is showned as started. Restarting it solved it.

    Is there any other solution rather than restarting the service every day?

     

    Friday, January 27, 2012 6:52 AM
  • Hi All,

    I got the solution for this issue, Actully RPC client access service is started on my one server and another one it was stopped, I was not able to start this.

    I found an issu in registry setting for MSExchangeRPC service on both CAS server. Here is the steps to configure it:

    Go to Start -> RUN -> type Regedit -> Enter.

    Now go in to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeRPC

    Right-click MSExchangeRPC,--> point to New, and then click Key and Type ParametersSystem to name the new key -->  Right-click ParametersSystem, point to New, and then click DWORD (32-bit) Value  --> Type TCP/IP Port to name the new value -->Double-click TCP/IP Port     .-> In Base section Select Decimal --> In the Value data box, type 59595, and then click OK. and restart the CAS server. Do the same thin on all CAS server.

    Regards,

    Vinesh Rathi

     


    Thanks Vinesh Rathi
    Friday, January 27, 2012 10:06 AM
  • You Should look after your host file
    Tuesday, February 21, 2012 5:15 PM
  • This exactly the problem i had, and this is exactly the solution that fixed it.  Thanks for the pointer.

    Steve Meggeson A+, MCSA, MCSE, MCITP, MCT steve@teksource.ca

    • Proposed as answer by londewa Friday, September 21, 2012 11:52 PM
    Friday, August 24, 2012 6:08 PM
  • Thank you Russel,

    After two day i've resove it with your advice.  Thank you very much.

    Michel

    Wednesday, October 10, 2012 6:56 PM
  • Hi

    I am facing the same issue at my end. Earlier it was working fine with my Win Xp, now I switched to Windows 8. Now its started giving problem to me. But I am able to add a Outlook account in Live Mode i.e. using apps and i can see my mails.

    But through Outlook clint I am facing this issue. Some I managed to us my my prev data file and see those mails in client, but I am not able to connect to my exchange server.

    I tried many options which is mentioned in this community, but could make it work.

    Could some please help me to resolve this issue, thanking youRegards,

    Gopinath B

    Wednesday, November 14, 2012 6:38 PM
  • The answer from John Winner was a true winner for me. Thank you John Regards Srini
    Friday, November 23, 2012 9:01 AM
  • The Issues has been fixed...:)

    Thank You Russell.,..

    • Proposed as answer by balait09 Wednesday, December 19, 2012 11:55 AM
    Wednesday, December 19, 2012 11:55 AM
  • Hey russel, this works perfectly!
    Saturday, January 05, 2013 4:32 AM
  • Hi, thanks for the simple solution. I use Outlook with hotmail and suddenly this problem showed up.

    I can resume using Outlook normally now.

    Saturday, February 23, 2013 4:09 AM
  • I have solved my problem - the Microsoft Exchange RPC Client Access service was not starting with the server booting up, after starting this service outlook opened on my clients.

    Hi Russel, I've checked the service is running on my server, so how to fix this problem?
    Friday, March 08, 2013 9:45 AM
  • Jazz... I had the problem with just a single OLK client. Service was running. I restarted the RPC client access service and that fixed it.

    Try restarting the service if it IS running.

    Those who have recurring issues: I read in another thread that too many MAPI connections can cause this symptom, and I suspect restarting the RPC-CA service clears the open connections. The user with the problem in my case has an Android running 'touchdown', a third party task/calendar app on his PC and phone, and a pretty complicated calendar sharing configuration. They're coming out by the roots, one-by-one, if Outlook client disconnects again!
    • Edited by rklarr Thursday, March 21, 2013 8:53 PM
    Thursday, March 21, 2013 8:49 PM
  • Hi all.

    Simply you could run the service (Microsoft Exchange Information Store) on the Exchange Server.

    for some mystic reason, this service does not start automatically, this helped me solving this issue, once and for all.

    Thanks..

    • Proposed as answer by Fady Alshaar Thursday, March 28, 2013 12:29 AM
    Thursday, March 28, 2013 12:28 AM
  • I was experiencing this same issue in an environment with Microsoft Exchange 2010 and one client running Outlook 2003 on Windows 7. This client was updated to Outlook 2010, but the problem followed. Nothing in this thread helped.

    Essentially, the Outlook client would not connect to the server, except when setting up the initial connection. One of the challenges is that the server and client computers were in different domains. While the mail setup resolved the mail domain name to the actual FQDN of the server and the username, once it was setup, it would not resolve to the FQDN of the server again.

    Probably not the best solution, but I fixed this by adding an IP address entry and used the FQDN the mail server in the local host file of the problem computer.


    Brian

    Thursday, March 28, 2013 4:10 PM
  • Hi,

    In my case I resolved the issue by clearing the Synchronization error folder (Ctrl+6). And also I would suggest to move a problem mailbox to another DB and then try to connect to it.

    BR,

    Andrey.


    MCTS: Microsoft Exchange Server 2007/2010 | MCSA


    Monday, April 15, 2013 10:40 AM
  • I am from test team and we have 5 Exchange servers / domains installed in our test environment. I used Outlook on machine A in domain A that had bad Exchange A and I got the error from title of this thread. Then I put machine A in domain B which had good Exchange B and Outlook worked just fine. That's how I figured out that problem was on Exchange side, not on machine A or Outlook, or ost file. Further investigation uncovered there was a problem with certificate on Exchange A - we were setting up integration between Exchange A and some other server, so the certificates messed up. Anyway... make sure to have 5 Exchange servers / domains in your test environment :)
    Thursday, August 01, 2013 12:28 PM
  • Hi,

    Try this Option...

    Since you have repaired the Office program but the issue persist, you can consider to create a new outlook profile refers to:

     

    To create a new email profile in Outlook 2010, Outlook 2007 and in Outlook 2003, follow these steps:

    1. Click Start > control panel>User Accounts> Mail
    2. In the Mail Setup dialog box, click Show Profiles.
    3. On the General tab, under When starting Microsoft Office Outlook, use this profile, click Prompt for a profile to be used, and then click Add.
    4. In the Profile Name box, type the name that you want to use for the new email profile, and then click OK.
    5. In the E-mail Accounts dialog box, click Add a new e-mail account, and then click Next.
    6. Click the appropriate server type for your new email account, and then click Next.
    7. Type your account information in the required boxes, and then click Next.
    8. Click Finish, and then click OK.

     

    If it’s working, You can add previous mail accounts and data files to the new profile.


    Tuesday, September 24, 2013 4:49 AM
  • Go to Control Panel > Mail > Email Account > Click Change > Insert your correct User ID and Password > Check box Save Password > Click OK.

    Now start Outlook.


    Naushad Khan - System Administrator - MCITP
    Thank you!!!!  Yours was the only remedy I could find that worked!!!!  
    Thursday, October 03, 2013 4:15 PM
  • Excellent. John Winner sorted out my customers Outlook client.

    Thanks!


    Tuesday, November 19, 2013 10:07 AM
  • I felt obliged ,after hours of searching and testing, to say that what begainer says solved my problem and to add my own 0,2$

    There is a weird plot to it. I have managed to make it work in one user. After i changed to another user profile, outlook behaved with the same problem. So, you will have to edit the hosts file (not necessarily add or remove something ) so to force it to write/save the file again. After that outlook worked for that user as well.

    Weird but maybe something with read/write access to the hosts files? don't really understand.

    Friday, December 13, 2013 1:04 PM
  • I had this issue happening for only one of our users. All of our RPC settings were working fine.  All of our other users were working fine.  This happened on all machines we tried to set this user up on, even freshly formatted hard drive.  I moved the user to a different database on the exchange server and it started working.

    There wasn't necessarily any problems with the database, I've tried moving other users into that database and haven't been able to re-create the problem.

    Friday, December 13, 2013 4:51 PM
  • I found that the Microsoft Exchange RPC Client Access service was already started, so I restarted it and that fixed the problem in my case.It was only happening for one user.

    I was creating new profiles and it would continue to give that error. But after restarting the RPC client Access service, it fixed it for all profiles on the problematic PC. 

    Wednesday, January 15, 2014 4:05 AM
  • So far this seems like it solved my problem, which the same as the original post. Just to add to it, OWA seemed to function just fine. If this stops working I'll update this post.

    Thanks to John!

    Friday, February 14, 2014 7:04 AM
  • Adding RPC folder and DefConnectOpts to 0 to user profile registry did not help. We have W7 SP1 and Outlook 2010, and adding new patches created this mass problem with new installed Computers. Existing Computers with allready created Outlook profiles still works, but new Computers does not. I´m still waiting for exchange server reboot, it´s out of my scope.

    If I kill Defailt Profile from Control Panel\Mail, the outlook profile can be created manually and it will work, but this is not proper solution for mass deployment.

      
    Tuesday, June 10, 2014 5:56 AM
  • I had the same problem but mine didn't have anything to do with the Outlook client. Somehow on my Exchange 2010 server two mailboxes had been created with the same LegacyExchangeDN attribute. I renamed the one in the AD attribute editor and the problem was resolved. Hope this helps someone.
    Friday, June 13, 2014 10:49 AM
  • I restarted the service "Microsoft Exchange Client RPC Access" and the issue was resolved.

    Ayman Saleh

    Sunday, July 06, 2014 12:18 PM
  • i know this a old post but just going to services on the actual machines. just go to the Remote Procedure Call (RPC) Locator and set on start Automatically and start it, fixed the issue we had with hosted exchange. and a multi user Machine 
    Monday, August 11, 2014 5:20 PM