none
Exchange 2010 error Event ID: 2937

    Question

  • Hello, I am receiving the following error on an Exchange 2010 CAS and Hub transport server.  There once was an Edge transport server but it is now orphaned.  I will be forwarding mail from a hub transport server to a smart host. 

    Event ID: 2937

    Process edgetransport.exe () (PID=3376). Object [CN=Text Messaging Delivery Agent Connector,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=XXXXXX,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=YYYYY,DC=net]. Property [HomeMtaServerId] is set to value [YYYY.net/Configuration/Deleted Objects/Microsoft MTA
    DEL:5de51193-9c3c-4482-97e4-56f7c38c650a], it is pointing to the Deleted Objects container in Active Directory. This property should be fixed as soon as possible.

    Name                      AddressSpaces                   DeliveryProtocol               Enabled
    ----                      -------------                   ----------------               -------
    Text Messaging Deliver... {MOBILE:*;1}                    MOBILE                         True


    [PS] C:\Users\ZZZZZZ\Desktop>Get-DeliveryAgentConnector "text messaging delivery agent connector" | Format-List

    RunspaceId               : 97229127-eb37-40bd-85bf-35381ad53de2
    Enabled                  : True
    DeliveryProtocol         : MOBILE
    MaxConcurrentConnections : 5
    MaxMessagesPerConnection : 20
    AddressSpaces            : {MOBILE:*;1}
    ConnectedDomains         : {}
    IsScopedConnector        : False
    IsSmtpConnector          : False
    Comment                  :
    SourceRoutingGroup       : Exchange Routing Group (DWBGZMFD01QNBJR)
    SourceTransportServers   : {SRV4, SRV3}
    HomeMTA                  : YYYY.net/Configuration/Deleted Objects/Microsoft MTA
                               DEL:5de51193-9c3c-4482-97e4-56f7c38c650a
    HomeMtaServerId          : YYYY.net/Configuration/Deleted Objects/Microsoft MTA
                               DEL:5de51193-9c3c-4482-97e4-56f7c38c650a
    MaxMessageSize           : unlimited
    AdminDisplayName         :
    ExchangeVersion          : 0.1 (8.0.535.0)
    Name                     : Text Messaging Delivery Agent Connector
    DistinguishedName        : CN=Text Messaging Delivery Agent Connector,CN=Connections,CN=Exchange Routing Group (DWBGZMF
                               D01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group (FYDIBOHF23SPDLT),CN=Administra
                               tive Groups,CN=XXXXXXX,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=YYYY,DC=
                               net
    Identity                 : Text Messaging Delivery Agent Connector
    Guid                     : 4f14747d-9cd4-4018-ba34-b9d97cfe0c62
    ObjectCategory           : YYYY.net/Configuration/Schema/ms-Exch-Delivery-Agent-Connector
    ObjectClass              : {top, msExchConnector, mailGateway, msExchDeliveryAgentConnector}
    WhenChanged              : 6/8/2011 2:03:41 PM
    WhenCreated              : 4/22/2011 3:03:09 PM
    WhenChangedUTC           : 6/8/2011 7:03:41 PM
    WhenCreatedUTC           : 4/22/2011 8:03:09 PM
    OrganizationId           :
    OriginatingServer        : srv2.YYYY.net
    IsValid                  : True

    My question is how can I repair the text messaging delivery agent connector?  What value should HomeMTA and HomeMtaServerId have?

    Thank you!

    Tuesday, June 28, 2011 8:38 PM

Answers

  • Just take a gander at other connectors in that container and copy and paste the HomeMTA  value into that connectors properties.

    That connector is unique because it will have all the Hub Transports in the org as its source server

     

    • Marked as answer by CountyBrad Thursday, June 30, 2011 3:04 PM
    Tuesday, June 28, 2011 10:00 PM
    Moderator

All replies

  • Just take a gander at other connectors in that container and copy and paste the HomeMTA  value into that connectors properties.

    That connector is unique because it will have all the Hub Transports in the org as its source server

     

    • Marked as answer by CountyBrad Thursday, June 30, 2011 3:04 PM
    Tuesday, June 28, 2011 10:00 PM
    Moderator
  • AndyD, I copied the HomeMTA value from another connector as you suggested, rebooted all Exchange 2010 servers, and the error message did not come back, thank you for the advice!
    Thursday, June 30, 2011 3:04 PM