none
MSExchange Mailbox Replication Event 1007 logged every boot

    Question

  • Windows 2008 R2 SP1 with Exchange 2010 SP1 UR3v3 installed (CAS/HT/MB) into existing Exchange 2007 organization.  Clean installation, no errors.  Only one database exists and no DAG is present.  Every boot, the following is logged in the Application event log:

    Level:  Warning
    Source:  MSExchange Mailbox Replication

    Event ID: 1007

    Description: 

    The Mailbox Replication service was unable to determine the set of active mailbox databases on a mailbox server.

    Mailbox server: XXX-YYY.domain.tld

    Error: MapiExceptionNetworkError: Unable to make admin interface connection to server. (hr=0x80040115, ec=-2147221227)

     

    Now, the Exchange Replication Service starts a couple of seconds later and the Information Store starts around 10 seconds later according to the System log.  The MSExchangeRepl service does then successfully mount the database 13 seconds or so later, so it doesn't seem to cause a problem, but I don't want Warnings and Errors every boot on a new system.  Does anyone have a resolution for this please?

     

    Thank you.

    Wednesday, August 03, 2011 10:30 AM

All replies

  • Hi,

    How many DC's you have on the site. 

    As per your description it sounds like latency. Now what happens when you restart bot the service manually? Do you get the same event? 


    Gulab | MCITP: Exchange 2010-2007 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com
    • Proposed as answer by David Dawson Tuesday, March 26, 2013 6:42 PM
    Wednesday, August 03, 2011 10:34 AM
    1. Could be issues with your NIC settings such as IPV6, as a test you can try to disable if not being used and test.
    2. You may to put a automatic delayed start on the service or disable it, youre not using any replication.

    Sukh
    • Proposed as answer by Sukh828 Monday, August 08, 2011 6:26 PM
    Wednesday, August 03, 2011 11:01 AM
  • Hi,

    How many DC's you have on the site. 

    As per your description it sounds like latency. Now what happens when you restart bot the service manually? Do you get the same event? 


    Gulab | MCITP: Exchange 2010-2007 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com


    Hi there,

    There are 3 DC / GC's in the AD Site.

    If I manually restart the 'Information Store' and the 'Microsoft Exchange Replication Service', you do not see the same event logged.

    Please advise.

    Wednesday, August 03, 2011 11:44 AM
    1. Could be issues with your NIC settings such as IPV6, as a test you can try to disable if not being used and test.
    2. You may to put a automatic delayed start on the service or disable it, youre not using any replication.

    Sukh


    Hi Sukh,

    I will be using a Database Availability Group shortly, but I like to ensure that everything is healthy without errors before moving on to database replication, so I'm reluctant to change the service startup order (or indeed disable it).

    I will try the 'Automatic Delayed Start' and see if this makes any different anyway.  I don't want to disable IPv6 as Microsoft seem to consider this a key part of the stack going forward.

    Thanks

    Wednesday, August 03, 2011 11:48 AM
  • If the above still fails, try to change the below

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

     

    change the vaule of TcpTimedWaitDelay to 30 in decimal.


    Sukh
    • Proposed as answer by Sukh828 Monday, August 08, 2011 6:26 PM
    Wednesday, August 03, 2011 11:52 AM
  • Hi,

     

    When did you notice this issue? Before the issue occurs, is there any change on the Exchange server?  Based on my research, this issue might be caused by NLB related. Did you setup NLB for this server and then move it out?

     

    Please verify the database properties in EMC (Exchange Management Console), make sure the OAB and Public Folder(if exists) are specified.

     

    If the issue continues, update the NIC driver and disable IPV6 or TCP chimney for a try.

     

    Let md know if there is any finds.


    Fiona
    Monday, August 08, 2011 7:34 AM