none
Email moved from inbox to deleted items automatically

    Question

  • I have 1 user that is getting email moved from his inbox to his deleted items folder automatically.
    I have checked the AutomateProcessing setting and that does not seem to be the problem.
    He does have a blackberry through thier web service that syncs email but the settings there are to leave messages alone and has work for over a year now.
    This just started happening without any known changes being made. He is the only user that is having this issue.
    Messages will stay in the inbox for a few minutes to a few hours before they are moved. It does not seem to coincide with blackberry syncing or any other owa\outlook mailbox access.

    I checked the exchange message tracking logs but that only tracks a message once it gets to the mailbox. Is there a feature that can log when a message is moved from one folder to another and what\who made the request to do so?

    Just me and me alone keeps this ship afloat!
    Wednesday, June 10, 2009 2:27 PM

Answers

  • Thanks for all the suggestions. Last Saturday I deleted the user mailbox, associated the dead mailbox with another account then recreated the user account and mailbox. This seems to have resolved the issue. Didn't want to just rip things out but it had been over a week that the company president was going to his deleted items to read email.
    Unfortunately I did not get to the bottom of the issue but it is now resolved.
    Thanks,
    Joel
    Just me and me alone keeps this ship afloat!
    • Marked as answer by Joel Austin Tuesday, June 16, 2009 2:17 PM
    Tuesday, June 16, 2009 2:17 PM

All replies

  • A single user is afflicted with autodeleting emails.
    Email will be delivered to his inbox properly. If he leaves the message in the inbox it will automatically go to deleted items over a period of time. It could be 15 minutes or several hours.
    He makes no action to have this happen. It only happens n recent email messages. It started happening last week. Any email message in the inbox older that several days before that time still remains in the inbox normally. Any new email since is autodeleted.
    I have disabled his blackberry to eliminate that possibility.
    There are no rules enabled in his profile. I have deleted his profile and created a new one. We have left Outlook closed and used OWA and it still happens.
    All users are in the same group with no special policies on the exchange server.
    Any troubleshooting suggestions?
    Joel

    Just me and me alone keeps this ship afloat!
    • Merged by Elvis Wei Friday, June 12, 2009 10:10 AM duplicated
    Thursday, June 11, 2009 2:27 PM
  • Hi,

    Ask user to close outlook completely and configure outlook on the different machien to check if the same in different computer
    Close outlook and ask user to access mail form OWA and check if same happens in OWA

    Regards,
    Krishna
    http://smtpport25.wordpress.com
    • Proposed as answer by Krishna.Kumar Sunday, July 05, 2009 1:31 PM
    Thursday, June 11, 2009 2:31 PM
  • I did have him close outlook and operate from owa for a day and it still happened.
    I am sure outlook was not running and exited properly on the machine so there would be no outlook behind the scenes action.
    I have disabled his blackberry from accessing email completely and it still happens.
    Joel

    Just me and me alone keeps this ship afloat!
    Thursday, June 11, 2009 2:34 PM
  • Any hidden or stale mailbox rules?
    Delete Corrupted, Hidden or Stale rules from mailbox with MFCMapi

    Amit Tank | MVP – Exchange Server | MCITP: EMA | MCSA: M | http://ExchangeShare.WordPress.com RSS

    Thursday, June 11, 2009 2:38 PM
  • HI,

    When you go to Advance settings in your Account of outlook, there is a option "Remove from server after X days "If this option is select outlook will automtically delete the copies of emails that are that many days old.

    Regards


    Chinthaka
    Thursday, June 11, 2009 2:45 PM
  • I have checked the AutomateProcessing setting and that does not seem to be the problem.

    So what is this parameter currently set to?
    Neil Hobson, Exchange MVP
    Thursday, June 11, 2009 2:55 PM
  • This sounds like a POP3 account setting.
    I don't see any setting like this in our Outlook 2007/Exchange 2007 accounts.
    Also there are older email messages still in the inbox uneffected. The only emails being moved are recent emails. Anything older than about 5 days is left alone.
    Joel

    Just me and me alone keeps this ship afloat!
    Thursday, June 11, 2009 3:04 PM
  • Had a single instance of an IPM.Rule.Message in the users inbox. (tried it on my mailbox first and had the same single instance.) Is there a default ipm.rule.message that should exist in the inbox? Should I not have deleted it?
    I will have to sit on this and see if it cures the problem.
    I don't think this is it because the user has never created a rule in his life.
    Joel

    Just me and me alone keeps this ship afloat!
    Thursday, June 11, 2009 3:09 PM
  • Check info:

    1.      Could you tell the version of exchange and outlook? Currently, I assume it’s exchange 2003

    2.      Is there any other user got same issue?

    3.      What’s the setting of AutomateProcessing?

    4.      Quote: “user has never created a rule in his life”

    Does it mean there are no rules in “Rules and Alerts” option in the “Tools” menu?

    5.      Please move the mailbox of the problematic user to another mailbox store, which can fix the corruption of mailbox, including corrupted rules (If has)

    Friday, June 12, 2009 7:20 AM
  • I have checked the AutomateProcessing setting and that does not seem to be the problem.

    So what is this parameter currently set to? It was set to AutoUpdate. I have now set it to None.

    Just me and me alone keeps this ship afloat!
    Friday, June 12, 2009 2:21 PM
  • Check info:

    1.      Could you tell the version of exchange and outlook? Currently, I assume it’s exchange 2003
    Exchange 2007

    2.      Is there any other user got same issue?
    No other users seem to be effected.

    3.      What’s the setting of AutomateProcessing?
    Currently set to "None"

    4.      Quote: “user has never created a rule in his life”

    Does it mean there are no rules in “Rules and Alerts” option in the “Tools” menu?
    Yes

    5.      Please move the mailbox of the problematic user to another mailbox store, which can fix the corruption of mailbox, including corrupted rules (If has)
    Single Exchange server installation. Do not have another mailbox store.



    Just me and me alone keeps this ship afloat!
    Friday, June 12, 2009 2:23 PM
  • Please use the cmdlet below to compare the output of problematic user and fine user:

    ·         Get-User

    ·         Get-Mailbox

    Notes: Especially, check the value of “RecipientTypeDetails” in the output of Get-Mailbox, see if it shows “RoomMailbox” for problematic user

    Monday, June 15, 2009 2:11 AM
  • Thanks for all the suggestions. Last Saturday I deleted the user mailbox, associated the dead mailbox with another account then recreated the user account and mailbox. This seems to have resolved the issue. Didn't want to just rip things out but it had been over a week that the company president was going to his deleted items to read email.
    Unfortunately I did not get to the bottom of the issue but it is now resolved.
    Thanks,
    Joel
    Just me and me alone keeps this ship afloat!
    • Marked as answer by Joel Austin Tuesday, June 16, 2009 2:17 PM
    Tuesday, June 16, 2009 2:17 PM
  • Please use the cmdlet below to compare the output of problematic user and fine user:

    ·         Get-User

    ·         Get-Mailbox

    Notes: Especially, check the value of “RecipientTypeDetails” in the output of Get-Mailbox, see if it shows “RoomMailbox” for problematic user


    Where are these commands executed from?
    Thursday, July 02, 2009 8:20 PM
  • I was experiencing the same problem and it turned out being that the "AutomateProcessing" flag got set to "AutoAccept" instead of "AutoUpdate". I am guessing that this had something to do with my Blackberry device sync as I was working with that over the weekend and thats when the problem occurred.

    To fix it, I did the following (using the Exchange Server 2007 Management Shell):

    1. Verify that the flag was set incorrectly:

         get-mailboxcalendarsettings username | fl

         The first line of the output showed that the AutomateProcessing was set to AutoAccept, which is great if you are a conference room, but not so good if you are a regular user

    2. I changed the setting to AutoUpdate

         set-mailboxcalendarsettings username -automateprocessing: Autoupdate


    My emails are now staying in my Inbox where they belong. I also checked some of our other users and they are set up the same way.
    • Proposed as answer by ukimn002 Sunday, April 11, 2010 11:14 AM
    Monday, July 20, 2009 2:31 PM
  • I was experiencing the same problem and it turned out being that the "AutomateProcessing" flag got set to "AutoAccept" instead of "AutoUpdate". I am guessing that this had something to do with my Blackberry device sync as I was working with that over the weekend and thats when the problem occurred.

    To fix it, I did the following (using the Exchange Server 2007 Management Shell):

    1. Verify that the flag was set incorrectly:

         get-mailboxcalendarsettings username | fl

         The first line of the output showed that the AutomateProcessing was set to AutoAccept, which is great if you are a conference room, but not so good if you are a regular user

    2. I changed the setting to AutoUpdate

         set-mailboxcalendarsettings username -automateprocessing: Autoupdate


    My emails are now staying in my Inbox where they belong. I also checked some of our other users and they are set up the same way.
    This fixed it for us aswell
    Sunday, April 11, 2010 11:16 AM
  • I am having this same problem.  

    As far as your questions above:  1.  We are using Exchange 2003 SP2 and Outlook 2003 SP3.   2. No other user having this problem.  3.  Can't get this setting.  4.  This user had no IPM.Rule.Message in the users box. 5.  Single server store.

    I have ckecked for deleted or stale rules...None.  No current rules.  I also deleted the users mailbox on the server, created a new profile and it seemed to work for a couple days, but now we are back to deleting messages from the last 3 to 4 days.  Something new today is that it is not ALL messages.  usually 2 or 3 are left in the inbox, from both internal and external senders.  I am currently forwarding all messages to a temp mailbox for the user to have access to through OWA and the messages are staying in the temp box.  I have seen the notes regarding the Automate Processing, but from what I have read that is primarily in 2007.  Am I correct in that? Any assistance would be greatly appreciated.

    Friday, June 25, 2010 4:37 PM
  • I have a user that is experiencing the same issue and we have Outlook 2003.  What is the fix for that?  Also, the settings changes above... where do those take place?  The Blamckberry?  The Blackberry Server?  Outlook?  Outlook Server?  Thanks in advance.

     

    Drew

    Tuesday, August 31, 2010 1:56 PM
  • Drew,

    As you may see in the thread I deleted the user mailbox and recreated it. That solved the problem. I did this from the Exchange 2007 server.

    Joel


    Just me and me alone keeps this ship afloat!
    Wednesday, September 01, 2010 3:41 AM
  • I have been having the same issue with a single user. Again it happens to the MD of the company!

    The automateprocessing is set correctly, there are no rules etc. There are external devices but with these off it still happens. Another outlook profile or different machine make no difference.

    . The server was a migration from sbs 2003 to sbs 2008, but the mailbox has been happy for about 18 months. 

     

    I am going to try and remove and replace the mailbox later this week.

    Monday, June 20, 2011 2:56 PM
  • Even recreating the mailbox did not make a change. It worked for about 4 days and then overnight it moved all mails back to a certain date into his deleted items.

    There are several devices connecting to the mailbox but these have been quite happy working for months.

    Is there a way to show movement of mails once they are in a mailbox?

    Wednesday, June 29, 2011 12:13 PM
  • I have just had the same problem. With outlook 2003 it sends your emails to the personal inbox folder and then deletes them off the OWA server. The trick is to change the folder from the personal inbox folder to the mailbox inbox folder.

    Tools>email accounts>change  and then under the tab "deliver new email to ...." make sure that you change it to "mailbox - yourname"

    This will keep the emails on the OWA server.

    Friday, August 19, 2011 11:33 PM
  • This same scenario is happening to 3 users out 768. All of them are Outlook 2010 connecting to Exchange 2010.

    There are NO stale rules and no other rules for that matter.

    There is no POP

    Short of removing the mailbox and recreating are there any other suggestions for fixing this issue?

    Thanks

    Tuesday, March 20, 2012 6:34 PM
  • In our environment we just found the cause of the problem.

    Lenovo 420 and 410 Laptops that when the lid was closed and an end user carried to meeting or picked up the delete key would depress and delete the unread email.

    May not be the solution in everyone's case but thought I would at least post what our "cure" was ...
    Wednesday, March 21, 2012 9:19 PM
  • Great! it worked for me also.
    Tuesday, May 15, 2012 6:39 AM
  • Great! it worked for me

    Dinesh Patil

    Thursday, May 17, 2012 7:30 AM
  • It worked for me

    Thanks buddy.

    • Proposed as answer by Jo9 Tuesday, September 25, 2012 7:22 AM
    Tuesday, September 25, 2012 7:21 AM
  • We’re using E2010 SP1 RU4 and had a single user with this problem.  There were no client/server Rules causing this (confirmed with MFCMAPI).  New profiles, different workstations and OWA 2010 all showed the problem. 

    Same basic solution worked for us (PS CMDLETS are different from E2K7, and so I've posted the E2010 equivalents).

      • Get-calendarprocessing <USERNAME OR EMAIL> | fl
      • A typical normally functioning employee mailbox should have “AutomateProcessing” set to “AutoUpdate”.  These users had it set to ‘AutoAccept’.
      • Once you know the value is incorrect, reset it thusly:
        • Set-CalendarProcessing <USERNAME OR EMAIL> -automateprocessing autoupdate
      • Re-run Get-calendarprocessing to confirm.

    Thanks and HTH other E2010-ers.


    "If You're Gonna Shoot, Shoot. Don't Talk." - Tuco

    Thursday, October 04, 2012 9:08 PM
  • Thursday, November 22, 2012 3:46 PM
  • That was the issue for me.

    Patrick Hoban
    http://patrickhoban.wordpress.com

    Friday, January 11, 2013 2:30 AM
  • Hi Mate,

    Can you try the below -

    1) Make sure the User is not accessing the mailbox from different versions of Outlook.

    2) Make sure that there are no hidden rules as suggested by Amit Tank below. 

    3) Make sure the user has not set any junk mail settings or safe senders list in that. Try to look for a pattern in the deleted mails. any specific smtp suffix!

    4) Move mailbox to a different server with ignore corrupted items checked in move mailbox wizard. skip maximum allowed. Exchange 2003 allows 100.

    Let us know the results...

    Kind Regards

    Taparshi

    Tuesday, July 09, 2013 2:46 PM
  • My solution was to go to Exchange management shell and set the following

    Set-CalendarProcessing -identity "alias" -DeleteNonCalendarItems $false

    Hope it works for you too!

    Wednesday, July 17, 2013 4:58 PM
  • I recently had a similar problem.  I had 1 user whose emails from 1 scanner were going directly to the "deleted items" folder in Outlook 2003.  The other scanner worked properly and the emails went into her inbox.  Other users on the network didn't experience this problem.

    My solution that worked was to allow the senders domain to be added to the safe senders list and I haven't had any issues since. 

    Hope my 2 cents helps.

    Pat Clark

    Internet Services Group, Manager

    Friday, August 30, 2013 6:48 PM
  • Hi All,

    Sorry to revive an old thread but I would like to explain my experience with this issue in the hopes that it saves someone like me time in the future.

    I recently did a migration from Exchange 2007 to Exchange 2013. In the initial pilot group of migrated users I had one such case where overnight the users mail older than 30 days, including any folder structure, was moved to the deleted items and anything older than 90 days was deleted permanently.

    After an in-depth look at everything I could think of and after trying everything in this thread I found nothing and was forced to delete the users mailbox and restore all their mail from a backup. This resolved the issue but did not pinpoint the cause.

    A week later, I migrated the remainder of the business only to find that 8 more users had exactly the same issue.
    Long story short, it turned out to be a residule setting from the Exchange 2007 server, "Managed Folder Mailbox Policy" in conjunction with "Managed Default Folders". Someone had set this up to move all old calendar entries and such to the deleted items after 30 days and delete permanently anything in the deleted items after 60 days. As we only had a Non-Enterprise licence and these settings are only avaliable for an enterprise licence, they were never applied. I do not know what caused Excahnge 2013 to decide to a) apply this rule when it shouldnt and b) apply it to ALL mail instead of expired calendar items etc but that was the case.
    To find out what mailboxes were effected, I ran "Get-Mailbox -Identity <username> | fl SamAccountName,ManagedFolderMailboxPolicy" which gave a list of all users with the "Managed Default Folders Policy" applied.
    I was then able to remove it via the old Exchange GUI (luckily) or it can be done manually on the New Exchange by running "Set-Mailbox -Identity <username> -RemoveManagedFolderMailboxPolicy".

    TLDR: run "Get-Mailbox -Identity <username> | fl SamAccountName,ManagedFolderMailboxPolicy" and compare an affected user to a non-affected user and go from there.

    I really hope this helps someone as this was a huge headache for me :)
    Regards
    Owen

    Tuesday, February 04, 2014 2:02 AM
  • Hello All,

    I know this has been answered awhile back but wanted to post what I found out anyway.   I just had the same problem and was researching trying to locate an answer.  I have Exchange 2010 and Outlook 2010.  All of my emails suddenly started going to deleted items.  They would show up briefly in my inbox and bam, there they were in deleted items.  This would happen even if Outlook was not open, it would happen in OWA as well.  The problem was my "AutomateProcessing" attribute on my account was set to "AutoAccept".  To check this, launch Exchange Powershell and type in the following command to check what it is currently set to:

    Get-CalendarProcessing -identity "YourAlias" | fl

    This will list all of your calendar processing attributes.  

    If "Automate Processing" is set to "AutoAccept" (and is not a intentional or a resource mailbox), set it to "AutoUpdate" (default).  

    To do this, type the following command:

    Set-CalendarProcessing -Identity "YourAlias" -AutomateProcessing AutoUpdate

    After I did this, my email stopped going to deleted items.

    Regards,

    Jason

    Friday, February 28, 2014 8:52 PM