none
Exchange 2010 Management Console "Initialization failed" troubleshooting

    Question

  • This error:

    The following error occurred when searching for On-Premises Exchange Server:
    [server#.Domain] Connecting to the remote server failed with the following error message:
    The WinRM client cannot process the request.  It cannot determine the content type of the HTTP response from the destination computer.  The content type is absent or invalid.  For more information, see the about_Remote_Troubleshooting help topic

    I've seen errors similar to this in these forums, but I haven't had any luck with the steps used to correct other's problems.  The most recent steps I've taken are:

    uninstalled and reinstalled IIS, then uninstalled and reinstalled CAS, along with various other fixes to no avail.  

    After installing Exchange and CAS the console was working for a couple of weeks, it died with this error after two things we can remember, although various other things may have been the cause:

    1. installed a lengthy list of windows updates

    2. installed the URL rewrite module: http://www.iis.net/expand/URLRewrite and set it up to rewrite http://domain to https://domain/owa, this has since been reverted and uninstalled, it still doesn't work.

     

    Tuesday, April 06, 2010 3:37 PM

Answers

  • Thank you for Your Post

    The First Error on this Blog is the error that you are facing

    http://msexchangeteam.com/archive/2010/02/04/453946.aspx

    Issue:

    Connecting to remote server failed with the following error message: The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

    Possible causes:

    1. Remote PowerShell uses Kerberos to authenticate the user connecting. IIS implements this Kerberos authentication method via a native module. In IIS Manager, if you go to the PowerShell Virtual Directory and then look at the Modules, you should see Kerbauth listed as a Native Module, with the dll location pointing to C:\Program Files\Microsoft\Exchange Server\v14\Bin\kerbauth.dll. If the Kerbauth module shows up as a Managed module instead of Native, or if the Kerbauth module has been loaded on the Default Web Site level (instead of, or in addition to, the PowerShell virtual directory), you can experience this issue. To correct this, make sure that the Kerbauth module is not enabled on the Default Web Site, but is only enabled on the PowerShell virtual directory. The entry type of "Local" indicates that the Kerbauth module was enabled directly on this level, and not inherited from a parent.

    2. If the WSMan module entry is missing from the global modules section of the C:\Windows\System32\Inetsrv\config\ApplicationHost.config file, as follows:

    <globalModules>
               <add name="WSMan" image="C:\Windows\system32\wsmsvc.dll" />

    This will result in the WSMan module displaying as a Managed module on the PowerShell virtual directory.

    To correct this, make sure that the WSMan module has been registered (but not enabled) at the Server level, and has been enabled on the PowerShell virtual directory.

    3. If the user that is attempting to connect is not Remote PowerShell enabled. To check if a user is enabled for Remote PowerShell, you need to open the Exchange Management Shell with an account that has been enabled, and run the following query.

    (Get-User <username>).RemotePowershellEnabled

    This will return a True or False. If the output shows False, the user is not enabled for Remote PowerShell. To enable the user, run the following command.

    Set-User <username> -RemotePowerShellEnabled $True

    Tuesday, April 06, 2010 3:46 PM

All replies

  • Thank you for Your Post

    The First Error on this Blog is the error that you are facing

    http://msexchangeteam.com/archive/2010/02/04/453946.aspx

    Issue:

    Connecting to remote server failed with the following error message: The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

    Possible causes:

    1. Remote PowerShell uses Kerberos to authenticate the user connecting. IIS implements this Kerberos authentication method via a native module. In IIS Manager, if you go to the PowerShell Virtual Directory and then look at the Modules, you should see Kerbauth listed as a Native Module, with the dll location pointing to C:\Program Files\Microsoft\Exchange Server\v14\Bin\kerbauth.dll. If the Kerbauth module shows up as a Managed module instead of Native, or if the Kerbauth module has been loaded on the Default Web Site level (instead of, or in addition to, the PowerShell virtual directory), you can experience this issue. To correct this, make sure that the Kerbauth module is not enabled on the Default Web Site, but is only enabled on the PowerShell virtual directory. The entry type of "Local" indicates that the Kerbauth module was enabled directly on this level, and not inherited from a parent.

    2. If the WSMan module entry is missing from the global modules section of the C:\Windows\System32\Inetsrv\config\ApplicationHost.config file, as follows:

    <globalModules>
               <add name="WSMan" image="C:\Windows\system32\wsmsvc.dll" />

    This will result in the WSMan module displaying as a Managed module on the PowerShell virtual directory.

    To correct this, make sure that the WSMan module has been registered (but not enabled) at the Server level, and has been enabled on the PowerShell virtual directory.

    3. If the user that is attempting to connect is not Remote PowerShell enabled. To check if a user is enabled for Remote PowerShell, you need to open the Exchange Management Shell with an account that has been enabled, and run the following query.

    (Get-User <username>).RemotePowershellEnabled

    This will return a True or False. If the output shows False, the user is not enabled for Remote PowerShell. To enable the user, run the following command.

    Set-User <username> -RemotePowerShellEnabled $True

    Tuesday, April 06, 2010 3:46 PM
  • Hi,

    How about your question? Any updates?

    Just a reference, suggest you follow the Exchange Technet article to simplify the OWA URL:

    Simplify the Outlook Web App URL

    Frank Wang
    Thursday, April 08, 2010 3:40 AM
  • Knock Knock....

    Thursday, April 08, 2010 7:33 AM
  • I have exactly the same issue (as the topic starter) when I start the EMC or the EMS on my brand-new Exchange 2010 (win 2008 R2) CAS server.

     

    I've installed this in an organization with coexistence with E2003 and E2007. 

     

    The above points didn't solve the issue... Also disable anonymous auth in IIS > PowerShell didn't fix it. I'm domain administrator so I have the correct roles applied?

     

    Maybe some other suggestions?

     

    Regards,

    Thursday, April 08, 2010 9:45 PM
  • I have finaly solved the issues...

    Reinstalling/Repairing the CAS installation didn't solve the issue. After I removed the Exchange installation from the server and removing all roles and features from the CAS server (and rebooting the server to finalize that), I have installed the requirements and CAS role again.

    Now I only used the "ServerManagerCmd.exe -ip Exchange-CAS.xml" installation script from the installation CD (and I've not installed IIS manualy as the first time) for the requirements. After that I run the setup.exe and after finishing the installation EMC and EMs works fine!

    Regards,

    • Proposed as answer by Master Yoyo Thursday, July 15, 2010 4:33 AM
    Friday, April 09, 2010 8:32 PM
  • Thank you for Your Update.

    Good Work :)

    I think that You must have forgot one of the Pre requsites(Just a WILD Guess)

    for any more querries Please feel free to post back on this forum.

    Regards


    Fazal Muhammad Khan | MCT, MCSE, MCSA, MCTS | Infrastructure Consultant, Technology Services | CDC Pakistan Ltd. | https://fazalmkhan.spaces.live.com | OFFICE: +92 21 111 111 500 Ext: 1402 | +5 GMT
    Saturday, April 10, 2010 9:03 AM
  • I am having the same error message returned to me as well. The machine is a Hyper running Server 2008 R2.  I checked all those possibilities listed in that article but the settings are correct to the first two suggestions and I can't connect at all (even with the enterprise admin account) to try the third fix.

     

    The WinRM client cannot process the request.  It cannot determine the content type of the HTTP response from the destiation computer.  The content type is absent or invalid. 

    + Category info:  OpenError: (System.Manageme...RemoteRunspace:RemoteRunspace) [], PSRemoting TransportExecption

    + FullyQualifiedErrorld : PSSessionOpenFailed

     

    Is it possible that I overlooked a Pre Req or that my Active Directory Lightweight Directory Services is not configured correctly?

    Friday, May 07, 2010 3:38 PM
  • Bump.  The Event Log gives the following error as well.

     

    Event 4, MSExchange Configuration Cmdlet - Management Console

     

    (PID 2124, Thread 53) Task New-PerfCounters writing error when processing record of index 0.  Error: System.ArgumentException:  The performance counter defiition file C:\Program Files\Microsoft\Exchange\Server\V14\Bin\Perf\AMD64\ProvisioningServiceCounters.xml could not be found.

     

    I would like to reinstall the whole Exchange Server but I cannot uninstall it as a mailbox is somehow linked to the server.  It won't let me uninstall it if i dont remove this mailbox and I cannot remove the mailbox as I cannot connect to the Exchange Server.

     

    Sunday, May 09, 2010 5:45 PM
  • Hi,

    Just Curious, do you have pst of user mailbox, if yes than you can remove the mailbox database directly from Adsiedit.msc and proceed with uninstallation of exchange server.

     

    Cheers,

    -Gulab

    Thursday, May 13, 2010 12:48 PM
  • I can't get into Modules  from the IIS Manager for the powershell application. It throws an error

     

    ---------------------------
    Modules
    ---------------------------
    There was an error while performing this operation.

     

    Details:

    Filename: \\?\C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\web.config

    Line number: 30

    Error: This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".

     


    ---------------------------
    OK  
    ---------------------------

    Thursday, June 03, 2010 3:24 PM
  •  

    Did you run Exchange-CAS.xml on a server 2008 R2 box? I installed the pre-requisites with Import-Module ServerManager and the Add-Module instructions and I'm still experiencing the problem.

    Thursday, June 03, 2010 3:26 PM
  • Hi All,

    Am really new to Exchange.....I had the issue and that was after I installed the AD CS on the Server. I assumed EMC was refusing the connection because the default Exchange Certificates was not trusted....I added the certificate to the Trusted Certificate Store and things worked fine for me.

    Am not sure this is the exact answer but it worked for me......someone can still give me an explaination.....

     

    Thanks.

    Wednesday, June 23, 2010 8:35 AM
  • I can't get into Modules  from the IIS Manager for the powershell application. It returns an error

    There was an error while performing this operation.

    Details:

    Filename: \\?\C:\Program Files\Microsoft\Exchange Server\V14\ClientAccess\PowerShell\web.config

    Line number: 30

     

    pls help

    Thursday, July 08, 2010 11:56 AM
  • I'm also having problem during installation of Exchange Server 2010. I'm stuck with Initialization Failed in my ESM.

     

    The direction above seems not helping me, so I placed a call to Microsoft Professional Service to address this issue. I will share it here when I resolve my issue.

    Regards,

    Emil

    www.king.net

     

    Tuesday, October 05, 2010 8:05 PM
  • Yes, I called Microsoft Professional Service to resolved this issue. If interested, see it here http://blog.king.net/2010/10/exchange-2010-management-console.html

    I hope this help you, and it will save you $274 in fees.

     

    Cheers for now, I have a server to complete.

    Em

    Wednesday, October 06, 2010 2:58 PM
  • Dear Mr. King dot net

    thank you , but the link does not work.

    ???

    Tuesday, December 21, 2010 10:26 AM
  • I had the same problem, also Exchange Management failed.

    After reinstalling the WinRM feature (using the servermanager) it worked again.

    • Proposed as answer by symoCBL Tuesday, March 19, 2013 6:51 PM
    Wednesday, January 05, 2011 8:15 AM
  • Isn't this weird, to pay for Microsoft Issues?? I have installed Exchange 2010 spend all day on the testing environment to  test for my client maybe to switch to Exchange 2010 in the future, and I see the ESM does not start. Reinstalled RM reinstalled IIS. Still not starting!
    First I had to go thru all those Patches in order to start the installation and after that was done ESM does not want to start, and what’s more weird you cannot submit to Error Reporting Services, that does not work as well even I selected the option during the installation.
    This is so frustrating after spending many hours and maybe days on the same issue!

    This is what you call a Sloppy Job!

     

    Thursday, January 13, 2011 1:57 PM
  • Thanks, reinstalling the WinRM IIS Extension worked for me after I made sure everything was registered correctly.
    Wednesday, February 23, 2011 8:47 PM
  • net tcp port sharing service shoule be automatic in active directory server .

    by this service only exchange 2010 can check GLOBAL catalog and AD services .

    on exchange check event logs you will get various alerts related to access denied of AD server .

    as soon as you enable this service automatic on DC issue will resolved

    Tuesday, June 07, 2011 8:41 AM
  • Thanks King dot Net!

    Your solution worked fine for me.

    I have fresh install of 2 CAS&HUB servers  + 2 MBX

    Just in some moment CAS&HUB servers' EMC and EMS stopped working.

    When first saw your solution I just thougth "You r kidding, it couldn't be as simple as that!" But it works! :)

    Thursday, February 02, 2012 7:06 AM
  • Found an even simpler solution. Ours is a one server operation but the Exchange Replication and Exchange Mailbox Replication services had been set to automatic.  Set them back to Manual - everything worked straight away.
    Friday, March 30, 2012 1:02 PM
  • First of all, nice thread here! :-)

    I've been looking into this problem for about 1 day, and my solution was :

    * WinRM IIS extension wasn't installed on my server either (I think it was uninstalled when removing Forefront, since that's about when I started receiving the error)

    * Afterwards I still received a 502 error when starting the EMS. Since 502 is gateway related I checked the proxy settings with netsh, and removed the proxy config that was entered there with "netsh winhttp reset proxy"

    After that EMS and EMC were working correctly again

    Wednesday, April 04, 2012 7:22 AM
  • Check out this little gem:

    The following error occurred while attempting to connect to the specified Exchange server ‘exchange.domain.org’:

    The attempt to connect to http://exchange.domain.org/PowerShell using “Kerberos” authentication failed:  Processing data from the remote server failed with the following error message: Cannot load Windows PowerShell  snap-in Microsoft.Exchange.Powershell.Support because of the following error:  Could not load type ‘Microsoft.Exchange.Management.PowerShell.SupportSupportPSSnapIn’ from assembly ‘Microsoft.Exchange.PowerShell.Configuration, Version=14.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35.  For more information , see the about_Remote_Troubleshooting Help Topic.


    I get this now in my Ex2k3 to Ex2k10 migration... just all of a sudden and out of the blue.  

    Exchange 2010 SP2

    After I had installed Exchange 2010 and added it to the org, I used the ESM to migrate most mailboxes over to the new Exchange server.  I also migrated all public folders over and we were just waiting for our cert to complete so I could add that and then complete the migration.  

    By the way, I had to do this in order to get my Powershell working:

    http://joetrombley.wordpress.com/2011/03/12/the-windows-powershell-snap-n-microsoft-exchange-management-powershell-e2010-is-not-installed-on-this-machine/

    After powershell was working, I continued with my migration.  Everything was going well until I needed to reboot the Exchange server for some updates.  Bad move.  ESM now gives me the above posted error each and every time that I try to connect to it.  This is universal for local and remote attempts to access the ESM.

    My account is a member of

    Domain Admins

    Schema Admins

    Enterprise Admins

    ..and all of the new groups needed to administrate Exchange 2010 (RBAC)

    I have tried many things to correct this but I haven't really been able to match up my exact situation with anything out in the forums.  Anyone have any idea what is going on here?  I know it is something simple that I have overlooked.

    Wednesday, May 02, 2012 7:07 PM
  • Got the same error "Initialization failed" when trying to open EMC.

    The following error occured when getting management role assignment information for "domain/Users/admin"

    Processing data for a remote command failed with the following error message: The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled.

    Can open EMC every 1 in 10.. the rest to  the time I get this message.

    Is there any update regarding this problem?

    Friday, October 05, 2012 1:02 PM
  • Ended up to be ESET NOD32 causing the problems.

    After removing ESET EMC started working without any issues.

    Monday, October 08, 2012 7:53 AM
  • The command "netsh winhttp reset proxy" worked like a charm for me!
    Thursday, November 08, 2012 2:43 PM
  • an IISRESET fixed my issue.
    Wednesday, December 18, 2013 2:06 PM