none
(Exchange 2013) Outlook unable to connect via Outlook Anywhere

    Question

  • Hi guys, been stuck with this for two days now...

    I have a Windows Server 2012 installation with Exchange 2013. The local server is called

    cts-uk-mail2012.cts-exchange.local

    and I have multiple domains registered on it as we will lease out the mailboxes.

    I've got a test domain pointed to it and configured, I've also registered a valid SSL certificate to the domain, mail.adlib-uk.com. OWA works perfectly from anywhere, no certificate warnings, all perfect, but no matter what I do I cannot get Outlook 2010 to connect to the server. I've enabled and changed anything valid to the mail.adlib-uk.com domain within the ecp and I configure outlook to connect via http with the relevant settings, but it tries to log me in and then it says outlook cannot connect to the server or outlook cannot log me in.

    running a RPC over HTTP test on testexchangeconnectivity.com works perfectly... Any ideas on how to get outlook working? I'm under severe pressure to have this finished by tomorrow!!

    Thanks,

    Oli


    • Edited by CTSOLI Thursday, March 07, 2013 2:50 PM
    Thursday, March 07, 2013 2:49 PM

Answers

  • Got MS on the phone and he had to reset the iis after factory defaulting the authentication on the default site before it started working.
    • Marked as answer by CTSOLI Monday, March 11, 2013 2:53 PM
    Monday, March 11, 2013 2:53 PM

All replies

  • To clarify some details:

    I have configured all the external URL's to the mail.adlib-uk.com within the Virtual Directories section of "Servers".

    There is a valid SSL Certificate for mail.adlib-uk.com, adlib-uk.com and AutoDiscover.adlib-uk.com from a 3rd party provider, the Certificates Services are SMTP, IMAP, POP, IIS.

    Outlook anywhere is enabled, the external and internal hostnames are configured to the adlib domain with NTLM authentication.

    Connection from an iPhone via my carriers 3g service to an *@adlib-uk.com account works and sends/receives emails internally and externally.

    Connection from a web browser to the OWA works, no certificate errors and sends/receives email internally and externally.

    Outlook is the only thing which wont connect to the Exchange server...

    Thursday, March 07, 2013 3:03 PM
  • Hi,
    Have you confirmed that Outlook 2010 is on a (for Exchange 2013) supported patch level?
    (Outlook 2010 SP1 with November 2012 Cumulative Update or later)

    Martina Miskovic

    Thursday, March 07, 2013 3:10 PM
  • My outlook says it is running Microsoft Outlook 2010 (14.0.6131.5000) SP1 MSO (14.0.6129.5000)

    I've checked for updates and there dont seem to be any. Could you confirm this is valid?

    Thursday, March 07, 2013 3:18 PM
  • To clarify further, the whole point of this setup is to enable clients on their own domains and networks to have outlook access this exchange server where their emails will be stored. They will not be members of the exchange servers domain and will not be on its LAN. Outlook needs to be able to connect via the servers external address using RPC over HTTP.

    Thursday, March 07, 2013 3:36 PM
  • My outlook says it is running Microsoft Outlook 2010 (14.0.6131.5000) SP1 MSO (14.0.6129.5000)

    I've checked for updates and there dont seem to be any. Could you confirm this is valid?


    Hi,
    I think you have the October CU 2012 installed.

    Here's the latest one.

    Office 2010 cumulative update for February 2013
    http://support.microsoft.com/kb/2800779

    Martina Miskovic

    Thursday, March 07, 2013 3:40 PM
  • hmm, will give it a go but doesn't feel like that will solve it :s

    Hotfix Request

    The system is currently unavailable. Please try back later, or contact support if you want immediate assistance.http://support.microsoft.com/contactus/?ws=support

    Have to wait i guess....

    Thursday, March 07, 2013 3:55 PM
  • Applied the updates, same error after configuring it and then it asks for my login details which i provide



    • Edited by CTSOLI Thursday, March 07, 2013 4:23 PM
    Thursday, March 07, 2013 4:16 PM
  • Is the computer you are testing with domain-joined and/or have primarysmtpaddresss *@adlib-uk.com

    Any errors when running Test-OutlookWebServices?


    Martina Miskovic

    Thursday, March 07, 2013 4:43 PM
  • The machine is joined to a different domain on a different LAN to the exchange server (its important it works in this manner for my clients).

    I'll give the test-outlookwebservices a go on the server shortly.

    Thursday, March 07, 2013 4:48 PM
  • Is there any Exchange Servers in the domain that the computer is a member of?
    If so, have you configured Autodisover settings to exclude SCP lookups (registry setting)?

    Can the client access these URLs without a problem:

    https://autodiscover.adlib-uk.com/Autodiscover/Autodiscover.xml
    https://mail.adlib-uk.com/ews/exchange.asmx


    Martina Miskovic


    Thursday, March 07, 2013 4:55 PM
  • Hi Martina,

    Firstly, thank you so much for your continued support!!!!

    There is an exchange server in the domain the test machine is a member of. I haven't configured Autodiscover at all really, sounds like that might be the problem?

    I can access the second address and it presents me with a login but the first one doesn't work.

    Friday, March 08, 2013 8:40 AM
  • I had a feeling that my local DNS might be getting in the way so I manually added autodiscover.adlib-uk.com to my DNS server and now the first site responds correctly. I am going to add autodiscover to the DNS configuration on the Exchange 2013 server to ensure it points back at itself properly.
    Friday, March 08, 2013 8:47 AM
  • Ok, Outlook still has the same problems connecting despite being able to connect to both of the urls that you posted. investigating autodiscover settings now :(
    Friday, March 08, 2013 8:59 AM
  • Furthermore, when I login to either https://adlib-uk.com/autodiscover/autodiscover.xml or https://autodiscover.adlib-uk.com/autodiscover/autodiscover.xml then it shows an error:

    .

    This XML file does not appear to have any style information associated with it. The document tree is shown below.
    <Autodiscover xmlns="http://schemas.microsoft.com/exchange/autodiscover/responseschema/2006">
    <Response>
    <Error Time="09:15:08.8533537" Id="2245901330">
    <ErrorCode>600</ErrorCode>
    <Message>Invalid Request</Message>
    <DebugData/>
    </Error>
    </Response>
    </Autodiscover>

    Friday, March 08, 2013 9:16 AM
  • Ok, with outlook logged into my normal Profile I ran a autodiscover test to the adlib-uk account and it seems to succeed :(

    Test E-mail Autoconfiguration Log tab:

     Autodiscover to https://adlib-uk.com/autodiscover/autodiscover.xml Succeeded (0x00000000)

    (and a bunch of other lines)

    Test E-mail AutoConfiguration Results tab:

    Autoconfiguration found the following settings:

    Display Name: **myaccountname**

    Internal OWA URL: https://cts-uk-mail2012."mydomain".local/owa

    External OWA URL: https://mail.adlib-uk.com/owa

    then it lists my availability service url, OOF url, OAB url and Unified message service URL. My Availability Service URL, OOF URL and Unified Message Service URL are all the internal address (cts-uk-mail2012.etc) while the OAB URL is the external https://mail.adlib-uk.com-etc one. 

    .

    Protocol: Exchange HTTP

    Server: mail.adlib-uk.com

    Login Name: **myaccount**

    SSL: Yes

    Mutual Authentication: Yes

    Availability Service, OOF, OAB, Unified Message Service URLS all mail.adlib-uk.com/

    Auth Package: NTLM

    ECP URL: adlib again.

    .

    Any ideas?

    Friday, March 08, 2013 11:20 AM
  • Got MS on the phone and he had to reset the iis after factory defaulting the authentication on the default site before it started working.
    • Marked as answer by CTSOLI Monday, March 11, 2013 2:53 PM
    Monday, March 11, 2013 2:53 PM
  • Hi,

    I know this was last posted to a while back... but what are the default settings? :)

    Thanks,

    Lee

    Thursday, June 12, 2014 8:41 PM