none
Outlook Prompting for Passwords to Connect to Exchange 2010

    Question

  • Hi All,

    i have upgraded my exchange 2007 SP2 to exchange 2010 SP2. Moved all the mailboxes to Exchange 2010, OWA is working fine, the problem is everytime a user opens outlook 2007/2010 a password is prompted continuesly. if you say cancel, you can work out nicely in the outloook, you can send/receive mails without any problems but password prompt come continuesly.

    please help.

    Yusuf Kamruddin

    Thursday, March 22, 2012 10:56 AM

All replies

  • Hello,

    I would suspect that it is an autodiscover issue.

    Please run a "Test E-MAIL Autoconfiguration ..." test and check the entries that you've got from autodiscover. Once done, check that they are all correct.


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Thursday, March 22, 2012 11:04 AM
  • Hi Mr X,

    Thank you for your reply.

    Please explain me how to run a "Test E-MAIL Autoconfiguration ..."?

    Regards

    Yusuf

    Thursday, March 22, 2012 11:13 AM
  • Hi Yusuf,

    please right-click your Outlook taskbar icon and hit "Test E-Mail Autoconfiguration"

    Uncheck the two "Guessmart" boxes, enter a valid account and password.

    Regards,

    Chris


    Christopher Dargel

    Chris' Exchange Blog - blog.dargel.at

    MCITP Enterprise Messaging Administrator 2007 / 2010

    Thursday, March 22, 2012 11:25 AM
  • We had this happening in our exchange 2010 enviroment, the fix was simple....

    On the exchange server,

    Open a command prompt.

    Type iisreset and press enter.

    If this does not work then check the authentication methods on the RPC virtual directoy in IIS make sure windows auth is set to enabled

    Theory behind the fix... feel free to shoot me down if im wrong

    Outlook 2007 / 2010 etc uses RPC over HTTP to communicate with exchange (hence why no nagging in outlook 2003 as it only uses RPC) 

    IIS uses windows authentication on RPC virtual directory for Outlook connections. If the connection between IIS and AD goes down it doesn't seem to be able to reconnect to AD without an IISRESET which effectively reboots IIS re-establishes connection to Active Directory and the nagging stops.


    • Edited by JonBridger Thursday, March 22, 2012 12:19 PM
    Thursday, March 22, 2012 12:16 PM
  • Hi Yusuf,

    please right-click your Outlook taskbar icon and hit "Test E-Mail Autoconfiguration"

    Uncheck the two "Guessmart" boxes, enter a valid account and password.

    Regards,

    Chris


    Christopher Dargel

    Chris' Exchange Blog - blog.dargel.at

    MCITP Enterprise Messaging Administrator 2007 / 2010

    Don't forget to hold ctrl while you right click the outlook icon otherwise the menu option doesn't appear!
    Thursday, March 22, 2012 12:22 PM
  • Hi JonBridger

    Thank you for your reply. i tried iisreset but not succesful and i cannot see RPC virtual directory in the IIS?

    i did hold ctrl while right clicking the outlook icon but still could not see the "Test E-MAIL Autoconfiguration ..." menu.

    regards

    yusuf

    Thursday, March 22, 2012 12:38 PM
  • Hi JonBridger

    Thank you for your reply. i tried iisreset but not succesful and i cannot see RPC virtual directory in the IIS?

    i did hold ctrl while right clicking the outlook icon but still could not see the "Test E-MAIL Autoconfiguration ..." menu.

    regards

    yusuf

    You ctrl+Right clicked on the outlook icon in system tray (next to clock)?

    Your exchange 2010 iis manager should look like the below.....

    The above screenshot is of the authentication setting page of the RPC virtual directory

    • Edited by JonBridger Thursday, March 22, 2012 12:44 PM
    Thursday, March 22, 2012 12:40 PM
  • Hi JonBridger

    I was succesfull to hold ctrl + right click and do the test.

    my exchange 2010 iis manager looks exactly the same as the one above except there is no rpc.

    regards

    yusuf

    Thursday, March 22, 2012 1:35 PM
  • Hi JonBridger

    I was succesfull to hold ctrl + right click and do the test.

    my exchange 2010 iis manager looks exactly the same as the one above except there is no rpc.

    regards

    yusuf

    So, have you checked that you are getting right information for OAB (...) from autodiscover?


    This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.   

    Microsoft Student Partner 2010 / 2011
    Microsoft Certified Professional
    Microsoft Certified Systems Administrator: Security
    Microsoft Certified Systems Engineer: Security
    Microsoft Certified Technology Specialist: Windows Server 2008 Active Directory, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Network Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows Server 2008 Applications Infrastructure, Configuration
    Microsoft Certified Technology Specialist: Windows 7, Configuring
    Microsoft Certified Technology Specialist: Designing and Providing Volume Licensing Solutions to Large Organizations
    Microsoft Certified IT Professional: Enterprise Administrator
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Trainer

    Thursday, March 22, 2012 2:26 PM
  • I suspect it's a DC issue, run DCdiag and check events on Exchange server, check the health of DC..

    what if you enter the username/password?


    Inderjit

    Thursday, March 22, 2012 2:29 PM
  • The RPC virtual directory should have there in CAS server, if it has been removed you can create it by uinstall the RpcProxy component from the Windows Add and Remove Programs Console and Reinstall It.

    There is no commands to recreate the Rpc Virtual Directory.

    Thanks


    Mihir Nayak If a post is helpful, please take a second to hit the green arrow on the left, or mark as answer, thanks

    • Proposed as answer by JonBridger Friday, March 23, 2012 12:53 PM
    Thursday, March 22, 2012 2:40 PM
  • Hi All,

    i did iisreset. diabled outlook anywhere, but still i am getting the password promt box.

    i am using windows server 2008 r2, i cant find anywhere i can uninstall rpcproxy.

    please guys help me.

    regards

    yusuf

    Saturday, March 24, 2012 9:44 AM
  •  

    Hi

    It is possible that the password prompt issue was caused by Outlook Anywhere.

    Please configure authentication refer to the following command , client set NTLM whilst it is basic in server setting.

    Set-OutlookAnywhere -Identity:CAS01\Rpc (Default Web Site) -ClientAuthenticationMethod:Ntlm

    Set-OutlookAnywhere -Identity 'EXCH1\Rpc (Default Web Site)' -IISAuthenticationMethods Basic

    Set-OutlookAnywhere:

    http://technet.microsoft.com/en-us/library/bb123545.aspx

    Please also test from internal. And verify if Outlook prompt password.


    Wendy Liu

    TechNet Community Support


    Tuesday, March 27, 2012 5:35 AM
  • hey Guys,

    I diasabled outlookanywhere on my server and i changed the ssl setting in the ISS manager for autodiscover,owa,rpc,rpcwithcert to accept.

    now not all users are getting the password prompt but only few users still, as before this settings all users were getting password prompt.

    regards

    yusuf

    Tuesday, March 27, 2012 10:46 AM
  •  

    Hi ,

    Please post the log of “Test E-MAIL Autoconfiguration”.

    Please verify Outlook Connection Status via ctrl+ right-click your Outlook taskbar icon.

    Please try to recreate Outlook Profile and restart it.

    Please also log on OWA verify if it can log on successfully.

    The Outlook issue in internal or external ?


    Wendy Liu

    TechNet Community Support

    Thursday, March 29, 2012 7:14 AM
  • Hi,

    Any update ?


    Wendy Liu

    TechNet Community Support

    Monday, April 02, 2012 2:36 AM
  • Hi Wendy,

    This is an internal issue.

    OWA is working very fine.

    Now the problem is with some users only on the local network, others no more get the password prompt.

    i will do the other test tomorrow and send the results.

    regards

    yusuf

    Monday, April 02, 2012 8:42 PM
  • Hi Wendy,

    Here are the screenshots of TEST Connection and outlook connection status.

    regards

    yusuf

    Tuesday, April 03, 2012 1:03 PM
  • Hi,

    In the user properties in the EMC enabled Mapi connections which were disabled.

    please use the following command verify if Autodiscover InternalURL have already configured.

    Get-AutodiscoverVirtualDirectory

    Please verify if Internal DNS is correct.


    Wendy Liu

    TechNet Community Support

    Friday, April 06, 2012 8:45 AM
  • Hi wendy_liu

    i use the command Get-AutodiscoverVirtualDirectory and the following error :

    The task wasn't able to connect to IIS on the server 'oldexchserver.contoso.com'. Make sure that the server exist
    s and can be reached from this computer: The RPC server is unavailable.
        + CategoryInfo          : ReadError: (OLDEXCHSERVER\Aut...fault Web Site):ADObjectId) [Get-AutodiscoverVirtualDirect
       ory], IISNotReachableException
        + FullyQualifiedErrorId : CBD8E803,Microsoft.Exchange.Management.SystemConfigurationTasks.GetAutodiscoverVirtualDi
       rectory

    Name                                                Server                                  InternalUrl
    ----                                                   ------                                  -----------
    Autodiscover (Default Web Site)          currentexchserver

    KEY :

    oldexchserver - old exchange server

    currentexchserver - new exchange server

    Regards

    Yusuf Kamruddin

    Friday, April 13, 2012 2:10 PM
  • Hi ,

    Please try to autodiscover virtual directory and test.

    When you reset a virtual directory, the virtual directory is removed and a new virtual directory with default settings is created.

    NOTE: When you reset a virtual directory, the corrent settings will be lost.

    Reset Client Access Virtual Directories:

    http://technet.microsoft.com/en-us/library/ff629372.aspx


    Wendy Liu

    TechNet Community Support

    Wednesday, April 18, 2012 6:12 AM