none
Can't share custom folders under inbox in Outlook

    Question

  • Hello,

    For some reason unknown to me, we're having an issue sharing out personal folders in Outlook. My version is Outlook 2007 running on Exchange 2010 SP2. Some of our users have Outlook 2010. I'm one of the Admin's.

    Step 1.

    So I have a sub-folder under my inbox, I navigate by right-clicking the folder>Change Sharing Permission's>Permissions. I add the user that I would like to add to be able to view this custom folder. Click Apply>OK. Go to that user's Outlook profile>Mailbox. File>Open Other User's Folder. I browse for my name in the GAL, click OK and OK. But then unable to open it. I even tried granting full access to this folder to test and still unable.

    Step 2, I went into his Outlook Account Settings and added myself so that my mailbox shows up in his/her navigation pane which it does. Still unable to view the folder I shared. I will say that the share/hand icon does appear under the folder that I shared under my inbox.

    I will say that the folder properties>Administration Tab. All those options/fields are greyed out. I check Group Policy but can't find anything in there. Is this normal? I thought this might have something to do with it because there I see also the fields:

    This folder is available to:

    All users with access permission

    Owners only

    Both Greyed out as everything else on that page

    Any Thoughts?

    Thanks, I appreciate it.

    ~Skelleyman

    Thursday, March 15, 2012 3:08 PM

Answers

All replies

  • If you want to use the Account settings method, then you need to grant permissions at the top of the tree.

    http://exchange.sembee.info/outlook/sharing-non-default-folders.asp

    For sub folders you will need to grant at least "Folder Visible" down the tree until you get to the folder that you want them to see.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    • Proposed as answer by JanGroshan Tuesday, April 09, 2013 3:16 PM
    Thursday, March 15, 2012 4:26 PM
  • Thanks Sembee. The only thing I differently was changed to "Folder Visable" only. I went to User 2's Outlook/mailbox and still unable to open. You'll see in the attached pic the folder Barracuda has the hand/share symbol visual under it. I made sure in his Outlook account settings>Advanced that my mailbox was added. My mailbox does show up under his but doesn't open anything or the folder we're trying to share. I'm stumped.

    Friday, March 16, 2012 2:00 PM
  • Do you have folder visible enabled on the Inbox as well? From memory it has to be the complete tree. So top level, sub folder, sub sub folder etc.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.

    Sunday, March 18, 2012 2:56 PM
  • Hi,

    I would suggest you for granting any permission on mailbox folders to use the cmdlet below,

    Set-MailboxFolderPermission


    MCTS: Microsoft Exchange Server 2007/2010 | MCSA

    Sunday, March 18, 2012 3:20 PM
  •  

    Hi ,

    As Sembee said , if you are sharing any sub folder under Inbox or any other sub folder or custom folder created by users, than you also have to give the permission to the parent folder.

    You need to give the appropriate permission to inbox folder.


    Wendy Liu

    TechNet Community Support

    Wednesday, March 21, 2012 10:37 AM
    Moderator