none
Outlook 2007 keeps asking for username and password

    Question

  •  

    We have a new exchange 2007 SP1 server but occasionally the outlook clients will ask for the username and password.

     

    Is this a bug or does anyone have a fix?

    Monday, September 08, 2008 8:14 AM

All replies

  •  

     

    Hi,

     

    In order to clarify the current issue, please answer me the following questions:

     

    1. Does this issue happen on every users or some specific users?

    2. How Outlook connect to Exchange? RPC over Http or TCP/IP?

    3. What were you doing when the authentication window pop up? E.g. You’re visiting a public folder or something else.

     

    I await your reply.

     

    Thanks,

     

    Elvis

     

    • Proposed as answer by faisalmurichira Saturday, December 01, 2012 7:09 AM
    Wednesday, September 10, 2008 2:42 AM
  • Hi, I have the same problem:

    Exchange 2007 SP1
    Outlook 2007 + all updates

    Outlook setup using the auto discover.

    When user starts outlook, it ask for password. It connects, and then ask for the password again. It keeps asking for the password.

    Disabled Outlook over RCP/HTTP with no luck.

    Set authentication fron NTLM to Basic, with no luck. Created a new outlook profile, no luck.

    It doesn't happen for all users, only some. But, all users are set up the same. Using the same computer image.

    This is happening with several customers.
    Friday, December 05, 2008 9:00 AM
  •  I am having the same issue.  I have Exchange 2007 SP1 in a CCR environment.  We just applied Rollup 5 yesterday and now, when anyone in my organization attempts to connect through Outlook, they receive a login dialog.  It's odd because this dialog box is asking the user to authenticate through the Client Access Server and not to the Mailbox Server.

    Any thoughts would be greatly appreicated.

    Wednesday, January 28, 2009 2:51 PM
  • anybody find a fix for this?  My users are starting to get cranky.
    • Proposed as answer by Aiole Tuesday, September 10, 2013 7:34 PM
    • Unproposed as answer by Aiole Tuesday, September 10, 2013 7:34 PM
    Thursday, February 12, 2009 4:38 PM
  • Same issue here. Somebody have an answer to the problem?
    Tuesday, May 26, 2009 9:57 AM
  • Same issue except all Outlook 2007 clients always ask for passwords.  Started happening after upgrading the server (SBS2008) to SP2 two days ago.
    Friday, May 29, 2009 8:09 PM
  • Are you only using Exchange 2007 or do you have a combination of servers?
    Friday, May 29, 2009 8:36 PM
  • There is an old SBS2003 server with Exchange 2003 that is currently off.  It's been a month or so since it crashed and haven't gotten to taking it off AD and Exchange configuration yet.  However Outlook started asking for a passwords only in the last two days.

    All mailboxes, public folders were moved to Exchange 2007.
    Friday, May 29, 2009 8:41 PM
  • I am having the same issue.  Not all users just some.  Any resolutions yet?
    • Proposed as answer by still_waters Thursday, June 25, 2009 1:44 PM
    Tuesday, June 16, 2009 7:32 PM
  • If you have a domain controller sometimes exchange is very picky and it is not able to authenticate with the domain controller. I had this happen when my supervisor rebooted the exchange server first and then the domain controller. If you have this issue reboot your exchange server then once it is back up go into services and restart the information store services.
    • Proposed as answer by still_waters Thursday, June 25, 2009 1:49 PM
    Thursday, June 25, 2009 1:49 PM
  • I have rebooted all servers mutliple times.
    however I did notice that if I turn off RPC over HTTP it stops the prompting.
    Thursday, June 25, 2009 2:01 PM
  • Hi

    I'm having the same issue with a few of the users. These users are getting the prompt every few minutes. The dialog box asks the user to authenticate through the Client Access Server and not to the Mailbox Server.

    Thanks
    Monday, August 17, 2009 11:08 AM
  • For us it was a simple storing of old password in Vista. Now it asks just once for a username and password
    Friday, October 09, 2009 12:29 PM
  • I installed Exchange 2007 SP2 on Sunday, made no configuration changes and now also have the problem where some users repeatedly get a log-in box appearing asking them to authenticate against the Client Access Server.

    Even if they get the OS to remember the password they have entered after a period of time the box re-appears.

    Outlook 2007 isn't configured for Outlook Anywhere.  Manually downloading the OAB, opening OOF and checking availability all seem to work.

    I've run Connection Status and can only see Outlook communicating with the mailbox server, the DC(GC) and the Public Folder server.  Even when re-authenticating against CAS nothing seems to appear in this window.

    I've also run the Test Email Configuration and nothing looks untoward.

    Creating a new Outlook profile doesn't alleviate the problem.

    Does anyone have any further ideas?

    Many thanks,
    Tuesday, November 24, 2009 2:58 PM
  • I had similar issue with a test domain. I found that it was the Certificate i issued the mail server. If you dont use RCP over HTTPS then un-check it and this will go away. If you do use RCP then you will have to reissue the certificate to the clients. For some reason the update affects the certificate. Try this and let me know if this helps. I can get into more detail on the steps needed if this does help out.
    • Proposed as answer by RobGlide Tuesday, November 24, 2009 9:19 PM
    Tuesday, November 24, 2009 9:19 PM
  • There is an old SBS2003 server with Exchange 2003 that is currently off.  It's been a month or so since it crashed and haven't gotten to taking it off AD and Exchange configuration yet.  However Outlook started asking for a passwords only in the last two days.

    All mailboxes, public folders were moved to Exchange 2007.
    In my case, it is "MSExchangeMailboxAssistants" service that fails to start and I have yet to figure out why.
    Tuesday, November 24, 2009 11:50 PM
  • Hi Rob. I'm having the problem where all Outlook 2007 clients in the LAN are constantly asking for username and password (I've noticed that if I click cancel instead of entering username and password it goes on working fine). There are a few old computers with Outlook 2003 and those are working perfectly. It's something that started a few days ago, averything was fine untill then. I have absolutely no idea about certificates, could you give me an explanation on how to check if this is a certificate problem and how I can reissue or fix it? Thanks.
    • Proposed as answer by prejesh Thursday, April 07, 2011 2:40 PM
    Friday, December 11, 2009 11:20 PM
  • Ian:

    I'm having the exact same problem. I am running Windows 7, Outlook 2007 (Office 2007 pro) and I'm connecting to our Exchange Server 2007 which is part of Small Business Server 2008 (running in a virtual Hyper-V environment).

    Everything was fine until this last round of updates was installed and after reading this thread I know at least 1 other person is having the same problem. Namely; Outlook 2007 on a client keeps asking for the password to the remote access URL. If I simply click cancel it's OK for a few minutes. Entering the password and clicking the save PW box does no good. Sometimes clicking cancel results in another dilog box asking the same thing and I may have to click cancel several times to get it to go away for a while. Occasionally Outlook may actually go into a mode where it says it needs the password typed so I click the link which brings the dilog back but simply clicking cancel will make Outlook connect again.

    Possibly MY problem could be related to a problem with the Virtual Machine file for the server. I had to recreate the file but since the Virtual Hard Drive was OK there wasn't any problem rebooting the server. HOWEVER, since I had ro recreate the Hyper-V environment the server sawe a different Virtual NIC. I had to configure the NIC with the same IP as before etc...

    This all happened right around the time of the updates so I'm not sure of the actual cause being the updates, the NIC change or something else.

    Did you recently change a NIC on your server?

    Edwin
    Freehold Consulting
    Tuesday, December 15, 2009 12:40 AM
  • Edwin:
    I've not changed anything in the server's hardware. The only thing that changed between the days when everything worked fine and now is a few updates that were installed on the server, but they were SBS 2008 updates, not Exchange 2007.
    I've noticed that sometimes, instead of asking for username and pass, Outlook shows a warning about the Security Certificate not matching the server name and asking if you want to continue. If you continue you can work for about 10 or 20 minutes before it asks for user and pass again.
    It's not preventing the people in the company to do their job, but it is quite bothersome.
    Any help would be appreciated. (And keep in mind I'm a total rookie in servers)

    Thanks

    Ian
    Tuesday, December 15, 2009 2:56 PM
  • Ian,

    The easiest way to allow a security certificate is to open up the url that is used in the HTTP-RCP settings tab. example is https://mail.example.com

    Put this in Internet Explorer, it will prompt you and ask if you want to continue or not. The continue is the red one. Hit continue and when the page loads (it will load with no prompt for password) There will then be a certificate error next to the refresh click on this and view certificate Then you will need to install the certificate. Use the automatic settings to do this. Now when you close and open outlook this should only prompt you one time for password. This resolved my issue. I think an update messed with my security certificate. I am doing this by memory so sorry about the steps not being so defined. If i forgot a step ( i dont think i did as i did this for all 20 work stations) please let me know or Ian so he can get this working. Thanks


    Rob Glide
    Glide LLC
    rglide@hotmail.com
    • Proposed as answer by tonymoey Tuesday, April 17, 2012 9:56 AM
    Tuesday, December 15, 2009 8:44 PM
  • I have installed the cert but that shouldn't be necessary in my case because the server cert is signed by GoDaddy. I don't get any warning when accessing remote.myserver.com.

    Ian:

    Exchange is so interdependant on the AD system that it is very much possible that a security update could have very well caused it even though the update wasn't specifically to Exchange.

    I'm thinking that the problem IS related to the December updates. Hopefully more will chime in and Microsoft will take notice and investigate. There's probably a troubleshooting proceedure in Technet or the KB. Just need to find the time to go looking.

    Edwin
    Freehold Consulting
    Wednesday, December 16, 2009 7:43 AM
  • Hi Edwin,

    I have an SBS 2008 install with a similar problem.  Using a GoDaddy Cert.  Worked fine prior to me running an update to the server.  So I think we are getting some where here.

    Symptoms
    • Win Server 2008 (Or SBS 2008)
    • Exchange 2007
    • Outlook Anywhere Enabled (RPC-HTTP)
    • SSL Cert Signed by GoDaddy
    • Outlook 2007 Clients
    • Outlook 2007 Clients show Login prompt to the 'remote.example.com' cancel or disable keeps poping it up after some time.
    • RPC-DIAG shows no problems
    • Client not configured for RPC-HTTPs
    • Outlook 2003 Clients unaffected
    Things I have tried:
    • Basic  & Windows Authentication on the EWS Virtual Directory in IIS7 on Exchange 07 (SBS 08) box - No Joy
    • New Profile on Outlook 2007 win XP SP3 - No Joy
    • New Profile on Outlook 2003 win XP SP3 - Works, but rest of office running Outlook 2007
    • Disabling Outlook Anywhere  - No Joy
    • Visiting https://remote.example.com on affected Outlook 2007 win XP SP3 Machine - No Error Pages, or dialog boxes, Internet Explorer sees it as a valid Cert
    Any KB Articles, or notices?? I have two end-user with a possible third (Business owner) who are getting cranky. :(


    EDIT: Found a fix for me potentially via - http://social.technet.microsoft.com/Forums/en-US/exchangesvrdeploy/thread/c1e72d2a-d360-4ff0-b2f5-1a9ae149df18 and http://www.microsoft.com/communities/newsgroups/list/en-us/default.aspx?dg=microsoft.public.exchange.admin&mid=00d4a681-f588-4eed-b4f8-5c3645e7376c&sloc=en-us
    wcodycombs@gmail.com
    
     	I had an issue similar to this. Win2k3 Ex07. All of my Outlook 2007
    users were getting prompted over and over for the username and
    password. It wasn't checking the certificate that they had installed
    via internet explorer. To fix the problem, I opened IIS on the
    Exchange server and checked the following directories under the
    default website (the root site(default web site), oab, autodiscover).
    Under the directory security tab, click Edit in the Secure
    Communications section. I had the require SSL checked and the 128bit
    encryption, but under Client Certificates, it was set to ignore. Once
    I changed that to Accept for each of the folders, stopped and started
    IIS, I stopped being prompted all the time for credentials. Hopefully
    this will help someone in the future. 
    Just confirmed fixed for client!!!

    -IL
    • Edited by Longbow2 Wednesday, December 16, 2009 6:27 PM New Info
    • Proposed as answer by Andes4717072 Tuesday, December 22, 2009 4:18 PM
    Wednesday, December 16, 2009 6:06 PM

  •   I had an issue similar to this. Win2k3 Ex07. All of my Outlook 2007

    users were getting prompted over and over for the username and

    password. It wasn't checking the certificate that they had installed

    via internet explorer. To fix the problem, I opened IIS on the

    Exchange server and checked the following directories under the

    default website (the root site(default web site), oab, autodiscover).

    Under the directory security tab, click Edit in the Secure

    Communications section. I had the require SSL checked and the 128bit

    encryption, but under Client Certificates, it was set to ignore. Once

    I changed that to Accept for each of the folders, stopped and started

    IIS, I stopped being prompted all the time for credentials. Hopefully

    this will help someone in the future. Just confirmed fixed for client!!!

    -IL
    Joy Joy Joy!!!

    The last few days have been a nightmare of complaints. This month's update definately broke a perfectly working SBS 2008/Exchange 2007/Outlook 2007 authentication system, both over RPC and regular. Just keeps asking for password! Tried a million things just like the others, no joy. Went into IIS Manager, opened SBS Web Applications, Select Autodiscover, double click SSL settings (you have to scroll down to see it), check Accept instead of ignore or require, and Apply. I repeated for owa, remote, Rpc, RpcWithCert (possibly don't have to do all these). Restarted Web Publishing and Joy Joy Joy!!!

    Thank you Longbow2!

    - MikeBTexas
    Thursday, December 17, 2009 7:34 PM
  • Hey.

    Thanks a lot - worked for me !!! And I tried (almost) ANYTHING !!!!

    Regards Anders
    Tuesday, December 22, 2009 4:19 PM
  • Thanks a lot. It worked quite nicely (at least for now).

    Regards.

    Ian.
    Tuesday, December 22, 2009 10:17 PM
  • Thanks to all you gentlemen....  You were dead on. I had the exact same issues....  Using SBS2008 with the integral Exchange 2007. All my clients, whether inside my firewall or outside, kept prompting for creds.  Your solution seems to have solved my issues. All I did was go into my IIS, change the OAB and Autodiscover sites to accept credentials in SSL, and "Voila!", it seems to start working again. Now all I need do is test this with my new MacBook Air after Christmas Day....  That will be my present to myself, and it is all wrapped up, so I can't check it until after Santa gives it to me....  ;)

    Thanks a million.

    Rick
    Thursday, December 24, 2009 12:23 AM
  • I applied the settings above and after several days I'm happy to report that I have had absolutely NO popups asking for a un/pw.

    Thanks everybody.

    Edwin
    Freehold Consulting
    Monday, December 28, 2009 10:56 PM
  • Just so you know, changing Autodiscover on my SBS 2008 server to accept client certificate has made autodiscover stop working for Outlook 2007 internal/external clients because it wants to provide client certificate.

    I have resolved the problem by changing the other directories as mentioned, and leaving Autodiscover on ignore.

    Cheers,
    Ross

    (Though, Out of Office Assistant is failing to work from within Outlook 2007, will keep working on this.. may be related to Autodiscover but seems unlikely. I have applied the .NET Framework 2.0 hotfix 952883 (http://support.microsoft.com/kb/952883) for System.xml.dll to rectify the parameter problem that was plaguing some people earlier in the year, but this has not fixed anything and I doubt it was the root cause of it not working regardless.)

    -- Edit -- FIX To OOFA not working. The EWS directory cannot be set to accept client certificates else out of office assistant does not work in Outlook 2007 clients internally and externally. By changing the Virtual Directories named "Autodiscover" and "EWS" as listed under SBS Web Applications in IIS7 Manager to "Ignore" Client Certificates in SSL settings, two problems have been resolved that were created by implementing the above listed changes for fixing the recurrent prompting of username/password. Namely, Autodiscover works again, and Out of Office Assistant as well.

    Microsoft really dropped the ball on that patch! I have had no shortage of problems since I rebooted to complete installation on the 23rd.

    Under SBS web apps, I changed them all to accept client certificate (that didn't already have require and had SSL ticked), and now I have changed Autodiscover and EWS back to ignore. Everything seems to be hunky dory finally!
    Monday, January 04, 2010 8:30 AM
  • Rick,

    1. Get the internet connected and on the VPN
    2. Make Sure Outlook is close
    3. Then go to start/settings/Control Panel
    4. Double Click on Mail/Then E-mail accounts
    5. On the email tab highlight your username(Exp. sachin@msft.com) and hit Change
    6. Then Click on More Settings/Connection/Exchange Proxy Settings
    7. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the msstd:webmail.covad.com box will go grey.
    8. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    9. Open Outlook and Put in Domain\(Your username) and password.
    Put check Mark on remember my password.
    I am sure this will resolve the above issue.
    Have a good day, Sachin Shetty| MCP|MCTS|MCITP|
    Monday, January 04, 2010 10:05 AM
  • Mike,

    1. Get the internet connected and on the VPN
    2. Make Sure Outlook is close
    3. Then go to start/settings/Control Panel
    4. Double Click on Mail/Then E-mail accounts
    5. On the email tab highlight your username(Exp. sachin@msft.com) and hit Change
    6. Then Click on More Settings/Connection/Exchange Proxy Settings
    7. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the msstd:webmail.covad.com box will go grey.
    8. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    9. Open Outlook and Put in Domain\(Your username) and password.
    Put check Mark on remember my password.
    I am sure this will resolve the above issue.
    Have a good day, Sachin Shetty| MCP|MCTS|MCITP|
    Monday, January 04, 2010 10:06 AM
  • Hello,

    1. Get the internet connected and on the VPN
    2. Make Sure Outlook is close
    3. Then go to start/settings/Control Panel
    4. Double Click on Mail/Then E-mail accounts
    5. On the email tab highlight your username(Exp. sachin@msft.com) and hit Change
    6. Then Click on More Settings/Connection/Exchange Proxy Settings
    7. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the msstd:webmail.covad.com box will go grey.
    8. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    9. Open Outlook and Put in Domain\(Your username) and password.
    Put check Mark on remember my password.
    I am sure this will resolve the above issue.
    Have a good day, Sachin Shetty| MCP|MCTS|MCITP|
    Monday, January 04, 2010 10:07 AM
  • Ian,

    1. Get the internet connected and on the VPN
    2. Make Sure Outlook is close
    3. Then go to start/settings/Control Panel
    4. Double Click on Mail/Then E-mail accounts
    5. On the email tab highlight your username(Exp. sachin@msft.com) and hit Change
    6. Then Click on More Settings/Connection/Exchange Proxy Settings
    7. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the msstd:webmail.covad.com box will go grey.
    8. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    9. Open Outlook and Put in Domain\(Your username) and password.
    Put check Mark on remember my password.
    I am sure this will resolve the above issue.
    Have a good day, Sachin Shetty| MCP|MCTS|MCITP|
    Monday, January 04, 2010 10:08 AM
  • Hi DJ,

    1. Get the internet connected and on the VPN
    2. Make Sure Outlook is close
    3. Then go to start/settings/Control Panel
    4. Double Click on Mail/Then E-mail accounts
    5. On the email tab highlight your username(Exp. sachin@msft.com) and hit Change
    6. Then Click on More Settings/Connection/Exchange Proxy Settings
    7. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the msstd:webmail.covad.com box will go grey.
    8. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    9. Open Outlook and Put in Domain\(Your username) and password.
    Put check Mark on remember my password.
    I am sure this will resolve the above issue.
    Have a good day, Sachin Shetty| MCP|MCTS|MCITP|
    Monday, January 04, 2010 10:09 AM
  • Great! Thank you!
    I had the same problem until this post ;)
    Monday, January 11, 2010 1:29 AM
  • Hi DJ,

    1. Get the internet connected and on the VPN
    2. Make Sure Outlook is close
    3. Then go to start/settings/Control Panel
    4. Double Click on Mail/Then E-mail accounts
    5. On the email tab highlight your username(Exp. sachin@msft.com) and hit Change
    6. Then Click on More Settings/Connection/Exchange Proxy Settings
    7. Then unclick the “Only connect to proxy servers that have this principal name in their certificate” the msstd:webmail.covad.com box will go grey.
    8. Then hit OK/Then Apply/Then OK/Then Cancel/Then Close/Then Close
    9. Open Outlook and Put in Domain\(Your username) and password.
    Put check Mark on remember my password.
    I am sure this will resolve the above issue.
    Have a good day, Sachin Shetty| MCP|MCTS|MCITP|

    Doesn't work for me. Also, I need these settings on my laptop.

    This is a server problem not an outlook problem.

    Edwin
    Freehold Consulting
    Thursday, January 14, 2010 6:52 AM
  • I've got the exact same problem after updating, sbs2008, exchange 2007 sp1, and outlook 2007 clients only.

    I've tried the above steps, when i set the auto discover to allow, the username and password prompt problem goes away, but then the out of office assistant then stops working. When I change it back, out of office assistant starts working, but then the user name prompts appear. I've got the EWS set to ignore as suggested above by Ross C. Is there something else I’m missing?

    Cheers

    Tuesday, January 19, 2010 6:16 AM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM

    Same problem here after restarting SBS 2008 for upgrades (annoying login box popping up after starting Outlook and also other times).

    This solved the problem for me:

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings:

    Autodiscover: Ignore
    EWS: Ignore
    OAB: Accept *)
    owa: Accept *)
    Rpc: Accept *)
    RpcWithCert: Accept *)

    *) All these have to be Accept to get rid of login box

    Best regards
    Bjorn

    • Proposed as answer by szybki_filozof Thursday, January 21, 2010 3:52 AM
    Wednesday, January 20, 2010 10:00 PM
  • I solved my problem by upgrading to Exchange 2007 SP2.

    http://www.microsoft.com/downloads/details.aspx?FamilyID=ffd2fe61-9278-489e-9b96-3816394c9cb6&displayLang=en

    Edwin


    Freehold Consulting
    Thursday, January 21, 2010 4:00 AM
  • The problem related to MS Small Business Server 2008 is discussed here also:

    https://connect.microsoft.com/sbs08/community/discussion/richui/default.aspx


    news.microsoft.com/microsoft.public.backoffice.smallbiz

    Seems like Rollup 9 may be another fix. I will try it later.

    Best regards
    Bjorn
    Thursday, January 21, 2010 12:12 PM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM:

    Update Rollup 9 for Exchange Server 2007 Service Pack 1 fixed it also.

    Installed Rollup 9 and re-entered default settings in IIS (IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates ).

    Works!

    Best regards
    Bjorn
    • Proposed as answer by RobGlide Wednesday, February 10, 2010 6:51 PM
    Saturday, January 23, 2010 9:16 PM
  • Help Please.  I am having the same problem with outlook 2007.  It got to the point where it would never log me in and I had to delete the accounts and start over.  Then after a few hours its starts up again.  This is the same old problem I had with my old laptop and Outlook 2003.  After searching and searching Microsoft said too bad.  This is a flaw and there's nothing they can do about it.  This is happing to a lot of people.  Also happens on my POP accounts.  Someone please help as Microsoft doesn't give a damn.  Rich
    Thursday, February 11, 2010 2:24 AM
  • Hi guys, i have been struggling with this issue myself and i have tried all the options on this page and none of them seem to fix the issue.

    im getting both issues
    keeps prompting for credentials.
    and OOF does not work
    Auto discover also not working.

    outlook upgraded to sp1
    exchange 2007

    Thursday, February 11, 2010 5:10 PM
  • Have you tried this?


    Tom

    Monday, February 15, 2010 3:28 PM
  • Thanks a lot! That solved this irritating problem!
    Monday, February 15, 2010 10:51 PM

  •   I had an issue similar to this. Win2k3 Ex07. All of my Outlook 2007

    users were getting prompted over and over for the username and

    password. It wasn't checking the certificate that they had installed

    via internet explorer. To fix the problem, I opened IIS on the

    Exchange server and checked the following directories under the

    default website (the root site(default web site), oab, autodiscover).

    Under the directory security tab, click Edit in the Secure

    Communications section. I had the require SSL checked and the 128bit

    encryption, but under Client Certificates, it was set to ignore. Once

    I changed that to Accept for each of the folders, stopped and started

    IIS, I stopped being prompted all the time for credentials. Hopefully

    this will help someone in the future. Just confirmed fixed for client!!!

    -IL
    Joy Joy Joy!!!

    The last few days have been a nightmare of complaints. This month's update definately broke a perfectly working SBS 2008/Exchange 2007/Outlook 2007 authentication system, both over RPC and regular. Just keeps asking for password! Tried a million things just like the others, no joy. Went into IIS Manager, opened SBS Web Applications, Select Autodiscover, double click SSL settings (you have to scroll down to see it), check Accept instead of ignore or require, and Apply. I repeated for owa, remote, Rpc, RpcWithCert (possibly don't have to do all these). Restarted Web Publishing and Joy Joy Joy!!!

    Thank you Longbow2!

    - MikeBTexas


    Thanks guys!!

    Awesome fix! worked for me!!

    Thursday, April 01, 2010 1:28 AM
  • "Went into IIS Manager, opened SBS Web Applications, Select Autodiscover, double click SSL settings (you have to scroll down to see it), check Accept instead of ignore or require, and Apply."

     

    Did this on just that folder, fixed the problem. Thanks!

    Tuesday, May 04, 2010 1:51 PM
  • God Bless you JerSea

    This has worked for me!

    This Post was make on the Wednesday, January 20, 2010 10:00 PM

    http://social.technet.microsoft.com/Forums/en-US/exchangesvrgeneral/thread/383d130e-869f-4fce-9502-8b340904b0ba

    Thank you JerSea

    This solved the probklem for me:

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings:

    Autodiscover: Ignore
    EWS: Ignore
    OAB: Accept *)
    owa: Accept *)
    Rpc: Accept *)
    RpcWithCert: Accept *)

    *) All these have to be Accept to get rid of login box

    Thanks again Troy

    Sunday, May 09, 2010 5:02 AM
  • Dear All,

    I have the same problem. I'm using all windows 2008 server as:

    - Windows server 2008 standard as ADDS

    - Windows Server 2008 Enterprise with Exchnage Server 2007 as Hub and CAS

    - 2 Windows Server 2008 Enterprise with Exchange Server 2007  cluster (CCR)

    - Most of Clients 90% running with Windows XP SP3 with Microsoft Outlook 2007

    When user starts outlook, it ask for password. It connects, and then ask for the password again. It keeps asking for the password.

    Do you have any solution to help me?

    Khemarin

    Monday, June 07, 2010 8:01 AM
  • Well I have come accross this now twice and what I have done to fix the problem is as follows:

    for domain connected

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings: 

    Autodiscover: Ignore 
    EWS: Ignore 
    OAB: Accept *) 
    owa: Accept *) 
    Rpc: Accept *) 
    RpcWithCert: Accept *) 

    *) All these have to be Accept to get rid of login box

    For Exchange over HTTP I always have to do the following.

    In Windows on the client computer where I have outlook installed I have to open Network credentials manager and add a key for server\username with their network password.

     

    for some reason when using http exchange it wants to authenticate with the CAS server.

    Monday, June 07, 2010 1:56 PM
  • Dear All,

    I have the same problem. I'm using all windows 2008 server as:

    - Windows server 2008 standard as ADDS

    - Windows Server 2008 Enterprise with Exchnage Server 2007 as Hub and CAS

    - 2 Windows Server 2008 Enterprise with Exchange Server 2007  cluster (CCR)

    - Most of Clients 90% running with Windows XP SP3 with Microsoft Outlook 2007

    When user starts outlook, it ask for password. It connects, and then ask for the password again. It keeps asking for the password.

    Do you have any solution to help me?

    Khemarin

    • Proposed as answer by jimmyg50 Tuesday, June 15, 2010 2:04 PM
    Tuesday, June 08, 2010 1:11 AM
  • All the answeres (Actually, I skipped over about 1/4 of them towards the end) were of no use to me. 

    I googled some more & THIS finally worked:

    1: Open Windows explorer.  copy this into the address bar:   %userprofile%\AppData\Roaming\Microsoft\Protect  

    2. Rename the S-1-5-21- ... folder by adding "OLD" to the end.

    3.Re-open Outlook, and re-type you password and confirm that box.  A new filder S-1-5-21.... will appear with the corrected, non-corrupt information.

    4. Problem should be fixed.   It worked great for me & was really simple.  Thanks to "How-to Geek"

    Tuesday, June 15, 2010 2:11 PM
  • I have yet another way around this.

    If you find an error in the eventviewer. telling you that search can't access mapi:{S-1-1...}, then you should recreate the search indexes in the controlpanel.

    This solved the issue for me.

     

    Wednesday, June 30, 2010 10:55 AM
  • Joy Joy Joy!!!

    The last few days have been a nightmare of complaints. This month's update definately broke a perfectly working SBS 2008/Exchange 2007/Outlook 2007 authentication system, both over RPC and regular. Just keeps asking for password! Tried a million things just like the others, no joy. Went into IIS Manager, opened SBS Web Applications, Select Autodiscover, double click SSL settings (you have to scroll down to see it), check Accept instead of ignore or require, and Apply. I repeated for owa, remote, Rpc, RpcWithCert (possibly don't have to do all these). Restarted Web Publishing and Joy Joy Joy!!!

    Thank you Longbow2!

    - MikeBTexas
    I was dubious to try this fix, as I couldnt see the relevance to if I wasnt using RPC over HTTP, however it fixed it,, Thanks, This was a brand new SBS buid and a Brand new desktop testing against it,, if I wasnt nald already i would have been pulling my hair out :-) Thanks
    Friday, July 23, 2010 8:41 PM
  • Same SBS 2080 / Outlook 2010 on a TS  , probably worked for me too ! ( need to check the PC's in the morning )

    How did you get to IIS / SSL  ??? Would have never crossed my mind to look there.

    Wednesday, July 28, 2010 7:25 PM
  • All the answeres (Actually, I skipped over about 1/4 of them towards the end) were of no use to me. 

    I googled some more & THIS finally worked:

    1: Open Windows explorer.  copy this into the address bar:   %userprofile%\AppData\Roaming\Microsoft\Protect  

    2. Rename the S-1-5-21- ... folder by adding "OLD" to the end.

    3.Re-open Outlook, and re-type you password and confirm that box.  A new filder S-1-5-21.... will appear with the corrected, non-corrupt information.

    4. Problem should be fixed.   It worked great for me & was really simple.  Thanks to "How-to Geek"

    Didn’t work for me, but in the ‘Protect’ folder there is a file called ‘CREDHIST’ which is a backup of credentials. I deleted the whole ‘Protect’ folder, opened Outlook and entered my password, ticked the ‘remember’ box and now my password is saved.

    Thursday, August 05, 2010 8:28 AM
  • All other users in the company could access mails etc. so there was no problem there. I could ping the server from every machine and resolve it by name. so no problem there. Outlook kept asking for username password again and again. It was behind sonicwall but then its just a VPN connection. The only changes that i did after researching on the problem was Went to Accounts Settings-> Change -> More Settings -> Security -> Logon network security-> Password Authenticaion NTLM That solved the whole problem. - - Never Jump to conclusion----
    Saturday, August 07, 2010 10:04 AM
  • On our newtork the issue seemed be caused by delay in communication between exchange and outlook.  The issue was resolved by unchecking the "Encrypt data between Microsoft Outlook and Microsoft Exchange.  In Outook go to File-> Accounts Settings-> Change -> More Settings -> Security->uncheck the above.

    Tuesday, January 04, 2011 5:54 PM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM

    Same problem here after restarting SBS 2008 for upgrades (annoying login box popping up after starting Outlook and also other times).

    This solved the problem for me:

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings:

    Autodiscover: Ignore
    EWS: Ignore
    OAB: Accept *)
    owa: Accept *)
    Rpc: Accept *)
    RpcWithCert: Accept *)

    *) All these have to be Accept to get rid of login box

    Best regards
    Bjorn

    Awesome. This worked for me. Thanks!
    • Proposed as answer by rn701 Thursday, January 13, 2011 5:50 PM
    Thursday, January 13, 2011 5:43 PM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM:

    Update Rollup 9 for Exchange Server 2007 Service Pack 1 fixed it also.

    Installed Rollup 9 and re-entered default settings in IIS (IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates ).

    Works!

    Best regards
    Bjorn


    Also worked for me too guys. Thanks :)

    My Setup - 1 x SBS2008, 50 Clients, Outlook 2007 Pro, Exchange 2007 SP1, all SSL and Auth Default, OWA was still working perfect before the problem, as do Outlook 2003 Clients still pre-patch/fix (90% clients Windows 7, 10% XP)

    • Edited by Sense Telecom Tuesday, January 18, 2011 8:36 PM adding details
    Tuesday, January 18, 2011 8:34 PM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM

    Same problem here after restarting SBS 2008 for upgrades (annoying login box popping up after starting Outlook and also other times).

    This solved the problem for me:

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings:

    Autodiscover: Ignore
    EWS: Ignore
    OAB: Accept *)
    owa: Accept *)
    Rpc: Accept *)
    RpcWithCert: Accept *)

    *) All these have to be Accept to get rid of login box

    Best regards
    Bjorn

    We had this problem after installing some SBS2K8 updates last week  After trying multiple suggestions, applying SP3 on Exch2K7 we tried this solution and it worked! 

    Thank you for your help.

    D

    Wednesday, January 19, 2011 10:41 PM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM

    Same problem here after restarting SBS 2008 for upgrades (annoying login box popping up after starting Outlook and also other times).

    This solved the problem for me:

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings:

    Autodiscover: Ignore
    EWS: Ignore
    OAB: Accept *)
    owa: Accept *)
    Rpc: Accept *)
    RpcWithCert: Accept *)

    *) All these have to be Accept to get rid of login box

    Best regards
    Bjorn

    We had this problem after installing some SBS2K8 updates last week  After trying multiple suggestions, applying SP3 on Exch2K7 we tried this solution and it worked! 

    Thank you for your help.

    D

    Worked on the password error but it made Outlook over http from extern computers not connect annymore. Strange is that outlook over http from computers on internal lan still works as they should.

    I tried this before the weekend and when i return at work today i also can see the Windows server backup also has halted. 

    I changed back all the SSL settings and removed the update KB2412171 for Outlook. and that did the trick.

     

    Monday, January 31, 2011 8:25 AM
  • This seemed to work for me and my SBS 2008/Exchange 2007 is on SP3. Thanks!!!
    MCP SBSC
    Wednesday, February 02, 2011 12:32 AM
  • I was pretty happy with the fix of changing the SSL stuff and then i too realized that outlook anywhere was broken. I removed the patch from an offending pc and set the iis perms to the state that a new exch10 server had them but wanted to verify the default perms on the exch07 directories if someone has one that back to "default". Thanks in advance.
    Tuesday, February 15, 2011 9:54 PM
  • Outlook 2007 Credential Prompts in Small Business Server 2008 - The Official SBS Blog - Site Home - TechNet Blogs:
    http://blogs.technet.com/b/sbs/archive/2010/02/16/outlook-2007-credential-prompts-in-small-business-server-2008.aspx
    Wednesday, February 23, 2011 10:45 PM
  •  

     

    Hi,

     

    In order to clarify the current issue, please answer me the following questions:

     

    1. Does this issue happen on every users or some specific users?

    2. How Outlook connect to Exchange? RPC over Http or TCP/IP?

    3. What were you doing when the authentication window pop up? E.g. You’re visiting a public folder or something else.

     

    I await your reply.

     

    Thanks,

     

    Elvis

     


    I am the only user of this pc.How do i check outlook is connected to the exchanve.I thinm its wireless.I just booted up from last night.
    Friday, February 25, 2011 5:52 PM
  • One more thing to try. I noticed that when Outlook kept prompting for a password I was finding 401 errors in my IIS log files with the client of BITS requesting the address book via /OAB. So, I enabled Anonymous Auth for that direcotry in IIS and granted everyone Full Controll on the physical directory. That seems to have enabled my Outlook 2010 client to be able to download the offline address book. As an alternative you could always remove the Download Address Book from the Send/Receive Group settings so that Outlook doesn't try to sync the address book all the time.

    Thursday, March 03, 2011 7:13 PM
  • I have a client who has the same problem.   They have applied this fix but now complain of exactly the same with rpc over http not working.  they also cleverly did not write down the original ssl settings for the directories that changed.

    Can you please list what the default settings are before change so that I can take them back to step one as I cannot find them anywhere.

    Cheers

    M

    Tuesday, March 22, 2011 1:35 PM
  • There are a couple of reasons why this could be happening, I have outlined them in my blog post here: http://demazter.wordpress.com/2010/02/09/outlook-continually-prompting-for-username-and-password-2/

    Another potential cause is the authentication setting used on Outlook & exchange, if they do not match then the same problem will be caused when using RPC-HTTPS or Outlook Anywhere, see my blog post here: http://demazter.wordpress.com/2010/11/09/outlook-prompting-for-username-and-password-when-using-exchange-2010/

    Whilst a 3rd part SSL Certificate is not a requirement, it can save a lot of problems when using RPC-HTTPS, and for the sake of $89 for a signed certificate from http://www.exchangecertificates.com is it really worth the hassle?

     


    demazter

    http://demazter.wordpress.com
    http://www.demazter.co.uk

    Monday, March 28, 2011 7:32 AM
  • Go to your account setting, select the account where the problem exists and use the option 'change', 'Go to connection tab' and select 'Exchange Proxy settigs' then change the 'Proxy Authenticationation Settings' to 'Basic Authentication'
    Saturday, April 09, 2011 4:12 AM
  • Hi,

    We have an Exchange 2010 (SP1 rollup 3v3) environment with 2 CAS/HUB with NLB and 2 MAILBOX with DAG enabled.

    Only some users were having this issue. All of them have Windows 7, but not all Windows 7 users were having this...

    I though it should be something related to OAB or Outlook Anywhere. Prompt for credentials appeared only when using cached mode.

    After confirming NTLM were configured on both sides (CAS and Outlook), I finally found a solution for this:

    http://support.microsoft.com/kb/956531/en-us

    Although Office SP2 was installed on the computers showing this annoying prompt, I appied the "Fix it for me" session of this article and BUM! Problem solved.

    After digging further I found that setting UseWindowsUserCredentials value to 1 is just what you need.

    I hope that helps...

     

     

     

     

     

     

    Wednesday, June 22, 2011 4:28 PM
  • Hyper-V / SBS 2008 - Exch 2007 VM / Win 7 - Outlook 2007 VM

    Same problem here after restarting SBS 2008 for upgrades (annoying login box popping up after starting Outlook and also other times).

    This solved the problem for me:

    IIS Mgr on SBS 2008 / - / SBS Web Applications /
    - SSL Settings / Client certificates - Stop / Start web server after changing settings:

    Autodiscover: Ignore
    EWS: Ignore
    OAB: Accept *)
    owa: Accept *)
    Rpc: Accept *)
    RpcWithCert: Accept *)

    *) All these have to be Accept to get rid of login box

    Best regards
    Bjorn

     

    It works! Thank you so much!

    Friday, September 16, 2011 9:37 AM
  • In my experience these pop ups are always related to issue with the network or iis settings.

    when i ran into this issue, it was an issue with the F5 load balancer. f5 had a feature called oneConnect profile. i had to turn that off to get this working.


    Z-Hire -- Automate IT Account creation process ( AD / Exchange / Lync )
    Z-Term -- Automate IT account termination process ( AD / Exchange )
    Friday, September 16, 2011 3:48 PM
  • Ok, I just recently came across an ANNOYING situation involving outlook 2007 and exchange 2010. I thought I would post here in case anyone else had this issue!

    We recently experience outlook prompting us for login boxes... We restarted the computers and then outlook could not start at all, throwing off a message about not connecting to mail folders... I spent 5 hours on this issue and could not figure out why!

    To make a VERY LONG STORY short, be sure to check the services running on the server. Sort them by start type (automatic, manual, etc.) and make sure that all the automatic services are running, especially in exchange! The issue turned out being the "Microsoft Exchange RCP Client Access" service not running!

    Hope this helps a fellow tech guy out there!

    Joe Cap

    • Proposed as answer by Bobobot Monday, April 02, 2012 10:00 AM
    Thursday, September 22, 2011 5:45 PM
  • Ok, I just recently came across an ANNOYING situation involving outlook 2007 and exchange 2010. I thought I would post here in case anyone else had this issue!

    We recently experience outlook prompting us for login boxes... We restarted the computers and then outlook could not start at all, throwing off a message about not connecting to mail folders... I spent 5 hours on this issue and could not figure out why!

    To make a VERY LONG STORY short, be sure to check the services running on the server. Sort them by start type (automatic, manual, etc.) and make sure that all the automatic services are running, especially in exchange! The issue turned out being the "Microsoft Exchange RCP Client Access" service not running!

    Hope this helps a fellow tech guy out there!

    Joe Cap


    I wish Microsoft had better way to handling these credentials pop ups. Now that we've deployed Lync, we get credential pop up whenever we sign on the client. To endusers, this make it seems like application is broken!!!!


    Z-Hire -- Automate IT Account creation process ( AD / Exchange / Lync )
    Z-Term -- Automate IT account termination process ( AD / Exchange )
    Friday, September 23, 2011 1:13 AM
  • I replaced quotation marks (") by hash signs (#) in my password - it helped in my case - maybe quotation marks were misundertood (deleted) first, but when username/password were asked again, they weren't deleted.

    JR

    Friday, December 02, 2011 10:39 AM
  • Its very simple....

     

    Open Outlook

    Go to Tools --> Options

    Inside Options --> Click on Mail SetUp --> click on Send/Receive

    A new pop up window opens

    Double click on All accounts --> one more window is opened.

    Inside this new window all the mail accounts appears. Please select the desired one and tick on remember password and give your password.

    Thats It.

     

    NOTE: Remember password checkbox is disabled when you try to open this from Account Settings.

    Thursday, December 22, 2011 6:30 AM
  • 5 hours is just a tiny fraction on the time of spent trying to solve this problem. This was my first SBS2011 migration and all went GREAT except for this problem. I learned a LOT about certificates and authentication Including how to use the Exhange Power Shell to run diagnostics and change settings. I've literally lost sleep over this problem. I've been up all night troubleshooting and trying EVERYTHING I've found related to this issue and trust me, there's plenty of material out there addressing this problem and many others that sound exactly the same. All of that for a silly service startup issue. Well, thank you for taking the time to post that Joe! No way of telling how many more hours of impatient end users you saved me from. Thanks again.

    Nathan

    Monday, April 02, 2012 11:29 AM
  • The exact same thing happened to all my clients who had Outlook 2007 newly installed and i followed your recommendation and it worked!!! Thanks!

    Tuesday, April 17, 2012 9:57 AM
  • Just found a new reason that this might be happening.

    Check out Microsoft article http://technet.microsoft.com/en-us/library/a15f34b1-a7bf-4f44-9142-0c5c3174cb0f.aspx which is called "Mutual AUthentication Established by Subject Alternative Name"

    Basically it says, if you are running XP or Vista before SP1, Office 2007 will not look down the Certificate to the Subject Alternative Names for the msstd: string match, even if the name is further down in the cert.

    To fix this, you have to upgrade the OS to Vista SP1 or later, or make sure that the Outlook Anywhere url is listed as the primary name in the UC certificate. When it is not, the connection will fail, even though it works on Windows 7 boxes. Most windows 7 is not running Office 2007, so it is natural to think it is an office issue, but it is a certificate issue with the Operating Systems.

    • Proposed as answer by sunnylowe Thursday, July 12, 2012 8:21 PM
    Thursday, July 12, 2012 8:21 PM
  • Hello and Salutations,

    I can't believe this thread has gone on this long!!!!!

    Basically your network admin needs to restart the MSInformationStore service on the Exchange Server because for some reason or another, it did not start properly when they rebooted the Exchange Server last. This has been an issue since Exchange 2003.... 2007 and Outlook 2007 or 2010 did not introduce this problem.

    Net Stop MSExchangeIS

    Net Start MSExchangeIS

    My Exchange Server stopped doing this when I set the Information Store on "Delayed Start" in the Services.msc Management Console.

    If this is the SSL issue and AutoDiscover issue... the only fix I've ever come across successful is to delete the user profile and start over... It would not fix otherwise.

    Toodles =)


    Steve Kline
    Microsoft Certified IT Professional: Server Administrator
    Microsoft Certified Technology Specialist: Active Directory, Network Infrastructure, Application Platform, Windows 7
    Microsoft Certified Product Specialist & Network Product Specialist
    Red Hat Certified System Administrator
    Microsoft® Community Contributor Award 2011
    This posting is "as is" without warranties and confers no rights.


    Tuesday, July 24, 2012 8:16 PM
  • There are a lot of good suggestions here.  One other thing for people to check is this:  Make sure there isn't another app or device trying to log in to that same account.  Ran into this problem some time ago, tried many of the suggestions already mentioned here with no luck.  It turned out the user was synching his phone to the exchange account.  The phone had the wrong password, but since it kept trying over and over, it would lock the account, which cause outlook to pop up the authentication window.  The user was still able to work, as long as he didn't lock the workstation or logout, that window wouldn't go away.

    Once we fixed his phone, no more problems.

    Just something else to check

    Friday, September 14, 2012 5:19 PM
  • I have had the same issue. Ingram link is the way to go: http://itswapshop.com/tutorial/how-fix-outlook-2007-keeps-prompting-username-password-when-using-outlook-anywhere

    http://www.hotfixcomputers.com.au

    Saturday, September 15, 2012 12:45 PM
  • i forgot my outlook username,how to get it

    Wednesday, December 12, 2012 7:26 AM
  • i forgot my outlook username,how to get it

    Open control panel>Mail>Email Accounts.

    Or if you're setting up on a new machine and don't remember your account then ask your system admin

    Wednesday, December 12, 2012 10:10 AM
  • Worked!

    You rock!!!

    Friday, March 08, 2013 1:59 PM
  • I've tried EVERYTHING on here but am still getting that stupid 'connect to sites' popup. I'm using SBS2008 and Exchange 2007. All client PCs are affected. I'm trying a scheduled task to do an iisreset every 15 minutes but I don't even know if that will work. Was it updates that caused this? And if so, can't I just remove them?
    Monday, July 15, 2013 2:45 PM
  • I'm having the same problem as above.  Tried the hotfix 956531 but it didn't work.  This problem seemed to coincide with the start of the new Office 365 mail setup but I don't know if that is related or is a coincidence.

    Wednesday, July 31, 2013 6:33 AM
  • Check the Exchange Server name the password prompt is trying to connect to vs the actual Exchange Server for Mail. In my case it was trying to connect to a Sharepoint Server. The user had a connection to Sharepoint for which she didn't know the password. I removed the Sharepoint connection and the pop-ups stopped. 

    Tuesday, September 10, 2013 7:36 PM
  • i have same use but with exchange 2010.

    install service pack 3 for office 2007 work for me...


    Systems Support Engineer

    Tuesday, December 31, 2013 7:51 AM
  • I also resolved this issue by using a Service Pack. I used Service Pack 3. Probably should have installed the latest service pack as part of the server install anyway.
    Sunday, February 09, 2014 12:44 PM