none
your automatic reply settings cannot be displayed because the server is unavailable

    Question

  • I have outlook connected to a TMG server that sits in my DMZ that proxies to my hub transport.  All email flows jsut as it should.   From my phone and OWA i can change my out of office just fine.  When i go to change it from inside of Outlook when i am remote I get the message in my title.  When i run the Test-Email auto config from the right click of the outlook icon i get the following.  

     

    Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml starting

    Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml failed (0x800C8203)

    Autodiscover to https://autodiscover.mydomain.com/autodiscover/autodiscover.xml starting

    Autodiscover request completed with http status code 403

     

    Autodiscover to https://autodiscover.mydomain.com/autodiscover/autodiscover.xml failed (0x80004005)

    local autodiscover for mydomain.com starting

    local autodiscover failed

    srv record lookup for https://autodiscover.mydomain.com/autodiscover/autodiscover.xml failed (0x80004005)

    srv record lookup for mydomain.com starting

    autodiscover url redirection to https://webmail.mydomain.com/autodiscover/autodiscover.xml 

    autodiscover to https://webmail.mydomain.com/autodiscover/autodiscover.xml succeeded

    srv record lookup for mydomain.com succeeded

    Friday, May 06, 2011 4:42 AM

Answers

  • By setting the external OOF and making the change to TMG to accept that new url it has started to work.  Thanks everyone for the help.  
    • Marked as answer by KirkSH Friday, May 13, 2011 7:01 PM
    Friday, May 13, 2011 7:00 PM

All replies

  • Check in DNS and see if you have HOST record of AutoDiscover?


    Gulab | MCTS-MCITP Messaging: 2010 | MCTS-MCITP Messaging: 2007 | MCC 2011 | Skype: Gulab.Mallah
    Friday, May 06, 2011 5:49 AM
  • Most frequently the problem outlined is caused by missing/incorrectly setup autodiscover record that is recommended to be a CNAME.

    Please check that to make sure it is setup properly.


    MCITP: EMA 2007/2010 | MCSA | Blog http://ehlo.me
    Friday, May 06, 2011 5:52 AM
  • Hello,

    Access the autodiscover url in IE on the problematic computer:

    https://autodiscover.mydomain.com/autodiscover/autodiscover.xml

    Does it return any error code?

    Please also post the IIS log on the CAS server for further troubleshooting.

    For more information, you can also consider using SRV record for autodiscover in DNS.

    http://support.microsoft.com/kb/940881

    Thanks,
    Simon

    Monday, May 09, 2011 9:33 AM
    Moderator
  • the dns is set properly.  It poitns to my TMG server just as it should.  When i type in the url 

    https://autodiscover.scic.com/autodiscover/autodiscover.xml

     

    I get the following.

     

    • Error Code: 403 Forbidden. The server denied the specified Uniform Resource Locator (URL). Contact the server administrator. (12202)  

    Monday, May 09, 2011 1:39 PM
  • Hello,

     

    You need to locate the detailed error code in IIS log. For your reference, here are some generate error codes for 403:

     

    403 - Forbidden.

     

    IIS 7.0 defines the following HTTP status codes that indicate a more specific cause of a 403 error:

    403.1 - Execute access forbidden.

    403.2 - Read access forbidden.

    403.3 - Write access forbidden.

    403.4 - SSL required.

    403.5 - SSL 128 required.

    403.6 - IP address rejected.

    403.7 - Client certificate required.

    403.8 - Site access denied.

    403.9 - Forbidden: Too many clients are trying to connect to the Web server.

    403.10 - Forbidden: Web server is configured to deny Execute access.

    403.11 - Forbidden: Password has been changed.

    403.12 - Mapper denied access.

    403.13 - Client certificate revoked.

    403.14 - Directory listing denied.

    403.15 - Forbidden: Client access licenses have exceeded limits on the Web server.

    403.16 - Client certificate is untrusted or invalid.

    403.17 - Client certificate has expired or is not yet valid.

    403.18 - Cannot execute requested URL in the current application pool.

    403.19 - Cannot execute CGI applications for the client in this application pool.

    403.20 - Forbidden: Passport logon failed.

    403.21 - Forbidden: Source access denied.

    403.22 - Forbidden: Infinite depth is denied.

     

    This will give you more senses to troubleshoot the issue.

     

    By the way, can we access the autodiscover url in IE on the CAS server?

     

    Thanks,

    Simon

     

    Tuesday, May 10, 2011 2:46 AM
    Moderator
  • ok so now i went and adjusted my rule in TMG to accept the following URL:

    https://autodiscover.scic.com/autodiscover/autodiscover.xml

     

    and then i enter my username and password i get the following

    <Autodiscover><Response><Error Time="21:49:55.6549888" Id="3217131707"><ErrorCode>600</ErrorCode><Message>Invalid Request</Message><DebugData/></Error></Response></Autodiscover>

    and now when i run test email auto config from the right click of the outlook icon i get the followng.

     

    Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml starting

    Autodiscover to https://mydomain.com/autodiscover/autodiscover.xml failed (0x800C8203)

    Autodiscover to https://autodiscover.mydomain.com/autodiscover/autodiscover.xml starting

    Autodiscover to https://autodiscover.mydomain.com/autodiscover/autodiscover.xml succeeded

    but my out of office still won't change and it still gives me the same pop up message.

    • Edited by KirkSH Tuesday, May 10, 2011 2:55 AM more info
    Tuesday, May 10, 2011 2:50 AM
  • oh and i do have an SRV record set in DNS and when i test it via the exchange Remote connectivity website it succeeded.  
    • Edited by KirkSH Tuesday, May 10, 2011 2:56 AM misspelling
    Tuesday, May 10, 2011 2:56 AM
  • one final thing:  When i run the Test e-mail auto config and enter my username and password and click on results it says my OOF Url is my internal CAS server.  Is that correct?  
    Tuesday, May 10, 2011 3:30 AM
  • You can use the following command to see the internal and external url for the OOF.

     

    Get-WebServicesVirtualDirectory |fl

     

    Thanks,

    Simon

    Wednesday, May 11, 2011 4:56 AM
    Moderator
  • By setting the external OOF and making the change to TMG to accept that new url it has started to work.  Thanks everyone for the help.  
    • Marked as answer by KirkSH Friday, May 13, 2011 7:01 PM
    Friday, May 13, 2011 7:00 PM